Si no has actualizado tu PS4 en las últimas 2 semanas, ya puedes piratearla

PlayStation 4 sufre de una serie de problemas similares a los que afectaron a PS3. Mediante la presencia de dos vulnerabilidades en el kernel y en el WebKit, es posible hacer jailbreak a la consola e introducir homebrew, dando pie al uso de emuladores, aplicaciones no oficiales, y copias de juegos. Ahora, han conseguido piratear las consolas con el penúltimo firmware más reciente.

El pasado 15 de septiembre, PS4 recibió su segunda actualización de 2021 con el firmware 9.00. Posteriormente, no hace ni dos semanas, la consola se actualizó a la versión 9.03, donde había rumores de que en esa actualización se habían parcheado varias vulnerabilidades de la consola que permitían piratearla. Si quieres seguridad y buena conexión, los servidores DNS de la PS4 son esenciales.

Nuevo jailbreak de PS4 para piratearla

Ahora, finalmente, los desarrolladores SpecterDev, Chendochap y Znullptr han lanzado pOOBs4, el jailbreak para el firmware 9.00. Estos desarrolladores descubrieron una vulnerabilidad en el kernel de la versión 9.00, y a partir de ahí sólo necesitaban una vulnerabilidad en el Webkit como punto de entrada para introducirla. Esta vulnerabilidad fue descubierta por Sleirsgoevy, y con ella han conseguido crear el jailbreak para esta versión, tal y como venía rumoreándose desde principios de mes.

Introducir el exploit en PS4 es tan fácil como utilizar un simple pendrive formateado en exFAT con ligeras modificaciones, ya que la vulnerabilidad reside en un fallo del sistema de archivos de PS4. El código que el pendrive introduce permite ejecutar código arbitrario en el kernel, pudiendo hacer modificaciones en el sistema a nivel de kernel, como el jailbreak. No obstante, el pendrive hay que introducirlo en un momento concreto para que funcione.

Imagen del usuario de twitter

Specter
@SpecterDev

9.00 is up. Again, grats to ChendoChap, fast work and great exploit (and @sleirsgoevy for webkit)

https://t.co/9OyNNNxIN2

07 de septiembre, 2022 • 13:56


920

35

Así, los usuarios de PS4 que ya pueden ejecutar homebrew en su consola. En el repositorio de GitHub de ChendoChap se encuentra toda la información al respecto de pOOBs4. A partir de ahí, es posible instalar un CFW para ejecutar Homebrew en la consola. Si has actualizado ya al firmware 9.03, no vas a poder hacer nada para aprovechar esta vulnerabilidad. Lo único que puedes hacer es esperar a futuras vulnerabilidades, o ir a una tienda a comprar una PS4, la cual vendrá probablemente todavía con el firmware 9.00.

También afecta a PS5

Lo curioso de esta vulnerabilidad en el kernel es que también afecta a PS5. No sabemos si tiene que ver con la vulnerabilidad que describió TheFlow0 en noviembre y que le permitió activar el modo Debug en PS5, pero lo cierto es que se trata de la primera gran vulnerabilidad conocida en el kernel de PS5. Si se consigue encontrar un punto de introducción, podría llegarse a piratear la nueva consola de Sony. En octubre, se descubrió una vulnerabilidad en el WebKit, por lo que no sería una locura que en los próximos días o semanas viéramos un jailbreak en PS5.

En el caso de que se consiguiera piratear PS5, se demostraría que eliminar el navegador web de la consola no ha servido nada más que para hacerle perder funcionalidades con respecto a su antecesora. Esto es debido a que el WebKit sigue presente en la consola, a pesar de que no se use para un navegador web.

¡Sé el primero en comentar!