Red Kad no conecta y Red Kad tras cortafuegos en eMule

Página 1 de 1
Avatar de Usuario
Alfort
Registrado: 02/01/2007
Mensajes: 7766
Moderador
Moderador
Vie 26 Ago, 01:36
________________RED KAD________________________


Para que funcione la Red Kad es necesario que su puerto UDP no esté bloqueado por cortafuegos, como pueden ser del sistema operativo o del router.
-->ID baja en eMule


_____________Red Kad no conecta___________________


Con
-->servidores fiables se facilitará el arranque de esta Red.

Si la Red Kad no conecta, en la pantalla Servidores se verá lo siguiente:
Imagen
Con la flecha superior de la bola en rojo.

Y en su pantalla no habra ningún contacto establecido.

Imagen

Comprobar que esté marcada la casilla de Red Kad en
Preferencias --> Conexión.

Imagen

Para conectar esta Red, en la pantalla Kad y en su zona de Autorranque se marca "De clientes conocidos" y se acciona el botón "Autoarranque", y en breve espacio de tiempo debería conectarse la Red.
Si la Red no conecta suele ser efectivo lo siguiente: mediante "Global Servidores" se pone en descarga uno o varios archivos con muchas fuentes y se dejan un rato descargando. Finalmente se vuelve a intentar el autoarranque de clientes conocidos.

Imagen

Si sigue sin conectar, se cierra eMule y se sustituye el archivo
-->nodes.dat en la carpeta "Config".

También marcando la casilla Nodes.dat de URL y copiando una dirección de carga del archivo:
-->http://www.nodes-dat.com/
-->http://upd.emule-security.org/nodes.dat


En este caso la causa puede ser un nodes.dat corrupto, o desactualizado después de un largo periodo de inactividad de eMule.
El nodes.dat (equivalente al server.met de la Red eD2K) contiene contactos Kad y cómo enlazar con éstos.
Otra opción es poner manualmente un contacto: se pone la IP y el puerto UDP de un cliente que esté conectado, como puediera ser un amigo.


_____________Red Kad tras cortafuegos_________________

Equivalente a la ID baja de la Red eD2K.

Imagen

La flecha superior de color amarillo

Si está correctamente abierto el puerto UDP en los cortafuegos, para tener una buena conexión bastará con accionar repetidamente el botón "Comprobar cortafuegos" en la pantalla Kad.

Imagen

________________________________

Una vez conseguida una buena conexión.

Imagen

En la pantalla Kad se verán los contactos establecidos.

Imagen

Significado de los colores:

Imagen

___________La pantalla de la Red Kad____________

Imagen


1.- Autoarranque.

2.- Lista de contactos. Registra los datos de los contactos establecidos. Los colores indican si están activos y cuánto tiempo, va desde el rojo: inactivo; hasta el verde: activo y durante horas.

3.- Búsquedas actuales. Registra la actividad de Kad. Por ejemplo si eMule comienza una búsqueda en la red Kad o publica un archivo se verá aquí una entrada para esta acción. La mayor parte del tiempo se ven acciones internas de enrutamiento realizadas por Kad.

4.- Gráficos de contactos. Registra una visión de los contactos Kad conocidos y su distancia. En general se conocerán más contactos cercanos a ti, pero no hay que preocuparse si el gráfico tiene una apariencia diferente o una silueta extraña, eso no significa que haya ningún problema con Kad.

Más información de la Red Kademlia en estos dos enlaces:
Enlace 1
Enlace 2
________________________________
Documentación: http://forum.emule-project.net
Imagen Imagen
Dimitrivia
Dimitrivia
Registrado: 16/04/2017
Mensajes: 51
ZoNeR@ habitual
ZoNeR@ habitual
Jue 20 Abr, 20:43
Al cambiar el nodes.dat manualmente no me a funcionado pero luego parece que con paciencia y añadiendo la dirección que das el enlace que aun esta activo en "nodes.dat de URL" y dar a autoarranque si se actualizado el numero de contactos, pero aun así todos van quedándose en rojo y muriendo.

También decir que el enlace que pones la pagina por mas que ponga actualizados... de los 3 enlaces que da 2 tienen dominio caducado...
Creo que la pagina miente respecto a que están actualizadas. Seria bueno si alguien sube un nodes suyo.

A ed2k según el otro manual conecto perfecto con ID alta.

uso la 0.50a oficial.

ACTUALIZO!!!


El nodes.dat de esa pagina esta muy desfasado y no funciona he probado con este que si funciona:

http://www.emule-security.org/e107_plugins/faq/faq.php?0.cat.6.6

Esta URL la he añadido en la pestaña de KAD, la parte de nodes desde URL y le di a autoarranque, y funcionando perfecto en verde al momento.
http://upd.emule-security.org/nodes.dat
Avatar de Usuario
Alfort
Registrado: 02/01/2007
Mensajes: 7766
Moderador
Moderador
Vie 21 Abr, 22:53
Gracias por la aportación, cuando tenga tiempo comprobaré y rectificaré en su caso. Por otra parte es normal que los nodes en la nube queden desfasados, porque son como fotos fijas de un momento dado, de los clientes que están activos,  y por lo tanto si no se actualizan constantemente se desfasan. Creo haber dicho que lo mejor es hacerse uno mismo este nodes.dat, poniendo a bajar archivos con muchas muchas fuentes al solo objeto de arrancar, de formar el nodes.dat, y ya se pueden eliminar esos archivos, y luego el nodes.dat irá cambiando día a día si tenemos emule en funcionamiento.

Saludos.
Imagen Imagen

Volver a Emule