SOLUCIONAR NAT EN B5_1027/ B.11 / B.12 en 660hw-d1 con P2P

Parece que sigue dando el mismo error:

41 Tue Sep 08 18:11:02 2009 PP01 INFO SMT Session End
43 Tue Sep 08 18:11:04 2009 PP14 ERROR 192.168. exceeds the max. number of session per host!
44 Tue Sep 08 18:11:11 2009 PP16 ERROR Last errorlog repeat 6 Times
45 Tue Sep 08 18:11:11 2009 PP16 INFO SMT Password pass
46 Tue Sep 08 18:11:11 2009 PP01 INFO SMT Session Begin
47 Tue Sep 08 18:11:12 2009 PP14 ERROR 192.168. exceeds the max. number of session per host!
48 Tue Sep 08 18:21:41 2009 PP01 ERROR Last errorlog repeat 900 Times
49 Tue Sep 08 18:21:41 2009 PP01 INFO SMT Session End
51 Tue Sep 08 18:21:41 2009 PP14 ERROR 192.168. exceeds the max. number of session per host!
52 Tue Sep 08 23:27:02 2009 PP16 ERROR Last errorlog repeat 29954 Times
53 Tue Sep 08 23:27:02 2009 PP16 INFO SMT Password pass
54 Tue Sep 08 23:27:02 2009 PP01 INFO SMT Session Begin
55 Tue Sep 08 23:27:03 2009 PP14 ERROR 192.168. exceeds the max. number of session per host!
56 Tue Sep 08 23:32:12 2009 PP01 ERROR Last errorlog repeat 505 Times
57 Tue Sep 08 23:32:12 2009 PP01 INFO SMT Session End
59 Tue Sep 08 23:32:13 2009 PP14 ERROR 192.168. exceeds the max. number of session per host!
60 Tue Sep 08 23:58:10 2009 PP16 ERROR Last errorlog repeat 2539 Times
61 Tue Sep 08 23:58:10 2009 PP16 INFO SMT Password pass
62 Tue Sep 08 23:58:10 2009 PP01 INFO SMT Session Begin
63 Tue Sep 08 23:58:19 2009 PP14 ERROR 192.168. exceeds the max. number of session per host!


No sé como ver si tiene firewall....

gracias por la prontitud de tus respuestas
 
Se me van acabando las ideas.

Sospecho que tienes unos puertos abiertos para los P2P. Cuando tienes puertos abiertos, las sesiones de NAT no solamente se generan desde adentro sino también desde afuera, a un ritmo que no podemos controlar, por lo cual es difícil saber mejor qué es lo que está pasando, ya que no tenemos forma de ver los datos de la Tabla de NAT. De seguro que cerrar los puertos ayudaría para tu problema, pero perjudicaría para los P2P, así que mejor déjalo como está hasta que tengamos mejor idea.

Una posibilidad es que reduzcas sustancialmente el timeout del protocolo TCP, al menos para probar si mejora. Podrías llevarlo por ejemplo a 30 segundos e inclusive menos. Si tuviera firewall lo verías en el menú por web, pero como es un firmware modificado para Telefónica, quedan eviencias del firewall después del recorte, así que haslo tanto con el comando IP NAT como SYS TOS. Prueba esto y nos cuentas.

Tienes el parche de Lvllord para el TCP del XP? En qué valor?
Si es así, te puede estar perjudicando no solamente el NAT sino también el P2P, ya que al estar la tabla colapsada, intentar abrir conexiones te juega en contra.
 
Efectivamente, tengo los puertos de los P2P abiertos.
Voy a probar a reducir los timeout como me dice (supongo que es poner los de 400 a 30) y pruebo a ver que tal.

¿Hay algún comando para liberar la tabla totalmente?

El parche lo utilizaba antes de cambiar a telefónica, pero como empecé a tener problemas con el router volví a reducir las conexiones a 10 o a 20.

Mañana cuento como va.

Gracias.
 
Puedes vaciar la tabla de un plumazo con
ip nat reset wanif0

Te va a funcionar en ese momento, pero supuestamente, al rato vas a tener el mismo problema.

Slds.
 
Buenos días.

Parece que le ha sentado bien la noche al router. Ahora me va perfectamente las páginas web desde los dos ordenadores, supongo que a lo largo de la noche y habiendo modificado los timeout, fue liberando la tabla. No use el comando para vaciar la tabla.

He hecho un ip nat nat wanif0 y curiosamente me ha cambiado el nat session per host:
========================================================================
NAT Global information
========================================================================
Lookup set table pointer (NatHashTable): 0x944fc624
Server set table pointer (pNatLookupSetBuf): 0x94989930
natTable_t: 128 bytes, natHash_t: 32768 bytes, natEntry_t: 128 bytes
NAT_SESSION_TABLE_SIZE: 6000
Total NAT slot size: 768000 bytes
Session Per Host: 6000
NAT_HASH_TABLE_SIZE: 4096, NAT_HASH_TABLE_MASK: 4095

No sé en que momento a cambiado, ni si será lo que ha influído en el funcionamiento.

Una última pregunta, ¿Cómo hay que hacer el fichero autoexec.net y dónde hay que guardarlo?

Muchas gracias por la ayuda OGalati, no solo parece que he solucionado el problema sino que he aprendido un montón de cosas sobre los routers.

Un saludo
 
El autoexec.net es un archivo incluído en el propio router. Lo ves con el comando
sys view autoexec.net
y lo editas con el comando
sys edit autoexec.net
Es un editor muy rudimentario línea a línea, no pantalla completa, tienes que tener cuidado. Al principio te a parece una línea de ayuda con las letras que debes presionar para cada comando. Lo que haces es insertar una línea con la letra i, escribir el comando en ella, luego insertas otra y así, luego sales con la letra de grabar, que es la x.

Luego nos comentas cómo sigue el funcionamiento y si descubres cómo se cambió a 6000.

Slds
 
De momento el funcionamiento es bueno, aunque hoy se me a desconectado el router un par de veces. No sé si será debido a los cambios.

Lo de como cambié a 6000 por host, ni idea, no usé nada más que los comandos que me ibas diciendo.

Mañana comento si me sigue con los cortes o han sido puntuales.

Un saludo.
 
OGalati eres mi nuevo Dios, apartir de hoy te adoraré! XD Estaba buscando soluciones para los cortes continuos que llego a tener en el día y tus consejos de limitar el tiempo de la conexion ha sido genial. Ni una vez me he caido desde ayer que realizé los cambios. Para mi es algo ya que me solia desconectar al día como 3 o 5 veces minimo.
Algo que si me tiene mosca es el numero de conexiones máxima hice un ip nat session 2048 y cuando tecleo ip nat session, muestra 2048, pero cuando hago un ip nat nat ifwan0 en el numero de conexiones por host sigue saliendo 512.

¿A cuál de los 2 datos tengo que creer?
 
Esto supongo es lo que quieres ver:

ras> ip nat nat wanif0
========================================================================
NAT Global information
========================================================================
Lookup set table pointer (NatHashTable): 0x94503f24
Server set table pointer (pNatLookupSetBuf): 0x9488bc14
natTable_t: 2180 bytes, natHash_t: 16384 bytes, natEntry_t: 132 bytes
NAT_SESSION_TABLE_SIZE: 2048
Total NAT slot size: 270336 bytes
Session Per Host: 512
NAT_HASH_TABLE_SIZE: 2048, NAT_HASH_TABLE_MASK: 2047
Cone NAT support: enabled

ras> ip nat session
NAT session number per host: 2048
ras>
 
Se acabó la felicidad, he reiniciado el router, la tabla y el host son de 2048. Pero ahora no hace más que cortarse la conexión todo el santo rato, de hecho mientras escribo esto se ha cortado y tendré que esperar a que conecte para postearlo. :S
 
Ogalati eres un crack tio, lo estoy probando con AGL.4 y con la solución que das unas páginas atras ya no tiene el problema de que se ralentiza el navegador pasadas las horas.
salu2!
 
Buenas,

A mí lo que me pasa es lo siguiente

Tengo el zyxel P660HW D1 de Telefónica desde hace unos días (sin imagenio)...Desde entonces cada vez que utilizo algún programa torrent, en poco tiempo no sólo no puedo navegar, ya que es cómo si se quedara sin conexión, si no que también se me peta el pc, ralentizando al máximo el movimiento del ratón, y el abrir las carpetas...Lo curioso es que via wifi (tengo un móvil conectado) navego sin problema...

Tengo que reinciar el router y el pc para que vuelva a funcionar...

Ya he actualizado el firmware, aumentado via telnet las conexiones (no me deja a 6000, sólo a 204:cool:, bajado las conexiones en dichos programas, y me sigue pasando, cuando antes con el router anterior (un zyxel negro de los antiguos incluso cogía velocidades de descarga de más de 300kb y podía navegar sin problema)

Gracias de antemano y un saludo.

PEGO LOS REPORTES DE TELNET


ras> ip nat nat wanif0
========================================================================
NAT Global information
========================================================================
Lookup set table pointer (NatHashTable): 0x94503f24
Server set table pointer (pNatLookupSetBuf): 0x9488bc14
natTable_t: 2180 bytes, natHash_t: 16384 bytes, natEntry_t: 132 bytes
NAT_SESSION_TABLE_SIZE: 2048
Total NAT slot size: 270336 bytes
Session Per Host: 2048
NAT_HASH_TABLE_SIZE: 2048, NAT_HASH_TABLE_MASK: 2047
Cone NAT support: enabled







ras> ip nat timeout disp
TCP opened: 150 (minute)
TCP reset: 10 (second)
TCP wait: 2 MSL (second)
TCP other: 270 (second)
UDP: 3 (minute)
UDP specific port -1: 300 (second)
ICMP: 3 (minute)
ESP: 150 (minute)
GRE: 150 (minute)
Others: 3 (minute)
Iamt: 151 (minute)
ras> ip nat timeout disp
TCP opened: 150 (minute)
TCP reset: 10 (second)
TCP wait: 2 MSL (second)
TCP other: 270 (second)
UDP: 3 (minute)
UDP specific port -1: 300 (second)
ICMP: 3 (minute)
ESP: 150 (minute)
GRE: 150 (minute)
Others: 3 (minute)
Iamt: 151 (minute)
ras>




ras> sys tos timeout disp
TCP connection timeout (s): 270
TCP idle timeout (s): 9000
TCP FIN-wait timeout (s): 270
UDP idle timeout (s): 300
ICMP idle timeout (s): 180
GRE idle timeout (s): 9000
ESP idle timeout (s): 9000
AH idle timeout (s): 180
IGMP idle timeout (s): 180
Other IP idle timeout (s): 180
ras>
 
Cuéntanos qué versión de firmware es esa y prueba reduciendo los timeouts como se explica en este mismo hilo.

Slds.
 
Hola de nuevo OGalati!!!

El firmware que tengo es 340AHF0b12_20080409 y ya he ejecutado ip nat generic 10...(si quisiera volver al original, el 10 lo debería sustituir por los segundos correspondientes, no?) Perdona mi ignorancia en el tema...

Pero tengo una duda del post en el que lo explicas:

Verificamos que en una línea que sea UDP, ese valor no va a pasar nunca de lo que acabamos de configurar, ya que en ese momento la sesión se cierra y esa entrada se libera, que es justamente lo que queremos lograr.

No se exactamente qué quieres decir...

También quería pedir consejo si seguir con este router, o conseguir uno nuevo (cuál?), ya que no me da más que problemas....Salvo que después de probar vuestros consejos me vaya mejor, ya os iré contando como me va...

Gracias de nuevo y un saludo
 
Con esa línea me refiero a cuando puedes ver el cuerpo completo de la Tabla NAT verás que cada línea (sesión) desaparece cuando el timeout lleva al valor establecido. En algunos modelos no puedes ver la tabla y en otros la ves con
ip nat hash wanif0

Prueba también usando el comando
sys tos timeout
que menciono en ese post para reducir ese timeout también, ya que juega por separado. Ese firmware tiene originalmente firewall y por lo tanto el juego de comandos para TOS.


Slds.
 
Hola de nuevo!!!

1 Te refieres entonces con esa línea simplemente a comprobar visulamente que los valores que hemos cambiado hacen su función con los TOS. , no?

He bajado los timeout, sólo los udp de nat con ip nat timeout generic 10 , y después de un rato el utorrent va a una velocidad más que aceptable, y puedo navegar perfectamente...

2 Como me va ahora bien, me aconsejas bajar también los TOS firewall, o virgencita virgencita que me quede como estoy??? No sé si tengo firewall o no, aunque me comentas que con ese firmware sí lo tengo ( lo actualicè ayer)

3 Además, se borrarán los TOS nat cuando apague, o sólo cuando resetee el router? Es que me da yuyu tocar el autoexec.net...Aconséjame por favor si lo edito o no...

Gracias mil por tu ayuda y paciencia y un saludo.
 
Te diría que si te funciona, no lo toques, si no, me refería a bajar los timeout TOS también, además de los NAT.
En cuanto a que los pierdas al reiniciar, eso te pasará con los timeout de NAT, no con los de TOS, que los han hecho persistentes a los reinicios, y para volver a los valores originales deberás reconfigurarlos a mano o resetear el router con el botón. Los NAT timeout deberás ponerlos en el autoexec.net para que sobrevivan a los reinicios.

Slds.
 
Arriba