Feature Bits Originales para Bootbase de Zyxel P-660HW T1 v3


Hola amigos:

Tengo un modem router Zyxel P-660HW T1 v3 provisto por Telefonica (ARG).
La cosa es que por varios problemas que le atribuyo al firmware, he decidido cambiar el que trae de Telefonica por el original de Zyxel.

Ya logre construir el cable (mas adelante posteare como hacerlo con un cable de Nokia CA-42) y el Tera Term me lo toma (estoy usando la version 2.3 - si existe alguna mas nueva o un programa mejor por favor avisen-).

El problema empieza cuando una vez que entro en modo DEBUG, no me toma el comando ATSE (me dice ERROR). Y si no puedo ingresar al modem no hay posibilidades de modificar el bootbase.

Lei que en los Zyxel P-660HW T1 v2 se arreglaba haciendo un downgrade del firmware de telefonica, pero para este modelo no encuentro nada.

Todavia me queda probar si funciona el firmware del otro modelo, aunque realmente dudo que funcione.

La pregunta seria, ¿alguien tiene un bootbase original de este modelo?
Porfavor el que tenga este modelo original que haga un backup del bootbase y lo comparta para extraer los feature bits a modificar.

Tambien agradeceria cualquier ayuda para llevar a cabo el proceso de convertir este modelo en original y alguna solucion para que me tome el comando ATSE el Tera Term.

Desde ya mil gracias!

_________________________________________

Código:
Model Number: P-660HW-T1 v3
ZyNOS Firmware Version: V3.40(BRR.0) | 03/19/2010
DSL Firmware Version: DMT FwVer: 3.11.11.25_A_TC
Proveedor: Telefonica (ARG)
romRasSize: 1809792
Bootbase version: V1.00 | 09/27/2008
-SYS ATSH-
Código:
Password: ****
Copyright (c) 1994 - 2010 ZyXEL Communications Corp.
DAMNEMESIS> sys atsh

RAS version            : V3.40(BRR.0) | 03/19/2010
Ram Size               : 16384 Kbytes
Flash Type and Size    : MXIC 16Mbits*1
romRasSize             : 1809792
bootbase version       : V1.00 | 09/27/2008
Product Model          : P-660HW-T1 v3
MAC Address            : ************
MAC Quantity           : 1
Default Country Code   : C6
Boot Module Debug Flag : 00
RomFile Version        : 3F
RomFile Checksum       : a237
RAS F/W Checksum       : 96b5
SNMP MIB level & OID   : 060102030405060708091011121314151617181920
Main Feature Bits      : C0
Other Feature Bits     :
02 72 00 00 01 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 02 41 13 00 00 00
DAMNEMESIS>
-ATSH-
Código:
Bootbase Version: V1.00 | 09/27/2008 15:23:34
RAM: Size = 16384 Kbytes
DRAM POST: Testing: 16384K
OK
Found SPI Flash 2MiB MX25L1605D

ZyNOS Version: V3.40(BRR.0) | 03/19/2010  17:50:00

Press any key to enter debug mode within 3 seconds.
.....
Enter Debug Mode
ATSH
ZyNOS Version          : V3.40(BRR.0) | 03/19/2010  17:50:00
Bootbase Version       : V1.00 | 09/27/2008 15:23:34
Vendor Name            : ZyXEL Communications Corp.
Product Model          : P-660HW-T1 v3
ZyNOS ROM address      : bfc12000
System Type            : 7
MAC Address            : ************
MAC Quantity           : 1
Default Country Code   : C6
Boot Module Debug Flag : 00
RomFile Version        : 43
RomFile Checksum       : 9c90
ZyNOS Checksum         : 96b5
Core Checksum          : b8ea
SNMP MIB level & OID   : 060102030405060708091011121314151617181920
Main Feature Bits      : C0
Other Feature Bits     :
          02 72 00 00 01 00 00 00-00 00 00 00 00 00 00 00
          00 00 00 00 00 00 00 00-02 41 13 00 00 00

OK
_________________________________________

 
Gracias!


Como siempre OGalati, MIL GRACIAS! Sos un capo!

En cuanto pueda entrar al modem modifico esos valores en el bootbase (Todavia no encuentro una solucion para que me tome el comando ATSE y no se otra forma de entrar, extraer y modificar el bootbase -cualquier sugerencia es bienvenida-).

Con repsecto a lo de la perdida de conexion cuando busco servidores, mirando el LOG del router me aparece el error "192.168.1.2 exceeds the max. number of session per host!".
Miré el post que me pasaste pero no me sirve la solucion del NAT.
Por defecto el NAT viene en 512. Lo agrando a 2000 (el modem soporta hasta 204:cool: y sigue el problema; pero si lo agrando hasta 2048 la conexion no se corta, pero tampoco me busca servidores.
En un post similar [http://www.adslzone.net/postx209827-0-0.html] lei que recomendaste utilizar el comando "ip nat timeout generic 20" pero tampoco funciona, ni siquiera reduciendo el valor a 5.
Por otro lado, el comando "ip nat iface wanif0" me devuelve esto:

Código:
Password: ****

Copyright (c) 1994 - 2010 ZyXEL Communications Corp.

Speedy> ip nat iface wanif0

hashTable       server          service         resetport
incikeport      session         addrmap         AOL-version9

Speedy>

Alguna otra solucion para ir probando?

Mientras tanto seguire en la busqueda de alguna solucion para respaldar y subir el bootbase modificado.

Un abrazo grande! ;)

 
Hola.

Ese modelo tiene firewall, por lo que al comando
ip nat timeout xxxx
hay que acompañarlo con
sys tos timeout xxxx
Ver:
http://www.adslzone.net/postp1150668.html#1150668


En el momento de la búsqueda y que no se puede navegar habría que usar estos comandos para ver si aparece algo útil
ip nat iamt wanif0
ip nat hash wanif0 (que reemplaza un poco al ip nat iface)

Estás usando el parche del TCP de lvllord? Qué sistema operativo?



Slds.
 

Te comento:

Probe estos comandos antes y despues de pedir servidores:

>>> COMANDO: ip nat iamt wanif0

VERSION COMPLETA EN TXT: http://www.mediafire.com/?u4sbkaqlkshi95h

Copio el resultado final

Código:
-ANTES-


Used:   219, Total:  5000

______________________________________________________________

-DESPUES-


Used:  2212, Total:  5000

>>> COMANDO: ip nat hash wanif0

VERSION COMPLETA EN TXT: http://www.mediafire.com/?2gfu8kiiv23yafu

Copio el resultado final

Código:
-ANTES-


================================Summary information=============================
Used:    45, Total:  2048

______________________________________________________________

-DESPUES-

================================Summary information=============================
Used:  2000, Total:  2048


Por otro lado probe los comandos "ip nat timeout generic 10" y "sys tos timeout udp 10", pero no hay caso, sigue el problema. En el LOG del modem sigue apareciendo "192.168.1.2 exceeds the max. number of session per host!".

Con respecto al tema del sistema operativo, estoy usando Windows 7 Ultimate de 64 bits; y no tiene modificado el TCP con ningun parche.

 
El problema es que no está cerrando las sesiones UDP al ritmo que debiera, por lo tanto la Tabla de NAT se le llena rápidamente (te comento que ese programa dispara sesiones como loco). Al llegar a 2000 sesiones (lo configurado como máximas sesiones por host) deja de abrir nuevas sesiones.

Fijate en "ip nat hash", la última columna que pone "Idle" no debería ser nunca superior al valor configurado con "ip nat timeout" ya que al alcanzar ese valor, la sesión debería desaparecer de la Tabla. Evidentemente el timeout no está funcionando.

Dejame ver qué encuentro.

Una manera de combatir este problema es filtrar la lista de servidores, como en P2P, con el PeerGuardian o similares. El punto es no desperdiciar sesiones tratando de contactar a servidores inexistentes o fakes. No sé si hay listas de ese tipo para ese tipo de búsquedas.

Slds.
 
No sé qué han hecho pero me parece que el comando
"ip nat timeout generic" no está funcionando
y el comando
"ip nat timeout udp" se usa para un único puerto específico.

Mientras encontramos algo mejor podrías probar
ip nat timeout udp 27015 10

Veo que la mayoría de las sesiones se disparan hacia un puerto 27015 remoto, por lo que reduciendo el timeout del las sesiones que tienen como destino ese puerto, supongo que debería mejorar.

Slds.
 
Hasta donde yo supe no se lo puede actualizar a a la ultima version.
Aprovecho para contarles que Telefonica me cambio el router por que tenia muchos cuelgues y se perdia la sincronizacion, y hablando con el tecnico de Telefonica que vino a traerme el nuevo router me conto que Telefonica les mando un comunicado para que dejaran de distribuir este modelo de Zyxel por que estaba andando muy mal y los tienen como locos quejandose por su pesimo funcionamiento.

Un abrazo!
 
DAMNEMESIS dijo:
Hasta donde yo supe no se lo puede actualizar a a la ultima version.
Aprovecho para contarles que Telefonica me cambio el router por que tenia muchos cuelgues y se perdia la sincronizacion, y hablando con el tecnico de Telefonica que vino a traerme el nuevo router me conto que Telefonica les mando un comunicado para que dejaran de distribuir este modelo de Zyxel por que estaba andando muy mal y los tienen como locos quejandose por su pesimo funcionamiento.

Un abrazo!

Un amigo mio tiene uno con el firmware original y no tiene problemas (con arnet al menos)

El que me dieron (a caballo regalado...) es de telefónica de perú y tiene en los feature bits 02 58... voy a ver con el ATHE si me dice que comandos soporta al menos.
 
EDIT:

Consegui en la web de telefonica el firmware que tengo en mi zyxel. Preguntas:

¿Qué validación hace el router para aceptar un firmware? ¿El problema mayor radica en los feature bits?
 
Salvo AT y ATHE que no sirven de mucho, nada.

Queria saber si en alguna página existe info de que micro usa el zyxel para intentar hacer algo de ingenieria inversa y ver donde estan los bloqueos de comandos.
 
mxmauro dijo:
Salvo AT y ATHE que no sirven de mucho, nada.

Queria saber si en alguna página existe info de que micro usa el zyxel para intentar hacer algo de ingenieria inversa y ver donde estan los bloqueos de comandos.

Hola.
Podrías hacer un comando
ATSH
tanto en tu router como en el de tu amigo que tiene el firmware original (si es el BJZ.x) ?
Slds.
 
Quizas sea una burrada lo que digo, pero no se podria hacer a la inversa, modificar el firmware para que cuando chequea la version coincidiera con la del modem?
 
Bienvenido al foro. ;)

No sabemos qué modificar en el firmware para que coincidan. :sneaky:

Slds.
 
Arriba