ACTUALIZAR EL 660HW-D1 DE TELEFONICA A ORIGINAL.

OGalati dijo:
elbully dijo:
Hola.


Estoy intentando actualizar un P660HW-D1 de telefónica al firm original y no lo consigo.
En lugar del cable estoy haciéndolo con el PL2303MDL, que es un conversor de usb a RS232.
Está instalado y configurado en el com2, pero cuando abro el TeraTermPro2.3 no consigo que haga nada.

Como datos diré:
- Lo he intentado en W7 y en XP y nada
- Si conecto los 4 cables que indicáis, GND, RX, TX, 3V3 el PL2303 se calienta un montón, tanto como que llega a quemar y si desconecto el 3V3 entonces ya no. Según he podido leer, el 3v sólo hace falta si el conector no está alimentado, con lo cual creo que no debería ponerlo.
- He conectado los cables tal y como indicais en la imagen, aunque también ha cambiado el orden del RX y TX y nada.


Os pongo una foto del conversor para que lo veais:



A ver si me dais más ideas o bien lo dejo por imposible.
En los conversores por USB no necesitas conectar el voltaje, puesto que la alimentación le llega desde el USB. Para probar el conversor, si es que no lo has quemado ya, desconéctalo del router, realiza un puente entre Tx y Rx y pruébalo en el PC. Todo lo que escribes debe repetirse en el PC (ya que el el mensaje va por Tx y vuelve por Rx), y si tienes activado el eco local de la consola, debes ver cada pulsación 2 veces.
Oh, genial. No he leído esto a tiempo, el mío ya está quemado... Y vaya si lo miré varias veces para asegurarme de que todo estaba bien puesto.

Sería también conveniente indicar en el tutorial que hay que conectar el puerto con el router apagado, no sólo a la hora de encenderlo.
 
Re: Enlaces caidos

Ankl dijo:
RESIDENT, se han caido los links del bootbase original 1.06 y del ZynPass; ¿Podrias resubirlos?

Salu2
<--ankl-->
Están subidos correctamente en Mega, lo que pasa es que no sé que pasa que el link no es compatible con algunos navegadores y da problemas. Prueba con Firefox, internete explorer o chrome.

Yo mismo lo acabo de bajar con un gestor de descargas como el Jdownloader, esa es otra opción.
 
Enlaces

Tienes razon RESIDENT, estaba en Chrome, no me funcionaban y me los he bajado de Firefox que, curiosamente si funcionan.

A ver que tal me sale, que nunca he hecho algo asi... :cautious:
Gracias

Salu2
<--ANKL-->
 
Re: Enlaces

Ankl dijo:
Tienes razon RESIDENT, estaba en Chrome, no me funcionaban y me los he bajado de Firefox que, curiosamente si funcionan.

A ver que tal me sale, que nunca he hecho algo asi... :cautious:
Gracias

Salu2
<--ANKL-->
Tu sigue los pasos al pie de la letra y no tendrás problemas. Aquí el punto mas crítico es subir la bootbase, una vez hecho aunque se te cortara al subir firmware tiene solución.

La gran mayoría lo consigue con éxito, los pocos que fallan es por no leer bien las instrucciones o poner el archivo de la bootbase de otro modelo.
 
Buenas. Me dieron hoy un zyxel 660 d1 viejecito pero que funciona perfecto. Con el último firm de telefónica me da de sincronismo:

Upstream Speed: 2261 kbps (En speedtest me da 1,92mbit de subida)
Downstream Speed: 15954 kbps

Me da algo más de subida que el Comtrend AR-5387un y menos bajada pero eso no me importa.

He pedido en ebay el conversor ese de rs232 a usb http://cgi.ebay.es/ws/eBayISAPI.dll?Vie ... 0947266297 que parece el mismo que nombráis más arriba y menos mal que he leído que no hay que conectar el 3.3v porque si no la lío.

¿Creéis que conseguiré 2,2mb de subida (reales, no de sincronismo) con el firm original más nuevo?
 
D4rKiTo dijo:
Buenas. Me dieron hoy un zyxel 660 d1 viejecito pero que funciona perfecto. Con el último firm de telefónica me da de sincronismo:

Upstream Speed: 2261 kbps (En speedtest me da 1,92mbit de subida)
Downstream Speed: 15954 kbps

Me da algo más de subida que el Comtrend AR-5387un y menos bajada pero eso no me importa.

He pedido en ebay el conversor ese de rs232 a usb http://cgi.ebay.es/ws/eBayISAPI.dll?Vie ... 0947266297 que parece el mismo que nombráis más arriba y menos mal que he leído que no hay que conectar el 3.3v porque si no la lío.

¿Creéis que conseguiré 2,2mb de subida (reales, no de sincronismo) con el firm original más nuevo?
Mi recomendación es que si sólo lo vas a utilizar como modem, te olvides del firm original.

Tengo 3 P660 HW D1 y tengo 2 con el firm original y el último con el de teléfonica, que es el que uso en la actualidad.

Es bastante sencillo flashearlo porque lo he hecho en 2 ocasiones y aún así, paso de hacerlo porque no noté absolútamente nada.


P.D. Como dato increible, te diré, que al cambiar de una Asus P7P55D PRO a una Asus P8Z68V PRO, noté una mejora en la subida del 5%. Es algo que ni muchísimo menos me esperaba pero así es. No cambian los valores de sincronización, simplemente consigo mas velocidad de subida en los tests aún sincronizando a la misma velocidad.
 
Bue, el usb-rs232 tll para lo que me ha costado (me llega mañana creo) lo voy a usar y actualizar por si las moscas. Hago streams de juegos y cuanta más subida mejor. Por probar, no pierdo nada, ya os diré.

Y con respecto a lo que comentas, igual tenías algo influyendo en el s.o. y al cambiar de placa como tuviste que formatear "se solucionó" xD. Porque vamos, el router sincronizará igual hasta sin pc.
 
elbully dijo:
D4rKiTo dijo:
Buenas. Me dieron hoy un zyxel 660 d1 viejecito pero que funciona perfecto. Con el último firm de telefónica me da de sincronismo:

Upstream Speed: 2261 kbps (En speedtest me da 1,92mbit de subida)
Downstream Speed: 15954 kbps

Me da algo más de subida que el Comtrend AR-5387un y menos bajada pero eso no me importa.

He pedido en ebay el conversor ese de rs232 a usb http://cgi.ebay.es/ws/eBayISAPI.dll?Vie ... 0947266297 que parece el mismo que nombráis más arriba y menos mal que he leído que no hay que conectar el 3.3v porque si no la lío.

¿Creéis que conseguiré 2,2mb de subida (reales, no de sincronismo) con el firm original más nuevo?
Mi recomendación es que si sólo lo vas a utilizar como modem, te olvides del firm original.

Tengo 3 P660 HW D1 y tengo 2 con el firm original y el último con el de teléfonica, que es el que uso en la actualidad.

Es bastante sencillo flashearlo porque lo he hecho en 2 ocasiones y aún así, paso de hacerlo porque no noté absolútamente nada.


P.D. Como dato increible, te diré, que al cambiar de una Asus P7P55D PRO a una Asus P8Z68V PRO, noté una mejora en la subida del 5%. Es algo que ni muchísimo menos me esperaba pero así es. No cambian los valores de sincronización, simplemente consigo mas velocidad de subida en los tests aún sincronizando a la misma velocidad.
Pues la verdad, tenías razón. He puesto el firm original AGL10 y no hay mejora apreciable, 15974 kbps / 2286 kbps vs 15954 kbps / 2261 kbps.

Tendré que hablar con jazztel a ver si tengo cobertura de vdsl ya que me vendría bien sincronizar como mínimo a 2500kbps de subida. Gracias por todo de todas formas ;)
 
En sincronización es difícil que aprecies mejora, la línea da para lo que da, pero sí puede que mejore en estabilidad.
Lo principal que mejora este firmware es el wifi, más estable y posibilidad de utilizar WPA2, y creo que gestiona mejor la NAT, te irá mejor con P2P y tal
También que tiene funciones avanzadas que no trae el firmware de Movistar, como firewall.
 
D4rKiTo dijo:
Y con respecto a lo que comentas, igual tenías algo influyendo en el s.o. y al cambiar de placa como tuviste que formatear "se solucionó" xD. Porque vamos, el router sincronizará igual hasta sin pc.
No tuve que reinstalar, son chipset similares y el cambio fue transparente para mí, solo instaló drivers nuevos.

Yo se lo achaco más a que el chip que controla la red es distinto en una y en otra y de ahí vengan las diferencias, que como te digo, no era pequeña desde mi punto de vista.
 
Nada

Tengo el adaptador usb rs232 pero no consigo que el tera term me detecte nada, ni apagandolo ni encendiendolo ni nada de nada. No está quemado, funciona correctamente pero ni cambiando la velocidad en el router por telnet ni de puerto, ni en modo de compabilidad de windows xp..todo es en vano.

Es un p660hw-d1 100% pero no hay forma. Ni con el firmware que decis, ni con el más actual de telefónica.
 
Re: Nada

tachenck0 dijo:
Tengo el adaptador usb rs232 pero no consigo que el tera term me detecte nada, ni apagandolo ni encendiendolo ni nada de nada. No está quemado, funciona correctamente pero ni cambiando la velocidad en el router por telnet ni de puerto, ni en modo de compabilidad de windows xp..todo es en vano.

Es un p660hw-d1 100% pero no hay forma. Ni con el firmware que decis, ni con el más actual de telefónica.
Para testear el cable, sus drivers y la configuración del TeraTerm prueba esto:
en la punta del cable que deberías conectar al router, juntas los terminales que son Rx y Tx. De esta forma, al teclear algo en el TeraTerm deberás verlo en la pantalla. Si en TeraTerm tienes activado el eco local, deberás ver dos veces cada pulsación.
 
Despejando dudas

Buenas, por fin he conseguido realizar la carga del firmware. El problema mayor que me he encontrado ha sido que no conseguía ver nada en el tera term pro.

¿Por qué?

En las ilustraciones del primer post viene correctamente cual es la masa, transmisión y recepcion (gnd, txd y rxd) pero no me resultó claro como debía conectarlo por ello he realizado unas fotos y las he editado para que nadie pierda el tiempo como yo jeje.

Antes de nada decir que si se usa un adaptador usb rs232 de ebay o dx.com NO tenemos que conectar los 3,3V. REPITO NO es necesario, por tanto solo nos harán falta 3 cables (gnd, txd y rxd).

Las imágenes vienen a mostrar que TXD del adaptador, el cable que está en TXD conectado (transmisión) ha de ir al RXD del router.

El RXD del adaptador debe ir al TXD del router.

Leerlo bien puede resultar un trabalenguas pero no. Hay que cruzar TXD-RXD Y RXD-TXD.

En las fotos creo que se aprecia mejor.

Adaptador comprado en dx.com lhttp://dx.com/es/p/pl2303hx-usb-to...er-w-4-dupont-cables-for-arduino-black-146784

http://i42.tinypic.com/wjwb47.png

http://i40.tinypic.com/vhymq0.png

http://i39.tinypic.com/16iy0hv.png
 
Conexión TTL alternativa

Buenas.

Llevo tiempo siguiendo este foro y me ha sido muy útil para solucionar muchas dudas respecto a mi conexión de internet. Cuando ví la posibilidad de actualizar este router y aprovechar el Anexo M de jazztel además de la configuración extra que te aporta el firmware original de fábrica no lo dudé.

Quiero compartir la forma que he realizado yo para actualizar el router, ya que veo que la mayoría de la gente utiliza un conversor USB a TTL y aunque parece funcionar bien, sí es cierto que a otra gente le da problemas. Además, si tienes un ordenador que cumple con las características, la actualización te puede salir por 1,5 Euros.

En mi caso parto de un ordenador moderno que no tiene puerto serie COM en la parte posterior, pero que como en casi todas las placas (yo diría que en todas) sí que viene implementado dicho puerto, únicamente hay que localizarlo en la placa y sacarlo al exterior.

Lo primero es localizar el puerto serie COM1 de tu placa. Esto es muy sencillo mirando el manual de la placa, y una vez localizado conectamos un cable como este:



En el conector de la placa:

http://i40.tinypic.com/282kgo3.jpg

Yo saqué el cable de un ordenador antiguo que tenía y que ya no usaba. Antes cuando los puertos serie eran comunes en los ordenadores estos cables eran muy frecuentes. Si no se dispone de un cable se puede adquirir en una tienda de informática o pedir por internet, por ejemplo aquí:

http://www.pccomponentes.com/bracket_placa_puerto_serie_2_x_rs_232.html

pero ya se sube del presupuesto indicado inicialmente, aunque la ventaja es que te quedas con un puerto serie instalado para siempre en el PC por si lo necesitas para cualquier otra comunicación serie.

Si tienes un puerto serie ya instalado en el ordenador, te puedes saltar todo lo anterior y continuar a partir de aquí.

Adquirí por internet en ebay este conversor RS232 a TTL: http://www.ebay.es/itm/V1NF-MAX3232...tor-with-Cables-/221317745080?#ht_4695wt_1365 aunque también sirve perfectamente este de dx: http://dx.com/es/p/rs232-to-ttl-serial-communications-module-w-indicator-blue-black-221240
La ventaja es que es baratísimo, ya digo que al cambio a mí me costó 1,5 Euros o menos, la desventaja es que tarda 2 semanas en venir, aunque yo no tenía mucha prisa.

Una vez tengamos el conversor en casa lo enchufamos al puerto serie

http://i40.tinypic.com/28u753r.jpg

y CON EL ROUTER APAGADO conectamos los cables del conversor al router. He de decir que en mi caso tuve que conectar los 4 cables (El integrado MAX3232 del conversor no viene alimentado por el puerto serie) y se conectan paralelos tal cual del conversor al rotuer, es decir:
- Vcc conversor --> Vcc router
- Tx conversor --> Tx del router
- Rx conversor --> Rx del router
- GND conversor --> GND del router

Más o menos quedaría así: http://i42.tinypic.com/155td7n.jpg

Una vez realizada la conexión, abrimos el TeraTerm, lo configuramos tal cual dice RESIDENT en su manual y encendemos el router. En ese momento el router conecta y seguimos el manual al pie de la letra.

Como digo este método es válido para gente que:
- O bien disponga directamente de un puerto serie en el ordenador (Los portátiles hasta hace poco traían uno).
- O bien quiera extraer el puerto serie de su placa al exterior para luego utilizarlo en otros menesteres
Y sobre todo nos ahorramos problemas con el conversor USB. Muchas veces no hay nada como un puerto serie COM1 nativo.

Y eso es todo, espero que haya servido para gente que quiera y/o necesite una conexión distinta.

Un saludo.
 
Buenas:

He creado un tema porque no podía actualizar el firmware del wouter P660HW-D1 y un compeñero del foro me guió hasta aquí.

Para mi sorpresa, cuando más aprende de los router má me doy cuenta de mi ignorancia, no sabía que telefónica cambia el FirmWare de los router como los móviles, me imagino que tendrtán los permiso del creador del router.

Estoy siguiendo paso a paso el tutorial del primer tema, tengo dudas. Mi versión de router es este:



La versión nueva se descarga directamente pinchando aquí. (1,6 MB).

Respecto al puerto serie, tengo uno que me viene en la placa base, lo que no se si directamente será compatible con la parte del 3.3V que indica en la imagen.



¿Puedo conectar directamente el cable de RS232 del PC al router sin ningún problema del 3.3V?

Un saludo.

PD: En el tema principal, he visto que faltan imágenes que no carga, espero que se resuelva para entender mejor.

PD2: Me gustó mucho ZynPass.

¿El creador del ZynPasssigue estando en pie por estos foros?

Quiero saber que fórmula hizo para hacer mi propio programa más actualizado. Lo haré bajo C#/C++/VBasic .net 2013, también para Linux. Se le entregará código fuente.

:)
 
Hola:

He llegado hasta el final, me ha costado lo suyo, por no fijarme bien en el tutorial y no escribir bien los comandos, también por subir o actualizar archivos que no debería, etc, hasta pensé que el router no servía para nada, si acaso como un pisapapeles. Me he pegado horas y horas pero valió l apena para coger el truco y hacerme mi propio tutorial con pasos más detallado por si acaso. Más adelante lo haré, ahora tengo otro objetivo en mente.



En mi casa uso un router principal de la telefónica que no tocaré. Este que he actualizado me lo han regalado pero hay un pero. No puedo conectarme a Internet, solo entrar en la Web de configuración del router. Este router lo conecto al otro router principal y me funcionaba, ya no lo hace.

Pregunta 1. ¿Qué debo configurar exactamente?
Por ahora le he puesto 192.168.1.2 porque si lo dejo en el 192.168.1.1 se me va al router principal.

Pregunta 2. El menú por Telnet o por Terra Term es diferente al de Telefónica, feo e incómodo. ¿Mientras tenga el firmware oficial me lo tengo que tragar así?



Por ahora es lo que hay, y quiero intentar como se conecta por Internet este router. Cuando consiga este objetivo iré por otro de añadir un botón físico que se pueda activar y desactivar WLAN directemente sin entrar en las opciones por vía Web.

Saludo.
 
¿Qué otro router exactamente usabas antes para conectar al router principal? Seguramente no era un router con entrada ADSL-RJ11 sino con etrada Ethernet-RJ45 ¿verdad?
 
Arriba