Problemas: VT (virtualization technology) y Firmware UEFI

#1
Buenas a tod@s!
Estoy usando un emulador de android en mi pc con windows 10 y me pide que habilite la VT (virtualization technology).
Lo primero, me descargo un programa que me detecte si mi bios y sistema operativo sea compatible con la VT y sí, es compatible.
Lo "unico" que tengo que hacer es meterme en la bios y habilitarla, y eso hago, me voy a la bios, la habilito, salvo los cambios y reinicio... pero no hay forma, me sigue indicando que está desabilitada...

Metiéndome en youtube y viendo tutoriales, siempre hacen lo mismo: van a "configuración" - "recuperación" - "inicio avanzado" - "reiniciar ahora". Una vez que hace el reinicio y entras en la "pantalla azul", le das a "solucionar problemas" - "opciones avanzadas " - y ahora viene el otro problema, yo no tengo la opción de configuración de firmware UEFI.

Es como si windows o el firmware uefi (al no tenerlo), no le dejase a la bios que habilite la virtualización, puesto que como digo, la cambio en bios, reinicio y me dice que está desabilitada...

Espero que alguien me pueda ayudar, por poner datos;

windows 10 pro 64 bits (actualizado a 11-01-2020) version 10.0.18363
Placa base Asus P8H61-M
micro intel i3-3220
8 gigas de ram
nvidia 1050
compatibilidad con Hyper-v (lo ponian en algunos tutoriales): Sí

Como dato, la bios de la placa ASUS no es como las de antes, pantalla azul y moverse con las flechas del teclado, la mia es en un entorno gráfico diferente, con gráficos avanzados y con el ratón habilitado.

Perdón por la chapa, pero lo veo tan súmamente fácil en los tutoriales... pero parece que tengo una version de windows 10 de otro mundo...
 
#2
Hola garfiox. Gracias por registrarte en ADSLZone.

Ese entorno gráfico que dices es precisamente el EFI/UEFI es un entorno avanzado mejorado respecto a lo que eran las BIOS clásicas.

Las tecnologías de virtualización dependiendo el procesador, depende del UEFI están en distintos sitios. Aunque generalmente están en las opciones avanzadas de los núcleos del procesador.

Si activas la opción y guardas los cambios, y luego en realidad no los guardas. Algo raro pasa. Seguro que ya lo hiciste, pero para grabar los cambios hay que darle a la tecla F10, generalmente. Porque también puedes salir sin guardar realmente los cambios. En cualquier caso deberían grabarse los cambios. Y prueba si lo de no dejarte cambiar la opción es sólo en el tema de la virtualización o es en otras opciones. Por qué si es así es que el problema es con la UEFI/BIOS.

Salu2
 
#3
Gracias por la respuestas y perdón por la tardanza, pero he pillado una buena gripe....
Al fin entendí lo de UEFI, pero no entiendo porqué a todos los windows 10 que veo le sale esa opcion cuando le das a reiniciar y a mi no, teniendo en cuenta que mi placa ya es "antigua".
La bios me va bien, porque en navidades me compré un SSD y dejé mi antiguo HDD de almacén, tuve que cambiar la secuencia de arranque y sin ningún problema... seguiré investigando y ya te contaré.
 
#4
Hola garfiox. No me refería al Windows 10 si no a la configuración de la BIOS/UEFI. Cuando sales de ella le tienes que dar a F10 los cambios, si no no te los guarda.

A ver te explico exactamente por el manual de la placa (aunque no se el modelo exacto, por que hay varios). Tienes que entrar en la UEFI y darle a la tecla F7 para activar el "Modo avanzado/Advanced Mode". Vas a ver como cambia todo el entorno gráfico con más opciones. Una de las pestañas tiene el icono o imagen de un ordenador (Advanced/Avanzado). Aquí tendrás varias opciones. La primera es donde tenemos que ir (CPU Configuration o Configuración de la CPU), que es la que hace referencia a la CPU. Cuando hagas click ahí vas a ver unas cuantas opciones más. Fíjate en una que ponga algo como Intel Virtualization Technology (dale a Enabled, o Activar). Después guardas con F10 y le das a Yes o Sí.

El ordenador se reiniciará y en teoría ya está con eso.

Salu2
 
#5
Si, claro que sí, le hago un save changes.

A ver, tengo bastante experiencia montando redes, equipos y demás, PERO sólo hasta windows xp y ya la verdad es que no tengo ni tiempo ni ganas de estar tan "al día".

Me he metido en el regedit, en el panel de control y todo está aparentemente bien, he reseteado desde el cmd (bcdedit) el VT....pero que mi bios dice que está habilitado y windows me dice que no.

Lo único que me deja dudas es que mi placa es windows8 ready, lo mismo tiene alguna incompatibilidad con win10.
Lo único que me queda es la duda si actualizar bios, pero que yo recuerde, actualizar bios era para compatibilizar ciertas ram´s nuevas y poco más.

Por lo que miro en los foros de windows... hay 1000 formas diferentes, todo un galimatias.
 
#6
Hola garfiox, ¿cual es el programa que usas para emular Android?

Y por cierto comprueba si tienes activado Hyper-V en Windows. Por que si es así no te funcionará ningún emulador que no sea compatible con este. Por ponerte un ejemplo, yo tengo VirtualBox y tengo y la virtualización hardware de AMD, SVM (el equivalente a Intel Virtualization Technology) y no tengo instalado Hyper-V. Por qué no puedes funcionar con dos sistemas de virtualización a la vez, por decirlo fácil.

Hyper-V debe estar desactivado como servicio de Windows. Esto es porque Hyper-V coge el control por completo del sistema y desactiva la virtualización hardware de la UEFI/BIOS. Así que comprueba si está activado y desinstálalo.

Si no es así, el problema puede ser del programa. Como hay varios por eso te pregunto cual usas.

Salu2
 
#7
Buenos dias.
Actualmente uso LDPlayer, antiguamente usé el Bluestacks y tampoco.

Acabo de arreglar el problema.... aunque no lo he arreglado.

Tengo el VT habilitado con el hyper-v habilitado...

He probado de todo, hay casos en los que el antivirus windows defender "bloquea" la posibilidad de habilitar, pero metiendote en el regedit lo solucionas, pero no es mi caso.
A través del panel de control veo que en la pestaña de Hyper-V aparecen 2 opciones;
-herramientas de de administración de Hyper-v (todo marcado)
-plataforma de hyper-v, aquí puede estar el problema, "servicios de hyper-v" lo tengo marcado, PERO "hipervisor hyper-v" no puedo marcarlo porque me dice que "no se puede instalar hyper-v: la compatibilidad con la virtualización está desabilitada en el firmware"...

Como me pasó lo del "firmware" lo que hice fue desabilitar todas las pestañas del hyper-v y seguía sin irme y hoy lo activé todo, esperando que la pestaña "hipervisor hyper-v" no pudiese marcarla y me dejó, reinicié y en el admin. de tareas - rendimiento, me pone habilitado...

En fin, que me va, pero que no tiene sentido...

Muchísimas gracias a todos por vuestro tiempo :)
 
Arriba