Desconexion entre el SurfBeam 2 y un Proxy cache Squid

Desde hace un tiempo he estado haciendo instalaciones de internet satelitales y es lo que tengo en mi casa, hasta ahora, todo sin problemas, por asi decirlo.

Tengo un amigo, que tambien tiene una instalacion, del paquete inexistente ilimitado de Tooway y lo comparte con 7 personas mas, pero ya le aplican muy duro el FAP y en las horas punta, se pone bastante lento.. logico, semanalmente se traga mas de 60 Gb.

Le he instalado un servidor proxy-cache con Squid y con Bind y cache DNS, con el fin de ahorrar al maximo el trafico.....

Resulta, que al colocarle el proxy, entre el router y el SufrBeam2, al rato, deja de tener internet... pensaba que era la maquina.. bueno, he cambiado todo y sigue igual..... cambie las tarjetas de red, pc, e igual....

Me traigo ayer el Pc a mi casa para poder estudiar mejor, y no veo nada en los logs.

Haciendo pruebas me doy cuenta que dejo de ver desde el proxy el modem satelital (SurfBeam2 de ViaSAT), si reinicio la tarjeta de red vuelve a la nromalidad, lo que indicaria que es la tarjeta, pero hecambiado tarjetas y maquinas, por lo que lo descarto.

Si desconecto el cable de Red del modem satelital y lo vuelvo a conectar, vuelve la conexion.... es como si el sufrbeam me baneara por asi decirlo.... el tiempo que ocurre esto es aleatorio....

No le gusta al surfbeam que haya un proxy cache... no lo creo... no lo puede identificar, creo yo..... si a la maquina la conecto directo al modem sin usar software proxy cache NO se desconecta....

Tambien he descartado problema en el surfbeam, ya que ocurre en casa de mi amigo, y en la mia..... asi que...... esperando sus consejos
 
Buenas.

Lo primero que se me viene es la renegociación del leasing DHCP. Asumo que hay IP dinámica en la conexión, por lo que la parte WAN del Squid debe ser Cliente DHCP. Pero como mencionas que es de tiempo aleatorio, quizás no sea esto.

Pienso que deberías montar un sniffer (Wireshark/Ethereal) en esa boca y ve qué circula y cuándo se corta. Si puedes montar u hub (no switch) entre el Squid y el modem y pegar ahí un PC con un sniffer en modo promiscuo sería ideal.

También sería bueno saber si se corta sin haber tráfico.

Slds.
 
Gracias por contestar estimado amigo.
Efectivamente pense lo del DHCP, pero la tarjeta de red NO ha perdido el IP que tiene al comenzar, lo mantiene, incluso, no ha llegado a expirar en algunos casos ni la primera vez.

No he montado el sniffer como tal en el medio con un HUB de lso viejos, o un switch repartiendo todo, pero si lo he hecho localmente en la maquina misma que hace de proxy y a mitad de cualquier trama aleatoria, deja de responder el surfbeam.

Es algo super super extraño.. simplemente no lo ve, como si no tuviera cable, pero si hay link. He cambiado cable, NIC, PC.... y ocurre lo mismo, pero si a la misma maquina le instalo otra cosa, NO ocurre nada......

El Surfbeam SOLO entrega un IP, esta hecho para que conectes un Pc unico, o un router, no entrega mas IP, asi que no es porque sea un solo IP/Mac que lo sature con muchas peticiones, porque esta hecho para eso. Y por otro lado, en casa de mi amigo, esta el router que luego va a una antena y reparte a 7 casas en la zona... con el router va perfecto, siendo este na unica conexion contra el Surfbeam
 
Creo que yo me inclinaría por problemas con el Squid.
Quizás algún parámetro en la instalación.
 
Arriba