Grandstream GXP1620 - llamadas a fijo con línea de cobre.

Buenas.
Tengo un teléfono voip Grandstream GXP1620 que he configurado para Movistar/O2.
El teléfono registra la cuenta y puedo hacer y recibir llamadas de móviles y de fijos (con línea ftth).

El problema viene cuando llamo a un fijo con línea de cobre, no me da el tono de llamada ( en el resto sí ) aunque en pantalla aparece el mensaje de llamando. Por lo visto si que llama pero cuando descuelgan del otro lado no se escucha nada en ninguno de los dos lados.

La verdad es que el teléfono voip tiene menos opciones de configuración que un ata-sip según he visto en otros hilos.
A ver si alguien sabe que puede estar pasando.
Saludos.
 
Suena a problema de codec. Asegúrate de que el equipo tenga el firmware actualizado, y usa PCMA/PCMU como los codecs principales.
Te paso como los tengo yo, en un modelo similar (1625) usando Telsome como proveedor VoIP:

1628501234589.png


Si necesitas cualquier otro dato dime. Creo que lo tengo con la configuración por defecto (o poco más cambiado). Créeme que tiene tantas o más características de configuración que un ATA-SIP.

Saludos!
 
Gracias @pokoyo

Paso captura de tu misma pantalla , algo cambia. A tí te sale la elección de 7 codecs y a mi 5. En mi captura sale la versión de firmware.
Creo que en la configuración del teléfono está marcado las actualizaciones automáticas en caso de haber nueva versión disponible.
Es el primer teléfono voip que tengo y más que nada es por juguetear y tenerlo de reserva.

Captura de pantalla_2021-08-09_11-47-54.png
 
He ido a la web de Grandstream y veo que hay un firmware más actual.
De mi firmware 1.0.2.27 a la versión 1.0.7.13.
Lo he descargado, pero no encuentro la manera de subirlo al teléfono y cargárselo.

Captura de pantalla_2021-08-09_11-59-31.png
 
Simplemente cambia el firmware server path; que esa url que te aparece ahí es vieja y juraría que ya no se usa.

Saludos!
 
Ok. He cambiado el server path a : firmware.grandstream.com
Reboot y ha cargado el nuevo firmware.
Le he hecho un reset de fábrica y voy a configurarlo de nuevo.
A ver que pasa. Más tarde digo algo.
Saludos.
 
Buenas.
Después de actualizar al último firmware y poner las 7 opciones de los codecs en el mismo orden que el pantallazo, sigue funcionando de la misma forma. Cuando se llama a teléfonos fijos en el cual la línea sigue siendo de cobre, fallan las llamadas. En el resto todo correcto.
Saludos.
 
¿"Fijo de cobre" significa que es una línea fija tradicional de Timofónica? Porque si es VoIP a través de ADSL no lo es.
 
Este teléfono, ¿lo tienes conectado al mirktok o es de otro setup? ¿cómo tienes el sip ALG del mikrotik? (export del /ip firewall)

Saludos!
 
¿lo tienes conectado al mirktok o es de otro setup?
Sí, conectado directamente al Mikrotik.

¿cómo tienes el sip ALG del mikrotik?
/ip firewall address-list
add address=192.168.1.151-192.168.1.254 list="Bloquear XXX"
/ip firewall filter
add action=accept chain=input comment="defconf: accept established,related,untracked" connection-state=established,related,untracked
add action=accept chain=input comment="Acepta el trafico de la vlan del telefono" in-interface=vlan3-telefono src-address=10.0.0.0/8
add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input protocol=gre
add action=accept chain=input protocol=ipsec-esp
add action=accept chain=input comment="Allow IPSec IKEv2" dst-port=500,4500 protocol=udp
add action=accept chain=input comment="Allow in-ipsec traffic" ipsec-policy=in,ipsec
add action=accept chain=input comment="Accept vpn encrypted input traffic - LAN machines" ipsec-policy=in,ipsec src-address=192.168.66.0/24
add action=accept chain=input comment="defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related
add action=accept chain=forward comment="defconf: accept established,related, untracked" connection-state=established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
add action=drop chain=forward comment="defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new in-interface-list=WAN
add action=drop chain=forward comment="drop communication from LAN to LAN_OUT" dst-address=192.168.5.0/24 src-address=192.168.1.0/24
add action=drop chain=forward comment="drop communication from LAN_OUT to LAN" dst-address=192.168.1.0/24 src-address=192.168.5.0/24
/ip firewall mangle
add action=set-priority chain=postrouting new-priority=4 out-interface=vlan3-telefono
add action=set-priority chain=postrouting new-priority=1 out-interface=pppoe-out1
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade voz" out-interface=vlan3-telefono
add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=out,none out-interface-list=WAN
add action=masquerade chain=srcnat comment=masquerade-vpn-ikev2 src-address=192.168.66.0/24
add action=dst-nat chain=dstnat comment="Redireccionar DNS a Cloudflare Family" dst-port=53 protocol=udp src-address-list="Bloquear XXX" to-addresses=1.1.1.3 to-ports=53
add action=dst-nat chain=dstnat comment=Qbittorrent dst-port=6655 protocol=tcp to-addresses=192.168.1.60 to-ports=6655
add action=dst-nat chain=dstnat comment=Amule_TCP dst-port=4662 protocol=tcp to-addresses=192.168.1.60 to-ports=4662
add action=dst-nat chain=dstnat comment=Amule_UDP dst-port=4672 protocol=udp to-addresses=192.168.1.60 to-ports=4672
/ip firewall service-port
set sip ports=5060,5070

Captura de pantalla_2021-08-09_14-27-12.png

¿"Fijo de cobre" significa que es una línea fija tradicional de Timofónica? Porque si es VoIP a través de ADSL no lo es.
Me refiero a una línea tradicional, sin adsl ni nada. La línea de cobre de nuestros abuelos.
 
Sí, conectado directamente al Mikrotik.




Ver el adjunto 85131


Me refiero a una línea tradicional, sin adsl ni nada. La línea de cobre de nuestros abuelos.
Probaría con los puertos por defecto (5060,5061) que trae la propia configuración de mikrotik. Si tampoco, probaría deshabilitándolo directamente; hay veces que da más problemas de los que soluciona el SIP ALG.

Pero me da que por ahí no van los tiros. A todas luces, este tipo de problemas suelen ser siempre por una incompatibilidad de los codec de audio entre ambos extremos. Si lo de antes no ayudó, déjalo con la configuración por defecto del mikrotik, y toca el siguiente parámetro en la configuración de audio del teléfono:

Codec Negotiation Priority, y lo cambias de Callee a Caller. Se supone que eso lo que hace es dejar que sea el otro extremo quien negocie el tipo de codec a usar, en lugar de usar la lista que tú has definido, con el orden en el que ahí aparecen.
Quizá simplemente con esa chorrada enganche el que necesita.

Saludos!
 
Pues mira, justo cuando me has contestado me ha dado por deshabilitar SIP ALG en el Mikrotik. Por ver que pasaba.
Voy al teléfono a probar y ahora si que da tono de llamada. No me lo han cogido porque sé que no hay nadie.
Esta noche pruebo de nuevo que ya estarán en casa y digo algo por aquí. De momento ya da tono de llamada correctamente como con los móviles y fijos de ffth.
Saludos y gracias.
 
Acabo de hacer la prueba. Da tono de llamada y al descolgar se escucha perfectamente por las dos partes.
Ahora ya funciona correctamente, era cuestión de deshabilitar SIP-ALG en el Mikrotik.
Muchas gracias.
 
Genial, pues listo, ya lo tienes. ¿Llegaste a probar a dejarlo habilitado, con los puertos que trae por defecto?

Saludos!
 
¿Llegaste a probar a dejarlo habilitado, con los puertos que trae por defecto?
Los que trae por defecto son los de la captura (5060,5070), yo no he cambiado nada en ese apartado. He mirado en el hAP AC2 y también salen los mismos puertos, igual que en el hEX-S.
Saludos.
 
Los que trae por defecto son los de la captura (5060,5070), yo no he cambiado nada en ese apartado. He mirado en el hAP AC2 y también salen los mismos puertos, igual que en el hEX-S.
Saludos.
Nop, eso no es así. Si fuera por defecto, no saldría en el export. Los puertos por defecto son el 5060 y el 5061. Si los pones, verás que ese apartado ya no sale en el export, puesto que es configuración por defecto.

Saludos!
 
Tienes toda la razón, no me acordaba de principios que fue una modificación mía.
Lo he dejado tal cual la configuración por defecto con los puertos 5060 y 5061.

Captura de pantalla_2021-08-10_10-01-22.png

Ahora funciona correctamente todo con la configuración por defecto. :)
Gracias por ayudarme a actualizar el firmware del teléfono, lo compré por Wallapop para probar el voip. Es la primera vez que toco un equipo de estas características.

Saludos.

PD: Podrías editar el hilo de configuraciones básicas para O2 ( https://www.adslzone.net/foro/mikrotik.199/manual-mikrotik-configuraciones-basicas-isps.538786/ ) y eliminar:
# Puertos del servicio voip.
/ip firewall service-port
set sip disabled=yes ports=5060,5070
De ahí vienen mis errores.
 
Genial. Corregido (editado tu post también, para no inducir a error). Con respecto al teléfono IP que has comprado, es canela en rama. Muy básicos, pero prácticamente indestructibles. Ya que el teléfono tiene para configurar dos líneas SIP, te recomiendo enfáticamente que pruebes una de verdad, para que veas de lo que es capaz la tecnología en sí, y no lo que nos "regalan" los operadores. Sácate una cuenta en el proveedor IP que más barato te resulte (me parece que netelip te regala un mes con una numeración) y pruebetea, que tienes para entretenerte un buen rato con ello.

Saludos!
 
Arriba