Freepbx recibir llamadas con extensión fuera de la lan

Hola a todos,
Voy a intentar explicar que me pasa. He instalado un Freepbx en mi casa. Puedo conectar las extensiones y lo he conectado también al trunk de netelip. Todo funciona correctamente. Sin embargo, cuando una extensión está fuera de la lan, aunque se conecta correctamente al freepbx y puede hacer llamadas, no puede recibirlas. Tengo los puertos abiertos en el router.
¿Alguien sabe que puedo hacer?

Un saludo
 
Tengo freepbx desde 2013 funcionando en casa, tambien lo tengo con netelip el fijo y puede ser que te falte una cosa por configurar por eso no te va bien a pesar de tener los puertos abiertos en el router. ¿Tienes ip fija o usas una dns?
 
Voy a intentar explicar que me pasa. He instalado un Freepbx en mi casa. Puedo conectar las extensiones y lo he conectado también al trunk de netelip. Todo funciona correctamente. Sin embargo, cuando una extensión está fuera de la lan, aunque se conecta correctamente al freepbx y puede hacer llamadas, no puede recibirlas. Tengo los puertos abiertos en el router. ¿Alguien sabe que puedo hacer?
¿Cuál es tu ISP? Si es Orange/Jazztel y tienes un Livebox, tendrías que cambiarlo por otro modelo de router.
 
Mira yo tuve ese problema, es mas y hace poco me volvio a pasar porque cambie de proveedor de internet y por no actualizar la ip, me volvio a suceder lo que cuentas.
Tienes que irte dentro de la centralita a Settings / Asterisk Sip Settings
Luego te vas a la pestaña de CHAN_SIP, suponiendo que uses ese sitema, que es por lo general lo que solemos usar.
La clave esta en la primera opcion NAT SETTINGS. Los apartados que aprecen los rellenaras de la siguiente forma:

Tienes que dejar NAT en YES.

IP CONFIGURATION : Ahi vas a marcar en funcion de lo que tengas, si usas una dns tipo dyndns para actualizar tu ip no fija seleccionaras DYNAMIC IP o si tienes ip fija pues STATIC IP.

Por ultimo, en funcion de lo que hayas seleccionado en el campo anterior, si elegiste STATIC IP, se te muestra el apartado para completar llamado "Override External IP" donde meteras tu IP fija y si por el contrario ha saleccionado DYNAMIC IP, se te mostrara el apartado "Dynamic Host" donde ahí meteras tu dns, ejemplo pbx.no-ip.com, xxxx.dyndns.org... o lo que tengas...

Esto que te he comentado es fundamental y obligatorio tenerlo en condiciones tal cual te he escrito, de lo contrario, por mucho puerto que abras, jamas te funcionaran de forma correcta las extensiones remotas, dandote fallos en el audio siempre.

Ya nos cuentas si es que no lo has solucionado ya...
 
Voy a intentar explicar que me pasa. He instalado un Freepbx en mi casa. Puedo conectar las extensiones y lo he conectado también al trunk de netelip. Todo funciona correctamente. Sin embargo, cuando una extensión está fuera de la lan, aunque se conecta correctamente al freepbx y puede hacer llamadas, no puede recibirlas. Tengo los puertos abiertos en el router. ¿Alguien sabe que puedo hacer?
¿Cuál es tu ISP? Si es Orange/Jazztel y tienes un Livebox, tendrías que cambiarlo por otro modelo de router.
Tengo O2 con hgu. Lo puse en modo Bridge y he conectado un asus 68u. Ip dinámica y uso los ddns de cloudflare. Sigo con el mismo problema...

Enviado desde mi Mi 9T Pro mediante Tapatalk
 
Pues echa un vistazo a eso que te cuento y nos dices, te aseguro que si ese apartado no esta bien, jamas te va a funcionar una extension remota, palabra
 
Arriba