MANUAL: FTTH Movistar/Jazztel/Orange con router Ubiquiti Edg

Si, bueno, es que eso tiene su historia detrás.
Cuando empezabamos si querías tener VOD había que indicar con esa regla que enviase el trafico a la IP que tenga el decodificador, y solo a un unico decodificador.

Despues compilamos un helper que existía de NAT para el RTSP (protocolo que usa en el VOD), para que automaticamente sin necesidad de esa regla, crease "al vuelo" un mapeo de puerto/IP cada vez cuando se solicitase un video por VOD. Con lo que ya se podía tener la funcionalidad en varios decos.

Por ultimo, los propios de ubiquiti acabaron añadiendo el helper en el EdgeOS, con lo que simplemente con el comando "set system conntrack modules rtsp enable" ya tenías lo mismo que con el script+modulos compilados. Si tienes eso en la config, que supongo que si, pues no hace falta esa regla.
Hola Begepeich, estupendo, es lo que entendía. Sí, el RTSP helper lo tengo activo, de hecho tengo 3 descos funcionando simultáneamente sin problemas, incluso con VOD. Muchas gracias por tu respuesta.

Pensando en lo que has comentado de compilar el módulo helper al no tenerlo el sistema en su momento, no se podría hacer lo mismo con IGMP Snooping? Creo que es lo que le falta a los Edgerouter para ser perfectos para Movistar, en mi caso.

Gracias de nuevo, saludos.
 
Hola, alguien ha probado a poner dos interfaces downstream en el IGMP Proxy? En lugar de hacerlo al switch?

Yo lo he hecho en un ER-X y funcionan los dos descos conectados a cada uno de esos interfaces, pero pasadas unas horas o incluso 1 día, en uno de ellos se congela la imagen, cambias de canal y a los 5 segundos se congela otra vez. Creo que pasa cuando tienes apagado el desco tiempo y al encenderlo parece que ya no pilla bien el multicast. Es raro que funcione unas horas y después en uno de ellos se congela la imagen, a veces en los dos.

Hay alguna limitación de movistar para no poder tener más de una interfaz como downstream? o faltará alguna configuración? Cuando utilizo sólo una sola interfaz downstream funciona perfectamente.

Esto me vendría bien porque me interesa tener 2 redes distintas separadas, cada una con su desco.

Gracias, saludos,
 
Hola Begepeich, estupendo, es lo que entendía. Sí, el RTSP helper lo tengo activo, de hecho tengo 3 descos funcionando simultáneamente sin problemas, incluso con VOD. Muchas gracias por tu respuesta.

Pensando en lo que has comentado de compilar el módulo helper al no tenerlo el sistema en su momento, no se podría hacer lo mismo con IGMP Snooping? Creo que es lo que le falta a los Edgerouter para ser perfectos para Movistar, en mi caso.

Gracias de nuevo, saludos.

En el ER-X existen unos comandos de bajo nivel para el switch donde aparece algo de igmpsnoop, que no son del edgeos, puedes probar a cacharrear para ver si te deja. Lo unico que luego no es persistente a no ser que los dejes metidos en un script en carpeta tipica de "post-config.d"

El comando este que esta ahí:
/sbin/switch
 
En el ER-X existen unos comandos de bajo nivel para el switch donde aparece algo de igmpsnoop, que no son del edgeos, puedes probar a cacharrear para ver si te deja. Lo unico que luego no es persistente a no ser que los dejes metidos en un script en carpeta tipica de "post-config.d"

El comando este que esta ahí:
/sbin/switch
Gracias, lo he revisado y al parecer ese comando ya no está en esa ruta. Por lo que he leído lo han quitado en las últimas versiones.
 
Buenas a todos.

Recientemente me he hecho con un router Ubiquiti edgerouter 12p, y estoy intentando configurarlo para sustituir al hgu de movistar.

Ya he configurado la ont (ubiquiti nano g) y me funciona perfectamente, el router recibe internet y funciona. El problema viene con el teléfono voip. Dispongo de un adaptador Grandstream ht801 que también he configurado con los valores de movistar, excepto que no registra.

Para conectarlo al router he creado una vlan con id 3 , ip dhcp en el puerto 8 del router (del 0 al 7 están en switch, y en el 9 viene internet, también en vlan).

Si alguien me puede orientar con la configuración, ya que las que he intentado de aquí no me funcionan ( no hay firmware 1.8 para este router ni tiene el mismo número de puertos de ninguna configuración de aquí, que yo haya visto) lo agradecería, ya que como digo internet va perfecto pero no consigo hacer funcionar el voip.

Por si sirve, el router lo configuré con el wizard en basic settings.



Gracias!
 
Buenas a todos.

Recientemente me he hecho con un router Ubiquiti edgerouter 12p, y estoy intentando configurarlo para sustituir al hgu de movistar.

Ya he configurado la ont (ubiquiti nano g) y me funciona perfectamente, el router recibe internet y funciona. El problema viene con el teléfono voip. Dispongo de un adaptador Grandstream ht801 que también he configurado con los valores de movistar, excepto que no registra.

Para conectarlo al router he creado una vlan con id 3 , ip dhcp en el puerto 8 del router (del 0 al 7 están en switch, y en el 9 viene internet, también en vlan).

Si alguien me puede orientar con la configuración, ya que las que he intentado de aquí no me funcionan ( no hay firmware 1.8 para este router ni tiene el mismo número de puertos de ninguna configuración de aquí, que yo haya visto) lo agradecería, ya que como digo internet va perfecto pero no consigo hacer funcionar el voip.

Por si sirve, el router lo configuré con el wizard en basic settings.



Gracias!

El Grandstream no hace falta que lo conectes en un puerto distinto a los que ya tienes como switch, y tampoco necesita un DHCP a parte.

Si en el puerto 9 es por donde te llega internet será en el que va conectado la ONT, internet llega con la vlan 6, la voip llegaría con la vlan 3 por ahí.

- Te añades el subinterfaz en la eth9 con la vlan 3 que corresponde, con ip automatica
- Añades el rip para apreder la rutas de voip
- Activas un nat de salida por esa interfaz.

Por el CLI todo esto sería:

configure
set interfaces ethernet eth9 vif 3 address dhcp
set interfaces ethernet eth9 vif 3 description Voip
set interfaces ethernet eth9 vif 3 dhcp-options default-route no-update
set interfaces ethernet eth9 vif 3 egress-qos '0:4 1:4 2:4 3:4 4:4 5:4 6:4 7:4'
set protocols rip interface eth9.3
set protocols rip passive-interface default
set service nat rule 5001 description Masq_Voip
set service nat rule 5001 log disable
set service nat rule 5001 outbound-interface eth9.3
set service nat rule 5001 protocol all
save;exit
 
El Grandstream no hace falta que lo conectes en un puerto distinto a los que ya tienes como switch, y tampoco necesita un DHCP a parte.

Si en el puerto 9 es por donde te llega internet será en el que va conectado la ONT, internet llega con la vlan 6, la voip llegaría con la vlan 3 por ahí.

- Te añades el subinterfaz en la eth9 con la vlan 3 que corresponde, con ip automatica
- Añades el rip para apreder la rutas de voip
- Activas un nat de salida por esa interfaz.

Por el CLI todo esto sería:
Ostras muchas gracias por responder tan rápido, en cuanto pueda disponer de la red lo pruebo y te digo!!
 
Buenas pues mi gozo en un pozo, debo hacer algo mal. he entrado por putty , he copiado tal cual y me da error:


Pre-authentication banner message from server:
| Welcome to EdgeOS
|
| By logging in, accessing, or using the Ubiquiti product, you
| acknowledge that you have read and understood the Ubiquiti
| License Agreement (available in the Web UI at, by default,
| http://192.168.1.1) and agree to be bound by its terms.
|
End of banner message from server
ubnt@192.168.1.1's password:
Linux EdgeRouter-12P 4.9.79-UBNT #1 SMP Mon Jul 8 06:16:44 UTC 2019 mips64
Boot image can be upgraded to version [ e303_003_6be37 ].
Run "add system boot-image" to upgrade boot image.
Last login: Mon Feb 8 17:12:36 2021 from 192.168.2.38
ubnt@EdgeRouter-12P:~$ configure
[edit]
ubnt@EdgeRouter-12P# set interfaces ethernet eth9 vif 3 address dhcp
[edit]
ubnt@EdgeRouter-12P# set interfaces ethernet eth9 vif 3 description Voip
[edit]
ubnt@EdgeRouter-12P# set interfaces ethernet eth9 vif 3 dhcp-options default-rou te no-update
[edit]
ubnt@EdgeRouter-12P# set interfaces ethernet eth9 vif 3 egress-qos '0:4 1:4 2:4 3:4 4:4 5:4 6:4 7:4'
[edit]
ubnt@EdgeRouter-12P# set protocols rip interface eth9.3
[edit]
ubnt@EdgeRouter-12P# set protocols rip passive-interface default
[edit]
ubnt@EdgeRouter-12P# set service nat rule 5001 description Masq_Voip
[edit]
ubnt@EdgeRouter-12P# set service nat rule 5001 log disable
[edit]
ubnt@EdgeRouter-12P# set service nat rule 5001 outbound-interface eth9.3
[edit]
ubnt@EdgeRouter-12P# set service nat rule 5001 protocol all
[edit]
ubnt@EdgeRouter-12P# save
Warning: you have uncommitted changes that will not be saved.

Saving configuration to '/config/config.boot'...
Done
[edit]
ubnt@EdgeRouter-12P# exit
Cannot exit: configuration modified.
Use 'exit discard' to discard the changes and exit.
[edit]
ubnt@EdgeRouter-12P#
 
Ah si, perdón, te lo dice el propio equipo, se me ja olvidado ponerte el commit
Pon ese comando: commit antes del save
Bueno pues parece que funciona!, pero extrañamente sólo va si conecto el Voip en el puerto 8 (que no me parece mal, así tengo libres los puertos en switch para todo lo demás).
Por otra parte curiosamente me va más lento internet, con el hgu casí llega al giga simétrico, mientras que con el ubiquiti con ésta configuración me da 750 de bajada y 604 de subida. ¿Debería configurar algo más?
Gracias! Dejo aquí la config, de paso por si le sirve a alguien.

Edito: he actualizado el router a la versión 2.0.9 hotfix y ya alcanza casi el giga simétrico!

Una consulta más: dispongo de un punto de acceso ubiquiti Uac AC lr, el cual en el hgu conectaba directamente a un puerto switch del router. ¿Entiendo que en el ubiquiti he de hacer lo mismo, o debería cambiar algo para optimizar?

Muchas gracias!

Código:
firewall {
    all-ping enable
    broadcast-ping disable
    ipv6-receive-redirects disable
    ipv6-src-route disable
    ip-src-route disable
    log-martians enable
    options {
        mss-clamp {
            mss 1412
        }
    }
    receive-redirects disable
    send-redirects enable
    source-validation disable
    syn-cookies enable
}
interfaces {
    ethernet eth0 {
        description Local
        duplex auto
        speed auto
    }
    ethernet eth1 {
        description Local
        duplex auto
        speed auto
    }
    ethernet eth2 {
        description Local
        duplex auto
        speed auto
    }
    ethernet eth3 {
        description Local
        duplex auto
        speed auto
    }
    ethernet eth4 {
        description Local
        duplex auto
        speed auto
    }
    ethernet eth5 {
        description Local
        duplex auto
        speed auto
    }
    ethernet eth6 {
        description Local
        duplex auto
        speed auto
    }
    ethernet eth7 {
        description Local
        duplex auto
        speed auto
    }
    ethernet eth8 {
        address 192.168.1.1/24
        description Local2
        duplex auto
        speed auto
    }
    ethernet eth9 {
        duplex auto
        speed auto
        vif 3 {
            address dhcp
            description Voip
            dhcp-options {
                default-route no-update
                default-route-distance 210
                name-server update
            }
            egress-qos "0:4 1:4 2:4 3:4 4:4 5:4 6:4 7:4"
        }
        vif 6 {
            description "Internet (PPPoE)"
            pppoe 0 {
                default-route auto
                mtu 1492
                name-server auto
                password adslppp
                user-id adslppp@telefonicanetpa
            }
        }
    }
    ethernet eth10 {
        duplex auto
        speed auto
    }
    ethernet eth11 {
        duplex auto
        speed auto
    }
    loopback lo {
    }
    switch switch0 {
        address 192.168.2.1/24
        description Local
        mtu 1500
        switch-port {
            interface eth0 {
            }
            interface eth1 {
            }
            interface eth2 {
            }
            interface eth3 {
            }
            interface eth4 {
            }
            interface eth5 {
            }
            interface eth6 {
            }
            interface eth7 {
            }
            vlan-aware disable
        }
    }
}
protocols {
    rip {
        interface eth9.3
        passive-interface default
    }
}
service {
    dhcp-server {
        disabled false
        hostfile-update disable
        shared-network-name LAN1 {
            authoritative enable
            subnet 192.168.1.0/24 {
                default-router 192.168.1.1
                dns-server 192.168.1.1
                lease 86400
                start 192.168.1.38 {
                    stop 192.168.1.243
                }
            }
        }
        shared-network-name LAN2 {
            authoritative enable
            subnet 192.168.2.0/24 {
                default-router 192.168.2.1
                dns-server 192.168.2.1
                lease 86400
                start 192.168.2.38 {
                    stop 192.168.2.243
                }
            }
        }
        static-arp disable
        use-dnsmasq disable
    }
    dns {
        forwarding {
            cache-size 150
            listen-on eth8
            listen-on switch0
        }
    }
    gui {
        http-port 80
        https-port 443
        older-ciphers enable
    }
    nat {
        rule 5010 {
            description "masquerade for WAN"
            outbound-interface pppoe0
            type masquerade
        }
        rule 5011 {
            description Masq_Voip
            log disable
            outbound-interface eth9.3
            protocol all
            type masquerade
        }
    }
    ssh {
        port 22
        protocol-version v2
    }
    unms {
    }
}
system {
    analytics-handler {
        send-analytics-report false
    }
    crash-handler {
        send-crash-report false
    }
    host-name ubnt
    login {
        user ubnt {
            authentication {
                encrypted-password $5$RMZv0Ptq.o4uKJej$7fTKum4To28wjHqCBgOo5LDDBL.5V3IAxck/Yb3lwG8
            }
            level admin
        }
    }
    ntp {
        server 0.ubnt.pool.ntp.org {
        }
        server 1.ubnt.pool.ntp.org {
        }
        server 2.ubnt.pool.ntp.org {
        }
        server 3.ubnt.pool.ntp.org {
        }
    }
    offload {
        hwnat disable
        ipv4 {
            forwarding enable
            pppoe enable
            vlan enable
        }
    }
    syslog {
        global {
            facility all {
                level notice
            }
            facility protocols {
                level debug
            }
        }
    }
    time-zone UTC
}


/* Warning: Do not remove the following line. */
/* === vyatta-config-version: "config-management@1:conntrack@1:cron@1:dhcp-relay@1:dhcp-server@4:firewall@5:ipsec@5:nat@3:qos@1:quagga@2:suspend@1:system@5:ubnt-l2tp@1:ubnt-pptp@1:ubnt-udapi-server@1:ubnt-unms@2:ubnt-util@1:vrrp@1:vyatta-netflow@1:webgui@1:webproxy@1:zone-policy@1" === */
/* Release version: v2.0.9-hotfix.1.5371035.210122.1015 */
 
Última edición:
Buenos días!

Creo que ya se por qué solo me conecta el voip en el puerto 8.

En su día asigné ip fija al voip grandstream en rango 192.168.1.39 y claro, resulta que el router tiene 2 redes locales, la 192.168.2.1, en los puertos 0 a 7, y la 192.168.1.1 en el puerto 8. ¿Estoy en lo cierto? Mi pregunta es, ¿se podrían intercambiar de alguna manera, es decir , poner la 192.168.1.1 en los puertos 0-7 y la 192.168.2.1 en el puerto 8?

Saludos!

Edito: simplemente al principio, con el wizard, se intercambian las ip de las redes al crear las lan y a correr!
 
Última edición:
Hola,

Tengo un ER-12 con un ont HG8240H con la correspondiente regla de NAT de enmascaramiento y no consigo acceder vía web a la ONT. Conectándola al PC directamente se puede acceder pero una vez en el router no. Os pasa lo mismo? podéis acceder?

Muchas gracias, saludos,
 
Hola,

Tengo un ER-12 con un ont HG8240H con la correspondiente regla de NAT de enmascaramiento y no consigo acceder vía web a la ONT. Conectándola al PC directamente se puede acceder pero una vez en el router no. Os pasa lo mismo? podéis acceder?

Muchas gracias, saludos,
Buenas, yo para acceder tengo que cambiar el adaptador de red del pc, sino tampoco puedo...
 
Buenas, yo para acceder tengo que cambiar el adaptador de red del pc, sino tampoco puedo...
Tienes la regla de nateo siguiente?

rule 5003 {
description NAT_ONT
destination {
address 192.168.100.0/24
}
log disable
outbound-interface eth0
protocol all
type masquerade
}

Donde eht0 es la interfaz donde tienes puesto el ONT y si está en la 192.168.100.0/24
 
Tienes la regla de nateo siguiente?

rule 5003 {
description NAT_ONT
destination {
address 192.168.100.0/24
}
log disable
outbound-interface eth0
protocol all
type masquerade
}

Donde eht0 es la interfaz donde tienes puesto el ONT y si está en la 192.168.100.0/24
yo solo tengo éstas:
Una pregunta, ¿tú tienes configurado el qos? en el hgu era una casilla y ya pero aquí no sé si es tán fácil, y me han comentado que no va bien en los ubiquiti, sabes algo de esto?...
 

Adjuntos

  • Screenshot_2021-02-19 EdgeOS - EdgeRouter-12P(1).png
    Screenshot_2021-02-19 EdgeOS - EdgeRouter-12P(1).png
    30.1 KB · Visitas: 72
  • Screenshot_2021-02-19 EdgeOS - EdgeRouter-12P.png
    Screenshot_2021-02-19 EdgeOS - EdgeRouter-12P.png
    30.4 KB · Visitas: 69
Tienes la regla de nateo siguiente?

rule 5003 {
description NAT_ONT
destination {
address 192.168.100.0/24
}
log disable
outbound-interface eth0
protocol all
type masquerade
}

Donde eht0 es la interfaz donde tienes puesto el ONT y si está en la 192.168.100.0/24
También se debe tener una ip puesta en esa eth0 dentro del rango de la ONT. Lo comento por si acaso, ya que cualquiera que parta de configuraciones de la guía no tendrán puesta ninguna IP ahí.

Por otro lado, creo que ese rango solo servía para la huawei? Y no estoy seguro si responde siempre o solo cuando le quitabas la fibra, me pierdo un poco con lo que hacia cada modelo de ONT
 
También se debe tener una ip puesta en esa eth0 dentro del rango de la ONT. Lo comento por si acaso, ya que cualquiera que parta de configuraciones de la guía no tendrán puesta ninguna IP ahí.

Por otro lado, creo que ese rango solo servía para la huawei? Y no estoy seguro si responde siempre o solo cuando le quitabas la fibra, me pierdo un poco con lo que hacia cada modelo de ONT
Sí, la ip de la ONT es 192.168.100.1 y a la interfaz del router le tengo puesta 192.168.100.2. Lo que dices de que sólo responde cuando le quitas la fibra me cuadra, de hecho antes tenía una HG8110H y con la misma configuración podía acceder, así que va a ser eso seguro.

Gracias.
 
yo solo tengo éstas:
Una pregunta, ¿tú tienes configurado el qos? en el hgu era una casilla y ya pero aquí no sé si es tán fácil, y me han comentado que no va bien en los ubiquiti, sabes algo de esto?...
Tienes que tener esta también:

1613757286654.png


Pero es lo que dice Begepeich, si es una HG8240H seguramente sólo es accesible cuando tiene quitada la fibra. Antes tenía una HG8110H y sí me funcionaba con esa configuración.

En cuanto al QoS no lo tengo activo, personalmente no me gusta y además no lo hace por hardware por lo que consumirá bastante CPU. Para qué lo necesitas? no tienes suficiente caudal?

Saludos,
 

Adjuntos

  • 1613757274495.png
    1613757274495.png
    33.6 KB · Visitas: 52
Hola buenas a todos,

Tengo un Edgerouter 4 y un Edgerouter 12p con la version de firmware v2.0.9-hotfix.1, el problema que tengo es que con esta versión de
firmware no me deja hacer conexiones VPN PPTP des de clientes con Windows 10,Linux, smartphones o tablets. Lo curioso es que cuando hago un downgrade de la version de firmware a la 1.10.7 me funcionan las VPN por PPTP.

Alguien que se haya econtrado con este problema ? Espero que alguien tenga una solución porque me gustaria tener los routers actualizados a la ultima versión de firmware y con la conexiones VPN PPTP funcionando.

Saludos y gracias!!!
 
Arriba