OPENVNP NO PUEDO ACCEDER A MI ROUTER 192.168.1.1

Buenas, a ver si lo consigo explicar.

En mi router Asus Rt-ac3200 tengo configurado el servidor openvpn. Lo he configurado y lo hago correr en el movil y un pc windows/linux, funciona perfecto, puedo acceder a los diferentes dispostivos de mi casa estando conectando por ejemplo en casa de amigo.

Ahora viene el problema. El router de mi casa tiene la direccion 192.168.1.1 y el de casa la de mi amigo tambien tiene la misma 192.168.1.1. Cuando me conecto en la casa de mi amigo por openvpn a mi router me asigna la ip 10.8.0.x

Si activo openvnp en mi movil, que esta conectado a la wifi de la casa de mi amigo, al poner en el buscador la direccion 192.168.1.1 accedo a mi router y con el cliente ftp al acceder a la direccion 192.168.1.1 accedo al servidor ftp de mi router.

SIn embargo desde mi pc ya sea con S.O. Windows o Linux, al poner en el navegador la direccion 192.168.1.1 accedo al router de casa de mi amigo y con el cliente ftp tambien al router de mi amigo.

Lo que quiero saber es como tengo que hacer para que siempre que conecte por openvpn al escribir la direccion 192.168.1.1 siempre acceda a mi router no al router del que este conectado a su wifi si coincide en la misma direccion

Os copia la configuracion del programa OPENVPN de Windows por si es necesario

float
nobind
proto udp
dev tun
sndbuf 0
rcvbuf 0
keepalive 10 30
auth-user-pass
client
auth SHA512
cipher AES-256-CBC
remote-cert-tls server
 
La más sencilla es cambiando tu segmento de red y no haciéndolo coincidir con ninguno habitual. La otra es añadiendo esta opción al fichero openVPN.
Código:
redirect-gateway def1

Saludos!
 
La más sencilla es cambiando tu segmento de red y no haciéndolo coincidir con ninguno habitual. La otra es añadiendo esta opción al fichero openVPN.
Código:
redirect-gateway def1

Saludos!
Al fichero openvpn te refieres a:

1.Al fichero de configuración que te descargas del servidor openvpn del router asus

2. A la configuración del programa openvpn de Windows

Gracias

Editado: nada olvidalo era una pregunta muy chorra ya entiendo cómo va el tema. Cuando esté en casa de mi amigo probaré a ver si funciona con la que me has dicho. Un salufo y gracias
 
Última edición:
La más sencilla es cambiando tu segmento de red y no haciéndolo coincidir con ninguno habitual. La otra es añadiendo esta opción al fichero openVPN.
Código:
redirect-gateway def1

Saludos!
Buenas, he probado lo que comentaste añadir al fichero de openVpn del cliente , con resultado negativo, sigo igual
Código:
redirect-gateway def1

Por lo que probado añadir lo siguiente con el mismo resultado
Código:
redirect-gateway def1 bypass-dhcp

Tambien probado a añadir en la configuracion del servidor de openvpn , con el mismo resultado

Código:
push "redirect-gateway autolocal"

Lo unico que puedo apartor es que al añadir a alguna de estas opciones el log de openvpn muestra lo siguiente:

hu Nov 10 17:51:56 2022 WARNING: You have specified redirect-gateway and redirect-private at the same time (or the same option multiple times). This is not well supported and may lead to unexpected results

A ver si me pudierais echar una mano porque tu segunda opcion de cambiar el segmento de red me daria bastante trabajo sobre todo en un ordenador que tengo s.o. linux y siguiendo manuales configure temas en relacion a la ip que tenia asiganda y cambiar eso...

Entiendo que tiene que haber alguna manera porque desde el movil no me sucede este problema

Si al final tuviera que cambiar el segmento de red, cual me aconsejas? Y tambie es necesario cambiar la mascara de subred?
 
Arriba