Compartir fibra con mi vecino

Gracias,
tenia que borrar toda la configuración, correcto?
Importo el fichero y me sale:
Ver el adjunto 95337
Dicho esto, los dos routers parecen funcionar correctamente, el de mi vecino conectado al 192.168.88.250 , el mio , el EERO al 192.168.88.253.

no me cuadra, por esto:
Código:
# Cremos dos pools, con una única IP cada uno
/ip pool
add name=pool-micasa ranges=192.168.80.2-192.168.80.254
add name=pool-vecino ranges=192.168.90.2-192.168.90.254
No, no funcionan. O sí, pero no como debería (ahora mismo estáis en la misma red, comunicados). Había un error a la hora de poner las VLANs en los puertos del bridge, los estaba yo añadiendo en lugar de setear las VLANs sobre dichos puertos (si ya están dentro del bridge, como lo están en la config por defecto, no puedes hacer un "add", sino un "set".

Borra la config con un reset, y vuelve a importar este fichero que te mando. Espero no te de más problema (me pillas fuera y no puedo probarlo con un equipo propio)

Saludos!
 

Adjuntos

  • apachas4.rsc.zip
    1.3 KB · Visitas: 43
Gracias Pokoyo,
En primer lugar no tengo ninguna prisa, por lo tanto, cuando puedas...

He subido la ultima configuración que me has pasado, ahora si cuadran las IP, EERO 192.168.80.254 (router 192.168.80.1), Tenda 192.168.90.254 (router 192.168.90.1), pero volvemos al principio, este ultimo se queda en "fallo de conexion" :),:)

Será el router?
 
Me contesto solo, he probado a conectar un router 4G que tenía, poniéndolo en modo router, pero tampoco le da navegación
 

Adjuntos

  • F901176D-2660-4955-80D6-B31C4DFEA2D4.jpeg
    F901176D-2660-4955-80D6-B31C4DFEA2D4.jpeg
    341.6 KB · Visitas: 42
Coño, qué raro. Porque ahora mismo ether2 y ether3 son idénticos. ¿Te funciona si conectas el Tenda a ether2? ¿y si lo conectas a ether4?

Me da que no le gusta el modo de ARP!

Disculpa, que lo que te pasa no es lo normal, por lo general, estas configuraciones tan sencillas salen a la primera. Pero bueno, si no tienes urgencia mejor, así lo afinamos del todo.

Saludos!
 
Con algo así creo que resolverías

Código:
# may/21/2022 19:13:46 by RouterOS 7.2.3
# software id =
#
/interface ethernet
set [ find default-name=ether1 ] comment=WAN
set [ find default-name=ether2 ] comment=Casa
set [ find default-name=ether3 ] comment=Vecino
set [ find default-name=ether4 ] comment="Administracion"
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/ip pool
add comment=Casa name=dhcp_pool0 ranges=192.168.10.2
add comment=Vecino name=dhcp_pool1 ranges=192.168.20.2
add comment=Administracion name=dhcp_pool3 ranges=192.168.30.2
/ip dhcp-server
add address-pool=dhcp_pool0 comment=Casa interface=ether2 name=dhcp1
add address-pool=dhcp_pool1 comment=Vecino interface=ether3 name=dhcp2
add address-pool=dhcp_pool3 comment=Administracion interface=ether4 name=dhcp3
/port
set 0 name=serial0
/interface list member
add interface=ether1 list=WAN
add interface=ether2 list=LAN
add interface=ether3 list=LAN
add interface=ether4 list=LAN
/ip address
add address=192.168.10.1/30 comment=Casa interface=ether2 network=192.168.10.0
add address=192.168.20.1/30 comment=Vecino interface=ether3 network=\
    192.168.20.0
add address=192.168.30.1/30 comment=Administracion interface=ether4 network=\
    192.168.30.0
/ip dhcp-client
add interface=ether1
/ip dhcp-server network
add address=192.168.10.0/30 dns-server=192.168.10.1 gateway=\
    192.168.10.1
add address=192.168.20.0/30 dns-server=192.168.20.1 gateway=\
    192.168.20.1
add address=192.168.30.0/30 dns-server=192.168.30.1 gateway=192.168.30.1
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,1.1.1.1
/ip firewall address-list
add address=192.168.10.0/30 list=MisLAN
add address=192.168.20.0/30 list=MisLAN
/ip firewall filter
add action=accept chain=input comment=\
    "defconf: accept established,related,untracked" connection-state=\
    established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
    invalid
add action=accept chain=input comment="Acepta DNS" dst-port=53 \
    in-interface-list=LAN protocol=udp
add action=drop chain=input comment="LAN DROP" dst-address-list=MisLAN log=yes \
    src-address-list=MisLAN
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
    "defconf: accept to local loopback (for CAPsMAN)" disabled=yes \
    dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
    in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
    ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
    ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related hw-offload=yes
add action=accept chain=forward comment=\
    "defconf: accept established,related, untracked" connection-state=\
    established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
    connection-state=invalid
add action=drop chain=forward comment="LAN DROP" dst-address-list=MisLAN log=\
    yes src-address-list=MisLAN
add action=drop chain=forward comment=\
    "defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
    connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=\
    out,none out-interface-list=WAN
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www address=192.168.30.2/32
set ssh disabled=yes
set api disabled=yes
set winbox address=192.168.30.2/32
set api-ssl disabled=yes
/system identity
set name=Internet
/tool bandwidth-server
set enabled=no
 

Adjuntos

  • vecino.jpg
    vecino.jpg
    100.8 KB · Visitas: 42
Última edición:
Coño, qué raro. Porque ahora mismo ether2 y ether3 son idénticos. ¿Te funciona si conectas el Tenda a ether2? ¿y si lo conectas a ether4?

Me da que no le gusta el modo de ARP!

Disculpa, que lo que te pasa no es lo normal, por lo general, estas configuraciones tan sencillas salen a la primera. Pero bueno, si no tienes urgencia mejor, así lo afinamos del todo.

Saludos!
Si lo conecto a Eth2, no funciona. Si lo conecto a a Eth4 si funciona
 

Adjuntos

  • BE52B4FC-4893-481E-A298-DBC8ECB12916.jpeg
    BE52B4FC-4893-481E-A298-DBC8ECB12916.jpeg
    233.2 KB · Visitas: 37
Con algo así creo que resolverías

Código:
# may/21/2022 19:13:46 by RouterOS 7.2.3
# software id =
#
/interface ethernet
set [ find default-name=ether1 ] comment=WAN
set [ find default-name=ether2 ] comment=Casa
set [ find default-name=ether3 ] comment=Vecino
set [ find default-name=ether4 ] comment="Administracion"
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/ip pool
add comment=Casa name=dhcp_pool0 ranges=192.168.10.2
add comment=Vecino name=dhcp_pool1 ranges=192.168.20.2
add comment=Administracion name=dhcp_pool3 ranges=192.168.30.2
/ip dhcp-server
add address-pool=dhcp_pool0 comment=Casa interface=ether2 name=dhcp1
add address-pool=dhcp_pool1 comment=Vecino interface=ether3 name=dhcp2
add address-pool=dhcp_pool3 comment=Administracion interface=ether4 name=dhcp3
/port
set 0 name=serial0
/interface list member
add interface=ether1 list=WAN
add interface=ether2 list=LAN
add interface=ether3 list=LAN
add interface=ether4 list=LAN
/ip address
add address=192.168.10.1/30 comment=Casa interface=ether2 network=192.168.10.0
add address=192.168.20.1/30 comment=Vecino interface=ether3 network=\
    192.168.20.0
add address=192.168.30.1/30 comment=Administracion interface=ether4 network=\
    192.168.30.0
/ip dhcp-client
add interface=ether1
/ip dhcp-server network
add address=192.168.10.0/30 dns-server=192.168.10.1 gateway=\
    192.168.10.1
add address=192.168.20.0/30 dns-server=192.168.20.1 gateway=\
    192.168.20.1
add address=192.168.30.0/30 dns-server=192.168.30.1 gateway=192.168.30.1
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,1.1.1.1
/ip firewall address-list
add address=192.168.10.0/30 list=MisLAN
add address=192.168.20.0/30 list=MisLAN
/ip firewall filter
add action=accept chain=input comment=\
    "defconf: accept established,related,untracked" connection-state=\
    established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
    invalid
add action=accept chain=input comment="Acepta DNS" dst-port=53 \
    in-interface-list=LAN protocol=udp
add action=drop chain=input comment="LAN DROP" dst-address-list=MisLAN log=yes \
    src-address-list=MisLAN
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
    "defconf: accept to local loopback (for CAPsMAN)" disabled=yes \
    dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
    in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
    ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
    ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related hw-offload=yes
add action=accept chain=forward comment=\
    "defconf: accept established,related, untracked" connection-state=\
    established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
    connection-state=invalid
add action=drop chain=forward comment="LAN DROP" dst-address-list=MisLAN log=\
    yes src-address-list=MisLAN
add action=drop chain=forward comment=\
    "defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
    connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=\
    out,none out-interface-list=WAN
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www address=192.168.30.2/32
set ssh disabled=yes
set api disabled=yes
set winbox address=192.168.30.2/32
set api-ssl disabled=yes
/system identity
set name=Internet
/tool bandwidth-server
set enabled=no
Gracias por tu aportación Santiago. Entiendo que sería borrando toda la configuración anterior, correcto?
 
Gracias por tu aportación Santiago. Entiendo que sería borrando toda la configuración anterior, correcto?
Por supuesto, pero primero mira el código, le puse el extra que para entrar al mikrotik solo podrá ser administrado desde ether4, es decir desde la Red del vecino y la tuya no podrás entrar a administrarlo, sino lo quieres así modificalo.
Yo lo probé en una máquina virtual y funcionaba.
 
Si lo conecto a Eth2, no funciona. Si lo conecto a a Eth4 si funciona
Vale, el ARP, no puede ser otra cosa. Sobre la configuración que tienes, ve a Inteeface > VLAN y edita ambas entradas. En la opción donde pone arp = reply-only, seleccionas “enabled”.
Luego, vas a IP > DHCP Server, y en la primera pestaña, editas las dos entradas correspondientes a “micasa” y “vecino” y desmarcas la opción “Add ARP for Leases”.

Saludos!
 
Buenos días,

misma config que ayer, pero sin reply-only como opción de ARP. En este caso, abres la puerta a que el router que cuelga del mikrotik tenga IP estática.

Si por un casual tampoco te funcionase, la única diferencia que hay ya entre estas dos subredes y la general .88 que se entrega en ether4 y 5 es que las direcciones que entregamos en el DHCP no llevan broadcast (netmask=32), sería cuestión de quitar ese parámetro. Prueba y me dices.

Saludos!
 

Adjuntos

  • apachas5.rsc.zip
    1.3 KB · Visitas: 47
Buenos días,

misma config que ayer, pero sin reply-only como opción de ARP. En este caso, abres la puerta a que el router que cuelga del mikrotik tenga IP estática.

Si por un casual tampoco te funcionase, la única diferencia que hay ya entre estas dos subredes y la general .88 que se entrega en ether4 y 5 es que las direcciones que entregamos en el DHCP no llevan broadcast (netmask=32), sería cuestión de quitar ese parámetro. Prueba y me dices.

Saludos!
Buenos días Pocokoyo.

hasta he dudado del cable, y lo he cambiado, pero no hay manera, lo he probado con los dos (tenda y tplink)
 

Adjuntos

  • 37700DC0-6CB5-4142-ACEA-155BD6E8A001.jpeg
    37700DC0-6CB5-4142-ACEA-155BD6E8A001.jpeg
    285.8 KB · Visitas: 40
Buenos días Pocokoyo.

hasta he dudado del cable, y lo he cambiado, pero no hay manera, lo he probado con los dos (tenda y tplink)
Abre el dhcp server > networks y quita el netmask = 32, dejando ese parámetro vacío. Es lo único que diferencia la subted nueva de la que trae el router.

Saludos!
 
# may/21/2022 19:13:46 by RouterOS 7.2.3
# software id =
#
/interface ethernet
set [ find default-name=ether1 ] comment=WAN
set [ find default-name=ether2 ] comment=Casa
set [ find default-name=ether3 ] comment=Vecino
set [ find default-name=ether4 ] comment="Administracion"
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/ip pool
add comment=Casa name=dhcp_pool0 ranges=192.168.10.2
add comment=Vecino name=dhcp_pool1 ranges=192.168.20.2
add comment=Administracion name=dhcp_pool3 ranges=192.168.30.2
/ip dhcp-server
add address-pool=dhcp_pool0 comment=Casa interface=ether2 name=dhcp1
add address-pool=dhcp_pool1 comment=Vecino interface=ether3 name=dhcp2
add address-pool=dhcp_pool3 comment=Administracion interface=ether4 name=dhcp3
/port
set 0 name=serial0
/interface list member
add interface=ether1 list=WAN
add interface=ether2 list=LAN
add interface=ether3 list=LAN
add interface=ether4 list=LAN
/ip address
add address=192.168.10.1/30 comment=Casa interface=ether2 network=192.168.10.0
add address=192.168.20.1/30 comment=Vecino interface=ether3 network=\
192.168.20.0
add address=192.168.30.1/30 comment=Administracion interface=ether4 network=\
192.168.30.0
/ip dhcp-client
add interface=ether1
/ip dhcp-server network
add address=192.168.10.0/30 dns-server=192.168.10.1 gateway=\
192.168.10.1
add address=192.168.20.0/30 dns-server=192.168.20.1 gateway=\
192.168.20.1
add address=192.168.30.0/30 dns-server=192.168.30.1 gateway=192.168.30.1
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,1.1.1.1
/ip firewall address-list
add address=192.168.10.0/30 list=MisLAN
add address=192.168.20.0/30 list=MisLAN
/ip firewall filter
add action=accept chain=input comment=\
"defconf: accept established,related,untracked" connection-state=\
established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
invalid
add action=accept chain=input comment="Acepta DNS" dst-port=53 \
in-interface-list=LAN protocol=udp
add action=drop chain=input comment="LAN DROP" dst-address-list=MisLAN log=yes \
src-address-list=MisLAN
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
"defconf: accept to local loopback (for CAPsMAN)" disabled=yes \
dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
connection-state=established,related hw-offload=yes
add action=accept chain=forward comment=\
"defconf: accept established,related, untracked" connection-state=\
established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
connection-state=invalid
add action=drop chain=forward comment="LAN DROP" dst-address-list=MisLAN log=\
yes src-address-list=MisLAN
add action=drop chain=forward comment=\
"defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=\
out,none out-interface-list=WAN
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www address=192.168.30.2/32
set ssh disabled=yes
set api disabled=yes
set winbox address=192.168.30.2/32
set api-ssl disabled=yes
/system identity
set name=Internet
/tool bandwidth-server
set enabled=no



[/CODE]
Con esta configuración si funciona, pero veo que asigna la misma ip del router a las dos redes. Estarían completamente aisladas?
 
Abre el dhcp server > networks y quita el netmask = 32, dejando ese parámetro vacío. Es lo único que diferencia la subted nueva de la que trae el router.

Saludos!
Esta tarde hago la prueba, que ya he salido. Te cuento y gracias
 
Con esta configuración si funciona, pero veo que asigna la misma ip del router a las dos redes. Estarían completamente aisladas?
Como la misma IP? en ether2 y ether3 no puede darle la misma ip, ether2 tiene que darte 192.168.10.2 y ether3 192.168.20.2
 
Como la misma IP? en ether2 y ether3 no puede darle la misma ip, ether2 tiene que darte 192.168.10.2 y ether3 192.168.20.2
Me refiero a la ip del router. El problema que he tenido, es que no podía volver a acceder al microtik desde ningún puerto, siempre me rechazaba la conexión. al final tuve que hacer un haré reset
 
Abre el dhcp server > networks y quita el netmask = 32, dejando ese parámetro vacío. Es lo único que diferencia la subted nueva de la que trae el router.

Saludos!
Pokoyo, de esa manera si he podido y funciona perfectamente:). Lo que me pregunto, qué implicaciones tiene respecto a la configuración anterior y lo del ARP?
 
Pokoyo, de esa manera si he podido y funciona perfectamente:). Lo que me pregunto, qué implicaciones tiene respecto a la configuración anterior y lo del ARP?
Que abres la puerta a que ese equipo te configure cualquier otra IP privada a mano. Entregando el ARP por DHCP, fuerzas a que el equipo sólo funcione si pide dirección de manera dinámica, por DHCP.

El /32 en el network del DHCP hace que el equipo no tenga broadcast. Pero se ve que a esos equipos esa config no les vale.

En fin, menos mal que hemos dado con la tecla, porque me estaba volviendo loco. Todas las configuraciones que te he mandado las he probado en algún momento, y las he revisado varias veces. No me encajaba que no te funcionaran. Pero ya veo que hay routers un tanto especialitos...

Lo dicho, prueba esa, y si hace falta las refinamos o lo ajustamos a lo que necesites.

Saludos!
 
Última edición:
Me refiero a la ip del router. El problema que he tenido, es que no podía volver a acceder al microtik desde ningún puerto, siempre me rechazaba la conexión. al final tuve que hacer un haré reset
Para acceder al router tenias que conectarte al ether4, si leiste la configuración deberías ver visto que solo se podía acceder desde esa boca, ni por la LAN tuya ni por la del vecino y como el mikrotik está en tu casa eso no sería una problema y te evitas cualquier intento de acceso a su ADMINISTRACIÓN.
Claro, conectarte directamente al ethr4 con un cable a tu portátil, el router te dará la ip en el rango de 192.168.30.0/30 y podrás acceder desde winbox y desde la web, de tu LAN 192.168.10/30, ni el vecino desde la 192.168.20.0/30 no podrán acceder al router.
 
Última edición:
Para acceder al router tenias que conectarte al ether4, si leiste la configuración deberías ver visto que solo se podía acceder desde esa boca, ni por la LAN tuya ni por la del vecino y como el mikrotik está en tu casa eso no sería una problema y te evitas cualquier intento de acceso a su ADMINISTRACIÓN.
Claro, conectarte directamente al ethr4 con un cable a tu portátil, el router te dará la ip en el rango de 192.168.30.0/30 y podrás acceder desde winbox y desde la web, de tu LAN 192.168.10/30, ni el vecino desde la 192.168.20.0/30 no podrán acceder al router.
Si, lo hice, tanto con el 4 como con el 5. También es verdad que lo intenté con la ip del router (192.168.88.1), pero no había manera, decia que no tenía acceso. Algo mal estaría haciendo.,..
 
Arriba