Compartir fibra con mi vecino

La misma config que la segunda que te mandé (sin VLANs), sin colas, aprovechando el fasttrack. Y con acceso desde el Eero al mikrotik.
Código:
# Sacamos dos puertos del bridge principal
/interface bridge port
remove [find interface=ether2]
remove [find interface=ether3]

# Comentamos dichos puertos,
# ether2 para ti, ether3 para el vecino
# y forzamos a que no tengan aprendan ARP (forzar sólo conexiones dinámicas)
/interface/ethernet
set [find name=ether2] arp=reply-only comment="micasa"
set [find name=ether3] arp=reply-only comment="vecino"

# Direccionamos los puertos independientemente
/ip address
add address=172.16.0.1/30 comment=micasa interface=ether2
add address=172.16.0.5/30 comment=vecino interface=ether3

# Creamos una lista nueva para meter ambas subredes
/interface list
add name=SUBREDES

# Añadimos las dos subredes, la de tu casa y
# la del vecino, a la lista SUBREDES
# la tuya, además, a la lista LAN
# para que tengas acceso al router
/interface list member
add interface=ether2 list=SUBREDES
add interface=ether2 list=LAN
add interface=ether3 list=SUBREDES

# Creamos los servidores DHCP para cada red nueva
# Primero, cremos dos pools, con una única IP cada uno
/ip pool
add name=pool-micasa ranges=172.16.0.2
add name=pool-vecino ranges=172.16.0.6
# A continuación, damos de alta los servidores DHCP
# Añadimos ARP únicamente si se conectan de manera dinámica
/ip dhcp-server
add interface=ether2 name=dhcp-micasa add-arp=yes address-pool=pool-micasa
add interface=ether3 name=dhcp-vecino add-arp=yes address-pool=pool-vecino
# Definimos el tipo de red y un /32 (IP aislada) para la única IP del pool
/ip dhcp-server network
add address=172.16.0.0/30 gateway=172.16.0.1 netmask=32 dns-server=172.16.0.1,1.1.1.1
add address=172.16.0.4/30 gateway=172.16.0.5 netmask=32 dns-server=172.16.0.5,1.1.1.1

# Firewall
# - Permitimos que ambas subredes accedan al servicio DNS del router
# - Incomunicamos ambas subredes entre sí
/ip firewall filter
add action=accept chain=input comment=\
  "dns: subredes pueden usar el servicio DNS cache del router" dst-port=53 protocol=udp \
  in-interface-list=SUBREDES place-before=[find comment="defconf: drop all not coming from LAN"]
add action=reject chain=forward comment=\
  "subredes: aislar ambas subredes entre si" out-interface-list=!WAN \
  reject-with=icmp-net-prohibited in-interface-list=SUBREDES

# Habilitamos el DNS del router y el servicio de caché
/ip dns
set allow-remote-requests=yes servers=1.1.1.1,1.0.0.1

Te adjunto el fichero también. Tan sencillo como darle un reset al equipo (marca si quieres la opción de que te guarde los usuarios creados, si ya borraste el usuario admin y le creaste uno tuyo) y cargar el .rsc una vez accedas a él.

Saludos!
 

Adjuntos

  • apachas3.rsc.zip
    1.5 KB · Visitas: 50
Si vas por la opción de no usar colas de prioridad y usar fasttrack para todo el equipo, incluida la conexión que sale para el vecino, simplemente quítale los filtros a la regla de firewall, los que pone que se use para todo, menos para las lista SUBREDES.

Y, si quieres arrancar desde cero dime, y modificamos el fichero que te mandé con esos dos cambios: quitamos las colas y omitimos desactivar el fasttrack.

Saludos!
Buenos días,
Si, prefiero volver a arrancar desde cero, he toqueteado muchas opciones, sin saber exactamente a qué correspondían, me da miedo haber comprometido la configuración.
Lo que si me gustaría es tener limitada sólo la banda en la conexión eth3 a 500dw/200up, que es lo que pacté, entiendo que no debería de haber más problema.

saludos y gracias
 
La anterior que te he pasado lleva fasttrack, es decir, no lleváis límite ninguno de los dos. El problema de limitarlo sólo a él es que, por narices, te tienes que meter tú también como parte del total del tráfico que se mueve, porque sino te podrías estar tú zampando el 80% de la conexión, y él no recibir lo que le garantizas, si es que vas a jugar con velocidad garantizada, que es lo que planteas (limitarlo es una cosa, garantizarle un flujo de XMbps es otra bien distinta). Si lo que quieres es limitarle y no limitarte tú, se puede, pero no le puedes garantizar nada, si ether2 va a ir vía fasttrack, sin que le afecten las colas.

Yo probaría simplemente así, con fasttrack para ambos. Con semejante conexión, va a ser rara la vez que los dos demandéis tanto tráfico como para que notéis una merma en la conexión. Si luego ves que no va como debe, podemos ir a probar la solución de la PCQ, que simplemente divide la conexión total entre el número de streams que haya conectados, entre dos, en vuestro caso.

Y, sino, no te queda otra que aplicar colas a ambas conexiones, y prescindir del fasttrack. Váis a tener menos velocidad, pero siempre la tendréis garantizada ambos. Se podrían poner garantías de 400/200 (dw/up), y que coja el máximo de la conexión en best effort (cuando el otro no la use).

Saludos!
 
Pues, perfecto. Tienes razón… vamos a probar así y si hay “conflictos” ya estaríamos a tiempo a poner colas o limitaciones.
Una duda, en el último fichero que me has mandado para restablecer después de resetear, no es necesario añadir los primeros 3 pasos?
Crear Vlans, meter la interfaz en la lista wan y añadir el DHCP sobre la Vlan?
 
Pues, perfecto. Tienes razón… vamos a probar así y si hay “conflictos” ya estaríamos a tiempo a poner colas o limitaciones.
Una duda, en el último fichero que me has mandado para restablecer después de resetear, no es necesario añadir los primeros 3 pasos?
Crear Vlans, meter la interfaz en la lista wan y añadir el DHCP sobre la Vlan?
Nada, porque ya hemos descartado que tu conexión vaya sobre ninguna VLAN, estás obteniendo IP pública por DHCP tal cual lo conectas a la ONT, sin mas tagging ni más nada. Así que lo único que te queda es resetear (puedes marcar la opción de que guarde los usuarios "Keep users", pero asegúrate de NO marcar la de "No default configuration", para dejarle que restablezca la config de serie) y aplicar el último .rsc encima. Hecho esto, tú conectarías a ether2 (que tiene acceso al propio router) y tu vecino a ether3 (que sólo sale a internet).

Saludos!
 
Buenas tardes Pokoyo,
he reseteado y vuelto a subir la configuración. Aparentemente mi conexión (eth2) funciona correctamente, sin embargo he conectado potro router a eth3 (vecino), selecciono ip dinámica en la wan, y efectivamente le asigna 172.16.0.6, pero no tiene salida a internet (fallo de conexión).
Si lo conecto al eth4, si funciona, le asigna la ip 192.168.88.254
alguna pista?
 
Última edición:
Qué raro. He revisado la configuración tres veces y es correcta. Lo único que se me ocurre es que no le guste que le demos una IP privada para los DNS. ¿puedes apagar el mikrotik, los otros dos routers y luego encender el mikrotik y luego los otros dos pasados un par de minutos? por si se hubiera quedado pillada la única IP que estamos entregando en el lease.

Por otro lado, para comprobar que no es nada de su router, prueba a enganchar tu Eero a ether3, a ver si funciona o no.

Saludos!
 
No… no hay manera. He invertido el EERO en la Eth3, le ha costado bastante, pero se ha conectado, pillando la ip 172.16.0.6 , navego sin problemas. Sin embargo, el otro router, en el eth2, pilla la 172.16.0.2, pero se queda en “fallo de conexión”.
 

Adjuntos

  • CC5837B1-0E32-4DD3-822F-E015AB64C7C6.png
    CC5837B1-0E32-4DD3-822F-E015AB64C7C6.png
    661.1 KB · Visitas: 42
  • 8C0051C7-D532-4E68-801F-9C73E39E5152.png
    8C0051C7-D532-4E68-801F-9C73E39E5152.png
    510.2 KB · Visitas: 41
Última edición:
lo he conectado directamente a la ONT para probar… y en ese caso, si funciona……
 
Para hacerlo aún más entra versado, he conectado el cable de red a un puerto diferente del WAN del router. Conectadome a la red wifi 2.4g, le asigna al mismo iPad la ip 712.16.0.6 (router 172.16.0.5) y puedo navegar…. Conectadome al wifi 5g, le asigna la ip del router en cuestión (192.168.0.x, router 192.168.0.1) y no puedo navegar….

se me escapa completamente
 
Más pruebas…. He conectado directamente el ordenador a eth3, se queda un buen rato con una ip auto asignada, pero después de unos minutos, coge la IP correcta y puedo navegar …
 

Adjuntos

  • 6DE2C046-D962-4BE0-B861-B94D34DE2E3E.jpeg
    6DE2C046-D962-4BE0-B861-B94D34DE2E3E.jpeg
    93.7 KB · Visitas: 48
  • 98570BFA-B45C-411E-8CB6-1D0948CAC27D.jpeg
    98570BFA-B45C-411E-8CB6-1D0948CAC27D.jpeg
    85 KB · Visitas: 44
No te preocupes, es por el setup que hemos hecho, para una sola IP. Si el router es un poco picajoso a la hora de comprobar la conexión a internet o deja pillada la única IP del pool, pasan estas cosas.
Sabiendo que de entrada no vas a usar colas, añadimos un pool más amplio y DNS públicos, verás como se deja de quejar. O incluso podemos manejar un único pool y meter las interfaces de vuelta en el bridge principal, y simplemente modificar el dhcp para que se asignen IP’s /32, sin broadcast.

Mañana te paso otra alternativa, a ver si le gusta más.

Saludos!
 
No te preocupes, es por el setup que hemos hecho, para una sola IP. Si el router es un poco picajoso a la hora de comprobar la conexión a internet o deja pillada la única IP del pool, pasan estas cosas.
Sabiendo que de entrada no vas a usar colas, añadimos un pool más amplio y DNS públicos, verás como se deja de quejar. O incluso podemos manejar un único pool y meter las interfaces de vuelta en el bridge principal, y simplemente modificar el dhcp para que se asignen IP’s /32, sin broadcast.

Mañana te paso otra alternativa, a ver si le gusta más.

Saludos!
Vale, me estaba volviendo un poco loco. Ya me indicas cuando puedas.
Gracias
 
Vale, me estaba volviendo un poco loco. Ya me indicas cuando puedas.
Gracias
Volvemos al concepto VLANs. Todo en un bridge, con un pool de IP's más amplio y DNS públicos. A ver si así no se queja el router del vecino.
Código:
# Creamos las VLANs que vamos a usar
/interface vlan
add interface=bridge name=micasa vlan-id=80 arp=reply-only
add interface=bridge name=vecino vlan-id=90 arp=reply-only

# Filtramos las VLANs en el bridge
/interface bridge vlan
add bridge=bridge comment=micasa tagged=bridge vlan-ids=80
add bridge=bridge comment=vecino tagged=bridge vlan-ids=90

# Marcamos el puerto 2 para tu vivienda (vlan 80)
# y el puerto 3 para la del vecino (vlan81)
/interface bridge port
add bridge=bridge frame-types=admit-only-untagged-and-priority-tagged \
  interface=ether2 pvid=80
add bridge=bridge frame-types=admit-only-untagged-and-priority-tagged \
  interface=ether3 pvid=90

# Habilitamos el filtrado de VLANs en el bridge principal
/interface bridge
set 0 vlan-filtering=yes

# Creamos una lista nueva para meter ambas VLANs
/interface list
add name=VLANS

# Añadimos las VLANs de tu casa y el vecino
# en la lista VLANs
/interface list member
add interface=micasa list=VLANS
add interface=micasa list=LAN
add interface=vecino list=VLANS

# Direccionamos las dos VLANs
/ip address
add address=192.168.80.1/24 interface=micasa
add address=192.168.90.1/24 interface=vecino

# Cremos dos pools, con una única IP cada uno
/ip pool
add name=pool-micasa ranges=192.168.80.2-192.168.80.254
add name=pool-vecino ranges=192.168.90.2-192.168.90.254

# Creamos los DHCP para ambas vlans
# Añadimos ARP sólo si el cliente usa DHCP
# es decir, prohibimos el setup estático
/ip dhcp-server
add interface=micasa name=dhcp-micasa add-arp=yes address-pool=pool-micasa
add interface=micasa name=dhcp-vecino add-arp=yes address-pool=pool-vecino
# Y las dos redes del DHCP
/ip dhcp-server network
add address=192.168.80.0/24 gateway=192.168.80.1 dns-server=8.8.8.8,8.8.4.4 netmask=32
add address=192.168.90.0/24 gateway=192.168.90.1 dns-server=8.8.8.8,8.8.4.4 netmask=32

# Firewall
# - Incomunicamos ambas VLANs entre sí
/ip firewall filter
add action=reject chain=forward comment=\
  "vlans: isolated" out-interface-list=!WAN \
  reject-with=icmp-net-prohibited in-interface-list=VLANS
 

Adjuntos

  • apachas4.rsc.zip
    1.3 KB · Visitas: 40
Tampoco, con esa configuración ni se conecta el EERO, ni el router del vecino. He vuelto a la configuración de ayer. He visto el siguiente error en el DHCP Server (con la configuración de hoy)
1653123931273.png
 
Última edición:
una vez cargado el fichero de ayer, el router del vecino si que funciona... aunque con esta IP:
1653124504588.png
 
Te paso la última config que te mandé esa mañana, "apachas4.rsc", corrigiendo un pequeño error de copia/pega en del DHCP server del vecino. Resetea el equipo y carga esa config. Si te da algún problema, me dices.

Saludos!
 

Adjuntos

  • apachas4.rsc.zip
    1.3 KB · Visitas: 45
Te paso la última config que te mandé esa mañana, "apachas4.rsc", corrigiendo un pequeño error de copia/pega en del DHCP server del vecino. Resetea el equipo y carga esa config. Si te da algún problema, me dices.

Saludos!
Gracias,
tenia que borrar toda la configuración, correcto?
Importo el fichero y me sale:
1653145270148.png

Dicho esto, los dos routers parecen funcionar correctamente, el de mi vecino conectado al 192.168.88.250 , el mio , el EERO al 192.168.88.253.

no me cuadra, por esto:
Código:
# Cremos dos pools, con una única IP cada uno
/ip pool
add name=pool-micasa ranges=192.168.80.2-192.168.80.254
add name=pool-vecino ranges=192.168.90.2-192.168.90.254
 
Última edición:
Arriba