192.168.1.1 --> 192.168.2.1 -> Puerto 80 abierto en 2º

#1
Hola amig@s.
Tengo un problemilla, a ver si me podéis ayudar.

Datos:
1 Conexión de ADSL, Router de telefónica (con IP FIJA)
1 oficina (2 despachos)
El despacho 2 tiene una red propia con un router/puntodeacceso pero conecta con el router de telefónica para tener Internet

Conexiones:
- 1.er Router de telefónica Zystel (Internet para todos los despachos)
..... 192.168.1.1 (puerta de enlace)
- 2.º Router/puntodeacceso despacho 2 que recibe Internet del router 1
..... 192.168.1.15 (IP de este router) Enlaza con el router de telefónica
..... Genera una nueva red DHCP para 3 ordenadores
..... 192.168.2.1 (puerta de enlace de esta nueva red)
- Uno de esos ordenadores del despacho 2 tiene estos datos
..... 192.168.2.100
..... 255.255.254.0
..... 192.168.2.1

El problema es que en este ordenador (192.168.2.100) tiene que tener el puerto 80 abierto porque hay que poner un IIS para un programa que así le permite conectar fuera de la oficina con dispositivos iPad o iPhone.

Mis pasos han sido:
- Abrir el puerto 80 en el router de telefónica abierto para IP 192.168.1.15 (IP router Despacho 2)
- En el router del despacho 2 he abierto el puerto 80 para 192.168.2.100

Luego he comprobado en una web especial si el puerto está abierto y dice que NO está abierto.
Si solo fuera 1 router esto sería coser y cantar pero como del router de telefónica al router del despacho 2 genera una nueva red, no sé como configurarlo, he probado varias opciones abriendo el puerto para 2.100 o 2.1 y no funciona.

¿Alguna idea de como configurarlo?

Espero haberlo explicado bien.
Muchas gracias por vuestras respuestas y soporte.
Un gran saludo.
Kalko
 
#4
Hola,


Una consulta en la red del router 2 (192.168.2.X) tienes puesta como máscara 255.255.254.0?

Pon 255.255.255.0.

Yo precisamente tengo una configuración como la tuya y a mi me funciona.

Puede ser que te falte una cosa, sería añadir una ruta estática en el router de telefónica para ir a la red 192.168.2.0 a traves de 192.168.1.15 y otra ruta al router de la red 192.168.2.0 para que vaya a la red 192.168.1.0 a traves de 192.168.1.1.

Como te he dicho tengo esta configuración con un FTP y me puedo conectar des de cualquier parte del mundo.

Saludos
 
#5
Muchas gracias por responde Garvarma.
Pondré la máscara en 255.0 pero me he perdido en tu explicación.
"Poner una ruta estática en el router de telefónica"
¿Cómo hago eso? ¿En qué apartado del router?
Pienso que con DHCP no puedo porque está en la red 192.168.1.1 y si cambio el DHCP de telefónica el despacho 1 se queja.
Por más que le doy vueltas no sé donde poner la configuración que me propones.
El el otro post hablan de DMZ pero ahí si que ya me pierdo total

Un saludo y de verdad muchas gracias por vuestra ayuda.
 
#6
Hola,

"Poner una ruta estática en el router de telefónica"
¿Cómo hago eso? ¿En qué apartado del router?
Todos los router tienen una tabla la cual explica que vias existen para llegar a X red. Es decir, un router normalmente tiene varias entradas, Ethernet's, Serie, xDSL, etc. pues en esta tabla se le indica porque interfaz tiene que enviar el paquete P para llegar a la red X.

Entonces, suponiendo que tienes un zyxel si entras a traves de telnet en el menú 12, esta la opción Static Routing Setup y ahi la tienes que añadir. Para el punto de acceso no se que modelo tienes, por lo tanto no te puedo ayudar, aunque mira si existe alguna opción en advancing setup.

El DHCP no tiene nada que ver, Al tener 2 redes debes de tener 2 DHCP, asi que por eso no te preocupes (yo también tengo 2 DHCP).

El el otro post hablan de DMZ pero ahí si que ya me pierdo total
El DMZ es el nombre de zona desmilitarizada, eso quiere decir que cualquier IP de un equipo que pongas en esa zona tendrá todos lo puertos abiertos, pero no todos los routers tienen esa opción DMZ, sobretodo si son antiguos.

Osea que prueba lo de las rutas estáticas.

Saludos
 
#7
Muchas gracias por responder.
El otro router es un aqprox! de 4 puertos con wifi.
No está configurado como punto de enlace, está configurado como nueva red, la 192.168.2.1
Ahora no puedo entrar porque no estoy en esa oficina pero probaré tus enseñanzas en cuanto esté.

Gracias.
Un saludo.
 
#11
Hola Garvarma.
Continúo perdido.
Te doy más datos

Router Telefónica: ZyXEL
LAN
- IP Address: 192.168.1.1
- IP Subnet Mask: 255.255.255.0

DHCP
- Client IP Pool Starting Address: 192.168.1.33
- Size of Cliente IP Pool: 222

NAT --> SUA ONLY
- 80 - 80 - 192.168.1.15 (Abro el puerto 80 para la IP WAN del otro router)
NAT --> FULL Feature (NO he puesto nada)


Router APPROX APPR150 Despacho 2 - 3 ordenadores
Network --> WAN
- IP Address: 192.168.1.15
- Subnet Mask: 255.255.255.0
- Default Geteway: 192.168.1.1

Network --> Lan
- IP Address: 192.168.2.1
- Subnet Mask: 255.255.255.0

DHCP --> Settings
Start IP Address: 192.168.2.100
End IP Address: 192.168.2.199
Default Geteway: 192.168.2.1

Static Routing (Aquí no he puesto nada todavía)
- Destination IP Address:
- Subnet Mask:
- Default Getaway:
- Status: Enabled

Como ves el router APPROX tiene la opción de Static Routing pero no sé que tengo que poner.
Y en el router de telefónica no se tampoco dónde poner el Static Routing. Lo intentaré por telnet pero el NAT Full Feature me confunde.
Tampoco sé exactamente que debo poner en el router de telefónica en el apartado 12

Puedes echarme otro cable.
Te estoy/estaré eternamente agradecido.

Muchas gracias
Un saludo

PD: He entrado por telnet al router de telefónica y me pide
Menú 12 - Static Route Setup
- 1 IP Static Route
- 3 Bridge Static Route
Y en los 2 me pide que ponga una IP
¿Qué pongo y dónde lo pongo?

Muchas gracias por tu tiempo.
Un saludo
 
#12
Hola,

Siguiendo un orden de prioridad/importancia de routers, el de telefonica entrando via telnet tiene la opción de añadir una ruta estatica como me has comentado.

PD: He entrado por telnet al router de telefónica y me pide
Menú 12 - Static Route Setup
- 1 IP Static Route
Te interesa el Static Route, olvidate la opción Bridge, entonces el formato seria algo como:

Route #: 1
Route Name= Entrada1
Active= Yes
Destination IP Address= 192.168.2.0 (RED del APPROX)
IP Subnet Mask= 255.255.255.0
Gateway IP Address= 192.168.1.15 (IP del router APPROX)
Metric= 2
Private= Yes

Luego grabas y sales del telnet y listo.

En el caso del APPROX vas a Static Routing y pones:

- Destination IP Address: 192.168.1.0 (RED Zyxel)
- Subnet Mask:255.255.255.0
- Default Getaway: 192.168.1.1 (IP del router Zyxel)
- Status: Enabled

Grabas y reinicia y en principio ya deberia de estar todo listo.

Para probar que funciona una opción que puedes hacer es entrar al router APPROX des de la red Zyxel, pero a traves de la IP 192.168.2.1 y viceversa, es decir des de un PC de la red APPROX entrar a la interfaz web del Zyxel mediante 192.168.1.1.

saludos
 
#13
Hola.
Gracias por tu ayuda.
Ahora el router APPROX cuando le pongo los datos me dice.

Error code: 4009
Destination IP address can not be in the same subnet with WAN or LAN IP address, please input another one...

Esto lo dice cuando le pongo los datos de la Static Routing
192.168.1.0
255.255.255.0
192.168.1.1

En el de telefónica ha ido todo bien.
He puesto lo que me has dicho por telnet
Tambien he activado el puerto 80 para 192.168.1.15
Y he cambiado el acceso al pueto 80 al router por el de 8080 que he leido por ahí que es mejor cambiarlo para dejar libre la redirección del puerto 80 a 192.168.1.15
También he leido que para lo del puerto 80 los 2 ordenadores tienen que estar conectados por la clavija (RJ45) 1 del router ZyXEL, parece ser que las otras clavijas no hacen eso, pero todavía no lo he cambiado o mirado.
El lío de todo esto es poder abrir el puerto 80 al exterior, pero por ahora nada de nada.

Perdona por molestarte tanto.
Gracias
Un saludo.
Kalko
 
#14
El error es porque en el approx no hace falta poner nada, ya que la red del Zyxel está directamente conectada a una de las interfaces del approx, y por lo tanto ya sabe por dónde tiene que ir.
 
#15
Hola,

Una vez tienes hecha la configuración y comentas que la cosa no funciona ahora te toca probar/descubrir en que parte esta el fallo.

En la tabla de enrutamiento del APPROX en vez de poner la dirección 192.168.1.0 que te da error intenta poner esta entonces: 0.0.0.0 (significa cualquier paquete que vaya fuera de la red 192.168.2.0) que lo envie por 192.168.1.1 o 192.168.1.15.

Y prueba esto. Si no funciona, entonces decantante por la via de probar/descubrir:

Te recomiendo que cojas un portatil, intala un snifer tipo Whiteshark para ver el tráfico que entra y sale en cada una de las redes. Para empezar snifa el tráfico de la red 192.168.1.0 y des de un pc de una red exterior (amigo familiar, etc) que intente acceder por la ip fija a la red privada 192.168.1.0, previamente configurando el port forwarding en el zyxel.

Si esto funciona, repite el paso pero para la red 192.168.2.0 y analiza donde puede estar el fallo.

saludos
 
#16
Hola.
Gracias por la ayuda.
Estoy completamente desesperado.
El otro día probé a conectar directamente a la red del router ZyXEL de telefónica y el puerto 80 dice que no está abierto.
Lo puse en NAT --> SUA only --> Start y End port 80 --> 192.168.1.40
Conecté un ordenador directamente al router teniendo la misma IP en las configuraciones de red de ese ordenador y dice que el puerto 80 NO está abierto.
Para probar si estaba abierto o no, he ido a una web que te dice cómo está el puerto al exterior.
Ya me estoy volviendo loco.
También he hecho esto:
- Telnet - cambiar el romoute management control - WEB de 80 a 8080 porque he leído por ahí que es mejor, cuando quieres abrir el puerto 80 al exterior, para que no haga conflicto. Sobre todo en el ZyXEL

Lo de conectar con el otro router la verdad es que conectar, conecta y todos tienen Internet, pero hasta que no vea el puerto 80 abierto en el de Telefónica no sabré si los 2 routers enlazan bien.
Incluso estoy pensando poner los 2 routers en la misma red y que el APPROX actúe como punto de acceso dentro de la misma 192.168.1.1
Además cuando estuve en la oficina el otro día, resulta que también tienen una centralita/concentrador NEC donde van los cables por la pared a los despachos.
Y no se si ese NEC me está parando algo porque del router va a ese NEC
Como veis estoy hecho un lío.

Perdonar por el rollo.
Un saludo
 
#17
Hola,

Por lo que comentas para empezar el problema está en Zyxel y hasta que no encuentres la solución en ese punto no podrás hacer nada al respeto según la configuración actual.

Buscando por internet he visto esto:

Despues de poner bien el NAT dirigiendo el 80 al pc que actua de servidor web entra por telnet al router, entra a la opcion 24 y dentro de ella a la 8.
Entraras en un interprete de comandos.
Escribe:
ip nat loopback on
exit

Y prueba ahora el servidor web

P.D. Sino puedes probar tambien a escribir ip sua loopback on
y reinicia el router.

Por otro lado en el buscador del foro de Zyxel de esta web busca por la palabra intport que por lo visto un administrador (OGalati) tiene posts en relación al redireccionamiento de puertos en el Zyxel.

saludos
 
#19
Hola.
Después de mil batallas contra el router y con vuestra ayuda, al fin he conseguido derrotarlo, abrir el puerto 80 y redireccionarlo al puesto 15

Los pasos finales han sido estos.
Router ZyXEL P-660HW-D1
- He entrado por telnet al router = 192.168.1.1
- Una vez dentro = Opción 21 - filter set configuration
- Luego = Opción 10 - filtro_gest2
- Después sale una lista del 1 al 6 y vamos a la opción 4 = puerto 80
- En la siguiente pantalla tenemos otra lista de los datos del puerto 80 y en la segunda línea pone "Active = Yes", vamos hasta esa línea con los cursores y damos a la barra espaciadora para cambiarlo por Active = NO.
- Luego damos varios enters hasta que lo graba en la ROM del router.

Y ya está, ya hemos desactivado el puerto 80 que este router lo pone difícil al ponerle varios filtros.
El resto puede ser con el panel normal a través del navegador, poniendo en NAT la IP donde queremos que redireccione el puerto 80.
- NAT --> SUA Only --> 80 - 80 - 192.168.x.x

Un saludo y muchas gracias a todos por vuestra ayuda.
by Kalko
 
#20
Hola soy garvarma, pero escribo des de Moscú si que no me puedo loggear.

Me alegro que todo haya salido bién y hayas dado con el problema.

saludos y hasta otra.
 
Arriba