Obtener la Lista de Canales y Programación de Movistar TV

Hola a todo el mundo, me interesa mucho lo que hace este grabador, me parece una pasada que te genere los canales que tienes contratados, y te descargue la guía e iconos y los integre con TVHeadend. Pero no me queda claro cuales son los pasos a seguir .......
Me he bajado el archivo tv_grab_es_movistartv.py de GitHub lo he editado y he puesto mi región, ahora debería mover el script a /usr/bin y cambiar el propietario y los permisos con los siguientes permisos:
$ sudo mv tv_grab_es_movistartv.py /usr/bin/tv_grab_es_movistartv
$ sudo chown root:root /usr/bin/tv_grab_es_movistartv
$ sudo chmod 755 /usr/bin/tv_grab_es_movistartv
Y aqui ya me pierdo.... ¿Como se ejecuta el script para que genere la lista de canales, descargue la guía y demás?? ¿los primeros pasos que he puesto son los correctos??
 
Buenas, al ejecutar el script para obtener el listado de canales me da error:
pi@raspberrypi:/home/hts $ sudo tv_grab_es_movistartv --m3u /home/pi/ Excepción: 'NoneType' object has no attribute '__getitem__' Traceback: Traceback (most recent call last): File "/usr/bin/tv_grab_es_movistartv", line 1195, in <module> xdata = iptv.get_service_provider_data() File "/usr/bin/tv_grab_es_movistartv", line 804, in get_service_provider_data self.__get_epg_data(connection['mcast_grp'], connection['mcast_port']) File "/usr/bin/tv_grab_es_movistartv", line 796, in __get_epg_data 'channels': self.__get_channels(xml['2_0']), TypeError: 'NoneType' object has no attribute '__getitem__'

Lo he reportado en el canal oficial, no obstante lo dejo aquí por si alguien ha tenido el mismo error.

Además, tengo unas dudas respecto al uso que llevo haciendo de tvheadend y no aparece en el manual de uso. ¿Hay que configurar en una red con el listado m3u de canales que generemos con el script?

¿Alguien me podría pasar el listado de canales para ir avanzando en la configuración?

gracias,
 
Última edición:
Hola,

Estoy intentando usar el tv_grab_es_movistartv para poder acceder a la tv de movistar pero me estoy volviendo loco con el multicast.

Tengo todo montando en OpenWRT, sobre x86-64.

El servidor independiente del addon cerrado de kodi que hay de movistartv me funciona bien dentro de un docker en el que solo tiene acceso al interface de tv (eth0.2 en el host, eth1 dentro del container) y a otro interface creado por el docker (eth0 dentro del container).

El tema es que este servidor funciona si activo la opcion que tiene de hacer multicast a todos los interfaces, con ella desactivada no hay manera. He intentado usar el igmpproxy pero no da resultado.

En el mismo container, con el servidor ese independiente funcionando (haciendo el multicast a todos los interfaces), el tv_grab_es_movistartv también falla.

Las DNS son correctas, todo tira del dnsmasq del host y ruta correctamente las consultas del iptv al 172.26.23.3.

Las rutas las obtengo con bird, tanto dentro como fuera del container:

root ~ $ route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 192.168.144.1 0.0.0.0 UG 0 0 0 pppoe-wan
10.10.0.0 0.0.0.0 255.255.255.0 U 0 0 0 wg0
10.10.0.5 0.0.0.0 255.255.255.255 UH 0 0 0 wg0
10.10.0.6 0.0.0.0 255.255.255.255 UH 0 0 0 wg0
10.20.0.0 0.0.0.0 255.255.255.0 U 0 0 0 wg1
10.20.0.6 0.0.0.0 255.255.255.255 UH 0 0 0 wg1
10.20.0.11 0.0.0.0 255.255.255.255 UH 0 0 0 wg1
10.20.0.12 0.0.0.0 255.255.255.255 UH 0 0 0 wg1
10.23.64.0 0.0.0.0 255.255.192.0 U 0 0 0 eth0.3
10.31.255.128 10.23.64.1 255.255.255.224 UG 0 0 0 eth0.3
10.64.0.0 0.0.0.0 255.224.0.0 U 0 0 0 eth0.2
172.16.0.0 10.64.0.1 255.240.0.0 UG 0 0 0 eth0.2
172.23.96.0 10.64.0.1 255.255.248.0 UG 0 0 0 eth0.2
172.26.22.0 10.64.0.1 255.255.255.192 UG 0 0 0 eth0.2
172.26.23.0 10.64.0.1 255.255.255.224 UG 0 0 0 eth0.2
172.26.80.0 10.64.0.1 255.255.248.0 UG 0 0 0 eth0.2
192.168.0.0 0.0.0.0 255.255.240.0 U 0 0 0 br-21a6284ee557
192.168.16.0 0.0.0.0 255.255.240.0 U 0 0 0 br-a4d17de3c33c
192.168.32.0 0.0.0.0 255.255.240.0 U 0 0 0 br-dee135391ef3
192.168.48.0 0.0.0.0 255.255.240.0 U 0 0 0 br-2b1684154c18
192.168.137.0 0.0.0.0 255.255.255.0 U 0 0 0 br-lan
192.168.144.1 0.0.0.0 255.255.255.255 UH 0 0 0 pppoe-wan
192.168.237.0 0.0.0.0 255.255.255.0 U 0 0 0 docker0

root ~ $ ip mroute
(192.168.137.12,239.255.255.250) Iif: br-lan State: resolved
(172.26.77.130,239.0.5.187) Iif: eth0.2 State: resolved
(192.168.137.5,239.255.255.250) Iif: br-lan State: resolved
(192.168.137.11,239.255.255.250) Iif: br-lan State: resolved
(10.77.251.16,239.254.127.63) Iif: eth0.2 Oifs: br-lan State: resolved
 
Yo también tengo OpenWRT en x86_64, pero uso LXC en vez de Docker, Quagga-RIPd en vez de Bird e IGMPProxy en lugar de lo que uses tú para enrutar el tráfico multicast.

interfaces-openwrt.png

Entiendo que en la LAN todo funciona correctamente, ves la TV por Multicast y demás. El problema lo tienes sólo dentro del router... ¿no?

Podrían ser mil cosas:
  • IGMPProxy (o lo que uses) no está enrutando el tráfico multicast al contenedor
  • Sí lo está haciendo, pero el Firewall no lo deja pasar
  • Un problema en Docker o en Containerd, de configuración o directamente un bug
  • ...
Yo empezaría por el Firewall:

fiewall-openwrt.png


Asegúrate de tener bien definidas las zonas, los reenvíos y las interfaces.
 
Aún sigo probando cosas.

De momento he encontrado algo más que también me choca. Siguiendo dentro del container de docker donde tengo el blob de movistar que funciona mientras haga él el multicast. Dentro de este container, usando mcproxy el blob sigue funcionando pero el video no se reproduce bien, se oye pero se ve la imagen toda corrupta. Pasa aunque tenga activado el MulticastAllInterface en el addon.

Sólo consigo que las rutas salgan bien resueltas con el mcproxy dentro del container y con el omcproxy en el host. Aún así la imagen como te digo llega corrupta.

Estoy tentando de probar el quagga, aunque nunca me pareció un problema de rutas unicast, como prueba que puedo ver bien la tv con el blob. ¿Crees que vale la pena?

En cuanto al igmpproxy, qué pones en altnet para el upstream? En el host tanto igmp como mcproxy producen unresolved status en las rutas multicast.

¿Y qué cambios tienes en el sysctld?

Y lo que uso es kodi en android que conectan con el blob, por el puerto 5000 tcp, o sea, no hay ningún multicast por la lan.
 
Última edición:
Es que no uso nada de lo que usas tú, salvo OpenWRT.

Lo único que te puedo decir es que OpenWRT + LXC + Quagga-RIPd + IGMPProxy funciona perfectamente:
Bash:
xxxxx@xxxxxx:~$ ssh root@router

BusyBox v1.31.1 () built-in shell (ash)
Enter 'help' for a list of built-in commands.
  _______                     ________        __
|       |.-----.-----.-----.|  |  |  |.----.|  |_
|   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
|_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
-----------------------------------------------------
OpenWrt 20.02, Makintos Edition
-----------------------------------------------------
root@router:~# lxc-attach -n xxxxxxx
root@xxxxxxx:~# tail -f .xmltv/tv_grab_es_movistartv.log
[INFO] ---------------------------------------------------
[29/05/2020 22:02:23] [INFO] MovistarTV EPG Grabber
[29/05/2020 22:02:23] [INFO] Parámetros: ['--m3u', 'canales.xml']
[29/05/2020 22:02:23] [INFO] ---------------------------------------------------
[29/05/2020 22:02:23] [DEBUG] Caché: tv_grab_es_movistartv.cookie cargado
[29/05/2020 22:02:23] [INFO] Cookie: JSESSIONID=8AB9499180D3250964CA9C802D737492-node6; Path=/appserver; HttpOnly
[29/05/2020 22:02:23] [DEBUG] Caché: config.json cargado
[29/05/2020 22:02:23] [INFO] tvPackages: UTXC3|UTXCP|UTXF9
[29/05/2020 22:02:23] [INFO] Demarcation: 13
[29/05/2020 22:02:23] [INFO] Buscando el Proveedor de Servicios de Asturias
[29/05/2020 22:02:23] [DEBUG] Caché: provider.json cargado
[29/05/2020 22:02:23] [INFO] Proveedor de Servicios de Asturias: 239.0.2.150
[29/05/2020 22:02:23] [DEBUG] Caché: metadatos de la EPG no encontrados
[29/05/2020 22:02:23] [INFO] Descargando canales, paquetes e índices
[29/05/2020 22:02:23] [DEBUG] Descargando XML de 239.0.2.150:3937
[29/05/2020 22:02:52] [DEBUG] XML: 2_0
[29/05/2020 22:04:31] [DEBUG] XML: 5_0
[29/05/2020 22:04:44] [DEBUG] XML: 6_0
[29/05/2020 22:04:44] [DEBUG] El canal 4803 no tiene la estructura correcta: ('child index out of range',)
[29/05/2020 22:04:44] [DEBUG] El canal 4717 no tiene la estructura correcta: ('child index out of range',)
[29/05/2020 22:04:44] [DEBUG] El canal 4804 no tiene la estructura correcta: ('child index out of range',)
[29/05/2020 22:04:44] [INFO] Canales: 427
[29/05/2020 22:04:44] [INFO] Paquetes: 382
[29/05/2020 22:04:44] [INFO] Días de EPG: 8
[29/05/2020 22:04:44] [DEBUG] Cache: epg_metadata.json guardado
[29/05/2020 22:04:44] [INFO] Lista de canales exportada: canales.xml
Y la configuración, más sencilla imposible...
 
Última edición:
Pues parto de la configuracion de noltari para la configuracion de movistar, con ripd para las rutas. Accedo a la voip desde android sin problema, tanto en la lan como a través de wireguard que uso para los túneles.

En el host tengo udpxy y reparte perfectamente la tv a donde quiera. La lista de canales la genero de lo que genera el blob de movistar que tengo en un container de docker, con default networking más macvlan:

Código:
version: '2.4'

services:
  movistartv:
    build: ./movistartv
    container_name: movistartv
    privileged: true
    restart: on-failure
    #network_mode: host
    #dns:
    #  - '172.26.23.3'
    mac_address: xxxxxxxx
    ports:
      - '192.168.137.1:5000:5000'
    networks:
      default:
      iptv:
        ipv4_address: 10.77.xx.xx
    #extra_hosts:
    #  - "www-60.svc.imagenio.telefonica.net:172.26.23.23"
    volumes:
      - /etc/localtime:/etc/localtime
      - /opt/movistartv:/home/MovistarTV.Server
      - /storage/recordings:/home/MovistarTV.Server/Videos
    cpus: 1
    mem_limit: 512mb
    memswap_limit: 512mb
    healthcheck:
      test: wget http://127.0.0.1:5000/ 2>&1 | grep -q ':5000... connected.'
      interval: 30s
      timeout: 5s
      retries: 3

networks:
  iptv:
    driver: macvlan
    driver_opts:
      parent: eth0.2
    ipam:
      config:
         - subnet: 10.64.0.0/11

Código:
root@xxxxxx ~/dockers/xxxxxx $ docker exec -it movistartv bash                                                                            
root@20d3e27f2b3c:/opt/MovistarTV.Server# ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.X.X  netmask 255.255.240.0  broadcast 192.168.15.255
        ether   txqueuelen 0  (Ethernet)
        RX packets 234980  bytes 16458205 (15.6 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 264254  bytes 1662216302 (1.5 GiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

eth1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.77.X.X  netmask 255.224.0.0  broadcast 10.95.255.255
        ether   txqueuelen 0  (Ethernet)
        RX packets 1216221  bytes 1647824223 (1.5 GiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 3805  bytes 372974 (364.2 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 1002  bytes 72040 (70.3 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1002  bytes 72040 (70.3 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

root@20d3e27f2b3c:/opt/MovistarTV.Server# ps aux
USER       PID %CPU %MEM    VSZ   RSS TTY      STAT START   TIME COMMAND
root         1  0.0  0.0   2384   768 ?        Ss   21:37   0:00 /bin/sh /opt/start.sh
bird        16  0.0  0.0   3008  1904 ?        Ss   21:37   0:00 /usr/sbin/bird -u bird -g bird
root        17  0.0  0.0   6904  3224 ?        S    21:37   0:00 sudo -u nobody -g nogroup tail -f /home/MovistarTV.Server/log/log.txt
nobody      21  0.0  0.0   2324   748 ?        S    21:37   0:00 tail -f /home/MovistarTV.Server/log/log.txt
root        23  0.0  0.0   6904  3240 ?        S<   21:37   0:00 sudo -u nobody -g nogroup HOME=/home /opt/MovistarTV.Server/Kodi_MovistarTV_Server.pvr
nobody      24  3.5  0.4 1458228 66352 ?       S<l  21:37   1:46 /opt/MovistarTV.Server/Kodi_MovistarTV_Server.pvr
root       800  0.5  0.0   3984  3260 pts/0    Ss   22:26   0:00 bash
root       806  0.0  0.0   7636  2788 pts/0    R+   22:26   0:00 ps aux
root@20d3e27f2b3c:/opt/MovistarTV.Server# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.0.1     0.0.0.0         UG    0      0        0 eth0
10.64.0.0       0.0.0.0         255.224.0.0     U     0      0        0 eth1
172.23.96.0     10.64.0.1       255.255.248.0   UG    0      0        0 eth1
172.26.22.0     10.64.0.1       255.255.255.192 UG    0      0        0 eth1
172.26.23.0     10.64.0.1       255.255.255.224 UG    0      0        0 eth1
172.26.80.0     10.64.0.1       255.255.248.0   UG    0      0        0 eth1
192.168.0.0     0.0.0.0         255.255.240.0   U     0      0        0 eth0

Es en este container donde con el blob que hay en sourceforge para el kodi puedo ver la TV. encargándose él de acceder y pasar a la lan (del container) el tráfico multicast. Desde fuera todo pasa por un solo puerto tcp.

El grabber falla, si inicio el mcproxy, el blob pasa a fallar con imagen corrupta y el grabber recibe algún tráfico pero falla también.

Usando host networking falla igual, con el añadido que no puedo activar la opción de hacer muticast en el blob, así que no me funciona nada.
 
Algo más. Usando mcproxy en el container o también pasando a modo host, donde tengo el omcproxy, y sin la opción de pasar el multicast a todos los interfaces, del blob, los útimos 7 días funcionan bien.

Con default networking y mcproxy dentro del container el video en directo lo veo corrupto. Con host networking y el omcproxy directamente no empieza el video en directo. De vez en cuando el omcproxy se queja de
Código:
omcproxy: mrib_mld_source: failed to detect local source address on 8

El grabber falla en todos los casos.
 
Mi /etc/config/network sin los túneles:

Código:
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth1'
        option type 'bridge'
        option proto 'static'
        option igmp_snooping '1'
        option ipaddr '192.168.XX.1'
        option netmask '255.255.255.0'

config interface 'wan'
        option ifname 'eth0.6'
        option proto 'pppoe'
        option username 'adslppp@telefonicanetpa'
        option password 'adslppp'                                                                                                     
        option ipv6 '1'

config interface 'iptv'
        option ifname 'eth0.2'
        option proto 'static'
        option ipaddr '10.77.XX.XX'
        option netmask '255.224.0.0'
        option gateway '10.64.0.1'
        option defaultroute '0'
        option peerdns '0'

config route
        option interface 'iptv'
        option target '172.16.0.0'
        option netmask '255.240.0.0'
        option gateway '10.64.0.1'

config interface 'voip'
        option ifname 'eth0.3'
        option proto 'dhcp'
        option defaultroute '0'
        option peerdns '0'

El /etc/config/firewall, de nuevo sin los túneles:

Código:
config defaults
        option syn_flood '1'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option drop_invalid '1'
        option flow_offloading '0'
        option flow_offloading_hw '0'
        
config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan'
        
config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'wan'
        
config zone
        option name 'iptv'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option network 'iptv'
        option masq '1'
        
config zone
        option name 'voip'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option network 'voip'
        option masq '1'
        option mtu_fix '1'

config rule
        option name 'DSCP_IPTV_UDPXY_IN'
        option src '*'
        option proto 'tcp'
        option dest_port '4022'
        option target 'DSCP'
        list dest_ip '192.168.137.1'
        option family 'ipv4'
        option set_dscp 'CS5'
         
config rule
        option name 'DSCP_IPTV_UDPXY_OUT'
        option proto 'tcp'
        option src_port '4022'
        option target 'DSCP'
        option family 'ipv4'
        list src_ip '192.168.137.1'
        option dest '*'
        option set_dscp 'CS5'
         
config rule
        option name 'DSCP_IPTV_MOVISTARTV_IN'
        option src '*'
        option proto 'tcp'
        option dest_port '5000'
        option target 'DSCP'
        option family 'ipv4'
        option set_dscp 'CS5'
         
config rule
        option name 'DSCP_IPTV_MOVISTARTV_OUT'
        option proto 'tcp'
        option src_port '5000'
        option target 'DSCP'
        option family 'ipv4'
        option set_dscp 'CS5'
        option src '*'
        option dest '*'
         
config rule
        option name 'DSCP_MOVISTARTV'
        option src_port '5000'
        option proto 'tcp'
        option family 'ipv4'
        option target 'DSCP'
        option dest '*'
        option set_dscp 'CS5'
        list src_ip '172.18.0.0/16'
        option src '*'

config rule
        option name 'DSCP_VOIP_IN'
        option src '*'
        option target 'DSCP'
        option family 'ipv4'
        list dest_ip '10.23.64.0/18'
        list dest_ip '10.31.255.0/24'
        list proto 'all'
        option set_dscp 'CS6'


config rule
        option name 'DSCP_VOIP_IN'
        option src '*'
        option target 'DSCP'
        option family 'ipv4'
        list dest_ip '10.23.64.0/18'
        list dest_ip '10.31.255.0/24'
        list proto 'all'
        option set_dscp 'CS6'

config rule
        option name 'DSCP_VOIP_OUT'
        option dest '*'
        option target 'DSCP'
        option family 'ipv4'
        list src_ip '10.23.64.0/18'
        list src_ip '10.31.255.0/24'
        list proto 'all'
        option src '*'
        option set_dscp 'CS6'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'


config forwarding
        option src 'lan'
        option dest 'wan'
         
config forwarding
        option src 'lan'
        option dest 'iptv'
         
config forwarding
        option src 'iptv'
        option dest 'lan'
         
config forwarding
        option src 'lan'
        option dest 'voip'
       
config include
        option path '/etc/firewall.user'

config include 'miniupnpd'
        option type 'script'
        option path '/usr/share/miniupnpd/firewall.include'
        option family 'any'
        option reload '1'
 
Por último un ifconfig del host:

Código:
br-21a6284ee557 Link encap:Ethernet  HWaddr
          inet addr:192.168.0.1  Bcast:192.168.15.255  Mask:255.255.240.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:431743 errors:0 dropped:0 overruns:0 frame:0
          TX packets:404406 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2704721829 (2.5 GiB)  TX bytes:33503132 (31.9 MiB)

br-2b1684154c18 Link encap:Ethernet  HWaddr
          inet addr:192.168.48.1  Bcast:192.168.63.255  Mask:255.255.240.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6 errors:0 dropped:0 overruns:0 frame:0
          TX packets:667 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:220 (220.0 B)  TX bytes:41394 (40.4 KiB)

br-a4d17de3c33c Link encap:Ethernet  HWaddr
          inet addr:192.168.16.1  Bcast:192.168.31.255  Mask:255.255.240.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:111 errors:0 dropped:0 overruns:0 frame:0
          TX packets:827 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:40086 (39.1 KiB)  TX bytes:60023 (58.6 KiB)

br-dee135391ef3 Link encap:Ethernet  HWaddr
          inet addr:192.168.32.1  Bcast:192.168.47.255  Mask:255.255.240.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:666 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:41292 (40.3 KiB)

br-lan    Link encap:Ethernet  HWaddr
          inet addr:192.168.XX.1  Bcast:192.168.137.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1930115 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3303909 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1686404879 (1.5 GiB)  TX bytes:3651480427 (3.4 GiB)

docker0   Link encap:Ethernet  HWaddr
          inet addr:192.168.XX.1  Bcast:192.168.237.255  Mask:255.255.255.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

eth0      Link encap:Ethernet  HWaddr
          inet6 addr: fe80::be5f:f4ff:fe4a:2dce/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2562112 errors:0 dropped:0 overruns:0 frame:0
          TX packets:39340 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:3445830079 (3.2 GiB)  TX bytes:7064585 (6.7 MiB)

eth0.2    Link encap:Ethernet  HWaddr
          inet addr:10.77.XX.XX  Bcast:10.95.255.255  Mask:255.224.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2526845 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10099 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:3391179399 (3.1 GiB)  TX bytes:950460 (928.1 KiB)

eth0.3    Link encap:Ethernet  HWaddr
          inet addr:10.23.XX.XX  Bcast:10.23.127.255  Mask:255.255.192.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:187 errors:0 dropped:0 overruns:0 frame:0
          TX packets:858 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:10314 (10.0 KiB)  TX bytes:54244 (52.9 KiB)

eth0.6    Link encap:Ethernet  HWaddr
          inet6 addr: fe80::be5f:f4ff:fe4a:2dce/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:33996 errors:0 dropped:0 overruns:0 frame:0
          TX packets:28355 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:18712637 (17.8 MiB)  TX bytes:6001236 (5.7 MiB)

eth1      Link encap:Ethernet  HWaddr
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1930292 errors:0 dropped:175 overruns:0 frame:0
          TX packets:3303912 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1690296439 (1.5 GiB)  TX bytes:3677911877 (3.4 GiB)

ifb4pppoe-wan Link encap:Ethernet  HWaddr
          UP BROADCAST RUNNING NOARP  MTU:1500  Metric:1
          RX packets:31928 errors:0 dropped:0 overruns:0 frame:0
          TX packets:31928 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:32
          RX bytes:17853045 (17.0 MiB)  TX bytes:17853045 (17.0 MiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:27021 errors:0 dropped:0 overruns:0 frame:0
          TX packets:27021 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:5523893 (5.2 MiB)  TX bytes:5523893 (5.2 MiB)

pppoe-wan Link encap:Point-to-Point Protocol
          inet addr:XX.XX.XX.XX  P-t-P:192.168.144.1  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:32363 errors:0 dropped:0 overruns:0 frame:0
          TX packets:26716 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:32
          RX bytes:18383932 (17.5 MiB)  TX bytes:5363665 (5.1 MiB)

veth137644f Link encap:Ethernet  HWaddr
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:666 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:41292 (40.3 KiB)

veth38476a8 Link encap:Ethernet  HWaddr
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:667 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:41294 (40.3 KiB)

veth4042dde Link encap:Ethernet  HWaddr
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:8465 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9918 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:5619028 (5.3 MiB)  TX bytes:1379777 (1.3 MiB)

veth78133b9 Link encap:Ethernet  HWaddr
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:9407 errors:0 dropped:0 overruns:0 frame:0
          TX packets:14088 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:950321 (928.0 KiB)  TX bytes:9409261 (8.9 MiB)

veth8b12780 Link encap:Ethernet  HWaddr
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:334 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4431 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:34599 (33.7 KiB)  TX bytes:4656468 (4.4 MiB)

veth97c72c7 Link encap:Ethernet  HWaddr
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6145 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8016 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:8304442 (7.9 MiB)  TX bytes:4432758 (4.2 MiB)

veth98bbf10 Link encap:Ethernet  HWaddr
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1884 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6387 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:152476 (148.9 KiB)  TX bytes:5532168 (5.2 MiB)

vetha464777 Link encap:Ethernet  HWaddr
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:667 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:41294 (40.3 KiB)

vethb2da486 Link encap:Ethernet  HWaddr
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4155 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3279 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:484550 (473.1 KiB)  TX bytes:4175515 (3.9 MiB)

vethb85ca21 Link encap:Ethernet  HWaddr
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:669 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:41418 (40.4 KiB)

vethc37f729 Link encap:Ethernet  HWaddr
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4135 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:4415540 (4.2 MiB)

vethd72f683 Link encap:Ethernet  HWaddr
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3200 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4200 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:3907218 (3.7 MiB)  TX bytes:4211615 (4.0 MiB)

vethe2e1f48 Link encap:Ethernet  HWaddr
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:12298 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11417 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1689151 (1.6 MiB)  TX bytes:5848792 (5.5 MiB)

vethf0fa8b7 Link encap:Ethernet  HWaddr
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2125 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3607 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:169741 (165.7 KiB)  TX bytes:350570 (342.3 KiB)

Y un route del host:
Código:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.144.1   0.0.0.0         UG    0      0        0 pppoe-wan
10.23.64.0      0.0.0.0         255.255.192.0   U     0      0        0 eth0.3
10.31.255.128   10.23.64.1      255.255.255.224 UG    0      0        0 eth0.3
10.64.0.0       0.0.0.0         255.224.0.0     U     0      0        0 eth0.2
172.16.0.0      10.64.0.1       255.240.0.0     UG    0      0        0 eth0.2
172.23.96.0     10.64.0.1       255.255.248.0   UG    0      0        0 eth0.2
172.26.22.0     10.64.0.1       255.255.255.192 UG    0      0        0 eth0.2
172.26.23.0     10.64.0.1       255.255.255.224 UG    0      0        0 eth0.2
172.26.80.0     10.64.0.1       255.255.248.0   UG    0      0        0 eth0.2
192.168.0.0     0.0.0.0         255.255.240.0   U     0      0        0 br-21a6284ee557
192.168.16.0    0.0.0.0         255.255.240.0   U     0      0        0 br-a4d17de3c33c
192.168.32.0    0.0.0.0         255.255.240.0   U     0      0        0 br-dee135391ef3
192.168.48.0    0.0.0.0         255.255.240.0   U     0      0        0 br-2b1684154c18
192.168.XX.0   0.0.0.0         255.255.255.0   U     0      0        0 br-lan
192.168.144.1   0.0.0.0         255.255.255.255 UH    0      0        0 pppoe-wan
192.168.XX.0   0.0.0.0         255.255.255.0   U     0      0        0 docker0
 
Última edición:
No había visto que editaste el post... de momento te respondo a eso, el resto... vas a tener que darme algo de tiempo para verlo todo :D

Quagga en este caso no importa, Bird te está funcionando perfectamente.

La configuración de IGMPProxy (formato OpenWRT):
C:
config igmpproxy
    option quickleave '1'

config phyint
    option network 'iptv'
    option zone 'iptv'
    option direction 'upstream'
    list altnet '172.16.0.0/12'
    list altnet '192.168.1.0/24'

config phyint
    option network 'lan'
    option zone lan
    option direction 'downstream'
iptv es el nombre de la interfaz configurada en "Interfaces" para la VLAN 2

Y produce esta configuración (la real, formato propio de IGMPProxy):
C:
quickleave

phyint eth1.2 upstream ratelimit 0 threshold 1
    altnet 172.16.0.0/12
    altnet 192.168.1.0/24

phyint br-lan downstream ratelimit 0 threshold 1
Ten en cuenta que mis contenedores obtienen la IP a través del servidor DHCP del router como cualquier otro equipo y están asociados a la zona LAN del Firewall.

Luego te digo algo y te pongo mi configuración completa para Movistar, que funciona todo: VoIP, IPTV, los decos oficiales... en la LAN y en los contendores LXC del router.
 
Debo entender que 192.168.1.0/24 es tu br-lan ? O a qué corresponde esa red?

Si es así, usando lo mismo, las rutas multicast me salen unresolved, sin embargo con omcproxy me salen bien. Auqnue bueno, en ningún caso funciona ni el grabber ni la tv en directo con el blob.

Me parece muy interesante eso de que los containers obtengan su ip del router, me pareció muy lioso hacerlo en docker, y lo que no me gustaba es que dejaba menos aisladas las cosas.
 
Última edición:
Con la misma configuración que tú en el igmpproxy, aunque me salen rutas multicast unresolved:

Código:
(192.168.XX.100,239.254.127.63) Iif: eth0.2     Oifs: br-lan  State: resolved
(10.77.251.16,239.255.3.22)      Iif: unresolved  State: unresolved

Consigo lo mismo que con el omcproxy, ver los u7d, incluso el programa en emisión si es desde el principio, pero no los directos, ni tampoco va el grabber. Esto es con el container en modo host.

Código:
Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: Searching for config file at '/var/etc/igmpproxy.conf'                                                                                                                                                             Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: Config: Quick leave mode enabled.                                         Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: Config: Got a phyint token.                                                       Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: Config: IF: Config for interface eth0.2.                                   Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: Config: IF: Got upstream token.                                               Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: Config: IF: Got ratelimit token '0'.                                             Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: Config: IF: Got threshold token '1'.                                           Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: Config: IF: Got altnet token 192.168.XX.0/24.                     Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: Config: IF: Altnet: Parsed altnet to 192.168.XX/24.             Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: IF name : eth0.2                                                                         Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: Next ptr : 0                                                                                 Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: Ratelimit : 0                                                                                 Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: Threshold : 1                                                                               Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: State : 1                                                                                       Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: Allowednet ptr : 98edce60                                                       Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: Config: Got a phyint token.                                                       Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: Config: IF: Config for interface br-lan.                                     Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: Config: IF: Got downstream token.                                         Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: Config: IF: Got ratelimit token '0'.                                             Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: Config: IF: Got threshold token '1'.                                           Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: IF name : br-lan                                                                         Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: Next ptr : 0                                                                                 Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: Ratelimit : 0                                                                                 Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: Threshold : 1                                                                               Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: State : 2                                                                                       Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: Allowednet ptr : 0                                                                     Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: buildIfVc: Interface lo Addr: 127.0.0.1, Flags: 0x0049, Network: 127/8                                                                                                                                              
Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: buildIfVc: Interface br-lan Addr: 192.168.XX.1, Flags: 0x1043, Network: 192.168.XX/24                                                                                                                            
Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: buildIfVc: Interface eth0.2 Addr: 10.77.XX.XX, Flags: 0x1043, Network: 10.64/11                                                                                                                                    
Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: buildIfVc: Interface eth0.3 Addr: 10.23.XX.XX, Flags: 0x1043, Network: 10.23.64/18                                                                                                                                
Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: buildIfVc: Interface pppoe-wan Addr: XXXXXX, Flags: 0x10d1, Network: 192.168.144.1/32                                                                                                                      
Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: buildIfVc: Interface br-21a6284ee557 Addr: 192.168.0.1, Flags: 0x1043, Network: 192.168.0/20                                                                                                                        
Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: buildIfVc: Interface br-2b1684154c18 Addr: 192.168.48.1, Flags: 0x1043, Network: 192.168.48/20                                                                                                                      
Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: buildIfVc: Interface docker0 Addr: 192.168.XX.1, Flags: 0x1003, Network: 192.168.237/24                                                                                                                            
Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: buildIfVc: Interface br-a4d17de3c33c Addr: 192.168.16.1, Flags: 0x1043, Network: 192.168.16/20                                                                                                                      
Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: buildIfVc: Interface br-dee135391ef3 Addr: 192.168.32.1, Flags: 0x1043, Network: 192.168.32/20                                                                                                                      
Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: Found config for br-lan                                                             Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: Found config for eth0.2                                                             Sat May 30 00:07:52 2020 user.notice igmpproxy[30090]: adding VIF, Ix 0 Fl 0x0 IP 0x0189a8c0 br-lan, Threshold: 1, Ratelimit: 0                                                                                                                                          
Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]:         Network for [br-lan] : 192.168.XX/24                           Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: Found upstrem IF #0, will assing as upstream Vif 2               Sat May 30 00:07:52 2020 user.notice igmpproxy[30090]: adding VIF, Ix 1 Fl 0x0 IP 0x10fb4d0a eth0.2, Threshold: 1, Ratelimit: 0                                                                                                                                          
Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]:         Network for [eth0.2] : 10.64/11                                       Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]:         Network for [eth0.2] : 192.168.XX/24                         Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: Got 262144 byte buffer size in 0 iterations                           Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: Joining all-routers group 224.0.0.2 on vif 192.168.XX.1     Sat May 30 00:07:52 2020 user.notice igmpproxy[30090]: joinMcGroup: 224.0.0.2 on br-lan                                           Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: Joining all igmpv3 multicast routers group 224.0.0.22 on vif 192.168.137.1                                                                                                                                          
Sat May 30 00:07:52 2020 user.notice igmpproxy[30090]: joinMcGroup: 224.0.0.22 on br-lan                                         Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: SENT Membership query   from 192.168.XX.1   to 224.0.0.1                                                                                                                                                          
Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: Sent membership query from 192.168.XX.1 to 224.0.0.1. Delay: 10                                                                                                                                                    
Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: Created timeout 1 (#0) - delay 10 secs                                   Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: (Id:1, Time:10)                                                                             Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: Created timeout 2 (#1) - delay 21 secs                                   Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: (Id:1, Time:10)                                                                             Sat May 30 00:07:52 2020 user.debug igmpproxy[30090]: (Id:2, Time:21)                                                                             Sat May 30 00:07:52 2020 user.notice igmpproxy[30090]: RECV Membership query   from 192.168.XX.1   to 224.0.0.1                                                                                                                                                          
Sat May 30 00:07:53 2020 user.notice igmpproxy[30090]: RECV V2 member report   from 192.168.XX.1   to 224.0.0.106
Sat May 30 00:07:53 2020 user.notice igmpproxy[30090]: The IGMP message was from myself. Ignoring.
Sat May 30 00:07:55 2020 user.notice igmpproxy[30090]: RECV V2 member report   from 192.168.XX.1   to 224.0.0.2
Sat May 30 00:07:55 2020 user.notice igmpproxy[30090]: The IGMP message was from myself. Ignoring.
Sat
 
Última edición:
Una duda sobre el contenedor:
Código:
iptv:
        ipv4_address: 10.77.xx.xx
¿Esa IP es la que te ha asignado Movistar para el servicio de IPTV?

Porque en las interfaces de OpenWRT tienes:
Código:
config interface 'iptv'
        option ifname 'eth0.2'
        option proto 'static'
        option ipaddr '10.77.XX.XX'
        [...]
 
Apostaría a que el problema está ahí.

Se supone que esa es la IP "pública" del router para la interfaz IPTV. Si quieres que un equipo detrás de la NAT tenga acceso al tráfico multicast que le llega por esa interfaz, necesitas IGMPProxy/OMCProxy/MCProxy. Pero si estás en el router y tienes acceso directo a la interfaz IPTV no hay nada que enrutar. O uno o lo otro... no sé si me explico ;)

Estoy muy cansado, dame un rato más y te subo mi configuración de OpenWRT.

Y mañana le echo otro ojo.
 
Me habías preguntado por sysctl:

/etc/sysctl.conf
Código:
net.ipv4.conf.all.force_igmp_version = 2
net.nf_conntrack_max = 262144
vm.max_map_count = 262144
Ojo, que tengo 8GB de RAM.
 
Hmm, no, eso sucede en un namespace diferente, tiene diferente mac, es parte de la funcionalidad del macvlan. Es la forma de tener en un container acceso a determinados interfaces de forma directa.

En todo caso, de partida lo usaba con la iptv en el opewnrt con proto none, para evitar eso que dices pero no era necesario.

Además, cuando lo intento en modo host,la ip que se usa es la del openwrt, la interna del docker queda anulada.

No sólo eso, el tcpdump me muestra exactamente el mismo trafico dentro que fuera del container, usando eth0.2 fuera y eth1 dentro. Y el blob de sourceforge funciona perfectamente desde ahí dentro.

Mi sysctl (con 16gb):
Código:
fs.file-max = 4294967296
net.bridge.bridge-nf-call-iptables = 1
net.bridge.bridge-nf-call-ip6tables = 1
net.core.rmem_max = 4194304
net.core.wmem_max = 1048576
net.core.somaxconn = 1048576
net.ipv4.icmp_echo_ignore_broadcasts = 0
net.ipv4.conf.all.force_igmp_version = 2
net.ipv6.conf.all.disable_ipv6 = 1
net.netfilter.nf_conntrack_helper = 1                                                                                                  
#net.netfilter.nf_conntrack_max = 1048576
net.nf_conntrack_max = 1048576
vm.swappiness = 1
 
Última edición:
Arriba