RB951G mode station / tethering usb

Hola.
Tengo un RB951G que quiero conectarlo a una red wifi portátil dada por un móvil.
El problema que tengo es cuando conecto un portátil por cable al router no tengo acceso a internet.
No sé si me he dejado algún paso en la configuración.
Os paso la configuración para ver si veis alguna cosa que falte.
Saludos.
 

Adjuntos

  • RB951G_station.txt
    3.7 KB · Visitas: 15
Tienes seleccionado el modo “station” en la pestaña wireless? Se pone con el flag “R” de running al conectar? Obtiene IP del móvil por dhcp?

Ojo que tienes un cliente dhcp, el del bridge donde va el EoIP, que tiene el “add default route=no”

Saludos!
 
Gracias @pokoyo.

Te pongo unas capturas.

Captura de pantalla_2021-04-08_10-31-23.png
Captura de pantalla_2021-04-08_10-31-07.png
Captura de pantalla_2021-04-08_10-31-39.png

Gracias.
 
Última edición:
Lo veo todo bien tío. Lo único que se me ocurre es que el router tenga conexión a internet y tú no, es decir, que el router o el móvil al que te conectas por encima no te esté entregando un DNS. Para verificarlo, abre la consola del terminal y haz un ping a 8.8.8.8. Si funciona, repitelo con "ping google.com". Si ese último falla, ya sabes dónde tienes el problema, mete en IP -> DNS unos servidores a mano.

Saludos!
 
haz un ping a 8.8.8.8. Si funciona, repitelo con "ping google.com".
Probado en terminal y funcionan las dos formas.
Puede que sea culpa del móvil ya que intentando conectarlo mediante usb también me da problemas, esta vez de conexión al router (interface lte1).
A ver si más adelante puedo probar con otro móvil.
Gracias.
 
Puede que el problema esté aquí. Hay gente que tiene problemas con la zona wifi y el tethering con O2.
Saludos.
 
Dale un pantallazo al APN que tienes configurado en el móvil, porfa. Me resulta extraño porque lo tengo montado igual en el hap-mini que llevo de viaje y funciona sin problemas con O2.

Otra que se me ocurre es hacer la trampa de modificar el TTL, si lo están controlando de esa manera. Básicamente, cuando enchufas un router a una conexión de tipo móvil, los paquetes tendrán un TTL menor que si salieran del propio móvil, puesto que el router ya ha restado -1 en el TTL en el primer salto (del cliente al router). Si la compañía detecta esto, sospecha que estás haciendo tethering y lo puede capar. La trampa la puedes hacer con mangle, aquí te la explican. En tu caso, tu interfaz de salida sería wlan1: https://wiki.mikrotik.com/wiki/Manual:Interface/LTE

Saludos!
 
Pantallazos APN.
Línea pasada de Movistar a O2 sin cambio de tarjeta sim.

Screenshot_2021-04-08-12-18-02-033_com.android.settings.jpgScreenshot_2021-04-08-12-18-07-975_com.android.settings.jpgScreenshot_2021-04-08-12-18-24-578_com.android.settings.jpg



La trampa la puedes hacer con mangle, aquí te la explican.
Código:
/ip firewall mangle
add action=change-ttl chain=postrouting new-ttl=set:65 out-interface=lte1 passthrough=yes
En mi caso cambiando lte1 por wlan1.

Gracias.
 
Última edición:
Lo bueno es que si conecto otro móvil a la zona wifi creada tengo acceso a internet.
Y conectando el portátil directamente a la zona wifi creada también tengo acceso a internet.
Mañana vuelvo a probar y le meto el truco del TTL (/ip firewall mangle).
Saludos.
 
:oops: De lo que se entera uno.
Yo ya lo había dado por imposible (perdí la paciencia y casi la razón intentándolo).
Jamás conseguí colgar un router al wifi del móvil y no comprendía el porqué.

Gracias ambos por sacar a la luz este tema.
Ahora empiezo a entender otras cosas. Que bien.

Mientras esperaba la instalación de fibra no tenía otra que tirar de los datos del
móvil compartiendo vía wifi, pero era un tedio no poder colgarr un router modo estación.
Este truco es super-importante !!!

Saludos.
 
:oops: De lo que se entera uno.
Yo ya lo había dado por imposible (perdí la paciencia y casi la razón intentándolo).
Jamás conseguí colgar un router al wifi del móvil y no comprendía el porqué.

Gracias ambos por sacar a la luz este tema.
Ahora empiezo a entender otras cosas. Que bien.

Mientras esperaba la instalación de fibra no tenía otra que tirar de los datos del
móvil compartiendo vía wifi, pero era un tedio no poder colgarr un router modo estación.
Este truco es super-importante !!!

Saludos.
Pues es por el maldito TTL. Cuando tú mandas un paquete, el ttl está a 64, y si lo recibe el móvil con ese valor, sabe que lo estás mandando desde ese mismo dispositivo. Si lo recibe con 63, sabe que hay un chisme de por medio, porque alguien se ha zampado un salto en el time to live. De ahí que el truco sea ponerle en mangle el contador a 65, para que llegue al móvil con valor 64 y engañes al mismo, pensando que el tráfico viene de él mismo.

Saludos!
 
Buenas.
Ya está todo en marcha y funcionando.
Añadida la regla al mangle.
Al final he vuelto a la configuración inicial que tenía en mente.
Conectar el móvil por usb al router y este que de conexión por los puertos ethernet y por wifi.

Captura de pantalla_2021-04-09_09-29-17.png
Captura de pantalla_2021-04-09_09-32-41.pngCaptura de pantalla_2021-04-09_09-33-06.png

Dejo la configuración por si sirve de ayuda o ejemplo.
Saludos.
 

Adjuntos

  • station-LTE1_v2.rsc.txt
    3.9 KB · Visitas: 14
¿Funciona sin la regla de mangle, o te toca meterla obligatoria para que tire?

Saludos
 
Arriba