Quiero probar con mikrotik

c) Esta regla, esta bien como está ahora:


Sin embargo, pudiera ser, aunque lo dudo, que lo de dst-type-local le molestara. Prueba a ver así:
add action=dst-nat chain=dstnat comment="VOD Desco" in-interface=tivo to-addresses=192.168.0.251
Para aclararte: Esta regla es fundamental que esté, para que le llegue al desco la información, paquetes desde servidores de vídeo bajo demanda. No tienes que deshabilitarla para probar nada, ni es peligroso que no esté, pero si no está, seguro que no te funciona el VOD. La prueba era simplemente quitando temporalmente lo de dst-type-local, o no, pero no tener esa instrucción de especificar que el destino es local, no entraña ningún peligro. Si funcionara grabaciones sin la instrucción, la quitamos y dejamos el resto de la regla. ¿aclarado?
 
Apostaría también por la MAC. No es el primer usuario que necesita la MAC del router de Vodafone a nivel de LAN para que le funcione algún servicio.

Saludos!
 
O espera "a alguien concreto (mac)" el servidor, o nos falta una ruta, porque ahora no veo que le estemos capando el acceso por ningún lado. Lo del DNS no lo descarto tampoco, con esa respuesta. ¿podríamos ver la configuración del desco, por si tuviera por ahí "atornillada" una dirección o DNS con la que espera comunicarse? No tengo ni idea de los descos que usa Vodafone ¿ideas?
Apostaría también por la MAC. No es el primer usuario que necesita la MAC del router de Vodafone a nivel de LAN para que le funcione algún servicio.

Acabo de clonar la mac del sercomm a ether1. Por ahora nada pero falta reiniciarlo
No nada extra de dns ni otras rutas salvo esta imagen de ayer

1610312951392.png




Calla, que no te he dicho la regla que tienes que deshabilitar!!!. ¡Qué despiste!:
jaja pues antes deshabilité la que no era. He deshabilitado ahora. En cuanto pueda cuando reiniciar con la nueva mac pruebo de nuevo

Para aclararte: Esta regla es fundamental que esté, para que le llegue al desco la información, paquetes desde servidores de vídeo bajo demanda. No tienes que deshabilitarla para probar nada, ni es peligroso que no esté, pero si no está, seguro que no te funciona el VOD. La prueba era simplemente quitando temporalmente lo de dst-type-local, o no, pero no tener esa instrucción de especificar que el destino es local, no entraña ningún peligro. Si funcionara grabaciones sin la instrucción, la quitamos y dejamos el resto de la regla. ¿aclarado?
Aclarado, sí
 
Esto lo que está haciendo es un mapeo de puertos. Con la regla NAT:
/ip firewall nat
add action=dst-nat chain=dstnat comment="VOD Desco" dst-address-type=local \
in-interface=tivo to-addresses=192.168.0.251
estamos haciendo algo más bestia: venga lo que venga por la interfaz tivo, se lo enchufamos al desco y que se la apañe.

Podríamos haber hecho el mapeo al puerto 161:
add action=dst-nat chain=dstnat in-interface=tivo protocol=udp src-port=161 to-port=161 to-addresses=192.168.0.251
pero nos faltaría, para ser coherentes, la acción dual en src-nat para cuando el desco iniciara la comunicación, pero para ello necesitaríamos saber la dirección del servidor. De ahí mi pregunta sobre otra dirección del servidor de ¿grabaciones? o una DNS específica para IPTV en Vodafone, a la cual el desco acudiera con un nombre para iniciar el proceso. Por lo que apuntaba el compi de bandaancha.eu, con la regla nat que hemos puesto deberíamos tener de sobra y no haría falta mapear ese puerto (y si hace falta, malo, pues no tenemos la dirección para la regla dual, como decía). ¿Qué opinas, @pokoyo?
 
Yo creo que tu regla de NAT es mucho más genérica que esa y que funcionaría de igual manera.
No obstante, ¿y si esa regla estuviera hecha para mapear el puerto 161 de la interfaz que lleva la conexión a internet, la del PPPoE, por si necesitara algún servicio de la misma? No sé, así pensando a lo loco, que el servidor de grabaciones no viniera por la red del IPTV, sino que resolviera alguna dirección pública por la otra.

Saludos!
 
Yo creo que tu regla de NAT es mucho más genérica que esa y que funcionaría de igual manera.
No obstante, ¿y si esa regla estuviera hecha para mapear el puerto 161 de la interfaz que lleva la conexión a internet, la del PPPoE, por si necesitara algún servicio de la misma? No sé, así pensando a lo loco, que el servidor de grabaciones no viniera por la red del IPTV, sino que resolviera alguna dirección pública por la otra.

Saludos!
Si. También lo he pensado, pero el compi de bandaancha.eu no mencionaba nada de la interfaz de pppoe (vlan100). Solo podríamos abrir el puerto en dst-nat, pero podríamos probar ver... sería añadir:

add action=dst-nat chain=dstnat in-interface=internet protocol=udp src-port=161 to-port=161 to-addresses=192.168.0.251

si quieres, puedes probar, @noriega

Ya nos dices...
 
Hola, probaré lo que comentáis pero voy con retraso

Llevaba toda la tarde intentando encontrar el fallo que hacía que después de clonar la MAC del Sercomm a la interfaz WAN del hAP mini no se viera la imagen de ningún canal, solo cargaba la guía.

Clonado de MAC y no se veía. Vuelvo a la MAC original y tampoco. Restauro backup y lo mismo. Reset completo a la desesperada y restaurado backup con igual resultado. Reviso el último export paso a paso y todo está bien pero la imagen en negro. Por último, restauro un backup anterior que contenía la regla del fw duplicada y lógicamente los canales que no ven la luz. Todo con reinicios del router

Al final me había olvidado de reiniciar la ONT que, como no la tengo junto al router, se me pasó por completo. Mi deducción es que al cambiarle la MAC al router que en teoría está espeando pues necesita reiniciarse.

Horas "perdidas" para una solución de solo unos segundos. No sé si llamarlo torpeza o inexperiencia jeje. Al menos, todo sigue bien.

En cuanto pueda me pongo con lo nuevo

Gracias
 
Si ves que metiendo la MAC en la interfaz que hace de WAN no te sirve, prueba a meterla en el bridge LAN como Admin MAC. Un usuario del foro tuvo ese problema y al final, sigo sin entender porqué, le funcionaba cuando la parte LAN era la que tenía la MAC del router de Vodafone.

Saludos!
 
Si. También lo he pensado, pero el compi de bandaancha.eu no mencionaba nada de la interfaz de pppoe (vlan100). Solo podríamos abrir el puerto en dst-nat, pero podríamos probar ver... sería añadir:

add action=dst-nat chain=dstnat in-interface=internet protocol=udp src-port=161 to-port=161 to-addresses=192.168.0.251

si quieres, puedes probar, @noriega

Ya nos dices...
...pero ten precaución. Estas abriendo el desco a internet abierta, y en el puerto que usa el Simple Network Management Protocol (SNMP, 161). Si ves que no tiene efecto, quita la regla. O al menos, si la vas a dejar un rato largo, ponle un log para que se registre lo que te entra por allí.

Suerte
 
Hola

Sin embargo, pudiera ser, aunque lo dudo, que lo de dst-type-local le molestara. Prueba a ver así:
add action=dst-nat chain=dstnat comment="VOD Desco" in-interface=tivo to-addresses=192.168.0.251
Como no recordaba si había probado o no lo he hecho ahora quitando el dst-address-type=local

add action=drop chain=input comment="defconf: drop all not coming from LAN" \
in-interface-list=!LAN
He deshabilitado unos 30 segundos. Salvo que sea necesario más rato no ha tenido efecto

Si ves que metiendo la MAC en la interfaz que hace de WAN no te sirve, prueba a meterla en el bridge LAN como Admin MAC. Un usuario del foro tuvo ese problema y al final, sigo sin entender porqué, le funcionaba cuando la parte LAN era la que tenía la MAC del router de Vodafone.
Probado con la MAC en el bridge sin resultado

add action=dst-nat chain=dstnat in-interface=internet protocol=udp src-port=161 to-port=161 to-addresses=192.168.0.251
Probado

Creo que no me dejo nada. Si se os ocurre algo más a probar perfecto. A ver si pruebo yo como dije antes a sacar del bridge ether2 y ve si sigue funcionando o no.

Gracias
 
Probado con la MAC en el bridge sin resultado
Vaya. Se resiste el tema... pues deja el mac clonado, en ether1, y todo lo demás como antes de estas últimas pruebas. Haz una puesta en marcha a todo desde frío (ONT, router y desco) y úsalo sin grabaciones durante unas cuantas horas, con normalidad. A ver si pilla finalmente las grabaciones. Como decía antes, el puerto 161 ese que utiliza el desco, es del protocolo SNMP. Con el se pueden configurar cosas en remoto desde la estación maestra al desco (agente). Vamos a dejarle sin marear al sistema, a ver si de una vez le engañamos y se cree que está con el router original, y deja acceder a grabaciones. Lamentablemente, no conozco los entresijos del TiVo, salvo que era un originalmente una especie de TDT con grabador que empezo en UK hace unos años y fue muy popular, adoptándolo Vodafone.

Si vemos que se nos resiste, habría que contactar al compi de bandaancha.eu, a ver si el hizo algo que no dejara documentado.

paciencia. Llegaremos al final.
 
Creo que no me dejo nada. Si se os ocurre algo más a probar perfecto. A ver si pruebo yo como dije antes a sacar del bridge ether2 y ve si sigue funcionando o no.
Una cosa, que no va de lo de intentar que funciones las grabaciones, sino el intento de sacar ether2 del bridge. La vez que reproduje la configuración primera que te subí en mi hAP mini, no se porque, pero no había forma de sacar ether2 del bridge (Con el Webfig, que uso normalmente). Lo sacaba, pero se quedaba dentro, no me hacía caso. Incluso, si insistía, se quedaba medio tieso. Es que, si tocas el bridge, este se reinicia, pero antes me duraba poco ese estado de “pasmado“. Como era tarde el día que hice la configuración tuya, e iba con prisa, me cansé, y hice un script de configuracion y lo subí por el terminal. Te lo aviso, por si se te resiste el tema, y que lo hagas con reglas por el terminal O cargando una configuración tras un reinicio.

Suerte!
 
Tengo que volver a probar a clonar la MAC porque he visto algo diferente.

La MAC clonada es la que recoge MK en Leases. Yo he dado por hecho que era esa pero ¿y si no es esa? La etiqueta de la MAC del Sercomm es otra que además coincide con la MAC que puedo ver en la configuración de LAN del Sercomm. No sé por donde verlo en la configuración del Sercomm, aseguraría que no sale, pero esta que recoge MK pienso que puede ser la de la interfaz WAN ¿tiene sentido?

A ver si puedo probarlo
 
Una cosa, que no va de lo de intentar que funciones las grabaciones, sino el intento de sacar ether2 del bridge. La vez que reproduje la configuración primera que te subí en mi hAP mini, no se porque, pero no había forma de sacar ether2 del bridge (Con el Webfig, que uso normalmente). Lo sacaba, pero se quedaba dentro, no me hacía caso. Incluso, si insistía, se quedaba medio tieso. Es que, si tocas el bridge, este se reinicia, pero antes me duraba poco ese estado de “pasmado“. Como era tarde el día que hice la configuración tuya, e iba con prisa, me cansé, y hice un script de configuracion y lo subí por el terminal. Te lo aviso, por si se te resiste el tema, y que lo hagas con reglas por el terminal O cargando una configuración tras un reinicio.
Bien. Lo iré haciendo desde terminal poco a poco. Agregaré las reglas del fw y si hay algo con lo que no me salgo por aquí acudiré

Gracias
 
Tengo que volver a probar a clonar la MAC porque he visto algo diferente.

La MAC clonada es la que recoge MK en Leases. Yo he dado por hecho que era esa pero ¿y si no es esa? La etiqueta de la MAC del Sercomm es otra que además coincide con la MAC que puedo ver en la configuración de LAN del Sercomm. No sé por donde verlo en la configuración del Sercomm, aseguraría que no sale, pero esta que recoge MK pienso que puede ser la de la interfaz WAN ¿tiene sentido?

A ver si puedo probarlo
Esa es la MAC que te interesa clonar.

Saludos!
 
Hola de nuevo

Por aquí sigo, no me rindo. He estado estos días tratando de investigar por posts de todo tipo. También di con un foro en portugués sobre la TV de Vodafone que han conseguido hacer funcionar con pfsense pero no he sacado nada en claro.

Voy a intentar que funcione la TV conectando el deco al Sercomm, que esto aún no lo he probado, y después continuaré con las grabaciones.

Cualquier mini avance o atasco por completo os voy contando
 
Animo compi, sigo este post con interés porque aunque no me afecte, veo el curro de los compañeros @furny y @pokoyo y como estás devanándote los sesos probando y probando y espero que al final lo consigas!

Además parece que si lo sacas adelante sera un gran avance con el tema de la tv de vodafone y ayudaria a mucha gente.
 
Hola, está igual sin ningún avance. Saqué ether2 del bridge para comprobar si así aún se veía la imagen pero nada. Seguro que algo me falta o me sobra. También dejé el Sercomm como principal y ahí conectado el hAP mini pero no consigo ver los canales.

El problema es que en casa somos bastantes y no es fácil dejar a todos sin red durante tiempo. Por las mañanas y algunas tardes teletrabajo y eso también lo complica. Bastantes días he trasnochado pero entonces no puedo reiniciar ONT y está comprobadísimo que es necesario hacerlo cada vez. Hasta he buscado la opción de reiniciarla a distancia pero nada, lo único que se me ocurre es utilizar un enchufe wifi para eso.

Me da mucha rabia por el curro de los compañeros pero bueno, encontraré el tiempo de algún modo.

Gracias
 
Arriba