Queue Types V7... Probando!!

Para los que busquen la mejor experiencia en juegos online, creo que fq_codel puede ser muy buena opcion.
 
Despues de varias pruebas, para mi el resultado ganador es fq codel

fq codel.png



Que opináis vosotros compis??
 
Estoy probando mas cosillas, el router va a reventar xD

Tengo el marcado y los siguientes ajustes en queue tree, pero cuando le doy chicha a la linea, el iptv se para, no consigo que me reserve sus 30 megas para evitar los cortes.

Se me está escando algo pero no lo veo...
 

Adjuntos

  • QUEUETREEFAILIPTV.PNG
    QUEUETREEFAILIPTV.PNG
    80.1 KB · Visitas: 243
Estoy probando mas cosillas, el router va a reventar xD

Tengo el marcado y los siguientes ajustes en queue tree, pero cuando le doy chicha a la linea, el iptv se para, no consigo que me reserve sus 30 megas para evitar los cortes.

Se me está escando algo pero no lo veo...
Cómo estás marcando paquetes?

Saludos!
 
Cómo estás marcando paquetes?

Saludos!
Te paso export del mangle.

Código:
/ip firewall mangle add action=mark-connection chain=prerouting comment=ICMP connection-state=new new-connection-mark="ICMP - DNS" passthrough=yes protocol=icmp
/ip firewall mangle add action=mark-packet chain=prerouting connection-mark="ICMP - DNS" new-packet-mark="ICMP - DNS_MARK" passthrough=no
/ip firewall mangle add action=mark-connection chain=postrouting connection-state=new new-connection-mark="ICMP - DNS" passthrough=yes protocol=icmp
/ip firewall mangle add action=mark-packet chain=postrouting connection-mark="ICMP - DNS" new-packet-mark="ICMP - DNS_MARK" passthrough=no
/ip firewall mangle add action=mark-connection chain=prerouting comment=DNS connection-state=new dst-port=53 new-connection-mark="ICMP - DNS" passthrough=yes protocol=udp
/ip firewall mangle add action=mark-packet chain=prerouting connection-mark="ICMP - DNS" new-packet-mark="ICMP - DNS_MARK" passthrough=no
/ip firewall mangle add action=mark-connection chain=postrouting connection-state=new dst-port=53 new-connection-mark="ICMP - DNS" passthrough=yes protocol=udp
/ip firewall mangle add action=mark-packet chain=postrouting connection-mark="ICMP - DNS" new-packet-mark="ICMP - DNS_MARK" passthrough=no
/ip firewall mangle add action=mark-connection chain=prerouting comment="XOBX LIVE" connection-mark=no-mark connection-state=new dst-port=!80,443 new-connection-mark="XOBX LIVE" passthrough=yes
protocol=tcp src-address=192.168.30.8/31
/ip firewall mangle add action=mark-connection chain=prerouting comment="XOBX LIVE - UDP" dst-port=!80,443 new-connection-mark="XOBX LIVE" passthrough=yes protocol=udp src-address=192.168.30.8/3
1
/ip firewall mangle add action=mark-packet chain=prerouting connection-mark="XOBX LIVE" new-packet-mark="XOBX LIVE_MARK" passthrough=no
/ip firewall mangle add action=mark-connection chain=prerouting comment="VOZIP - UDP - 5060-5062,10000-10050" dst-port=5060-5062,10000-10050 new-connection-mark=VOZIP passthrough=yes protocol=ud
p
/ip firewall mangle add action=mark-packet chain=prerouting connection-mark=VOZIP new-packet-mark=VOZIP_MARK passthrough=no
/ip firewall mangle add action=mark-connection chain=prerouting comment=IPTV connection-mark=no-mark connection-state=new dst-port=25461 new-connection-mark=IPTV passthrough=yes protocol=tcp
/ip firewall mangle add action=mark-packet chain=prerouting connection-mark=IPTV new-packet-mark=IPTV_MARK passthrough=no
/ip firewall mangle add action=mark-connection chain=prerouting comment=NAVEGACION connection-mark=no-mark connection-state=new dst-port=80,443 new-connection-mark=NAVEGACION passthrough=yes pro
tocol=tcp
/ip firewall mangle add action=mark-connection chain=prerouting comment="STREAMING - DESCARGAS" connection-bytes=5000000-0 connection-mark=NAVEGACION connection-rate=2M-200M new-connection-mark=
"STREAMING / DESCARGAS" passthrough=yes protocol=tcp
/ip firewall mangle add action=mark-packet chain=prerouting comment="STREAMING / DESCARGAS_MARK" connection-mark="STREAMING / DESCARGAS" new-packet-mark="STREAMING / DESCARGAS_MARK" passthrough=
no
/ip firewall mangle add action=mark-packet chain=prerouting comment=NAVEGACION_MARK connection-mark=NAVEGACION new-packet-mark=NAVEGACION_MARK passthrough=no
/ip firewall mangle add action=mark-connection chain=prerouting comment=QUIC connection-state=new dst-port=80,443 new-connection-mark=QUIC passthrough=yes protocol=udp
/ip firewall mangle add action=mark-connection chain=prerouting comment="QUIC_STREAMING / DESCARGAS" connection-bytes=5000000-0 connection-mark=QUIC connection-rate=2M-200M new-connection-mark="
QUIC_STREAMING / DESCARGAS" passthrough=yes protocol=udp
/ip firewall mangle add action=mark-packet chain=prerouting comment=QUIC_MARK connection-mark=QUIC new-packet-mark=QUIC_MARK passthrough=no
/ip firewall mangle add action=mark-packet chain=prerouting comment="QUIC_STREAMING / DESCARGAS_MARK" connection-mark="QUIC_STREAMING / DESCARGAS" new-packet-mark="QUIC_STREAMING / DESCARGAS_MAR
K" passthrough=no
/ip firewall mangle add action=mark-connection chain=prerouting comment=RESTO connection-mark=no-mark connection-state=new new-connection-mark=RESTO passthrough=yes
/ip firewall mangle add action=mark-packet chain=prerouting connection-mark=RESTO new-packet-mark=RESTO_MARK passthrough=no
 
Última edición:
La regla de xbox live con el !80,443 es para que marque todo el trafico menos las descargas de la tienda/actualizaciones, que iría por el trafico STREAMING / DESCARGAS_MARK
 
Estás seguro que el tráfico IPTV es sólo el que va destinado al puerto 25461? Puedes probar a usar mejor el filtro dst-address-type=multicast, a ver qué tal se porta.

Saludos!
 
Estás seguro que el tráfico IPTV es sólo el que va destinado al puerto 25461? Puedes probar a usar mejor el filtro dst-address-type=multicast, a ver qué tal se porta.

Saludos!
Si, siguiendo las conexiones en los dispositivos del iptv es el unico puerto que utiliza. Parece que retocando un poco los ajustes ya no tengo cortes.

2 iptv en dos dispositivos, youtube por otro sitio y 2 consolas encendidas, junto con el pc descargando un archivo de ovh.... 0 cortes.

Código:
/queue tree add max-limit=195M name="DOWNLOAD - QoS - CASA" parent=CASA queue=pcq-download-default
/queue tree add max-limit=195M name="UPLOAD - QoS - CASA" parent="WAN FTTH" queue=pcq-upload-default
/queue tree add name="ICMP - DNS - DOWNLOAD" packet-mark="ICMP - DNS_MARK" parent="DOWNLOAD - QoS - CASA" priority=1 queue=pcq-download-default
/queue tree add limit-at=5M max-limit=10M name="VOZIP - DOWNLOAD" packet-mark=VOZIP_MARK parent="DOWNLOAD - QoS - CASA" priority=2 queue=pcq-download-default
/queue tree add name="NAVEGACION - DOWNLOAD" packet-mark=NAVEGACION_MARK parent="DOWNLOAD - QoS - CASA" priority=4 queue=pcq-download-default
/queue tree add name="QUICK - DOWNLOAD" packet-mark=QUIC_MARK parent="DOWNLOAD - QoS - CASA" priority=4 queue=pcq-download-default
/queue tree add limit-at=40M max-limit=60M name="IPTV - DOWNLOAD" packet-mark=IPTV_MARK parent="DOWNLOAD - QoS - CASA" priority=3 queue=pcq-download-default
/queue tree add limit-at=50M max-limit=100M name="RESTO - DOWNLOAD" packet-mark=RESTO_MARK parent="DOWNLOAD - QoS - CASA" queue=pcq-download-default
/queue tree add name="XBOX LIVE - DOWNLOAD" packet-mark="XOBX LIVE_MARK" parent="DOWNLOAD - QoS - CASA" priority=1 queue=fq_codel
/queue tree add limit-at=75M max-limit=160M name="STREAMING / DESCARGAS - DOWNLOAD" packet-mark="STREAMING / DESCARGAS_MARK,QUIC_STREAMING / DESCARGAS_MARK" parent="DOWNLOAD - QoS - CASA" priori
ty=7 queue=pcq-download-default
/queue tree add name="ICMP - DNS - UPLOAD" packet-mark="ICMP - DNS_MARK" parent="UPLOAD - QoS - CASA" priority=1 queue=pcq-upload-default
/queue tree add limit-at=5M max-limit=10M name="VOZIP - UPLOAD" packet-mark=VOZIP_MARK parent="UPLOAD - QoS - CASA" priority=2 queue=pcq-upload-default
/queue tree add name="NAVEGACION - UPLOAD" packet-mark=NAVEGACION_MARK parent="UPLOAD - QoS - CASA" priority=4 queue=pcq-upload-default
/queue tree add name="QUIC - UPLOAD" packet-mark=QUIC_MARK parent="UPLOAD - QoS - CASA" priority=4 queue=pcq-upload-default
/queue tree add limit-at=10M max-limit=20M name="IPTV - UPLOAD" packet-mark=IPTV_MARK parent="UPLOAD - QoS - CASA" priority=3 queue=pcq-upload-default
/queue tree add limit-at=50M max-limit=100M name="RESTO - UPLOAD" packet-mark=RESTO_MARK parent="UPLOAD - QoS - CASA" queue=pcq-upload-default
/queue tree add name="XOBX LIVE - UPLOAD" packet-mark="XOBX LIVE_MARK" parent="UPLOAD - QoS - CASA" priority=1 queue=fq_codel
/queue tree add limit-at=75M max-limit=160M name="STREAMING / SUBIDAS - UPLOAD" packet-mark="STREAMING / DESCARGAS_MARK,QUIC_STREAMING / DESCARGAS_MARK" parent="UPLOAD - QoS - CASA" priority=7 q
ueue=pcq-upload-default
 
Última edición:
Estás seguro que el tráfico IPTV es sólo el que va destinado al puerto 25461? Puedes probar a usar mejor el filtro dst-address-type=multicast, a ver qué tal se porta.

Saludos!
Probando con el dst-address-type=multicast y no marca ningun byte.

Lo los ajustes del comentario de arriba va mucho mejor, lo unico que me tira el iptv es un test de velocidad de fast.com, el cual pasa por streaming / descargas....

El resto de test y pruebas no me corta el iptv.
 
Chicos, una duda de novato...

Los parent de Download y Upload... cuales se ponen? para Download el bridge de la LAN o la vlan6 del PPPOE? y para upload el pppoe-out? (En mi caso he sustituido el hgu por ont y mikrotik)

Gracias,
 
Arriba