Presentación y duda básica

Buenas a todos,
Antes de nada agradeceros la cantidad de información util que compartís y el soporte que le brindais a la gente que quiere iniciarse (como es mi caso) con Mikrotik.

Ahora mismo vivo en un piso y tengo desde hace años fibra Movistar (u O2) con el HGU. En breve me mudaré a un duplex (dos plantas, terraza grande, garaje 'modo bunker') y pensando en qué problemas podría encontrarme con mi setup actual, llegué a este Foro y a mi interés por Mikrotik.

Como soy muy novato en tema de redes he estado varias semanas leyendo en el foro y viendo videos y me he decidido a empezar a hacer pruebas en casa con un hAP lite. Ya que en el piso de ahora (al ser pequeño) no tengo problemas con el HGU he querido empezar por probar a configurar el hAP como wireless AP bridge y conectar dispositvos mediante cable al mismo. La idea la he sacado de este post.

La configuración sería algo como esto:
1654858397293.png

Consigo configurar el hAP para que se conecte a la WiFi del HGU, pero no consigo que al conectar dispositvos por ethernet al mismo estos reciban IP del HGU.
Os pido disculpas de nuevo si esto es algo muy básico y os adjunto a continuación el export del equipo por si me podéis echar una mano.

Código:
# jan/02/1970 00:49:30 by RouterOS 6.47.10
# software id = 5VWU-6776
#
# model = RB941-2nD
# serial number = D1130F49310A
/interface bridge
add admin-mac=DC:2C:6E:8A:10:73 auto-mac=no comment=defconf name=bridge
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n disabled=no distance=indoors \
    frequency=2432 installation=indoor mode=station-pseudobridge ssid=Ka \
    wireless-protocol=802.11
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk group-ciphers=\
    tkip,aes-ccm mode=dynamic-keys supplicant-identity=MikroTik \
    unicast-ciphers=tkip,aes-ccm
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=pwr-line1
add bridge=bridge comment=defconf interface=wlan1
add bridge=bridge interface=ether1
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=wlan1 list=WAN
/ip address
add address=192.168.88.1/24 comment=defconf interface=bridge network=\
    192.168.88.0
/ip dhcp-server network
add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 comment=defconf name=router.lan
/ip firewall filter
add action=accept chain=input comment=\
    "defconf: accept established,related,untracked" connection-state=\
    established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
    invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
    "defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
    in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
    ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
    ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related
add action=accept chain=forward comment=\
    "defconf: accept established,related, untracked" connection-state=\
    established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
    connection-state=invalid
add action=drop chain=forward comment=\
    "defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
    connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
    ipsec-policy=out,none out-interface-list=WAN
/routing bfd interface
set [ find default=yes ] disabled=yes
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN

Un saludo y muchas gracais de nuevo.
Pablo.
 
La manera más sencilla de montar un AP es desde cero: dale un reset al equipo y marca la opción de que no quieres cargar la config por defecto (será de las pocas veces que me veas recomendar hacerlo así). Una vez tengas acceso al equipo (necesitarás entrar por MAC address desde Neighbors y únicamente vía cable con Winbox), crea un bridge y mete todos los puertos dentro, incluido el que te conecta al HGU y el wlan1. Acto seguido, ve a IP -> DHCP Client y levanta un cliente sobre el propio bridge. En ese momento ya tendrás un switch (compruébalo pinchando el equipo al HGU y a su vez otro equipo cableado al mikrotik). Pasar a un AP es de lo más sencillo: configuras la interfaz WLAN en el apartado Wireless (Wireless interfaces para declarar el SSID del AP, frecuencia, etc y Security profiles para la password). Si ves que este último paso te resulta complejo, lo tienes ahora mismo en tu export ya hecho, en los apartados /interface wireless y /interface wireless security-profiles. Una vez tengas la wifi andando, al ser parte del bridge como puerto, se comportará como el resto de puertos, como un switch, obteniendo IP del router al que está conectado.

Como extra, puedes crear una IP de administración encima del bridge, tipo 192.168.88.1/24 en la interfaz bridge, en IP -> Address. De esa manera, y dándole una IP de ese segmento a tu ordenador, podrás acceder a él incluso cuando no lo tengas conectado a un router. Cuando lo tengas conectado, siempre podrás acceder a él por la IP que obtenga el cliente dhcp que has levantado sobre el bridge, la cual puedes hacer también estática si te resulta más cómodo.

Saludos!
 
La manera más sencilla de montar un AP es desde cero: dale un reset al equipo y marca la opción de que no quieres cargar la config por defecto (será de las pocas veces que me veas recomendar hacerlo así). Una vez tengas acceso al equipo (necesitarás entrar por MAC address desde Neighbors y únicamente vía cable con Winbox), crea un bridge y mete todos los puertos dentro, incluido el que te conecta al HGU y el wlan1. Acto seguido, ve a IP -> DHCP Client y levanta un cliente sobre el propio bridge. En ese momento ya tendrás un switch (compruébalo pinchando el equipo al HGU y a su vez otro equipo cableado al mikrotik). Pasar a un AP es de lo más sencillo: configuras la interfaz WLAN en el apartado Wireless (Wireless interfaces para declarar el SSID del AP, frecuencia, etc y Security profiles para la password). Si ves que este último paso te resulta complejo, lo tienes ahora mismo en tu export ya hecho, en los apartados /interface wireless y /interface wireless security-profiles. Una vez tengas la wifi andando, al ser parte del bridge como puerto, se comportará como el resto de puertos, como un switch, obteniendo IP del router al que está conectado.

Como extra, puedes crear una IP de administración encima del bridge, tipo 192.168.88.1/24 en la interfaz bridge, en IP -> Address. De esa manera, y dándole una IP de ese segmento a tu ordenador, podrás acceder a él incluso cuando no lo tengas conectado a un router. Cuando lo tengas conectado, siempre podrás acceder a él por la IP que obtenga el cliente dhcp que has levantado sobre el bridge, la cual puedes hacer también estática si te resulta más cómodo.

Saludos!
Muchas gracias @pokoyo por tu respuesta.
Me temo que no he sido capaz de sacarlo. Te copio los pasos que me has indicado y lo que he ido haciendo. Además te copio el resultado final del config:

. dale un reset al equipo y marca la opción de que no quieres cargar la config por defecto -> OK
. crea un bridge y mete todos los puertos dentro, incluido el que te conecta al HGU y el wlan1 -> OK, lo hice antes de conectar al HGU
. Acto seguido, ve a IP -> DHCP Client y levanta un cliente sobre el propio bridge -> OK, efectivamente desde ese momento puedo ver en DHCP Client la IP
. En ese momento ya tendrás un switch (compruébalo pinchando el equipo al HGU y a su vez otro equipo cableado al mikrotik) -> Exacto, conecto cualquier puerto al HGU y otro dispositivo mediante ethernet a otro puerto y obtengo una IP en el dispositivo en la red del HGU
. Pasar a un AP es de lo más sencillo: configuras la interfaz WLAN ... -> OK, desconecto hAP del HGU, me lo llevo a otro habitación, configuro la WLAN y se conecta al HGU mediante WiFi (enable / running / slave / connected to ess)

Pero ya no hay IP en el DHCP Client. Se queda en Status: searching
Cuando conecto cualquier dispositivo al hAP por ethernet no recibe IP

A continuación el export:
Código:
# jun/10/2022 15:57:59 by RouterOS 6.47.10
# software id = 5VWU-6776
#
# model = RB941-2nD
# serial number = D1130F49310A
/interface bridge
add comment="Bridge general para que se comporte como un switch" name=bridge1
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-eC \
    disabled=no frequency=auto mode=station-pseudobridge ssid=Ka
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk,wpa2-eap \
    group-ciphers=tkip,aes-ccm mode=dynamic-keys supplicant-identity=MikroTik \
    unicast-ciphers=tkip,aes-ccm
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=wlan1
/ip neighbor discovery-settings
set discover-interface-list=!dynamic
/ip dhcp-client
add comment="Cliente sobre el bridge general" disabled=no interface=bridge1
/system clock
set time-zone-name=Europe/Madrid

Muchas gracias de nuevo por la ayuda.

Pablo.
 
Vale, retrocedemos un paso, que la he cagado yo. Vi tu dibujo y del al decirme "wireless bridge" pensé directamente en un AP. Ahora que miro tu dibujo con más detenimiento, lo que buscas no es montar un AP, sino un CPE en modo estación. Frenazo y marcha atrás:

Tenemos dos opciones: Si quieres seguir con lo que tienes, simplemente cambia el modo wireless a "station" y lo conectas a la wifi del HGU, y debería darte lo que quieres.

Otro modo es darle un reset al equipo y, desde el quick set, selecciona la opción de CPE y rellena los campitos, a la izquierda la parte de la conectividad inalámbrica, a la derecha la parte del router. Eso meterá la wifi como WAN, y creará un router independiente del HGU con su propio DHCP server y demás, para el resto de puertos físicos.

Saludos!
 
Muchas gracias de nuevo por la respuesta @pokoyo

La opción 1 funcionó ... lo digo en pasado, porque nada mas poner mode "Station" reconecto y el DHCP Client cogió IP, pero rebootee el hAP porque lo que estaba intentado conectar mediante cable no cogía IP y nunca mas volvió a coger IP el DHCP Client. Se sigue quedando en "searching"

Como el tema es aprender hice también la segunda opción:
. reset del equipo -> OK
. Quick Set -> OK (he dejado Address Acquisition en "Automatic"
. Rellenado los datos de la parte LAN: IP / Netmask / DHCP Server / NAT

Ahora si que funciona :)

Muchísimas gracias.
Comparado con lo que veo que se hace en los post esto es una chorrada, pero que conste que me siento hasta orgulloso :p y me da ánimos para seguir aprendiendo.

Un saludo.
 
Muchas gracias de nuevo por la respuesta @pokoyo

La opción 1 funcionó ... lo digo en pasado, porque nada mas poner mode "Station" reconecto y el DHCP Client cogió IP, pero rebootee el hAP porque lo que estaba intentado conectar mediante cable no cogía IP y nunca mas volvió a coger IP el DHCP Client. Se sigue quedando en "searching"

Como el tema es aprender hice también la segunda opción:
. reset del equipo -> OK
. Quick Set -> OK (he dejado Address Acquisition en "Automatic"
. Rellenado los datos de la parte LAN: IP / Netmask / DHCP Server / NAT

Ahora si que funciona :)

Muchísimas gracias.
Comparado con lo que veo que se hace en los post esto es una chorrada, pero que conste que me siento hasta orgulloso :p y me da ánimos para seguir aprendiendo.

Un saludo.
La primera opción tiene su “pega”. Sólo te va a funcionar medio bien en el modo “station pseudobridge”, y es modo de trabajo a evitar en Mikrotik. Se debe a que, para montar un enlace inalámbrico transparente, necesitas usar WDS, porque el estándar 802.11 sólo te permite manejar 3 direcciones MAC en una comunicación inalámbrica. Con tres direcciones MAC (origen, AP y estación inalámbrica) todo funciona, cuando el cliente final es la estación inalámbrica (lo normal cuando te conectas por wifi al router principal con un móvil, por ejemplo), pero la cosa se complica cuando metes eso en un bridge, puesto que te falta una cuarta dirección MAC, la del destino del paquete, que no puedes transmitir en la cabecera del paquete. Si quieres más detalle, aquí lo explican mucho mejor que yo: https://help.mikrotik.com/docs/display/ROS/Wireless+Station+Modes

Lo segundo que hiciste fue hacer que la interfaz inalámbrica fuera cliente final, sacándola del bridge, el cual direccionas aparte. Ahí no tienes ese problema, puesto que la parte inalámbrica deja de estar en bridge.

Luego te busco cómo se monta lo primero, por si tienes curiosidad, y así lo tendrías todo en un mismo segmento de broadcast (una única red donde se ven todos los equipos en lan local).

De todas formas, de cara a la mudanza, piensa que esto no es un setup deseable, ninguno de los dos. Busca pasar como sea cable de red entre las plantas del duplex, tal que puedas montar, idealmente, un AP por planta.

Saludos!
 
Arriba