Percepción de velocidad baja tras cambiar HGU por Ufiber+Hex S

Hola mikrotikeros.

Hace unos días empezaba a leer los diferentes posts y chinchetas con el ánimo de instruirme en Mikrotik. Y en unos días ya me llegó mi ufiber nano g y un mikrotik hex s que tras conectar y configurar, funciona sin problemas. Tras el Mikrotik y a eth3, va un cable de red cat6 que conecta un switch mikrotik css326 que uso en casa para dar servicio a las diferentes tomas de red de la vivienda. Una de ellas, un NAS synology conectado con aggregate link al switch.

Explicado el contexto, os cuento que he notado que transmission (la app que corre en el synology para descarga de torrents) no alcanza las velocidades que obtenía con el HGU. Decir que tengo contratados 300Mbps con Movistar. Pues bien, en su día era fácil conseguir velocidades de 7MB/s, más o menos constantes. Ahora, para torrents con abundantes fuentes, consigo 2-3 MB/s, pero inestables, bajando a 700kB/s, volviendo a subir a 4 MB/s, pero no las velocidades de antaño.

Si os lo estáis preguntando, sí, tengo (en teoría) correctamente abierto el puerto oportuno (en mi caso, 63335) para transmission (y así configurado en la propia aplicación del NAS). Digo que está correcto porque accedo al mikrotik, entro en el WebFig a IP->Firewall->NAT y puedo ver la cantidad de paquetes y Bytes que han pasado por dicho puerto. Pero algo me hace dudar que esté bien del todo:

1) Que el propio transmission me dice en su sección de configuración, donde se indica el puerto, que este está cerrado (?¿).
2) Que uno de los trackers donde comparto ficheros, indica que "aparentemente tengo el puerto 63335 cerrado".

Que el problema de velocidad es algo del puerto está claro... porque haciendo tests de velocidad en speedtest saco 300/300 Mbps sin problema. Pero que en teoría el puerto está abierto (a la vista de lo que se ve) también... ¿Alguna idea?

Muchas gracias!
 
Pues que no está abierto, poco más te puede pasar.

Has puesto el hardware offloading a trabajar? Para que lo haga en ese equipo, tienes que quitar el rstp del protocol mode del bridge.

Pásame la regla de NAT, que la revisamos.

Saludos!
 
Creo que no lo he puesto...

Te envío imágenes de la regla:

Captura de pantalla 2021-09-15 a las 22.15.02.png


Captura de pantalla 2021-09-15 a las 22.13.20.png


Edit: acabo de poner el hardware offloading a trabajar haciendo:

/interface bridge set numbers=0 protocol-mode=none
 
Última edición:
Creo que no lo he puesto...

Te envío imágenes de la regla:

Ver el adjunto 86388

Ver el adjunto 86391

Edit: acabo de poner el hardware offloading a trabajar haciendo:

/interface bridge set numbers=0 protocol-mode=none
Aparentemente está bien. Dale un export a todo el NAT, a ver si hay algo más raro.

Tu interfaz de salida a internet, damos por hecho que está dentro de la lista WAN (si es una vlan y la conexión va por dhcp, asegúrate de que también lo esté).

Saludos!
 
Aparentemente está bien. Dale un export a todo el NAT, a ver si hay algo más raro.

Tu interfaz de salida a internet, damos por hecho que está dentro de la lista WAN (si es una vlan y la conexión va por dhcp, asegúrate de que también lo esté).

Saludos!
hehe, ¿cómo hago el export? siento la pregunta :LOL:
 
Mira, mejor dale un export a toda la configuración, y la repasamos entera. Si acabas de llegar al mundillo mikrotik, te vendrá bien.

Abre el terminal y escribe:
Código:
/export hide-sensitive file=conf

Luego vas a la carpeta “Files” y descargas el fichero conf.rsc a tu máquina, lo renombras a .txt y lo adjuntas a la respuesta de este post.

Saludos!
 
Gracias pokoyo, otra cosa aprendida :)

Aquí va. Verás que tengo un par de scripts hechos (sacados de aquí): el que avisa mediante bot de telegram de cambio de IP de la WAN así como de login/logout al mikrotik. He editado datos sensibles por privacidad (serial number, mac y api del bot y chat_id).

Código:
# sep/16/2021 16:59:56 by RouterOS 6.48.3
# software id = KTEQ-VD9B
#
# model = RB760iGS
# serial number = xxxxxxxx
/interface bridge
add admin-mac=xxxxxxxxxxx auto-mac=no comment=defconf name=bridge \
    protocol-mode=none
/interface vlan
add interface=ether1 name=VLAN6 vlan-id=6
/interface pppoe-client
add add-default-route=yes disabled=no interface=VLAN6 name=pppoe-out1 \
    use-peer-dns=yes user=adslppp@telefonicanetpa
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=hotspot
/ip pool
add name=dhcp ranges=192.168.1.2-192.168.1.163
add name=dhcp_pool1 ranges=192.168.1.2-192.168.1.126
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=bridge name=dhcp1
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=ether5
add bridge=bridge comment=defconf interface=sfp1
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN
add interface=pppoe-out1 list=WAN
/ip address
add address=192.168.1.1/24 comment=defconf interface=bridge network=\
    192.168.1.0
/ip dhcp-client
add comment=defconf interface=ether1
/ip dhcp-server network
add address=192.168.1.0/24 comment=defconf gateway=192.168.1.1 netmask=24
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.1.1 comment=defconf name=router.lan
/ip firewall filter
add action=accept chain=input comment=\
    "defconf: accept established,related,untracked" connection-state=\
    established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
    invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
    "defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
    in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
    ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
    ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related
add action=accept chain=forward comment=\
    "defconf: accept established,related, untracked" connection-state=\
    established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
    connection-state=invalid
add action=drop chain=forward comment=\
    "defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
    connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
    ipsec-policy=out,none out-interface-list=WAN
add action=dst-nat chain=dstnat dst-port=63335 in-interface-list=WAN \
    protocol=tcp to-addresses=192.168.1.7 to-ports=63335
add action=dst-nat chain=dstnat dst-port=3896 in-interface-list=WAN protocol=\
    tcp to-addresses=192.168.1.222 to-ports=3896
add action=dst-nat chain=dstnat dst-port=9091 in-interface-list=WAN protocol=\
    tcp to-addresses=192.168.1.7 to-ports=9091
add action=dst-nat chain=dstnat dst-port=28934 in-interface-list=WAN \
    protocol=tcp to-addresses=192.168.1.7 to-ports=28934
add action=dst-nat chain=dstnat dst-port=43679 in-interface-list=WAN \
    protocol=tcp to-addresses=192.168.1.7 to-ports=43679
/system clock
set time-zone-name=Europe/Madrid
/system script
add dont-require-permissions=no name=MyTGBotSendMessage owner=admin policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source=":\
    local BotToken \”xxxxxxxxx\”;\
    \n:local ChatID \”xxxxxxxxx\”;\
    \n:local parseMode \"HTML\";\
    \n:local SendText \$MessageText;\
    \n\
    \n/tool fetch url=\"https://api.telegram.org/bot\$BotToken/sendMessage\\\?\
    chat_id=\$ChatID&parse_mode=\$parseMode&text=\$SendText\" keep-result=no;\
    \n\
    \n:log info \"Enviado Mensaje Telegram\";"
add dont-require-permissions=no name="WAN IP Change" owner=admin policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source="B\
    ash:\
    \n\
    \n:global CurrentIP;\
    \n:local NewIP ([/tool fetch url=http://api.ipify.org/ as-value output=use\
    r] -> \"data\")\
    \n\
    \n:if (\$NewIP != \$CurrentIP) do={\
    \n    # Variables\
    \n    :local Time [/system clock get time];\
    \n    :local Date [/system clock get date];\
    \n    :local DeviceName [/system identity get name];\
    \n    :local Text \"Nueva IP: \$NewIP\\r\\nAnterior IP: \$CurrentIP\";\
    \n\
    \n    # START Send Telegram Module\
    \n    :local MessageText \"\\F0\\9F\\9F\\A2 \$DeviceName: La WAN IP ha cam\
    biado%0ANueva IP: \$NewIP%0AAnterior IP: \$CurrentIP\";\
    \n    :local SendTelegramMessage [:parse [/system script  get MyTGBotSendM\
    essage source]];\
    \n    \$SendTelegramMessage MessageText=\$MessageText;\
    \n    #END Send Telegram Module\
    \n\
    \n    :log info \"Detectada nueva IP WAN: \$NewIP - Anterior IP: \$Current\
    IP\";\
    \n\
    \n    :delay 5s;\
    \n    # Guarda la IP actual en una variable global\
    \n    :set CurrentIP \$NewIP;\
    \n\
    \n} else={\
    \n    :log info \"INFO: WAN IP anterior \$CurrentIP es igual a la IP actua\
    l, no ha cambiado\";\
    \n\
    \n    # Recibimos un aviso v\EDa Telegram en caso que no haya cambiado la \
    IP.\
    \n    # START Send Telegram Module\
    \n    :local MessageText \"\\F0\\9F\\9F\\A2 \$DeviceName: La WAN IP no ha \
    cambiado:%0A\$NewIP\";\
    \n    :local SendTelegramMessage [:parse [/system script  get MyTGBotSendM\
    essage source]];\
    \n    \$SendTelegramMessage MessageText=\$MessageText;\
    \n    #END Send Telegram Module\
    \n};\
    \n\
    \n"
add dont-require-permissions=no name="LogIN LogOUT Mikrotik" owner=admin \
    policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon \
    source=":local DeviceName [/system identity get name];\
    \n:local Time [/system clock get time];\
    \n:local Date [/system clock get date];\
    \n:local TelegramMessageText;\
    \n\
    \n:global ParseLogAccountEndArrayID;\
    \n\
    \n:local IDsEventsAccount [/log find where  topics ~ \"account\"];\
    \n\
    \n:local LenArrayIDs [:len \$IDsEventsAccount];\
    \n:local StartArrayID [:find \$IDsEventsAccount \$ParseLogAccountEndArrayI\
    D];\
    \n:local EndArrayID (\$IDsEventsAccount -> (\$LenArrayIDs-1));\
    \n\
    \n:if (\$EndArrayID != \$ParseLogAccountEndArrayID and [:tobool \$ParseLog\
    AccountEndArrayID] ) do={\
    \n\
    \n    :for KeyArray from=(\$StartArrayID+1) to=(\$LenArrayIDs-1) do={\
    \n        :local IDMessage (\$IDsEventsAccount ->\$KeyArray );\
    \n        :set TelegramMessageText \"\$TelegramMessageText %0D%0A  \$[/log\
    \_get number=\$IDMessage time] - \$[/log get number=\$IDMessage message];\
    \";\
    \n        }\
    \n\
    \n    # START SEND TELEGRAM\
    \n    :local MessageText \"\\F0\\9F\\94\\93 <b>\$DeviceName: Info Login</b\
    > \$TelegramMessageText\";\
    \n    :local SendTelegramMessage [:parse [/system script  get MyTGBotSendM\
    essage source]];\
    \n    \$SendTelegramMessage MessageText=\$MessageText;\
    \n    # END SEND TELEGRAM\
    \n}\
    \n\
    \n:set ParseLogAccountEndArrayID \$EndArrayID;"
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
 
Prueba cambiando el filtro de in-interface-list=WAN de las reglas del NAT para abrir puertos, a in-interface=pppoe-out1, a ver qué hace.

Saludos!
 
Pfff tienes toda la razón, disculpa pokoyo. Pfff, nada, aparentemente igual... Y he probado cambiando el In. Interface a ppoe-out1 y dejando en el In. Interface List "WAN" así como poniendolo en "none". De nuevo, velocidades que con el tiempo (es una descarga de 40gb por ejemplo) va subiendo hasta los 12-15 MB/s, pero constantemente irregular: bajando de repente a 1,5MB/s, vuelta a 12MB/s, etc... Si miro la ONT por ejemplo, que sabéis que la de ufiber muestra la velocidad momentánea de bajada u subida, va constantemente moviéndose (en este caso en Mbps: 29Mbps, 99Mbps, 101Mbps, 14Mbps, 75Mbps. Lo cual sorprende porque además es un torrent con muchos peers, cerca de 40.

No sé, quizás no sea del Mikrotik? Y sea cosa del transmission que nunca es que haya ido muy fino en Synology... Pero esto me ha dado pie a hacer pruebas moviendo ficheros en local (de un mac conectado por utp cat6 al switch CSS326 y el mismo NAS, en este caso con link aggregate de dos cat6 al mismo switch, y yo no sé si es que he montado la carpeta compartida en smb y la prueba deberia ser en NFS, pero mal igualmente... no pasa de los 25MB/s. Empiezo a pensar que el synology pueda estar siendo un cuello de botella a nivel software??

Edit: efectivamente montando las carpetas en NFS (vaya rollo para montarlas en el Mac) tengo velocidades estables de 60MB/s con picos de 75MB/s. Que teóricamente debería poder llegar a los 125MB/s, pero bueno, me conformo...
Edit 2: Y eso ha sido de subida de mac->synology. Haciendo bajada, 120MB/s. Así que al menos tranquilo con las velocidades entre equipos y switch en la red de casa.
 

Adjuntos

  • Captura de pantalla 2021-09-16 a las 22.12.14.png
    Captura de pantalla 2021-09-16 a las 22.12.14.png
    47.6 KB · Visitas: 23
  • Captura de pantalla 2021-09-16 a las 22.12.00.png
    Captura de pantalla 2021-09-16 a las 22.12.00.png
    38.3 KB · Visitas: 24
Última edición:
No, no nos estamos entendiendo. La regla de NAT la tienes que tocar para que solo quede el in-interface=pppoe-out1, y NADA en el otro filtro. Es decir, en donde tienes ahora mismo seleccionado in-interface-list=WAN, no hay que dejarlo así niseleccionar “none”, sino que hay que cerrar el desplegable. Si te resulta más sencillo, borramos esa regla y la creamos desde cero vía terminal, que es incluso más sencillo. Cuando la tengas, si le das un export, la regla debería verse así:
Código:
/ip firewall nat
add action=dst-nat chain=dstnat dst-port=63335 in-interface=pppoe-out1 \
    protocol=tcp to-addresses=192.168.1.7 to-ports=63335

Y recuerda que transmission en synology usa también un puerto adicional para DHT, de tipo UDP, por si lo quieres abrir también.

No obstante, yo uso el mismo chisme, con estos routers también, y sin abrir puertos ninguno, la velocidad es muy decente. Así que no miraría mucho al router, sino a lo que tienes por encima, cómo la causa de los fogonazos.

Las pruebas que hagas en red local son totalmente irrelevantes. El tráfico se queda a nivel de switch, no sube ni al router.

Saludos!
 
Nada, efectivamente abrí el UDP igualmente para el mismo puerto y la misma IP y todo sigue igual.

Nada, que es lo que tú dices pokoyo, probablemente sea algo del porpio transmission... Tendría la opción de instalarlo en el NAS a través de docker y no nativo, que hay gente que lo recomienda, pero me da una pereza... y prefiero hurgar con el mikrotik :D

Lo dicho, gracias por la ayuda y nos seguimos viendo por aquí.
 
Nada, efectivamente abrí el UDP igualmente para el mismo puerto y la misma IP y todo sigue igual.

Nada, que es lo que tú dices pokoyo, probablemente sea algo del porpio transmission... Tendría la opción de instalarlo en el NAS a través de docker y no nativo, que hay gente que lo recomienda, pero me da una pereza... y prefiero hurgar con el mikrotik :D

Lo dicho, gracias por la ayuda y nos seguimos viendo por aquí.
Instálalo en un pc y prueba. Me da que tu problema no es el o NAS.

Saludos!
 
Justo...

Acabo de hacerlo, y a la primera vaya. Sin abrir nuevos, puertos, sólo cambiando las reglas que había hacia el NAS poniendo la IP del PC en vez de la del NAS.

Captura de pantalla 2021-09-17 a las 22.34.16.png


Nada, que la app para synology es una patata...
 
Desentramado el entuerto... maldito firewall del Synology pokoyo... maldito firewall, que por otro lado estaba haciendo su trabajo, así que culpa mía jeje. Nada, fue abrir ahí el 63335 tcp/udp y listo, ya aparece como Open en el transmission. Ahora bien, que no va igual de fino este transmission que uno en pc/mac, ya te lo confirmo :ROFLMAO:
 
Jejeje, eso ya me cuadra más. Sí, yo también le noto que no aprovecha del todo la fibra, como sí lo hace un cliente de escritorio. Pero me parece muy cómodo tirarle los torrents y olvidarme.

Saludos!
 
Arriba