Obtener IP de enruteo y adoptar DNS de otro router

Hola buenas a todos.

Configurando un router Mikrotik me han surgido un par de dudas. Mi red es un router del propio ISP vodafone un Tc7230. Ademas tengo un Mikortik hap ac2 que utilizo como extensor de cobertura para mi habitación. Pongo un esquemilla:
rect10.png

En el lan_bridge tengo un dhcp, una regla para que "haga nat" a los paquetes para la red del router del ISP y una ruta definida para que todo paquete con destino distinto de la red local del lan_bridge tire por 192.168.0.111. Y todo esto funciona, es decir, si me conecto vía wifi o red tengo internet.

La cuestión es que ahora mismo en el router de vodafone tengo una ip reservada (192.168.0.111) para la interfaz wlan2 y le asigno esa ip. ¿Pero hay alguna forma obtener una ip de forma automática del router vodafone y ponérsela al interfaz wlan2? Y evidentemente que se actualicen las referencia a esa ip, es decir, estilo una variable o algo.

Otra duda. Como indico ahora para poder navegar necesito indicarle al dhcp el servidor DNS. Pero me gustaría saber si hay una forma de que use el DNS que ofrece el router TC7230. Bueno ese router no creo que tenga servidor DNS, me refiero a que use como DNS la dirección del DNS que ofrece ese router.

RouterOS 7.4
# model = RBD52G-5HacD2HnD
/interface bridge
add name=lan_bridge
/interface list
add comment="internet access net" name=WAN
add comment="local lan" name=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk mode=dynamic-keys supplicant-identity=hab
add authentication-types=wpa2-psk eap-methods="" group-ciphers=tkip,aes-ccm management-protection=\
allowed mode=dynamic-keys name=router_vodafone_pass supplicant-identity=vodafone \
unicast-ciphers=tkip,aes-ccm
add authentication-types=wpa-psk,wpa2-psk eap-methods="" group-ciphers=tkip,aes-ccm mode=\
dynamic-keys name=hab_ap supplicant-identity="" unicast-ciphers=tkip,aes-ccm
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n disabled=no mode=ap-bridge security-profile=\
hab_ap ssid=hab
set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=20/40/80mhz-Ceee disabled=no \
distance=indoors frequency=5500 mode=station-pseudobridge security-profile=\
router_vodafone_pass ssid=vodafone wireless-protocol=802.11
/ip pool
add name=pool_hab_clients ranges=192.168.11.3-192.168.11.99
add name=dhcp_pool1 ranges=192.168.0.1-192.168.0.125,192.168.0.127-192.168.0.254
/ip dhcp-server
add address-pool=pool_hab_clients interface=lan_bridge lease-time=30m name=dhcp-hab
/interface bridge port
add bridge=lan_bridge interface=ether1
add bridge=lan_bridge interface=ether2
add bridge=lan_bridge interface=ether3
add bridge=lan_bridge interface=ether4
add bridge=lan_bridge interface=ether5
add bridge=lan_bridge interface=wlan1
/interface list member
add comment="wan interface" interface=wlan2 list=WAN
add comment="lan bridge" interface=lan_bridge list=LAN
/interface wireless connect-list
add interface=wlan2 security-profile=router_vodafone_pass ssid=vodafone wireless-protocol=\
802.11
/ip address
add address=192.168.11.1/24 interface=lan_bridge network=192.168.11.0
add address=192.168.0.111/24 interface=wlan2 network=192.168.0.0
/ip dhcp-server network
add address=192.168.0.0/24 dns-server=9.9.9.9 gateway=192.168.0.111
add address=192.168.11.0/24 dns-server=9.9.9.9 gateway=192.168.11.1 netmask=24
/ip firewall nat
add action=masquerade chain=srcnat out-interface=wlan2
/ip route
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.0.1 pref-src=\
0.0.0.0 routing-table=main scope=30 suppress-hw-offload=no target-scope=10
 
Algo parecido tenia al principio, es decir, el Mikrotik como repetidor simple. Pero al router de vodafone (el ISP) se conecta "todo dios" invitados incluidos. Y prefiero que el NAS y la impresora no "esten a la vista para todos", osea que estén en su propia red. Decir que las opciones de configuración del router del ISP son mínimas. Por eso prefiero tener otra red interna con el Mikrotik.
 
Algo parecido tenia al principio, es decir, el Mikrotik como repetidor simple. Pero al router de vodafone (el ISP) se conecta "todo dios" invitados incluidos. Y prefiero que el NAS y la impresora no "esten a la vista para todos", osea que estén en su propia red. Decir que las opciones de configuración del router del ISP son mínimas. Por eso prefiero tener otra red interna con el Mikrotik.
En ese caso te recomiendo segmentar la red como la tenía yo antes de tener ningún mikrotik: el router del operador para invitados y/o chismes de los que no te fíes, y debajo de ese otro router, donde metes tus dispositivos de confianza.

Saludos!
 
Si y eso creo que es lo que tengo ahora con el Mikrotik, y funciona bien. Las preguntas es por saber si se puede. Todas la guías que he visto lo ponen así, pero tengo curiosidad por saber si se puede como pregunto.
 
Si y eso creo que es lo que tengo ahora con el Mikrotik, y funciona bien. Las preguntas es por saber si se puede. Todas la guías que he visto lo ponen así, pero tengo curiosidad por saber si se puede como pregunto.
Quieres decir, ¿poner el router de vodafone + el mikrotik debajo? Sí, claro. Siempre y cuando el mikrotik vaya cableado al router de vodafone (por ethernet) este setup que describimos se puede hacer sin problema. En inalámbrico es otro tema, porque ya empiezas a jugar con WDS, y eso es otro cantar.

Saludos!
 
En inalámbrico es otro tema, porque ya empiezas a jugar con WDS, y eso es otro cantar.
Perdonar la intromisión, para el modo inalámbrico el modo station-pseudobridge valdría?
-Router operadora con wifi activado
-En otra habitación un mikrotik con wlan1 en station-pseudobridge, conectado a la wifi de la operadora
-Bridge en el mikrotik con wlan1 y un puerto ether (o varios)
-Equipo (con ip por dhcp) conectado por cable al mikrotik en una boca que pertenezca al bridge.
 
Quieres decir, ¿poner el router de vodafone + el mikrotik debajo? Sí, claro. Siempre y cuando el mikrotik vaya cableado al router de vodafone (por ethernet) este setup que describimos se puede hacer sin problema. En inalámbrico es otro tema, porque ya empiezas a jugar con WDS, y eso es otro cantar.

Saludos!
Sin cables en inalámbrico. Pero no exactamente WDS. El WDS creo que necesita 2 routers Mikrotik no?

Es decir, el Mikrotik tiene 2 interfaces inalámbricas, una 2 GHz(wlan1) y otra de 5GHz(wlan2). Pues bien la wlan2 la ponía en modo "station pseudobridge" y la conectaba al router del ISP. La wlan1 la colocaba en modo "ap bridge", le ponía su SSID y demás. Luego al wlan2 le asigné una IP que tengo reservada en el router del ISP, creaba un "dhcp relay" y me ha funcionado, hasta que lo he cambiado como ahora lo tengo. Es decir, similar excepto que wlan1 y los puertos ethernet en otra subred y en lugar de un dhcp relay tengo un dhcp server y nateo.
Bueno aunque no siempre bien he de decir, pero eso se lo he achacado al router. Me parece que esta tocado o algo, algunas veces se bloquea iniciando y el puerto 3 del LAN no funciona. Pero eso es otra historia.

Perdonar la intromisión, para el modo inalámbrico el modo station-pseudobridge valdría?
-Router operadora con wifi activado
-En otra habitación un mikrotik con wlan1 en station-pseudobridge, conectado a la wifi de la operadora
-Bridge en el mikrotik con wlan1 y un puerto ether (o varios)
-Equipo (con ip por dhcp) conectado por cable al mikrotik en una boca que pertenezca al bridge.
Algo así he tenido yo. No sé si es la forma buena o ideal, pero ha funcionado, al menos con el Mikrotik hap ac2 y la versión 7 del RouterOS.

Es más, antes de usar la interfaz de 5Ghz (wlan2) de mi Mikrotik usaba la wlan1 en modo "station-pseudobridge" y creé otra wlan virtual en modo "ap bridge" y todo lo demas similar. Y funcionaba, aunque se perdia mucho ancho de banda, escasamente lograba mas de 15Mbps.
 
Última edición:
Sin cables en inalámbrico. Pero no exactamente WDS. El WDS creo que necesita 2 routers Mikrotik no?

Es decir, el Mikrotik tiene 2 interfaces inalámbricas, una 2 GHz(wlan1) y otra de 5GHz(wlan2). Pues bien la wlan2 la ponía en modo "station pseudobridge" y la conectaba al router del ISP. La wlan1 la colocaba en modo "ap bridge", le ponía su SSID y demás. Luego al wlan2 le asigné una IP que tengo reservada en el router del ISP, creaba un "dhcp relay" y me ha funcionado, hasta que lo he cambiado como ahora lo tengo. Es decir, similar excepto que wlan1 y los puertos ethernet en otra subred y en lugar de un dhcp relay tengo un dhcp server y nateo.
Bueno aunque no siempre bien he de decir, pero eso se lo he achacado al router. Me parece que esta tocado o algo, algunas veces se bloquea iniciando y el puerto 3 del LAN no funciona. Pero eso es otra historia.


Algo así he tenido yo. No sé si es la forma buena o ideal, pero ha funcionado, al menos con el Mikrotik hap ac2 y la versión 7 del RouterOS.

Es más, antes de usar la interfaz de 5Ghz (wlan2) de mi Mikrotik usaba la wlan1 en modo "station-pseudobridge" y creé otra wlan virtual en modo "ap bridge" y todo lo demas similar. Y funcionaba, aunque se perdia mucho ancho de banda, escasamente lograba mas de 15Mbps.
Si vas a sacrificar una de las interfaces inalámbricas para enlazar con el router principal, mejor úsala en modo station, no en station-pseudobridge. La sacas del bridge principal y la usas como WAN.

En el bridge principal, deja luego los puertos ethernet y la segunda interfaz inalámbrica, en modo ap-bridge.

El modo “station-pseudobridge” es un modo a evitar. Se usa cuando montad el chisme como repetidor, y como bien has comprobado, tiene mal rendimiento.

Por otro lado, si hay alguna posibilidad de unir los equipos por cable, mejorarías mucho el setup, trabajando todo en un mismo segmento de L2.

Para usar WDS no necesitas que ambos sean mikrotik. El 802.11 tiene un modo WDS, lo malo es que no hay una definición estándar del mismo, y cada uno lo implementa como le parece. No obstante, si el router de la operadora tiene alguna opción de WDS en la parte wireless, yo lo probaría.

Saludos!
 
Última edición:
Ah pues si, lo pongo en modo "station". Lo del modo WDS lo voy a dejar. No aparece ninguna opción en el router acerca de ello.

En fin, muchas gracias por la ayuda.
 
Arriba