No consigo poner en marcha CAPsMAN. (Solucionado)

@pokoyo

Hola a todos.
Pues llevo un tiempo peleándome para poner en marcha CAPsMAN y no hay manera. Sigo las indicaciones del manual y a la hora de la verdad no aparecen los interfaces wifi en la ventana de CAPsMAn. En cambio en el apartado Wireless aparece como CAP administrado por CAPsMAN pero sin identificación de canal ni ssid.
Ahora mismo tengo borradas todas las configuraciones para poder partir de cero.
El equipo es un hAP AC2 con RouterOS 6.47.8.
Gracias.


capsman.png
 
Última edición:
Vas a querer montar lo mismo que se describe en el manual (red normal + red de invitados separada) o te conformas con que haya una wifi funcionando desde un par de APs?

Saludos!
 
Vas a querer montar lo mismo que se describe en el manual (red normal + red de invitados separada) o te conformas con que haya una wifi funcionando desde un par de APs?

Saludos!

Sin red de invitados. Sólo para usar el mismo ssid y las dos bandas 2.4 y 5 GHZ. Todo centralizado y que pasen de un CAP a otro según la intensidad de la señal. En principio con esto me vale creo yo.
Gracias.
 
Vale. Te dejo una configuración. La del manual te vale perfectamente, pero necesitas un paso extra si tu equipo es a la vez manager y cap (es decir, si montas CAPsMAN en un equipo con parte inalámbrica, donde esa parte la vas a querer controlar también por CAPsMAN). En lugar de referenciar al bridge como interfaz de discovery (por donde estarías enganchado al CAPsMAN si fueras por ejemplo el segundo AP), en ese equipo particular, has de hacer referencia a él mismo, a su direccion de loopback, 127.0.0.1

Es decir, esta sería la configuración de un CAP normal:
1609243159138.png


Y esta otra la de un equip CAP, que es a su vez CAPsMAN:
1609243225697.png


Además de eso, necesitas que el router acepte el tráfico de CAPsMAN en el firewall. Si no lo has tocado, es una de las reglas por defecto que crea él mismo desde el quick setup. Deberías tener en el firewall, en el chain de input, una regla tal que así:
Código:
/ip firewall filter
add action=accept chain=input comment=\
    "defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1

Con eso, deberías poder aplicar el manual para implementar CAPsMAN en tu red. En tu casa, por ejemplo, donde creo que tenías un hex + cAP AC, como lo normal sería que el CAPsMAN lo montaras en el hex, y no te haría falta ese paso extra, con la configuración del manual te vale.

Te paso una de cómo lo configuraría yo, con todo en automático. Si ves que los dos AP's eligen el mismo canal para la red de 2,4GHz, pulsa el botón "reselect channel" en la lista de interfaces de CAPsMAN, cuando selecciones el "CAP Interface"

Y ojo con la frecuencia de 5GHz que seleccione en auto, puesto que, dependiendo de la que coja, así tardará más o menos en levantar la interfaz de 5GHz. Esto último lo he sufrido en mis propias carnes estos días, cuando estuve jugando con el hAP-ac3. Lo digo porque no os extrañéis cuando la wifi de 5GHz tarde en levantar, me explico:
  • Canales NO DFS ( del 36 al 48 ), frecuencias (5180 - 5240): la interfaz levanta instantáneamente, no necesita cumplir ningún requisito en dicha frecuencia.
  • Canales DFS ( del 52 al 116 ), frecuencias (5260 - 5580): la interfaz escanea en busca de radares durante 1m. Si todo ha ido bien y no hay un pulso de radar detectado, levanta la interfaz en dicho canal.
  • Canales DFS entre las frecuencias 5600 - 5650 (canales 120 - 132): banda reservada a radares meteorológicos, donde mikoritk cumple el estándar a rajatabla, es decir, extiende la detección del pulso de radar 10 minutos, para permitir que un radar meteorológico, como los que hay en el aeropuerto, complete un ciclo completo de rotación. Si el equipo selecciona esa frecuencia, tardará el menos ese tiempo en levantarla.
Las frecuencias DFS están bien, porque los equipos pueden emitir con más potencia en algunos de esos canales. Pero tened en cuenta de que, si detectan un pulso de radar, el AP de apaga y reselecciona otro canal, para cumplir con la ley.

Dicho esto, te paso una configuración de CAPsMAN que te puede valer (cambia password y SSID a tu gusto)
Código:
/caps-man rates
add basic=12Mbps name=gn-only supported=\
    12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps

/caps-man security
add authentication-types=wpa2-psk disable-pmkid=yes \
    encryption=aes-ccm group-encryption=aes-ccm group-key-update=1h \
    name=home-sp passphrase=MySuperW1f1P4ssW0rd!

/caps-man channel
add band=2ghz-g/n control-channel-width=20mhz \
    extension-channel=disabled frequency=2412,2437,2462 \
    name=2ghz-chs-auto tx-power=13
add band=5ghz-n/ac control-channel-width=20mhz \
    extension-channel=XXXX name=5ghz-chs-auto

/caps-man datapath
add bridge=bridge client-to-client-forwarding=yes \
    local-forwarding=no name=home-dp

/caps-man configuration
add channel=home-2ghz-chs-auto country=spain datapath=home-dp mode=ap \
    name=home-wifi-2ghz-cfg rates=gn-only security=home-sp ssid=MikrotikPalColega
add channel=5ghz-chs-auto country=spain datapath=home-dp mode=ap \
    name=home-wifi-5ghz-cfg rates=gn-only security=home-sp ssid=MikrotikPalColega

/caps-man provisioning
add action=create-dynamic-enabled hw-supported-modes=gn \
    master-configuration=home-wifi-2ghz-cfg name-format=prefix-identity \
    name-prefix=2ghz
add action=create-dynamic-enabled hw-supported-modes=ac \
    master-configuration=home-wifi-5ghz-cfg name-format=prefix-identity \
    name-prefix=5ghz

/caps-man manager
set enabled=yes

Si ves que los equipos cliente no hacen roaming, habría que bajarle la potencia a los APs (en 2,4 ya está hecho, bajado a 13dBm), o meter un access list que a partir de cierta señal te "escupa" del AP.

Saludos!
 
Muchas gracias. Esta tarde cuando tenga un rato me pongo y lo pruebo.

Y esta otra la de un equip CAP, que es a su vez CAPsMAN:
1609243225697.png

Esto se me escapaba de mi configuración, ahora ya lo sé, gracias.


Además de eso, necesitas que el router acepte el tráfico de CAPsMAN en el firewall. Si no lo has tocado, es una de las reglas por defecto que crea él mismo desde el quick setup. Deberías tener en el firewall, en el chain de input, una regla tal que así:
Código:
/ip firewall filter
add action=accept chain=input comment=\
"defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1

Con eso, deberías poder aplicar el manual para implementar CAPsMAN en tu red.

firewall.png

Correcto, la regla está incluida en el firewall.

Si ves que los equipos cliente no hacen roaming, habría que bajarle la potencia a los APs (en 2,4 ya está hecho, bajado a 13dBm), o meter un access list que a partir de cierta señal te "escupa" del AP.

Para el roaming tenía pensado como tu comentas poner un access list. A ver que te parece y si entonces hay que modificar algo referente a la potencia de emisión si aplicamos el access list.

Código:
/caps-man access-list
add action=accept interface=all signal-range=-70..120
add action=reject interface=all signal-range=-120..-71

Muchas gracias por tu ayuda.
 
Última edición:
¿Están muy cerca los dos routers? Porque, de no estarlo, relajaría un pelín esas reglas de acceso. De hecho, como la potencia de la red de 2,4 está bajada en 7-8dBm con respecto a la otra, es fácil que ambas lleguen al mismo punto con prácticamente la misma potencia. Siendo así, podrías definir simplemente una única regla:

Todo lo que llegue con mejor potencia que -75dBm, lo aceptas.
Código:
/caps-man access-list add action=accept signal-range=-75..0

Pero vamos, que las tuyas deberían funcionar también, es cuestión de verlo in-situ, que es como mejor se prueba esto. Eso sí, considera -70 como una señal "normal" no bajes de ahí, ni para la red de 2,4.

Saludos!
 
Pero vamos, que las tuyas deberían funcionar también, es cuestión de verlo in-situ, que es como mejor se prueba esto. Eso sí, considera -70 como una señal "normal" no bajes de ahí, ni para la red de 2,4.

OK, perfecto entonces también así y de esta manera se incluye una sóla regla.
Entonces quedaría:

Código:
/caps-man access-list add action=accept signal-range=-70..0

Gracias.
PD: En cuanto pueda lo pongo todo en práctica y vuelvo con los resultados de puesta en marcha de CAPsMAN.
 
OK, perfecto entonces también así y de esta manera se incluye una sóla regla.
Entonces quedaría:

Código:
/caps-man access-list add action=accept signal-range=-70..0

Gracias.
PD: En cuanto pueda lo pongo todo en práctica y vuelvo con los resultados de puesta en marcha de CAPsMAN.
Ojo que -70 es mejor señal que -75. No aprietes tanto, déjalo en el rango -75..0

Saludos!
 
@pokoyo
Los equipos no encuentran la red MOVISTAR_EA0D. Ni móviles ni portátil. Ahora estoy conectado por cable.

Captura de pantalla_2020-12-29_16-42-10.png


He dejado la señal a -75.
Las dos bandas tienen el mismo SSID y password.
Y la banda 5ghz puede coger 20/40/80 XXXX como fuera de CAPsMAN ?
Saludos.
 
Última edición:
Ahora a cambiado el estado.
Creo que hay 5GHZ pero falta la de 2.4 GHZ, por lo que puedo comprender.
Y aún y así algún móvil se conecta y otros no.
De todas maneras también preferiría tener b/g/N y a/N/ac para tener mayor compatibilidad con los diferentes equipos que se conecten.

Y el name de identificación salen con diferente formato en el pantallazo.

Captura de pantalla_2020-12-29_17-31-01.png


Screenshot_WiFiAnalyzer_20201229-182048.pngScreenshot_Wifi_Analyzer_20201229-182631.png

No sale el ssid en los pantallazos del WiFi analyzer. Un poco extraño todo.

En cuanto deshabilito CAPsMAN y saco los caps todo vuelve a la normalidad y estupendo.
Los he sacado de momento para que no se me echen encima los de casa. Cuando tenga que cambiar algo lo vuelvo ha habilitar todo de nuevo.
 
Última edición:
Dale un export. La regla de provisioning de 2,4 debe de estar mal hecha, porque la interfaz capsman no sale en ninguno de los tres canales definidos, ni con el nombre del "identity", así que está cogiendo lo primero que es capaz de provisionar... usease, averigua tú qué configuración.

Para 2,4 créeme que no quires "b" para nada, quieres g/n. Si a día de hoy tienes algún dispositivo con wifi "b", te pago una cerveza.

Para 5Ghz, si quires, puedes poner a/n/ac, aunque te pasará algo parecido, muy pocos o ningún dispositivo soportarán a sin soportar n o ac al mismo tiempo.

La interfaz de 5GHz, como te he comentado antes, dependiendo del canal que pille en automático, puede tardar hasta 10min en levantar. Si no quieres ese comportamiento, marca el "skip DFS" en la configuración del "channel".

Saludos!
 
Dale un export. La regla de provisioning de 2,4 debe de estar mal hecha, porque la interfaz capsman no sale en ninguno de los tres canales definidos, ni con el nombre del "identity", así que está cogiendo lo primero que es capaz de provisionar... usease, averigua tú qué configuración.

Para 2,4 créeme que no quires "b" para nada, quieres g/n. Si a día de hoy tienes algún dispositivo con wifi "b", te pago una cerveza.

Para 5Ghz, si quires, puedes poner a/n/ac, aunque te pasará algo parecido, muy pocos o ningún dispositivo soportarán a sin soportar n o ac al mismo tiempo.

La interfaz de 5GHz, como te he comentado antes, dependiendo del canal que pille en automático, puede tardar hasta 10min en levantar. Si no quieres ese comportamiento, marca el "skip DFS" en la configuración del "channel".

Saludos!
Te paso la config.
Ya había leido yo que hay gente que por lo que sea no les acaba de funcionar bien capsman. No sé.
Gracias de nuevo.
 

Adjuntos

  • capsmanager.txt
    11.5 KB · Visitas: 141
Te faltan tanto la regla de configuración como de 2,4. He metido yo la pata al definirlas y van apuntando a un nombre de canal que no existe. Si te vas a la pestaña Provisioning, verás que hay sólo una regla, y no dos, como debería haber; al igual que en Configurations. Además de eso, tienes una regla de CAP Interface metida a pelo. No se si será de otra vez o de la que se acaba de crear al no detectar nada en el provisioning de 2,4. Pasos para corregirlo:

En la primera pestaña de CAPsMAN, "CAP Interface", borra la entrada que no es dinámica, "cap1".

Mete la regla de configuración y provisioning que te faltan:
Código:
/caps-man configuration
add channel=2ghz-chs-auto country=spain datapath=home-dp mode=ap \
    name=home-wifi-2ghz-cfg rates=gn-only security=home-sp ssid=MikrotikPalColega
/caps-man provisioning
add action=create-dynamic-enabled hw-supported-modes=gn \
    master-configuration=home-wifi-2ghz-cfg name-format=prefix-identity \
    name-prefix=2ghz

Navega a la pestaña de Radio y verás dos entradas, una con una P delante, apuntando a la MAC address de la interfaz de 5GHz que está provisionada, y otra sin la P delante. Pulsas en esa entrada que no tiene la P y en el botón Provision. Una vez hecho, la nueva interfaz dinámica ha de aparecer en la primera pestaña. Cuando metas un segundo AP, en lugar de dos, tendrás cuatro en esa lista.

Una vez hecho, deberías tener todo funcionado. CAPsMAN funciona, descuida. Y actualiza a la 6,48 que corrige un cerro de cosas, entre ellas, un par de chorraditas con CAPsMAN.

Te paso la configuración de CAPsMAN completa, corregida:

Código:
/caps-man rates
add basic=12Mbps name=gn-only supported=\
    12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps

/caps-man security
add authentication-types=wpa2-psk disable-pmkid=yes \
    encryption=aes-ccm group-encryption=aes-ccm group-key-update=1h \
    name=home-sp passphrase=MySuperW1f1P4ssW0rd!

/caps-man channel
add band=2ghz-g/n control-channel-width=20mhz \
    extension-channel=disabled frequency=2412,2437,2462 \
    name=2ghz-chs-auto tx-power=13
add band=5ghz-n/ac control-channel-width=20mhz \
    extension-channel=XXXX name=5ghz-chs-auto

/caps-man datapath
add bridge=bridge client-to-client-forwarding=yes \
    local-forwarding=no name=home-dp

/caps-man configuration
add channel=2ghz-chs-auto country=spain datapath=home-dp mode=ap \
    name=home-wifi-2ghz-cfg rates=gn-only security=home-sp ssid=MikrotikPalColega
add channel=5ghz-chs-auto country=spain datapath=home-dp mode=ap \
    name=home-wifi-5ghz-cfg rates=gn-only security=home-sp ssid=MikrotikPalColega

/caps-man provisioning
add action=create-dynamic-enabled hw-supported-modes=gn \
    master-configuration=home-wifi-2ghz-cfg name-format=prefix-identity \
    name-prefix=2ghz
add action=create-dynamic-enabled hw-supported-modes=ac \
    master-configuration=home-wifi-5ghz-cfg name-format=prefix-identity \
    name-prefix=5ghz

/caps-man manager
set enabled=yes

Saludos!
 
Te faltan tanto la regla de configuración como de 2,4. He metido yo la pata al definirlas y van apuntando a un nombre de canal que no existe. Si te vas a la pestaña Provisioning, verás que hay sólo una regla, y no dos, como debería haber; al igual que en Configurations. Además de eso, tienes una regla de CAP Interface metida a pelo. No se si será de otra vez o de la que se acaba de crear al no detectar nada en el provisioning de 2,4. Pasos para corregirlo:

En la primera pestaña de CAPsMAN, "CAP Interface", borra la entrada que no es dinámica, "cap1".

Mete la regla de configuración y provisioning que te faltan:
Código:
/caps-man configuration
add channel=2ghz-chs-auto country=spain datapath=home-dp mode=ap \
    name=home-wifi-2ghz-cfg rates=gn-only security=home-sp ssid=MikrotikPalColega
/caps-man provisioning
add action=create-dynamic-enabled hw-supported-modes=gn \
    master-configuration=home-wifi-2ghz-cfg name-format=prefix-identity \
    name-prefix=2ghz

Navega a la pestaña de Radio y verás dos entradas, una con una P delante, apuntando a la MAC address de la interfaz de 5GHz que está provisionada, y otra sin la P delante. Pulsas en esa entrada que no tiene la P y en el botón Provision. Una vez hecho, la nueva interfaz dinámica ha de aparecer en la primera pestaña. Cuando metas un segundo AP, en lugar de dos, tendrás cuatro en esa lista.

Una vez hecho, deberías tener todo funcionado. CAPsMAN funciona, descuida. Y actualiza a la 6,48 que corrige un cerro de cosas, entre ellas, un par de chorraditas con CAPsMAN.

Te paso la configuración de CAPsMAN completa, corregida:

Código:
/caps-man rates
add basic=12Mbps name=gn-only supported=\
    12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps

/caps-man security
add authentication-types=wpa2-psk disable-pmkid=yes \
    encryption=aes-ccm group-encryption=aes-ccm group-key-update=1h \
    name=home-sp passphrase=MySuperW1f1P4ssW0rd!

/caps-man channel
add band=2ghz-g/n control-channel-width=20mhz \
    extension-channel=disabled frequency=2412,2437,2462 \
    name=2ghz-chs-auto tx-power=13
add band=5ghz-n/ac control-channel-width=20mhz \
    extension-channel=XXXX name=5ghz-chs-auto

/caps-man datapath
add bridge=bridge client-to-client-forwarding=yes \
    local-forwarding=no name=home-dp

/caps-man configuration
add channel=2ghz-chs-auto country=spain datapath=home-dp mode=ap \
    name=home-wifi-2ghz-cfg rates=gn-only security=home-sp ssid=MikrotikPalColega
add channel=5ghz-chs-auto country=spain datapath=home-dp mode=ap \
    name=home-wifi-5ghz-cfg rates=gn-only security=home-sp ssid=MikrotikPalColega

/caps-man provisioning
add action=create-dynamic-enabled hw-supported-modes=gn \
    master-configuration=home-wifi-2ghz-cfg name-format=prefix-identity \
    name-prefix=2ghz
add action=create-dynamic-enabled hw-supported-modes=ac \
    master-configuration=home-wifi-5ghz-cfg name-format=prefix-identity \
    name-prefix=5ghz

/caps-man manager
set enabled=yes

Saludos!

Ok. Muchas gracias por las configuraciones y los consejos.

Mañana lo pongo en práctica y me paso por aquí para comentar los resultados. Que con gente en casa poco margen te dejan de maniobras.

Saludos.
 
Por cierto, otra cosilla que tampoco hace falta que hagas y que veo en tu configuración:

Código:
/interface bridge
add comment=defconf name=bridge protocol-mode=none

Ese paso de poner el protocol-mode=none te lo puedes ahorrar en ese equipo. Ese equipo sí soporta R-STP (opción por defecto) como protocolo de spanning tree para protección de bucles en el bridge sin afectar al hardware offloading. Esto sólo es necesario para equipos con chipset MT7621, como el hEX (gr3) o hEX-S.

Saludos!
 
@pokoyo

Muchas gracias ya está en marcha. hAP AC2.

He seguido tus consejos:

1. Actualizar routerOS a la última versión 6.48
2. He cambiado el protocolo en el bridge a rstp porque no es un equipo con chip MT7621, aparece la H.
3. g/n y n/ac perfecto también en el funcionamiento de los equipos.
4. En channels he habilitado la pestaña Skip DFS para que levante más rápido la banda del 5Ghz.

Dudas/consultas:

1. Si al final sólo se decide usar un equipo con Capsman habilitado y sin otros Caps a su cargo como se puede subir el power tx que ahora está restringido en la banda de 2.4Ghz.

2.Cuales son los pasos correctos para actualizar el equipo con Capsman manager y los Caps que tuviera a su cargo. Edito: los he actualizado individualmente y todo bien.

3. En el manual de Capsman se podría indicar que los equipos que hacen de Capsman y Cap al mismo tiempo hay que configurarlos con la opción Capsman Addresses = 127.0.0.1.

Dejo unos pantallazos.

capsman_ok.png


capsman_channels.png


capsman_registration.png


Edito: he puesto el hap mini que tengo en modo CAP y después con sólo enchufarlo al hap AC2 ya lo ha adoptado automáticamente para administrarlo por Capsman. Están el uno al lado del otro sólo como prueba.

Con sólo conectarlo o desconectarlo por cable de red Capsman ya se hace cargo dinámicamente de todo?
No hay que dar de alta ni baja los Caps?

haplite_cap.png


capsman_haplite.png


capsman_remote.png


hapac2_ok.png


Saludos y mil gracias.
 
Última edición:
1. Actualizar routerOS a la última versión 6.48
2. He cambiado el protocolo en el bridge a rstp porque no es un equipo con chip MT7621, aparece la H.
3. g/n y n/ac perfecto también en el funcionamiento de los equipos.
4. En channels he habilitado la pestaña Skip DFS para que levante más rápido la banda del 5Ghz.
Bien. Pero ojo cuidado con lo del Skip DFS. Si sólo vas a tener un AP en la instalación... ni tan mal. Los canales en 5GHz tienen un ancho de canal de 20MHz por defecto. Los canales que cumplen con ese "Skip DFS" son los cuatro primeros del espectro: 36, 40, 44, 48. Si plantas una configuración de 80MHz con Skip DFS, significa que el AP se va a plantar en el 36 o el 48 y va a extender bien por arriba bien por abajo a los otros tres canales, zampándote de un plumazo los 4 canales; los únicos cuatro que cumplen con esa regla. Si mañana vas a plantar otro AP, no le quedará más remedio que usar el mismo canal, y ahí empiezan los problemas, si los AP's no están lo suficientemente separados y se "oyen" entre ellos. En ese caso, habría que bajar el ancho de canal a 40Mhz, donde sí tendrías dos canales sin solapamiento entre los NO DFS.
Resumiendo: los canales DFS están para usarlos, aunque siempre es bueno tener al menos un AP en un canal NO DFS, tal que si los otros detectan un pulso de radar y se ponen a reseleccionar una nueva frecuencia, no te quedes tirado por completo. Esto para instalaciones grandes, para casa no creo ni que te enteres.

Además de lo anterior, si en tu equipo ejecutas interface wireless info allowed-channels wlan2, verás que el equipo no emite con la misma potencia en todos los canales. El mío, hAP-ac3, por ejemplo, ya descontando la ganancia de las antenas, emite a 17dBm en los canales NO DFS, mientra sque emite a 21dBm en los canales del 5500 en adelante (23 y 27 dBm respectivamente, si cuento con la ganancia de las antenas). Si quieres potencia, no te quedan más narices que tirar de canales DFS.

Vamos a por las dudas ahora:
1. Si al final sólo se decide usar un equipo con Capsman habilitado y sin otros Caps a su cargo como se puede subir el power tx que ahora está restringido en la banda de 2.4Ghz.
En la definición del canal (pestaña Channels), ves que el canal está definido con cierto valor en el "Tx Power". Si quitas ese valor, el equipo emitirá con la potencia máxima, restringida por tu país, que pueda emitir en esa banda. Para 2,4GHz, dicha potencia en España son 20dBm (100mW). Puedes poner valores por debajo de 20 a ese campo, si los pones por encima, el propio firmware te capará y te dará como máximo 20dBm. Si quieres que ambas redes lleguen con igual intensidad a los sitios, reduce la potencia de la de 2,4GHz en torno a 7-8dBm. De esa manera, promueves un roaming natural a la red de 5GHz, puesto que a igual potencia, los clientes suelen implementar reglas de roaming donde prefieren la red con mayor velocidad; la de 5GHz. No obstante, esto lo vas a hacer cuando tienes varios AP's para cubrir una zona, normalmente con un único AP no te interesa restarle potencia.
Si tienes que plantar dos AP's asegúrate de que, entre ellos, no se oyen: reciben señal con menos de -80 a -85dBm cuando los pones a "escuchar" uno al otro.

2.Cuales son los pasos correctos para actualizar el equipo con Capsman manager y los Caps que tuviera a su cargo. Edito: los he actualizado individualmente y todo bien.
Si no te quieres complicar la vida, verás que los equipos en modo CAP tienen un bridge con un cliente dhcp corriendo, usease, tiene IP. Los localizas vía winbox y los actualizas, entras a ellos y los actualizas, tal cual haces con tu equipo normal.
Si te quieres complicar la vida, como obviamente en un despliegue de 200AP's no vas a ir uno a uno actualizando, CAPsMAN también ha pensado en eso: en el botón "Manager" de CAPsMAN verás dos campos, uno que se llama "Package Path" y otro que se llama "Upgrade Policy". Esos dos valen, respectivamente, para decirles dónde está el paquete software que contiene la actualización en el disco de tu CAPsMAN y cuándo tienen que actualizar. Las dos opciones para actualizar son:
require same version: cuando actualiza el CAPsMAN, fuerza a actualizar los CAPs a la misma versión, y si no puede los deshabilita; no los provisiona (se van de CAP Interface, aunque aún puedes crear una provisión a mano en dicha pestaña)
suggest same version: cuando actualiza el CAPsMAN, intenta actualizar los CAPs a la misma versión, y si no puede. los deja como estaba, provisionados.
En la práctica esto es un poco coñazo, especialmente para casa: si tienes varios equipos varipintos (un hEX-S como CAPsMAN [arquitectura MMIPS], hAP-lite/mini [arquitectura SMIPS] y hAP-ac3 [arquitectura ARM]) tendrás que bajarte sendos paquetes y meterlos todos en el CAPsMAN si quieres que se actualicen los CAPs. Resultado: tardas menos en entrar en cada uno y pulsar "System -> Packages -> Check for Updates", que además ya selecciona su arquitectura automáticamente. Supongo que en despliegues enormes con todos los APs iguales, es muy cómodo la opción de actualizarlos vía CAPsMAN, pero para casa, me quedo con el método manual.

3. En el manual de Capsman se podría indicar que los equipos que hacen de Capsman y Cap al mismo tiempo hay que configurarlos con la opción Capsman Addresses = 127.0.0.1.
Correcto. Me lo apunto para añadirlo.


Trabajo de campo:
Edito: he puesto el hap mini que tengo en modo CAP y después con sólo enchufarlo al hap AC2 ya lo ha adoptado automáticamente para administrarlo por Capsman. Están el uno al lado del otro sólo como prueba.

Con sólo conectarlo o desconectarlo por cable de red Capsman ya se hace cargo dinámicamente de todo?
No hay que dar de alta ni baja los Caps?
Esa es la gracia de CAPsMAN: le das un reset a un equipo y lo pones en modo CAP (desde las opciones del reset lo tienes), y con que le llegue un cable ethernet que le enchufe al CAPsMAN, ya no tienes que hacer más. Esto pasa porque las dos reglas de provisioning que tienes son totalmente automáticas, de ahí que no te haga falta dar de alta ni de baja nada, y dicen: si el equipo soporta g/n, mándale la configuración de g/n, y si soporta además ac, mándale también la de ac.
Como ves, esas reglas no llevan especificadas las direcciones MAC, que es lo que suele ir en una regla de provisioning normal en un despliegue grande: cada radio lleva su MAC y su regla de provisión, tal que nadie te pueda pinchar un AP en tu instalación y obtener una configuración que funcione. De hecho, se suelen meter configuraciones y reglas de provisioning "bogus" o "fakes" para que obtengan una provisión temporal que no haga nada, y luego ir metiendo a mano la suya, atendiendo a un plano de situación y distribución de canales.
Además de lo anterior, las reglas de provisioning que hemos metido tienen como "action" un "create dynamic enabled", que quiere decir "créame las interfaces CAP dinámicamente y de forma automática las das de alta en CAP Interface. Si te das cuenta, las reglas dinámicas no se pueden editar en la primera pestaña, sólo borrar, y dependen totalmente de las reglas de provisión. Lo bueno de esto es que si tocas algo en la configuración, el canal, la seguridad o cualquier otro parámetro, el propio CAPsMAN detecta el cambio y recrea la interfaz sin tú tocarlo (tarda un pelín, pero lo hace automático). Si quieres forzarlo y ver con tus propios ojos el cambio, sólo tienes que borrar la interfaz CAP de la primera pestaña e ir a Radio, seleccionar la entrada que no tiene "P" (sin provisión), y darle al botón Provision, y verás como se vuelve a crear la entrada dinámica en la primera pestaña.
Como las reglas de provisioning son totalmente automáticas y para que identifiques mejor quien es quien, el Name Format está puesto como Prefix + Identity, siendo el prefijo 2ghz / 5ghz, dependiendo de la regla. Las identidades o nombres de los CAPs también los puedes controlar desde la pestaña Remote CAP, con el botón Set Identity.
La configuración que te he facilitado es de las más sencillitas, pero perfectamente válida para casa. Todo esto se puede complicar lo que quieras, si le sabes sacar partido a la herramienta. Cuando quieras lo pones en casa y juega con ello, entre dos APs.

Si te interesa el tema, te dejo un vídeo muy chulo del manejo de CAPsMAN en modo dios:


Saludos!
 
Resumiendo: los canales DFS están para usarlos, aunque siempre es bueno tener al menos un AP en un canal NO DFS, tal que si los otros detectan un pulso de radar y se ponen a reseleccionar una nueva frecuencia, no te quedes tirado por completo. Esto para instalaciones grandes, para casa no creo ni que te enteres.
Entendido. Cuando hay más de un Cap es mejor deshabilitar skip DFS para evitar un posible solapamiento de canales.

En la definición del canal (pestaña Channels), ves que el canal está definido con cierto valor en el "Tx Power". Si quitas ese valor, el equipo emitirá con la potencia máxima, restringida por tu país, que pueda emitir en esa banda.
Entendido. Lo acabo de probar.

Si no te quieres complicar la vida, verás que los equipos en modo CAP tienen un bridge con un cliente dhcp corriendo, usease, tiene IP. Los localizas vía winbox y los actualizas, entras a ellos y los actualizas, tal cual haces con tu equipo normal.
Así lo hice antes de tu respuesta, se han actualizado los equipos correctamente.

Gracias por las explicaciones tan extensas y didácticas.

Saludos.
 
Solo paso por aquí para aplaudir y dar las gracias a @pokoyo porque además de ayudar, se aprende un montón con cada uno de sus post. En serio, me suelo leer las guias y los consejos que le da a todo el mundo y lo hace de manera didáctica y fácil de comprender.

Si te pones a stremear en twitch o youtube un canal sobre RouterOS y como configurar Mikrotik igual eres el nuevo rubius xD
 
Solo paso por aquí para aplaudir y dar las gracias a @pokoyo porque además de ayudar, se aprende un montón con cada uno de sus post. En serio, me suelo leer las guias y los consejos que le da a todo el mundo y lo hace de manera didáctica y fácil de comprender.

Si te pones a stremear en twitch o youtube un canal sobre RouterOS y como configurar Mikrotik igual eres el nuevo rubius xD
No podría estar mas de acuerdo con todo lo qje comentas sobre @pokoyo.
Saludos
 
Arriba