Mikrotik-WireGuard-Pihole

Buenas noches,

Quizás es una pregunta muy, muy tonta pero... con la siguiente disposición:

Mikrotik 962UiGS-5HacT2HnT con DHCP 10.0.0.1/24
Interface WireGuard 10.10.0.2
Raspberry PiHole 10.0.0.5...

Al configurar en el iphone la conexión VPN con WireGuard con el DNS 10.0.0.1 tengo navegación pero con publicidad si configuro 10.0.0.5 con el DNS veo el siguiente warning en el PIHOLE (además de no tener navegación, por falta de resolución):

ignoring query from non-local network 10.10.0.2 (logged only once)

Como puedo habilitar 10.10.0.2 para que resuelva el tema de los DNS?

Cordialmente,

Juhn_Hoo
 
Buenas noches,

Quizás es una pregunta muy, muy tonta pero... con la siguiente disposición:

Mikrotik 962UiGS-5HacT2HnT con DHCP 10.0.0.1/24
Interface WireGuard 10.10.0.2
Raspberry PiHole 10.0.0.5...

Al configurar en el iphone la conexión VPN con WireGuard con el DNS 10.0.0.1 tengo navegación pero con publicidad si configuro 10.0.0.5 con el DNS veo el siguiente warning en el PIHOLE (además de no tener navegación, por falta de resolución):

ignoring query from non-local network 10.10.0.2 (logged only once)

Como puedo habilitar 10.10.0.2 para que resuelva el tema de los DNS?

Cordialmente,

Juhn_Hoo
Quita la opción del pi-hole que previene usarlo desde fuera de la LAN (settings -> DNS -> allow only local requests).

Saludos!
 
Quita la opción del pi-hole que previene usarlo desde fuera de la LAN (settings -> DNS -> allow only local requests).

Saludos!
Buenas tardes,


He marcado respond only on interface eth0 y funciona... pero lo lógico y más seguro no sería marcar la primera? Allow only local request... no hay manera de decirle que la interface WireGuard es local?

Que diferencia hay con marcar Respond only on interface eth0 y Bind only on interface eth0?

Se entiende que si no tienes el puerto 53 redireccionado no hay problemas de seguridad "supuestamente" no?

Captura de pantalla 2022-05-15 a las 15.02.35 copia.png


Cordialmente,

Juhn_Hoo
 
No le des más vueltas. Si quieres usar el pi-hole desde otra subred, esa es la configuración que tienes que tener.

Saludos!
 
Arriba