Mikrotik rb4011 + Gpon uFiber nano g + tlf voIP + Wifi AP Nano HD

Para la VoIP no necesitas una boca dedicada. Un teléfono IP lo podrías pinchar en cualquier puerto del equipo. Mientras sigas dentro de la red principal que monta el 4011, lo tendrías disponible.

Saludos!
 
Qué operador tienes? Qué configuración?

Saludos!
 
Qué operador tienes? Qué configuración?

Saludos!
Es O2, y la configuracion que pusimos en este hilo.

Ahora si funciona (no he cambiado nada), pero se corta a los pocos segundos de estar llamando, y se me queda en estado "sin servicio" el tlf hasta pasados unos segundos
 
Pásame un export de cómo lo tienes ahora mismo. Y también de la configuración VoIP del teléfono que uses.
Prueba a no deshabilitar los helpers SIP de la VoIP en IP > Firewall > Service Ports

Saludos!
 
Pásame un export de cómo lo tienes ahora mismo. Y también de la configuración VoIP del teléfono que uses.
Prueba a no deshabilitar los helpers SIP de la VoIP en IP > Firewall > Service Ports

Saludos!

Del tlf te puedo pasar Pantallazos (No se como sacar la config)

Y del mikrotik pongo el export debajo de los pantallazos
 
Última edición:
Aquí la configuración del rb4011 :

Código:
# mar/06/2021 11:27:01 by RouterOS 6.48.1
# software id = 3XC7-U6FZ
#
# model = RB4011iGS+
# serial number = B8FE0xxxxxxxx
/interface bridge
add admin-mac=XX:AD:XX:8D:52:C0 auto-mac=no comment=defconf name=bridge
/interface vlan
add interface=ether1 name=internet vlan-id=6
add interface=ether1 name=voip vlan-id=3
/interface pppoe-client
add add-default-route=yes disabled=no interface=internet name=pppoe-out1 \
    service-name=MovistarO2 use-peer-dns=yes user=adslppp@telefonicanetpa
/interface ethernet switch port
set 0 default-vlan-id=0
set 1 default-vlan-id=0
set 2 default-vlan-id=0
set 3 default-vlan-id=0
set 4 default-vlan-id=0
set 5 default-vlan-id=0
set 6 default-vlan-id=0
set 7 default-vlan-id=0
set 8 default-vlan-id=0
set 9 default-vlan-id=0
set 10 default-vlan-id=0
set 11 default-vlan-id=0
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp ranges=192.168.1.10-192.168.1.254
add name=vpn ranges=192.168.89.2-192.168.89.255
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge name=defconf
/ppp profile
set *FFFFFFFE local-address=192.168.89.1 remote-address=vpn
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=ether5
add bridge=bridge comment=defconf interface=ether6
add bridge=bridge comment=defconf interface=ether7
add bridge=bridge comment=defconf interface=ether8
add bridge=bridge comment=defconf interface=ether9
add bridge=bridge comment=defconf interface=ether10
add bridge=bridge comment=defconf interface=sfp-sfpplus1
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface l2tp-server server
set enabled=yes use-ipsec=yes
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN
add interface=pppoe-out1 list=WAN
/interface pptp-server server
set enabled=yes
/interface sstp-server server
set default-profile=default-encryption enabled=yes
/ip address
add address=192.168.1.1/24 comment=defconf interface=bridge network=\
    192.168.1.0
add address=192.168.10.2/24 interface=ether1 network=192.168.10.0
/ip cloud
set ddns-enabled=yes
/ip dhcp-client
add comment=defconf interface=ether1
add add-default-route=no disabled=no interface=voip
/ip dhcp-server lease
add address=192.168.1.43 client-id=1:70:xx:10:a0:xx:6d comment="XBOX xxx" \
    mac-address=70:xx:10:A0:xx:6D server=defconf
add address=192.168.1.27 client-id=1:9c:8e:99:5e:38:88 comment=\
    "HP ML350P Esxi" mac-address=xx:8E:xx:5E:38:xxserver=defconf
add address=192.168.1.11 client-id=1:0:c:xx:96:xx:ed mac-address=\
    00:0C:29:96:A2:ED server=defconf
add address=192.168.1.30 client-id=1:8:bd:xx:f6:xx:xxmac-address=\
    08:BD:43:F6:30:70 server=defconf
add address=192.168.1.23 client-id=1:0:c:xx:fd:xx:xx mac-address=\
    00:0C:29:FD:87:B3 server=defconf
/ip dhcp-server network
add address=192.168.1.0/24 comment=defconf dns-server=\
    192.168.1.23,192.168.1.1 gateway=192.168.1.1 netmask=24
/ip dns
set allow-remote-requests=yes use-doh-server=\
    https://cloudflare-dns.com/dns-query verify-doh-cert=yes
/ip dns static
add address=192.168.1.1 comment=defconf name=router.lan
add address=104.16.249.249 name=cloudflare-dns.com
add address=104.16.248.249 name=cloudflare-dns.com
/ip firewall filter
add action=accept chain=input comment=\
    "defconf: accept established,related,untracked" connection-state=\
    established,related,untracked
add action=accept chain=input comment="allow IPsec NAT" dst-port=4500 \
    protocol=udp
add action=accept chain=input comment="allow IKE" dst-port=500 protocol=udp
add action=accept chain=input comment="allow l2tp" dst-port=1701 protocol=udp
add action=accept chain=input comment="allow pptp" dst-port=1723 protocol=tcp
add action=accept chain=input comment="allow sstp" dst-port=443 protocol=tcp
add action=accept chain=input comment=\
    "Acepta el trafico de la vlan del telefono" in-interface=voip \
    src-address=10.0.0.0/8
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
    invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
    "defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
    in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
    ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
    ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related
add action=accept chain=forward comment=\
    "defconf: accept established,related, untracked" connection-state=\
    established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
    connection-state=invalid
add action=drop chain=forward comment=\
    "defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
    connection-state=new in-interface-list=WAN
add chain=forward comment="xbox filter rules - TCP" dst-port=53,80,3074 \
    protocol=tcp
add chain=forward comment="xbox filter rules - UDP" dst-port=\
    53,500,3544,3074,4500 protocol=udp
/ip firewall mangle
add action=set-priority chain=postrouting new-priority=4 out-interface=voip
add action=set-priority chain=postrouting new-priority=1 out-interface=\
    pppoe-out1
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
    ipsec-policy=out,none out-interface-list=WAN
add action=masquerade chain=srcnat comment="default configuration" \
    out-interface=voip
add action=dst-nat chain=dstnat comment=XPENOLOGY dst-port=5001 protocol=tcp \
    to-addresses=192.168.1.222 to-ports=5001
add action=dst-nat chain=dstnat comment=FOSCAM_NVR dst-port=88 protocol=tcp \
    to-addresses=192.168.1.6 to-ports=88
add action=masquerade chain=srcnat comment="masq. vpn traffic" src-address=\
    192.168.89.0/24
add action=dst-nat chain=dstnat comment="xbox one NAT rules - UDP" dst-port=\
    3074,88,500,3544,4500,53,3075 in-interface=ether1 protocol=udp \
    to-addresses=192.168.1.43
add action=dst-nat chain=dstnat comment="xbox one NAT rules - TCP" dst-port=\
    53,80,3074,3075 in-interface=all-ethernet protocol=tcp to-addresses=\
    192.168.1.43
/ip firewall service-port
set sip disabled=yes ports=5060,5070
/ip upnp
set enabled=yes
/ip upnp interfaces
add interface=pppoe-out1 type=external
add interface=bridge type=internal
/ppp secret
add name=vpn
/routing rip interface
add interface=voip passive=yes receive=v2
/routing rip network
add network=10.0.0.0/8
/system clock
set time-zone-name=Europe/Madrid
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
 
Prueba dehabilitando el DoH y dejando los servidores dns de telefónica.

Saludos!
 
Puedes añadir a la configuración el host de telefónica.

Código:
/ip dns static
add address=10.34.255.134 name=telefonica.net
 
/ip firewall service-port set sip disabled=yes ports=5060,5070
Hola. No entiendo por qué deshabilitáis el ALG de SIP. No debería deshabilitarse, pues, precisamente, lo que hace es facilitar que progrese la señalización de este protocolo para los clientes de VOIP. Yo NUNCA lo he deshabilitado y tengo Voip en toda la red (es Movistar, pero es lo mismo). Ya sé que en diversos posts hay gente que lo deshabilita, pero nunca le he encontrado el sentido. Prueba habilitarlo y nos dices.

Otra cosa podría ser ruido por los PLCs...


Surte!!!
 
Hola. No entiendo por qué deshabilitáis el ALG de SIP. No debería deshabilitarse, pues, precisamente, lo que hace es facilitar que progrese la señalización de este protocolo para los clientes de VOIP. Yo NUNCA lo he deshabilitado y tengo Voip en toda la red (es Movistar, pero es lo mismo). Ya sé que en diversos posts hay gente que lo deshabilita, pero nunca le he encontrado el sentido. Prueba habilitarlo y nos dices.

Otra cosa podría ser ruido por los PLCs...


Surte!!!

Pues la verdad es que ni idea .....

Yo seguí las instrucciones del tutorial , y con la inestimable ayuda de pokoyo

Puede también que sea ruido de los PLC ..... sea como sea he puesto el DNS de telefónica estático del compañero anterior , y creo que está mas estable .....porque he hecho un par de llamadas y no se han cortado (antes si se cortaban, aunque conseguía hablar a veces unos segundos, a veces nada, y a veces un par de minutos)

En el tlf tengo un icono que me muestra si estoy conectado o no, y antes iba y venia con frecuencia.
Ahora con el DNS estático parece que no se va
 
Nada, mi gozo en un pozo ....sigue perdiendo la conexion de forma aleatoria.

le he quitado incluso la regla
Código:
/ip firewall service-port set sip disabled=yes ports=5060,5070

Y lo he habilitado de nuevo ..... pero la señal en el tlf viene y va sin patron definido
 
Nada, mi gozo en un pozo ....sigue perdiendo la conexion de forma aleatoria.

le he quitado incluso la regla
Código:
/ip firewall service-port set sip disabled=yes ports=5060,5070

Y lo he habilitado de nuevo ..... pero la señal en el tlf viene y va sin patron definido
Por aclarar una cosa. ¿lo de que la señal va y viene, que quieres decir? ¿que pierde el registro y después lo recupera? Si fuera eso, depende entonces del cliente de Voip. Yo por ejemplo uso en el Iphone sessiontalk como Softphone y no me pierde el registro. Eso se hace con parámetro, que pide volver a registrar cada cierto tiempo. Y es un coñazo, con algunos clientes. En el Mac uso bria solo y conseguí que estuviera estable y disponible. No se decir en tu caso, pero normalmente es un parámetro en de la configuración de la cuenta SIP, registro SIP, periodo de expiración o algo parecido. O bien lo pones digamos cada 10m o si se puede, pides que no haga re-registros o keepalive. A mí antes, con ciertas configuraciones, me tiraba una llamada en curso a los 90s, hasta que di con la tecla.
suerte.
 
Por aclarar una cosa. ¿lo de que la señal va y viene, que quieres decir? ¿que pierde el registro y después lo recupera? Si fuera eso, depende entonces del cliente de Voip. Yo por ejemplo uso en el Iphone sessiontalk como Softphone y no me pierde el registro. Eso se hace con parámetro, que pide volver a registrar cada cierto tiempo. Y es un coñazo, con algunos clientes. En el Mac uso bria solo y conseguí que estuviera estable y disponible. No se decir en tu caso, pero normalmente es un parámetro en de la configuración de la cuenta SIP, registro SIP, periodo de expiración o algo parecido. O bien lo pones digamos cada 10m o si se puede, pides que no haga re-registros o keepalive. A mí antes, con ciertas configuraciones, me tiraba una llamada en curso a los 90s, hasta que di con la tecla.
suerte.
Quiero decir que el tlf que uso (Un yealink TS42) como este :



En el ciruclo amarillo que he puesto cuando tengo linea me sale un icono con un tlf pequeñito, y en ese momento enm la zona que he puesto en rojo me sale la hora y la fecha así como la farse "voIP O2"

cuando se va la señal, en la zona amarilla sale un icono diferente (parece una señal de prohibido" , y en la zona roja cambia a "Sin servicio"
 
Prueba una cosa porfa. Probablemente no tenga nada que ver, pero me "rechina" ver los datos de "telefonica.net" en SIP1, y los del proxy en SIP2. Vuelve a meter los datos de telefonica.net 5060 en SIP2, con tu teléfono como usuario y contraseña (al igual que arriba) y baja el tiempo de expiración de registro a 180s. El del outbound proxy lo puedes dejar a 3600s.

Saludos!
 
Arriba