Mikrotik Hex - IPTV Pixela con tráfico elevado

Hola,

No sé por qué pero, por ejemplo si hago un test de velocidad o alguien está descargando un juego de steam u otra tienda, la IPTV de Movistar se pixela. El caso es que si monitoreas el router la CPU no pasa del 70-80% en picos (de media en los gráficos no pasa del 50%) descargando a full a 900-950Mb/s.

La configuración es ONT+Hex con Triple Play

####################################################
# MOVISTAR TRIPLE VLAN, TODO EN UN BRIDGE (HW = OFF)
####################################################
# Extraer la IP siguiente de la tabla de VLANs del
# router de Movistar, la que va sobre la vlan 2
# Calcular el CIDR de la máscara en función del número
# 255.128.0.0 -> /9
# 255.192.0.0 -> /10
# ¡¡¡CAMBIAR IP ANTES DE IMPORTAR EL FICHERO!!!
# Ejemplo:
:local iptv 10.192.230.50/9
####################################################
/interface/bridge
set 0 igmp-snooping=yes

/interface/vlan
add interface=ether1 name=vlan2-iptv vlan-id=2
add interface=ether1 name=vlan3-telefono vlan-id=3
add interface=ether1 name=vlan6-internet vlan-id=6

/interface/pppoe-client
add add-default-route=yes disabled=no interface=vlan6-internet \
name=internet use-peer-dns=yes user=adslppp@telefonicanetpa \
password=adslppp

/interface/list
add comment=vlans-iptv-voip name=VLANs2&3

/interface/list/member
set [find where interface=ether1 and list=WAN] interface=internet
add interface=vlan2-iptv list=VLANs2&3
add interface=vlan3-telefono list=VLANs2&3

/ip/dhcp-server/option
add code=240 name=opch-imagenio value="':::::239.0.2.29:22222'"

/ip/pool
set [find name=default-dhcp] ranges=192.168.88.10-192.168.88.239
add name=iptv-dhcp ranges=192.168.88.241-192.168.88.254

/ip/dhcp-server/matcher
add address-pool=iptv-dhcp code=60 name=descos server=defconf \
value="[IAL]"

/ip/dhcp-server/network
add address=192.168.88.240/28 comment=iptv-network \
dhcp-option=opch-imagenio dns-server=172.26.23.3 \
gateway=192.168.88.1 netmask=24

/ip/dhcp-client
add interface=vlan3-telefono add-default-route=no \
use-peer-ntp=no use-peer-dns=no

/ip/address
add address=$iptv interface=vlan2-iptv

/ip/firewall/filter
add action=accept chain=input comment="vlans: accept voip and iptv vlans" \
in-interface-list=VLANs2&3 place-before=\
[find where comment="defconf: drop all not coming from LAN"]

/ip/firewall/nat
add action=masquerade chain=srcnat comment="VLANs2&3: masquerade" \
out-interface-list=VLANs2&3

/ip/firewall/service-port
set [find name=rtsp] disabled=no

/routing/igmp-proxy
set query-interval=30s quick-leave=yes
/routing/igmp-proxy/interface
add alternative-subnets=0.0.0.0/0 interface=vlan2-iptv upstream=yes
add interface=bridge

/routing/rip/instance
add afi=ipv4 disabled=no name=rip
/routing rip interface-template
add instance=rip interfaces=vlan2-iptv,vlan3-telefono mode=passive
He estado intentando encontrar algo en el buscador por si ya hubiera sido tratado algo similar pero no he encontrado nada.

¿Alguna idea de qué puede ser y cómo hacer que no suceda?

Gracias de antemano a toda la comunidad.
 
Hola,

No sé por qué pero, por ejemplo si hago un test de velocidad o alguien está descargando un juego de steam u otra tienda, la IPTV de Movistar se pixela. El caso es que si monitoreas el router la CPU no pasa del 70-80% en picos (de media en los gráficos no pasa del 50%) descargando a full a 900-950Mb/s.

La configuración es ONT+Hex con Triple Play


He estado intentando encontrar algo en el buscador por si ya hubiera sido tratado algo similar pero no he encontrado nada.

¿Alguna idea de qué puede ser y cómo hacer que no suceda?

Gracias de antemano a toda la comunidad.
Es evidente el problema, ¿no? Estás dejando sin caudal algo que Movistar tiene priorizado en sus equipos. Así que, si quieres que eso no pase, tienes que priorizar ese tráfico por encima del resto.

Tu respuesta es usar colas de prioridad. Busca info en youtube de cómo hacerlo, de momento aquí no hay ningún manual al respecto.

Saludos!
 
Gracias @pokoyo echaré un ojo, aunque tengo entendido que para eso tengo que sacrificar el fasttrack. No sé si el heX irá sobrado implementando colas de prioridad y siendo un Paco.
 
Sí, ya lo he visto e implementando colas muy simples, es muy probable que esté haciendo cosas mal ojo, pero realmente muy simples... al desactivar el fasttrack el equipo cliente que más velocidad me coge por cable son ~200Mbps de los ~1000Mbps disponibles en la conexión del ISP habiéndole capado a 400Mbps en los test que he hecho.

Como dirían en las pelis de Vietnam: "no me alisté para esto". Imagino que tengo que darle más vueltas pero me temo si es posible que ¿el heX con colas no da para más de esos ~200Mbps?
 
Sí, ya lo he visto e implementando colas muy simples, es muy probable que esté haciendo cosas mal ojo, pero realmente muy simples... al desactivar el fasttrack el equipo cliente que más velocidad me coge por cable son ~200Mbps de los ~1000Mbps disponibles en la conexión del ISP habiéndole capado a 400Mbps en los test que he hecho.

Como dirían en las pelis de Vietnam: "no me alisté para esto". Imagino que tengo que darle más vueltas pero me temo si es posible que ¿el heX con colas no da para más de esos ~200Mbps?
Me extraña. Revisa lo que estás haciendo. También tened en cuenta que el fasttrack o es un todo o nada. Si alguna conexión no quieres que haga fasttrack, la aceptas antes de la regla de fasttrack y listo.

Saludos!
 
Pues por descartar he hecho algo tan sencillo como deshabilitar fasttrack y activar esta regla simple:

1669658341109.png


Con esa regla simple tiro un test para ver si capa el tráfico a 400Mbps:

1669658402337.png


Como digo ahí se queda la cosa... la red está ahora mismo 95% ociosa en el momento del test.

Habilito fasttrack:

1669658494780.png


Se admite cualquier tipo de orientación

Si la orientación es pon un 4011 en vez de un heX pues es lo que hay...

También he probado con la cola con la config por defecto a ver qué pasaba:

1669658798502.png


1669658828591.png


Algo parece que mejora vs FQ_Codel pero hasta 400Mbps que está el límite, se queda corto.

En general el ping sin fasttrack también se multiplica por dos o por tres como se puede ver.

¡Saludos!
 
Hola, refloto por si alguien puede echarme un cable. Voy a ver si puedo hacer pruebas con un router con más enjundia tipo 3011 o 4011 y supongo que la cosa mejorará. El problema de quitar el fasttrack y de routers no muy potentes con Movistar imagino que viene de la alta carga de trabajo que es soportar la conexión PPPoE ¿puede ser?
 

Similar threads

Arriba