mikrotik como repetidor

Hola, les escribo los entendidos, pues quise hacer algo que pensé era trivial pero que no me funciona, incluso con el quick-set, simplemente es conectar via radio a un router que tiene internet para usar los puertos ethernet dentro de la misma LAN como un switch.

Código:
# jan/02/1970 00:12:13 by RouterOS 7.1.2
# software id = H6CM-L1LB
#
# model = 951Ui-2HnD
/interface bridge
add name=bridge1
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-onlyn country=spain disabled=no mode=station-pseudobridge \
    ssid=Maga wireless-protocol=nv2-nstreme-802.11
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk group-ciphers=tkip,aes-ccm mode=\
    dynamic-keys supplicant-identity=MikroTik unicast-ciphers=tkip,aes-ccm
/interface bridge filter
add action=drop chain=input dst-port=68 in-interface=!wlan1 ip-protocol=udp mac-protocol=ip
/interface bridge port
add bridge=bridge1 interface=wlan1
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
/ip neighbor discovery-settings
set discover-interface-list=!dynamic

wlan1 me aparece como conectado R, sin embargo desde el router no puedo darle ping a nada y si le pongo un client-dhcp al bridge1 no coge ip. Según creo al unir wlan1 con las interfaces ethernet es como tener un switch y el cable es la radio, me podrían iluminar los entendidos
Hoy estoy algo bruto
gracias
 
Hola, les escribo los entendidos, pues quise hacer algo que pensé era trivial pero que no me funciona, incluso con el quick-set, simplemente es conectar via radio a un router que tiene internet para usar los puertos ethernet dentro de la misma LAN como un switch.

Código:
# jan/02/1970 00:12:13 by RouterOS 7.1.2
# software id = H6CM-L1LB
#
# model = 951Ui-2HnD
/interface bridge
add name=bridge1
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-onlyn country=spain disabled=no mode=station-pseudobridge \
    ssid=Maga wireless-protocol=nv2-nstreme-802.11
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk group-ciphers=tkip,aes-ccm mode=\
    dynamic-keys supplicant-identity=MikroTik unicast-ciphers=tkip,aes-ccm
/interface bridge filter
add action=drop chain=input dst-port=68 in-interface=!wlan1 ip-protocol=udp mac-protocol=ip
/interface bridge port
add bridge=bridge1 interface=wlan1
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
/ip neighbor discovery-settings
set discover-interface-list=!dynamic

wlan1 me aparece como conectado R, sin embargo desde el router no puedo darle ping a nada y si le pongo un client-dhcp al bridge1 no coge ip. Según creo al unir wlan1 con las interfaces ethernet es como tener un switch y el cable es la radio, me podrían iluminar los entendidos
Hoy estoy algo bruto
gracias
Eso de trivial no tiene nada compi. Meter una interfaz inalámbrica en un bridge haciendo de WAN (modo st = chungo. Eso sólo medio funciona con la interfaz en station pseudobridge, no demasiado bien.

opciones: si es un enlace punto a punto, con las interfaces inalámbricas en modo APBridge y StationBridge (enlace transparente) puedes montar un EoIP para propagar el mismo segmento de L2.
Otra opción: usar WDS, que viene a cubrir justo ese caso.

Y, si no necesitas extender el mismo segmento de red, saca la intetfaz inalámbrica del bridge y que haga de WAN en modo station, montando luego el resto con su propio dhcp y demás (como si fuera un CPE)

Saludos!
 
Vale, pokoyo, lo que pasa que el otro router es solo un router de operadora y no quería o pensaba que se iba a complicar tanto, solo quiero que el mikrotik se conecte al router de la operadora vía radio y los puertos ethernet funcionen en el mismo rango de la Red lan que hay en el router de la operadora.
Como se te ocurre que se pueda hacer?
Y muchas gracias
 
Vale, pokoyo, lo que pasa que el otro router es solo un router de operadora y no quería o pensaba que se iba a complicar tanto, solo quiero que el mikrotik se conecte al router de la operadora vía radio y los puertos ethernet funcionen en el mismo rango de la Red lan que hay en el router de la operadora.
Como se te ocurre que se pueda hacer?
Y muchas gracias
Usa el botón “setup repeater” que tienes en la interfaz inalámbrica. Pero ya te digo yo que eso funciona na más que regular.

Saludos!
 
Exactamente eso fue lo que hice incluso estuve buscando por internet videos, que aunque no es lo que quiero NO ME FUNCIONA TAN FACIL y como soy algo cabezón seguí probando y logré que me funcionara como yo quería a medias, por eso te escribo a ver que tu crees

Código:
# jan/02/1970 00:27:10 by RouterOS 7.1.2
# software id = H6CM-L1LB
#
# model = 951Ui-2HnD
/interface bridge
add name=bridge1
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa2-psk eap-methods="" mode=dynamic-keys name=profile-Maga supplicant-identity=MikroTik
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-onlyn country=spain disabled=no mode=station-pseudobridge security-profile=profile-Maga ssid=Magalis
/interface bridge port
add bridge=bridge1 interface=wlan1
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
/ip neighbor discovery-settings
set discover-interface-list=!dynamic
/ip address
add address=192.168.53.3/24 interface=bridge1 network=192.168.53.0

Esto es exactamente lo que yo quería, era tener el mikrotik como un swicht pero que el enlace de donde viene la internet fuera via radio (no necesito otro radio repitiendo) y tener los puertos ethernet libres para usarlos en la red LAN, ya se que lo mejor es el cable, pero no siempre se puede.
Ahora cuales son los problemas de la configuración anterior, pues que el DHCP no me funciona, es decir los equipos que se conectan a los puertos ethernet no pueden obtener ip por DHCP, ni tan siquiera el cliente dhcp del mikrotik, por lo que al bridge1 le puse una ip (dentro del rango de la LAN) a mano para conectarme al router via IP, aunque via MAC me funciona también.
En fin si a los equipos les pongo la ip fija a mano dentro del rango de la dirección de la LAN tienen internet y me ven los TV por lo que el broadcast creo que funciona pero no se porque no los paquetes del DHCP.
Que tu crees??
 
Creo que te falta la ruta, no? Si vas a usar IP's estáticas, necesitas una ruta por defecto (suponiendo que el router principal tenga la 192.168.53.1 como IP.
Código:
/ip route add gateway=192.168.53.1

Saludos!
 
Ya tire algunas piedras como esa o ponerle NAT, pero sigue sin funcionar, los paquetes del DHCP no van por rutas, solo tengo internet cuando pongo fija la IP, por lo que los paquetes se enrutan solo hasta el gateway.
 
Ya tire algunas piedras como esa o ponerle NAT, pero sigue sin funcionar, los paquetes del DHCP no van por rutas, solo tengo internet cuando pongo fija la IP, por lo que los paquetes se enrutan solo hasta el gateway.
El problema es la capa 2. Estás dando por supuesto que una wifi se puede meter en un bridge en modo estación, y hacer de WAN, y eso es un problema. Lo tienes explicado aquí: https://wiki.mikrotik.com/wiki/Manual:Wireless_Station_Modes#802.11_limitations_for_L2_bridging

Mira a ver si tu router de operadora soporta WDS, que es la solución a ese problema para crear un bridge inalámbrico transparente.

Saludos!
 
Vale, pues parece que por esa via no hay solución el router de operadora es un Livebox, y en las pocas opciones que tiene no veo nada para WDS. Así que por ahora lo dejaré así hasta encontrar otra solución y muchas gracias nuevamente.
 
Hola Pokoyo, te contaré que como soy un poco caprichoso seguí investigando el tema y puse mi pregunta en el forum de mikrotik y allí me dieron las ideas y la solución que comparto por ustedes por si algún día lo necesitan.
En fin la solución fue agregar un DHCP Relay al mikrotik y ya funciona, con la particularidad que si le pongo de forma manual la ip al Bridge donde está wlan1 las pc cogen la ip mas rápido, sin embargo si le quito la ip el DHCP funciona igual solo que demora un poco mas uno 10 segundos en coger la ip

Aqui poniéndole la ip manual al Bridge

Código:
# jan/02/1970 00:29:08 by RouterOS 7.1.2
# software id = H6CM-L1LB
#
# model = 951Ui-2HnD
/interface bridge
add name=bridge1
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa2-psk eap-methods="" mode=dynamic-keys name=profile-Maga supplicant-identity=MikroTik
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-onlyn country=spain disabled=no mode=station-pseudobridge security-profile=profile-Maga ssid=Magalis
/interface bridge port
add bridge=bridge1 interface=wlan1
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
/ip neighbor discovery-settings
set discover-interface-list=!dynamic
/ip address
add address=192.168.53.3/24 interface=bridge1 network=192.168.53.0
/ip cloud
set update-time=no
/ip dhcp-relay
add dhcp-server=192.168.53.2 disabled=no interface=bridge1 local-address=192.168.53.3 name=relay1

Y aqui el Bridge sin ip

Código:
# jan/02/1970 00:32:55 by RouterOS 7.1.2
# software id = H6CM-L1LB
#
# model = 951Ui-2HnD
# serial number = 8A3708C712B5
/interface bridge
add name=bridge1
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa2-psk eap-methods="" mode=dynamic-keys name=profile-Maga supplicant-identity=MikroTik
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-onlyn country=spain disabled=no mode=station-pseudobridge security-profile=profile-Maga ssid=Magalis
/interface bridge port
add bridge=bridge1 interface=wlan1
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
/ip neighbor discovery-settings
set discover-interface-list=!dynamic
/ip cloud
set update-time=no
/ip dhcp-relay
add dhcp-server=192.168.53.2 disabled=no interface=bridge1 name=relay1
# jan/02/1970 00:32:55 by RouterOS 7.1.2
# software id = H6CM-L1LB
#
# model = 951Ui-2HnD
# serial number = 8A3708C712B5
/interface bridge
add name=bridge1
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa2-psk eap-methods="" mode=dynamic-keys name=profile-Maga supplicant-identity=MikroTik
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-onlyn country=spain disabled=no mode=station-pseudobridge security-profile=profile-Maga ssid=Magalis
/interface bridge port
add bridge=bridge1 interface=wlan1
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
/ip neighbor discovery-settings
set discover-interface-list=!dynamic
/ip cloud
set update-time=no
/ip dhcp-relay
add dhcp-server=192.168.53.2 disabled=no interface=bridge1 name=relay1

La respuesta del forum está aquí

mikrotik as repeater

también miré este enlace

Configuring local network

Y muchas gracias por todo
 
El workaround es un tanto enrevesado, pero sí, te puede valer. No solventas el problema, pero te saca del paso con el tema del DHCP.

¿Entendiste lo que te trataban de explicar en ese hilo, que el problema viene de que te falta una “cuarta” dirección MAC? Es justo lo que te enlacé arriba, en la wiki de Mikrotik. Porque esa es la clave del asunto, y la razón de ser de WDS. WDS añade esa cuarta dirección MAC que te falta, consiguiendo justo lo que quieres: un enlace transparente.

Por cierto, de las dos formas de hacer relay, la primera es la correcta, con la IP sobre el bridge y el relay apuntando a ella.

Saludos!
 
Arriba