MANUAL: Mikrotik, Wake Up On WAN de manera segura (VPN transparente + WOL)

Pues ese es el problema, ni más ni menos. Si el dominio de cloud no actualiza, no tienes VPN, a menos que conozcas la IP dinámica de tu casa.

Saludos!
 
Pues ese es el problema, ni más ni menos. Si el dominio de cloud no actualiza, no tienes VPN, a menos que conozcas la IP dinámica de tu casa.

Saludos!
La ip dinámica es en realidad una ip casi fija porque no cambia nunca
¿Será un problema de puertos? ¿Están bien abiertos?
Es más, puedo hacer ping a mi ip y contesta bien pero con esa ip configuro todo el móvil y no hay conexión VPN
Si lo hago a la otra red que ya tenía configurada todo bien, pero en esta nuevo equipo no hay manera
¿Puede ser de las credenciales? El secreto va con un nombre largo y 4 dígitos a final

11.jpg
 
Última edición:
La ip dinámica es en realidad una ip casi fija porque no cambia nunca
¿Será un problema de puertos? ¿Están bien abiertos?
Es más, puedo hacer ping a mi ip y contesta bien pero con esa ip configuro todo el móvil y no hay conexión VPN
Si lo hago a la otra red que ya tenía configurada todo bien, pero en esta nuevo equipo no hay manera
¿Puede ser de las credenciales? El secreto va con un nombre largo y 4 dígitos a final

Ver el adjunto 89820

O es ip dinámica o es ip fija… si es dinámica, no bases las conexiones externas por esa ip, porque un día te la cambian y te quedas sin acceso externo….

Para eso está la ddns que ofrece de manera gratuita mikrotik…
 
O es ip dinámica o es ip fija… si es dinámica, no bases las conexiones externas por esa ip, porque un día te la cambian y te quedas sin acceso externo….

Para eso está la ddns que ofrece de manera gratuita mikrotik…
Lo sé, pero para el caso que nos ocupa en estos momentos da igual dinámica que fija.
Una vez solventado esto, ya usaría la de Mikrotik o cualquier dyndns
 
En casa tengo TCP + UDP abierto. En éste solo tenía TCP, he abierto también UDP y nada de nada
Por otra parte, en el router me pone:
No sé si esas DNS 8.8.8.8 tienen algo que ver ya que son las de Google y en el Mikrotik tengo las 9.9.9.9

IPv4 DNS Servers:213.60.xxx.xxx
8.8.8.8
 
Última edición:
También estoy intentando actualizar el software en Quick Set y botón Check For Updates. Cuando empieza a buscar, abajo sale un error que pone "ERROR: could not resolve dns name"
Tengo la versión 6.45.9 y sé que no es la última, pero no conecta.
Sin embargo, el pc está a través del Mikrotik y sin problema
 
No tienes DNS. Cambia el servidor que tengas definido en IP -> DNS. Si vas hasta el botón de "Cache", dentro de la ventana del DNS, verás que únicamente las entradas locales están en caché. Es decir, NO tienes dns.

Por otro lado, tienes el equipo en una versión de software totalmente obsoleta. Busca la arquitectura de tu equipo, que la puedes ver en system > resources, descarga el paquete main de la 7.1.1, y actualiza ese equipo, tanto software como firmware.

Saludos!
 
Por otro lado, tienes el equipo en una versión de software totalmente obsoleta. Busca la arquitectura de tu equipo, que la puedes ver en system > resources, descarga el paquete main de la 7.1.1, y actualiza ese equipo, tanto software como firmware.
¿Eso lo tengo que hacer de alguna forma especial? Desde Winbox no me conecta para comprobar
¿Es desde la página del fabricante?
Arquitectura, supongo que es "smips"

- Edito: en la web de Mikrotik he descargado la versión 7.1.1 stable (Main package) pero es un .npk y no tengo claro como ejecutarlo

- Edito de nuevo: lo he importado a Winbox y en Files tengo routeros-7.1.1-smips.npk
Ahora me falta ejecutarlo pero ni idea de como hacerlo. Supongo que en New Terminal con "import" y el nombre del archivo o algo así
 
Última edición:
¿Eso lo tengo que hacer de alguna forma especial? Desde Winbox no me conecta para comprobar
¿Es desde la página del fabricante?
Arquitectura, supongo que es "smips"

- Edito: en la web de Mikrotik he descargado la versión 7.1.1 stable (Main package) pero es un .npk y no tengo claro como ejecutarlo

- Edito de nuevo: lo he importado a Winbox y en Files tengo routeros-7.1.1-smips.npk
Ahora me falta ejecutarlo pero ni idea de como hacerlo. Supongo que en New Terminal con "import" y el nombre del archivo o algo así
Reiniciando, así de simple.
 
Sube también la versión de firmware (system routerboard upgrade + reboot).

Con respecto a tu problema, ve a ip -> routes y edita la regla del 0.0.0.0/0 y en gateway, en lugar de la .5, pones la ip del router principal, que sospecho será la .1

Se me fue a mi el dedo al escribir el comando.

Saludos!
 
Sube también la versión de firmware (system routerboard upgrade + reboot).

Con respecto a tu problema, ve a ip -> routes y edita la regla del 0.0.0.0/0 y en gateway, en lugar de la .5, pones la ip del router principal, que sospecho será la .1

Se me fue a mi el dedo al escribir el comando.

Saludos!
Bien!! Vamos bien
Ya aparece la IP en Cloud
¿Donde se te fue el dedo quedaría así? (Lo de negrita)


# Suponemos router en el segmento 192.168.1.0/24
/ip address
add address=192.168.1.1/24 interface=bridge

# Creamos la ruta por defecto apuntando a la IP estática del bridge
/ip route
add dst-address=0.0.0.0/0 gateway=192.168.1.1
[/code]


De todas formas, sigo sin VPN. Queda algo por ahí todavía. Desde el móvil no conecta y me da error
Volveré a meter las credenciales a ver que pasa
 
Bien!! Vamos bien
Ya aparece la IP en Cloud
¿Donde se te fue el dedo quedaría así? (Lo de negrita)


# Suponemos router en el segmento 192.168.1.0/24
/ip address
add address=192.168.1.1/24 interface=bridge

# Creamos la ruta por defecto apuntando a la IP estática del bridge
/ip route
add dst-address=0.0.0.0/0 gateway=192.168.1.1
[/code]


De todas formas, sigo sin VPN. Queda algo por ahí todavía. Desde el móvil no conecta y me da error
Volveré a meter las credenciales a ver que pasa
No, no me has entendido. La ip del bridge ha de ser una cualquiera del segmento de la red principal. En tu caso, la 192.168.0.5. Pero tu gateway ha de ser el equipo que te da salida a internet, que puede ser cualquiera del rango, pero suele ser la .1, así que en tu caso en gateway tendrías la 192.168.0.1

Saludos!
 
Entonces, en mi caso, así:

# Suponemos router en el segmento 192.168.0.0/24
/ip address
add address=192.168.0.5/24 interface=bridge

# Creamos la ruta por defecto apuntando a la IP estática del bridge
/ip route
add dst-address=0.0.0.0/0 gateway=192.168.0.1
[/code]


El ping ahora sí tiene respuesta. Solo falta que me conecte al VPN y, por consiguiente, se inicie el pc..... pero se resiste
En cuanto pruebe de nuevo con las credenciales ya comento
 
Entonces, en mi caso, así:

# Suponemos router en el segmento 192.168.0.0/24
/ip address
add address=192.168.0.5/24 interface=bridge

# Creamos la ruta por defecto apuntando a la IP estática del bridge
/ip route
add dst-address=0.0.0.0/0 gateway=192.168.0.1
[/code]


El ping ahora sí tiene respuesta. Solo falta que me conecte al VPN y, por consiguiente, se inicie el pc..... pero se resiste
En cuanto pruebe de nuevo con las credenciales ya comento
correcto.

Haz ping al ddns que ves en ip > cloud. Si responde con tu ip pública, deberías tener conexión vpn. Recuerda abrir los tres puertos correspondientes. Todos son UDP.

Saludos!
 
Estoy en otro pc, acabo de hacer ping a xxxxxxxx.sn.mynetname.net y no responde. Supongo que ahí está la clave. Desde el equipo local donde está el Mikrotik sí hay respuesta así que todo parece que es cosa de abrir puertos.
Lo extraño es que ya están abiertos (1701, 4500 y 500) para la ip 192.168.0.5 (la del Mikrotik), tando TCP como UDP

Bueno, eso ya lo miraré de nuevo el lunes porque es el pc del trabajo. Ahora toca otra cosa, así que feliz Navidad!!
 
Venga, felices fiestas, ya me contarás. Los puertos TCP te los puedes ahorrar, todo es UDP.

Saludos!
 
He dejado el equipo encendido y me he conectado desde casa. He revisado puertos y aparentemente todo bien pero he cambiado alguna cosa.
Desde casa ya responde al hacer ping a la dirección que aparece en Cloud, pero no conecta al VPN
En el móvil lo tengo configurado, tanto la de casa como la del trabajo, como L2TP, la dirección y las credenciales. Al VPN de casa se conecta, pero a la del trabajo no. Todavía hay algo que no permite el acceso externo
 
Pues al final lo he conseguido. Ya tengo VPN en el trabajo y finalmente era cosas de los puertos pero todavía no sé cual era el problema. He eliminado los 3 puertos, los he vuelto a configurar aparentemente igual que antes y 'voila'.... ya funciona!!
La única diferencia que veo es que ahora he marcado UDP y antes estaba en Both, pero eso no debería ser el problema
He apago el equipo remotamente y lo he vuelto a encender
Mil gracias una vez más a pokoyo por la ayuda y paciencia prestadas
Felices fiestas
 
Arriba