MANUAL: Mikrotik, Wake Up On WAN de manera segura (VPN transparente + WOL)

Estoy intentando hacer de nuevo todo esto en otro equipo y de nuevo me veo en problemas :eek:
En casa me funciona bien salvo alguna vez que no hay VPN hasta que reinicio el Mikrotik.
Lo estoy configurando en el trabajo siguiendo el manual pero me encuentro en que, después de hacer los primeros pasos y resetear el router, puedo acceder a él con Winbox pero no tiene ninguna IP asignada (0.0.0.0)
He hecho todo de la misma forma que en casa. La única diferencia que veo es que en casa el rango de IP es 1.1 y en el trabajo es 0.1
Salvo eso, he hecho todo igual. Cuando conecto el Mikrotik al router, me quedo sin internet en el pc
Estoy revisando todo y comparándolo con el de casa pero aparentemente los tengo igual
No sé si debería volver a empezar y resetear todo de nuevo pero ya tendría que ser con Winbox porque a través del navegador, que es como lo hice la primera vez, ya no puedo acceder porque no sé a que dirección apuntar
Si entro en el router del operador, tampoco aparece el Mikrotik entre los equipos conectados
Saludos
Arranca desde cero. Y, si no te va, pon IP estática al mikrotik, en lugar de que la coja por DHCP. Si con un reinicio se soluciona, lo más probable es que el servidor DHCP del router que tiene por encima falle.

Saludos!
 
He reseteado de nuevo, he entrado por el navegador y he vuelto a configurar todo. Aparecía la IP 192.168.0.8 y al cargar de nuevo el script, vuelve a poner a 0.0.0.0 en Winbox. En el router la MAC del Mikrotik tiene asignada la IP 0.15
Voy a resetear de nuevo y pondré la IP estática en la configuración inicial
 
He hecho y rehecho todo de nuevo y sigo igual. Si exporto la configuración me sale solamente esto:

# jan/02/1970 00:06:23 by RouterOS 6.45.9
# software id = ZVZ7-AAHK
#
# model = RB931-2nD
# serial number = xxxxxxxxxxx
/interface wireless
set [ find default-name=wlan1 ] ssid=MikroTik
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik


El script que he cargado es éste:

# Definimos las variables a usar en la configuración de la VPN
:local usuariovpn "xxxxx"
:local passwordvpn "xxxxx"
:local secretoipsec "xxxxx"

# Definimos las variables a usar en el script de WOL
:local macserverwol "xxxxxxxxxxxx"
:local ipserverwol 192.168.0.3
:local scriptwol "/tool wol mac=$macserverwol interface=bridge"

############################################################
# ARRANCA EL SCRIPT DE CONFIGURACIÓN
############################################################

# Deshabilitamos la interfaz inalámbrica
# puesto que de inicio no la vamos a usar
/interface wireless
set 0 disabled=yes

# Creamos un nuevo bridge
/interface bridge
add name=bridge auto-mac=no admin-mac=\
[/interface ethernet get ether1 mac-address]

# Añadimos todas las interfaces al bridge
/interface bridge port
add bridge=bridge interface=all

# Levantamos un cliente DHCP sobre ese bridge
# Para que obtenga IP del router principal
/ip dhcp-client
add interface=bridge disabled=no

# Creamos un nuevo bridge de loopback,
# Para tener una IP con la que conectarnos al router
/interface bridge
add name=loopback

# Creamos una IP de administración
/ip address
add interface=loopback address=192.168.90.1/24

/ip arp
add interface=bridge mac-address=$macserverwol address=$ipserverwol

# Creamos un pequeño pool para la VPN (ejemplo, 5 ususarios)
/ip pool
add name=vpnpool ranges=192.168.89.2-192.168.89.6

# Creamos un nuevo perfil para la VPN, asociado al pool
# Y que ejecute el script de WOL al detectar una conexión
/ppp profile
add copy-from=default-encryption local-address=192.168.89.1 \
remote-address=vpnpool name=l2tpprofile on-up=$scriptwol

# Damos de alta un nuevo usuario para la VPN
/ppp secret
add name=$usuariovpn password=$passwordvpn service=l2tp profile=l2tpprofile

# Damos de alta el servidor VPN con L2TP
# sin más encriptación ni más nada
# puesto que sólo lo vamos a usar para el WOL
/interface l2tp-server server
set enabled=yes use-ipsec=yes ipsec-secret=$secretoipsec

# Nateamos la subred de la VPN
/ip firewall nat
add action=masquerade chain=srcnat src-address=192.168.89.0/24

# Damos de alta el cliente cloud
# para que el router tenga un DDNS automáticamente
/ip cloud
set ddns-enabled=yes

# Opcional - Creamos un script para levantar a mano por WOL
# Por si tenemos que hacerlo en cualquier otro momento
# Descomentar las siguientes 2 líneas en caso de quererlo
# /system script
# add dont-require-permissions=yes name=wol source=$scriptwol


A saber donde estoy metiendo la pata...
 
Mira si el equipo al que estás subiendo el fichero de configuración tiene una carpeta llamada "flash" dentro de la capeta Files. Si la tiene, has de meter el fichero que subas dentro de esa carpeta, sino se pierde al hacer el reset y, obviamente el "run-after-reset=script.rsc" no funciona.

Saludos!
 
Todo lo hay es esto

Files.jpg
 
Vale. Y el “script.rsc” tiene la config que buscas aplicar u ahora mismo el router no tiene configuración y estás entrando por dirección MAC? Si las dos respuestas son correctas, simplemente abre la terminal desde el propio Winbox y ejecuta el “import script.rsc” y andando.

Saludos!
 
Vale. Y el “script.rsc” tiene la config que buscas aplicar u ahora mismo el router no tiene configuración y estás entrando por dirección MAC? Si las dos respuestas son correctas, simplemente abre la terminal desde el propio Winbox y ejecuta el “import script.rsc” y andando.

Saludos!
Muuuuchas gracias
Ahora ya sí tengo IP, internet y la configuración bien cargada. Voy a resevar esa IP en el router y abrir puertos
Ya te cuento...
 
Ahora tengo otra duda. Me ha asignado la IP 15
He llamado a la compañía y no saben decir como reservar esa IP (en casa tengo Adamo y en ese router es fácil. Aquí tengo R con un Technicolor pero no veo donde). El caso es que el router asigna de las ip's de 10 a la 254. Mi duda es en donde puedo cambiar mi ip 15 a una más baja de 10 a través de Winbox. Como ip's estáticas tengo 2 pc's que tienen la 3 y la 4 así que no habría problema en asignar de la 5 a la 9
 
Pues muy sencillo, sustituimos esto del script:
Código:
# Levantamos un cliente DHCP sobre ese bridge
# Para que obtenga IP del router principal
/ip dhcp-client
add interface=bridge disabled=no

Por esto otro (supongo tu router está entregando direcciones 192.168.1.X; si ese .1 es un .0 u otro segmento, cámbialo acorde).
Código:
# Asignamos una IP estática al bridge,
# del rango del router al que va conectado.
# Suponemos router en el segmento 192.168.1.0/24
/ip address
add address=192.168.1.5/24 interface=bridge

# Creamos la ruta por defecto apuntando a la IP estática del bridge
/ip route
add dst-address=0.0.0.0/0 gateway=192.168.1.5

Saludos!
 
Perfecto. Ya está la ip en 0.5
Ahora tengo otro tema. He hecho Ping a la dirección xxxxxxxxxxx.sn.mynetname.net y no hay respuesta
He probado a configurar la VPN directamente con la ip pública y tampoco conecta.
Si hago ping a mi ip pública, se agota el tiempo (Tiempo de espera agotado para esta solicitud)
Los puertos 1701, 4500 y 500 están abiertos para la ip 192.168.0.5
Lo extraño es que no me aparece la ip 192.168.0.5 como conectada al router. A nivel local todo funciona bien y está bien enchufado (de un puerto del router al puerto de internet del Mikrotik y del puerto 2 del Mikrotik al pc)

1.jpg
2.jpg




Edito: sin tocar nada, hago ping a la ip pública y responde bien. Hago ping a la dirección xxxxxxxx.sn.mynetname.net y no responde
 
Última edición:
En Config tengo lo siguiente:

# jan/02/1970 02:57:06 by RouterOS 6.45.9
# software id = ZVZ7-AAHK
#
# model = RB931-2nD
# serial number = xxxxxxxxxxxxxx
/interface bridge
add admin-mac= xxxxxxxxxxxx auto-mac=no name=bridge
add name=loopback
/interface wireless
set [ find default-name=wlan1 ] ssid=MikroTik
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=vpnpool ranges=192.168.89.2-192.168.89.6
/ppp profile
add change-tcp-mss=yes local-address=192.168.89.1 name=l2tpprofile on-up=\
"/tool wol mac=3Cxxxxxxxxxxxx interface=bridge" remote-address=vpnpool \
use-encryption=yes
/interface bridge port
add bridge=bridge interface=all
/interface l2tp-server server
set enabled=yes ipsec-secret=xxxxxxxxx use-ipsec=yes
/ip address
add address=192.168.0.5/24 interface=bridge network=192.168.0.0
add address=192.168.90.1/24 interface=loopback network=192.168.90.0
/ip arp
add address=192.168.0.3 interface=bridge mac-address=3Cxxxxxxxxxxxx
/ip cloud
set ddns-enabled=yes
/ip firewall nat
add action=masquerade chain=srcnat src-address=192.168.89.0/24
/ip route
add distance=1 gateway=192.168.0.5
/ppp secret
add name=xxxxxxxx password=xxxxxxxx profile=l2tpprofile service=l2tp


Son 2 pc's con las ip's 192.168.0.3 y 192.168.0.4
El Mikrotik la ip 192.168.0.5
 
Creo que te falta el DNS, mételo para que el propio router sepa resolver las peticiones a sus servidores para mantener el dominio de IP -> Cloud vivito y coleando. Esto te pasa por no usar el cliente DHCP, que lo propaga sólo.
Código:
/ip dns
set servers=1.1.1.1

Saludos!
 
¿Eso lo meto en cualquier línea del script o en algún punto concreto? No veo nada similar para sustituir, así que supongo que con pegarlo por ahí llega
De todas formas, utilizo las dns 9.9.9.9 y 1.1.1.1 por si tiene algo que ver
 
Lo puedes meter como último paso. Lo único que estás haciendo es definir un servidor dns para el propio router. Es más, si abres la terminal ahora mismo y copias y pegas esas líneas, lo metes y listo, no necesitas volver a resetear y empezar desde cero.

Puedes usar los DNS de tu gusto. Si quieres meter dos, separados por una coma.

Saludos!
 
Pues tampoco. Ahora sale esto

.....
add address=192.168.90.1/24 interface=loopback network=192.168.90.0
/ip arp
add address=192.168.0.3 interface=bridge mac-address=xxxxxxxxx
/ip cloud
set ddns-enabled=yes
/ip dns
set servers=1.1.1.1
/ip firewall nat
add action=masquerade chain=srcnat src-address=192.168.89.0/24
/ip route
add distance=1 gateway=192.168.0.5
/ppp secret
add name=xxxxxxxxx password=xxxxxxxxxprofile=l2tpprofile service=l2tp


Se está complicando el tema más de lo esperado. ¿Será mejor volver a hacerlo como al principio, sin definir la ip, y mirar como reservarla en el router de R?
 
Pues tampoco. Ahora sale esto

.....
add address=192.168.90.1/24 interface=loopback network=192.168.90.0
/ip arp
add address=192.168.0.3 interface=bridge mac-address=xxxxxxxxx
/ip cloud
set ddns-enabled=yes
/ip dns
set servers=1.1.1.1
/ip firewall nat
add action=masquerade chain=srcnat src-address=192.168.89.0/24
/ip route
add distance=1 gateway=192.168.0.5
/ppp secret
add name=xxxxxxxxx password=xxxxxxxxxprofile=l2tpprofile service=l2tp


Se está complicando el tema más de lo esperado. ¿Será mejor volver a hacerlo como al principio, sin definir la ip, y mirar como reservarla en el router de R?
Y la ip del bridge, dónde está?

Saludos!
 
Ahí va completo con las DNS 9.9.9.9
Sigue sin responder el ping

# jan/02/1970 00:01:27 by RouterOS 6.45.9
# software id = ZVZ7-AAHK
#
# model = RB931-2nD
# serial number = xxxxxxxxxxxxxxxxx
/interface bridge
add admin-mac=xxxxxxxxxxxxxxxxx auto-mac=no name=bridge
add name=loopback
/interface wireless
set [ find default-name=wlan1 ] ssid=MikroTik
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=vpnpool ranges=192.168.89.2-192.168.89.6
/ppp profile
add change-tcp-mss=yes local-address=192.168.89.1 name=l2tpprofile on-up=\
"/tool wol mac=xxxxxxxxxxxxxxxxx interface=bridge" remote-address=vpnpool \
use-encryption=yes
/interface bridge port
add bridge=bridge interface=all
/interface l2tp-server server
set enabled=yes ipsec-secret=xxxxxxxxxxxxxxxxx use-ipsec=yes
/ip address
add address=192.168.0.5/24 interface=bridge network=192.168.0.0
add address=192.168.90.1/24 interface=loopback network=192.168.90.0
/ip arp
add address=192.168.0.3 interface=bridge mac-address=xxxxxxxxxxxxxxxxx
/ip cloud
set ddns-enabled=yes
/ip dns
set servers=9.9.9.9
/ip firewall nat
add action=masquerade chain=srcnat src-address=192.168.89.0/24
/ip route
add distance=1 gateway=192.168.0.5
/ppp secret
add name=xxxxxxxxxxxxxxxxx password=xxxxxxxxxxxxxxxxx profile=l2tpprofile service=l2tp
 
Esa config es correcta. Si haces ping al DDNS que tienes en IP -> Cloud, ¿resuelve la IP pública del router principal? ¿Llegas a conectar a la VPN desde fuera de la red?

Saludos!
 
Esa config es correcta. Si haces ping al DDNS que tienes en IP -> Cloud, ¿resuelve la IP pública del router principal? ¿Llegas a conectar a la VPN desde fuera de la red?

Saludos!
Ahí veo que hay otro problema, porque no hay nada. Lo de "updating..." abajo a la izquierda, se queda así todo el rato

1.jpg
 
Arriba