MANUAL: Mikrotik, túneles EoIP: Cómo llevarte tu red a cuestas

Por mas vueltas que le doy no soy capaz de pasar la wifi por el tunel eoip.

No lo veo, mi cabeza no da más de si
 
Por mas vueltas que le doy no soy capaz de pasar la wifi por el tunel eoip.

No lo veo, mi cabeza no da más de si

¿Porqué no usas el otro manual, para el site-to-site, que se ajusta mucho más a lo que quieres hacer? Ahí los dos routers son routers listos (normales vaya, ni muy listos y muy tontos), cada uno maneja su lan y, vía tabla de rutas, uno sabe que tiene la otra LAN al otro lado del túnel, y viceversa. De esa manera, en lugar de enviar todo el tráfico por el túnel, accedes a él sólo en el caso de necesitar algo del otro extremo, quedando todo el tráfico local en el propio router.

Saludos!
 
¿Porqué no usas el otro manual, para el site-to-site, que se ajusta mucho más a lo que quieres hacer? Ahí los dos routers son routers listos (normales vaya, ni muy listos y muy tontos), cada uno maneja su lan y, vía tabla de rutas, uno sabe que tiene la otra LAN al otro lado del túnel, y viceversa. De esa manera, en lugar de enviar todo el tráfico por el túnel, accedes a él sólo en el caso de necesitar algo del otro extremo, quedando todo el tráfico local en el propio router.

Saludos!

Si no se puede tendré que buscar otra forma de controlar todo el tráfico de un router y encriptarlo

Saludos!
 
Buenas noches, logre establecer la comunicación entre el router "A" y router "B", hago ping de un extremo al otro y funciona, agrego las rutas de una red lan en cada router y cuando hago ping a las maquinas de la red lan de cada extremo de los router, estas no me responden.... me falta algo???, tengo que trabajar en el nat o solamente con cargar las rutas de manera manual las redes ya se tienen que ver... gracias

Aclaración: seguí la guía de site to site (pocoyo), al pie de la letra
 
Última edición:
Desde un equipo conectado al router A, ¿eres capaz de hacer ping a la IP del router B, al igual que a la IP de un cliente conectado a B?
¿Luego igual pero al revés, de B a A?

Si esas dos cosas funcionan y puedes hacer ping desde un equipo de un extremo a otro, el resto es trabajar con las reglas de firewall/NAT que necesites.

Si me dices lo que estás buscando hacer, una vez establecido el túnel, lo miramos.

Saludos!
 
Hola Pokoyo, he probado casi todos tus manuales y me han servido de mucho para comprender como funciona no solo RouterOS sino también las redes, ahora me puse a pensar en este caso donde usas el túnel Eoip, túnel de capa 2, por el cual extiendes la red del router de tu casa al otro que llevas contigo, todo funciona bien.
Ahora como los túneles Eoip son tuneles de capa 2, al igual que el tunel PPPT y el L2PT, por lo que intenté hacer lo mismo pero no me funciona.
Por ejemplo en el router servidor:
1- Cree un bridge donde adicioné un puerto del router (ether5)
2- Levanté un servidor DHCP y se lo asigné al bridge.
3- En PPP-Profile cree uno nuevo, le puse una dirección local y remota y también le asigné el bridge anterior creado.
4- Cree un secret usuario, contraseña y le asigné el profile anterior.
5- Habilité el servidor, probé con los dos PPPT y L2PT
En el otro router.
1- Cree un brigde donde le adicioné un puerto del router (ether4)
2- Creé un profile nuevo al que le asigné el bridge (lo demás lo dejé vacío)
3- Levanté el servicio correspondiente al servidor que había habilitado en el otro router (PPPT o L2PT), le puse el usuario, contraseña y el profile creado anteriormente.
Inmediatamente se crea el túnel, esta conectado. Sin problemas y se asigna dinámicamente el túnel al bridge junto al otro puerto.
Ahora le conecto una PC al puerto ether5 (el que está en el bridge) del router servidor y el DHCP me da la ip bien, sin embargo si conecto la computadora en el puerto ether4 del router cliente la computadora no recibe respuesta del DHCP que está en el router servidor, sin embargo la petición si le llega y éste le da una ip, pero al parecer no le llega la respuesta por el túnel por lo que se queda sin IP.
Tienes idea que estaré haciendo mal?
Ver el adjunto 73183
Después de darle un descanso a este tema que por un tiempo me consumió mucho tiempo, volví a empezar de cero y me funcionó, la idea era como dice pokoyo, llevarse la red de casa a cuesta, es decir crear un tunel donde estémos dentro de la red con el broadcast incluido, de lo contrario algunas cosas no se ven, Pokoyo usó el tunel EOIP, aquí logré lo mismo pero con un tunel L2PT.
Ahí le dejo el código de los 2 router.
De esta forma cualquier equipo conectado al ether5 de R1 o ether4 y ether5 de R2 resivirá la ip del servidor DHCP que corre en R1 y por lo tanto estan en la misma red como si estubieran en el mismo bridge en R1

Router R1, L2PT Servidor

Código:
# nov/18/2020 20:03:14 by RouterOS 6.47
# software id =
#
#
#
/interface bridge
add name=bridge1
/interface ethernet
set [ find default-name=ether1 ] comment=WAN disable-running-check=no
set [ find default-name=ether2 ] disable-running-check=no
set [ find default-name=ether3 ] disable-running-check=no
set [ find default-name=ether4 ] disable-running-check=no
set [ find default-name=ether5 ] comment=LAN disable-running-check=no
set [ find default-name=ether6 ] comment=Nube disable-running-check=no
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp_pool0 ranges=192.168.10.10-192.168.10.254
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=bridge1 name=dhcp1
/ppp profile
add bridge=bridge1 change-tcp-mss=yes name=profile1 use-encryption=yes
/interface bridge port
add bridge=bridge1 interface=ether5
/interface l2tp-server server
set authentication=mschap1,mschap2 enabled=yes ipsec-secret=locoloco \
    use-ipsec=yes
/ip address
add address=10.10.10.2/30 comment="IP PUBLICA" interface=ether1 network=\
    10.10.10.0
add address=192.168.10.1/24 interface=bridge1 network=192.168.10.0
/ip dhcp-client
add disabled=no interface=ether6
/ip dhcp-server network
add address=192.168.10.0/24 dns-server=8.8.8.8 gateway=192.168.10.1
/ip route
add distance=1 gateway=10.10.10.1
/ppp secret
add name=santia password=santia profile=profile1 service=l2tp
/system identity
set name=R1

Router R2 L2PT Cliente

Código:
# nov/18/2020 20:05:54 by RouterOS 6.47
# software id =
#
#
#
/interface bridge
add name=bridge1
/interface ethernet
set [ find default-name=ether1 ] comment=WAN disable-running-check=no
set [ find default-name=ether2 ] disable-running-check=no
set [ find default-name=ether3 ] comment=LAN2 disable-running-check=no
set [ find default-name=ether4 ] comment=LAN1 disable-running-check=no
set [ find default-name=ether5 ] comment=LAN1 disable-running-check=no
set [ find default-name=ether6 ] comment=Nube disable-running-check=no
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ppp profile
add bridge=bridge1 change-tcp-mss=yes name=profile1 use-encryption=yes
/interface l2tp-client
add allow=mschap1,mschap2 connect-to=10.10.10.2 disabled=no ipsec-secret=\
    locoloco name=l2tp-out1 password=santia profile=profile1 use-ipsec=yes \
    user=santia
/interface bridge port
add bridge=bridge1 interface=ether5
add bridge=bridge1 interface=ether4
/ip address
add address=10.10.20.2/30 comment="IP PUBLICA" interface=ether1 network=\
    10.10.20.0
add address=192.168.20.1/24 comment="LAN R2" interface=ether3 network=\
    192.168.20.0
/ip dhcp-client
add disabled=no interface=ether6
/ip route
add distance=1 gateway=10.10.20.1
/system identity
set name=R2
 

Similar threads

A
Respuestas
1
Visitas
3,703
A
Respuestas
0
Visitas
1,988
Anonymous
A
Respuestas
2
Visitas
2,897
Anonymous
A
Respuestas
1
Visitas
4,525
Anonymous
Arriba