MANUAL: Mikrotik, túneles EoIP: Cómo llevarte tu red a cuestas

El propósito
Quiero disponer de mi red local allá donde esté. Sin importar desde dónde me esté conectando o con qué equipos lo haga. Me valía con conectar por VPN, pero no quería tener sólo acceso a lo que hay en casa, quería estar en casa. Me puse a investigar y di con los túneles EoIP, una solución propietaria de mikrotik para enlazar dos routers remotos, en capa 2 (como si enganchases dos switches con un cable, mismo dominio de broadcast). Además, como llevaba ya un tiempo batalleando con @Otro+ que anda detrás de montar algo así, dije: vamos a matar dos pájaros de un tiro; voy a ver cómo narices se monta esto.

Hola, He seguido el tutorial y tengo una pequeña curiosidad, Si en los túneles EoIP pongo un IPsec Secret funciona todo correctamente, si quito los IPsec Secret el tunel no se establece. ¿por qué puede ser?
 
Porque tienes una regla en el firewall que permite el IPSec. Si no lo usas, tienes que permitir explícitamente el tráfico del EoIP (protocolo GRE) en input.
Código:
/ip firewall filter
add action=accept chain=input comment="eoip: allow gre" in-interface=eoip-X protocol=gre
 
Porque tienes una regla en el firewall que permite el IPSec. Si no lo usas, tienes que permitir explícitamente el tráfico del EoIP (protocolo GRE) en input.
Código:
/ip firewall filter
add action=accept chain=input comment="eoip: allow gre" in-interface=eoip-X protocol=gre
Hola, En cada router 1 regla en la que permito todo el trafico del otro (o eso creo)

Casa
/ip firewall address-list add address=viaje.sn.mynetname.net list=Permitir
/ip firewall filter add action=accept chain=input src-address-list=Permitir

Viaje
/ip firewall address-list add address=casa.sn.mynetname.net list=Permitir
/ip firewall filter add action=accept chain=input src-address-list=Permitir

¿Hay que pertimir explicitamente el gre?
Otra cosa. ¿Se puede hacer que cuando el tunel este levantado default route sea el tunel?
 
Arriba