MANUAL: Mikrotik, túneles EoIP: Cómo llevarte tu red a cuestas

/interface bridge
add igmp-snooping=yes name=bridge-home
add name=bridge-local
/interface eoip add name=tunnel-to-B remote-address=XXXXXXXXX.sn.mynetname.net tunnel-id=0 mtu=1500
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa-psk,wpa2-psk management-protection=allowed mode=\
dynamic-keys name=WIFI_Segura supplicant-identity=MikroTik
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-XX \
country=spain disabled=no distance=indoors frequency=auto installation=\
indoor mode=ap-bridge security-profile=WIFI_Segura ssid=XXXXXXXX \
station-roaming=enabled wireless-protocol=802.11
/interface bridge port
add bridge=bridge-home interface=ether3
add bridge=bridge-home interface=ether2
add bridge=bridge-home interface=wlan1
add bridge=bridge-home interface=tunnel-to-B
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface detect-internet
set detect-interface-list=WAN
/interface list member
add interface=ether1 list=WAN
add interface=bridge-local list=LAN
add interface=bridge-home list=LAN
/ip cloud
set ddns-enabled=yes ddns-update-interval=1m
/ip dhcp-client
add disabled=no interface=bridge-home
add disabled=no interface=ether1
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.26.56.26,8.20.247.20
/ip firewall filter
add action=accept chain=input comment="allow ipsec" dst-port=500,4500 \
protocol=udp
add action=accept chain=input protocol=ipsec-esp
add action=accept chain=input comment="allow HQ access to router" \
ipsec-policy=in,ipsec
/system clock
set time-zone-name=Europe/Madrid
/system identity
set name=Mikrotik
/system scheduler
add interval=5m name=IPCloud policy=read,write start-time=startup
/system script
add dont-require-permissions=no name=IPCloud owner=admin policy=\
ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source=\
"/ip cloud force-update"
Tienes una config popurrí. No es ni la configuración donde el router es router y sólo parte del tráfico va por el bridge-home en el túnel EoIP, ni en la que es un mero router tonto sin configuración. Decídete por una o por otra, y monta la configuración adecuada.

Saludos!
 
Tienes una config popurrí. No es ni la configuración donde el router es router y sólo parte del tráfico va por el bridge-home en el túnel EoIP, ni en la que es un mero router tonto sin configuración. Decídete por una o por otra, y monta la configuración adecuada.

Saludos!
¿Donde puede obtener una configuración de router tonto?
He intentado copiar la configuración del primer post excepto el tema del ether3 y la wifi que lo he metido todo en el bridge-home
Es cierto que no he borrado el bridge-local que no tiene ningún port asignado
 
Última edición:
Si vas a configurar el router tonto, resetea toda la configuración y no cargues la configuración por defecto. Crea el bridge principal, mete los puertos que vayas a usar, y da de alta el EoIP. Poco más te hace falta.

Saludos!
 
Si vas a configurar el router tonto, resetea toda la configuración y no cargues la configuración por defecto. Crea el bridge principal, mete los puertos que vayas a usar, y da de alta el EoIP. Poco más te hace falta.

Saludos!
¿La configuración de la WIFI está bien?
 
Yo restringiría a 20MHz de ancho de canal, y usaría únicamente una frecuencia que pertenezca a los canales de 1, 6 u 11 (2412, 2437, 2462).

Saludos!
 
Una pequeña introducción antes de poner el esquema de mi instalación:

Por trabajo vivo en el extranjero, tengo casa en España y un abono a movistar.Para aprovechar ese abono he instalado un servidor tvheadend en casa y veo mi abono aquí con kodi, pero cada vez son menos lo s canales que veo .

Dispongo de un router Mikrotik en casa , que lo recogí para dejarlo como router principal , pero no me dio tiempo y lo deje conectado como el esquema de mas abajo y esto no lo puedo cambiar hasta que vaya la próxima vez.

He hecho un túnel Eiop sobre ipsec(gracias @pokoyo ) , se me conecta perfectamente , me da ip por DHCP aquí , puedo ver todos lo aparatos conectados en casa , pero no tengo Iptv.. he hecho algunas modificaciones como esplica el compañero @furny , pero nada ...

Llevo varias semanas intentando diferentes configuraciones que he encontrado aqui en el foro y mi pregunta es .. ¿ Es que hay alguna posibilidad de tener iptv en este lado del tunel con esta configuración? , o ¿deberia abandonar hasta que tenga la posibilidad de ir (no antes de Agosto) y cambiar a monopuerto o poner una ONT?


Este es mi esquema actual y con el que he hecho las pruebas (foto incluida)





En casa :

  • Router original HGU (No esta en mono puerto) ,
  • Swicht compatible con IGMP snooping
  • RB4011iGS

Aquí :

  • fritzbox 7590
  • RBD52G
  • Decodificador Movistar(por el momento no lo tengo aquí, las pruebas las estoy haciendo con VLC)
Gracias y mi enhorabuena por este foro
 

Adjuntos

  • Captura.JPG
    Captura.JPG
    85.7 KB · Visitas: 53
El deco del otro lado debería coger una IP de las reservadas para el deco. Es decir, has de transportar el DHCP por el túnel EoIP.

Estoy trabajando esta semana en una config similar, a solicitud de un compañero, a ver si soy capaz de hacer eso mismo, pero con un mikrotik en modo full-bridge (como si fuera un switch), conectado a un HGU que está como router principal. Si eso funciona, sería una muy buena configuración para los que queréis usar esto en varios domicilios, y no queréis andar quitando el HGU (o poniéndolo en monopuesto) y cambiarlo por un mikrotik.

En cuanto sepa si es viable o no, te digo.

Saludos!
 
  • Like
Reactions: ncs
El deco del otro lado debería coger una IP de las reservadas para el deco. Es decir, has de transportar el DHCP por el túnel EoIP.

Estoy trabajando esta semana en una config similar, a solicitud de un compañero, a ver si soy capaz de hacer eso mismo, pero con un mikrotik en modo full-bridge (como si fuera un switch), conectado a un HGU que está como router principal. Si eso funciona, sería una muy buena configuración para los que queréis usar esto en varios domicilios, y no queréis andar quitando el HGU (o poniéndolo en monopuesto) y cambiarlo por un mikrotik.

En cuanto sepa si es viable o no, te digo.

Saludos!
Si, si coge ip , siguiendo tu manual con un router tonto aqui y el que envia en casa. Por supuesto redirigiendo los puertos en los routes principales tanto aqui como en casa de ipsec( 4500 y 500) y en protocolo GREP en el router de aqui que admite esa opcion.

Gracias por contestar
 
Desde hace un tiempo ya no se ven los canales utilizando VLC.
Otra puntualización, si utilizas imgp-snooping en el bridge acuérdate de cargar el paquete multicast al router.
Saludos.
Si es verdad no se ven , ya empieza a haber muchos con DRM , por eso tenia pensado darme de baja la proxima vez que bajara , pero buscando una configuracion para mi mikrotik encontre este subforo, y me dije de intentarlo con el aparato original.

Otra puntualización, si utilizas imgp-snooping en el bridge...
Efectivamente el brige lo tengo como en la foto que envio, con imgp snooping activado.

..acuérdate de cargar el paquete multicast al router.

Me podrias explicar como hacer esto

Gracias por contestar
Un saludo
 

Adjuntos

  • Captura.JPG
    Captura.JPG
    45.8 KB · Visitas: 46
Si es verdad no se ven , ya empieza a haber muchos con DRM , por eso tenia pensado darme de baja la proxima vez que bajara , pero buscando una configuracion para mi mikrotik encontre este subforo, y me dije de intentarlo con el aparato original.
Con otro desco sin problemas.

Me podrias explicar como hacer esto
Te vas a la página de descargas de Mikrotik. https://mikrotik.com/download
Te descargas el paquete "Extra packages" correspondiente a tu modelo de router.
Una vez descargado lo descomprimes y extraes el paquete llamado multicast y lo subes al router colocándolo en Files.
A continuación le haces un reboot al router para que cargue el paquete. Después puedes comprobar si lo ha instalado correctamente mirando en System>Packages.

Captura de pantalla_2021-05-24_18-56-43.pngCaptura de pantalla_2021-05-24_18-57-26.pngCaptura de pantalla_2021-05-24_19-00-36.png

Saludos.
 
Última edición:
  • Like
Reactions: ncs
Para qué necesitaría el paquete multicast, si en el lado del HGU el router no lo sustituye? Pregunto, desde el desconocimiento, no va con trampa.

Saludos!
 
  • Like
Reactions: ncs
Como podeis pedirme lo que querais yo lo he instalado pero sigue igual (mira Captura1)



Captura1





Para situarnos en las pruebas que estoy haciendo, las estoy haciendo en local conectados por escritorio remoto de widows en la misma maquina virtual conectada en un nic u otro, te lo explico de forma grafica:

En la entrada 2 , el windows por VLC se conecta perfectamente, es decir la conexión va desde el switch al Windows sin pasar por el router (ver captura2 color rojo), aquí se conecta (ver captura3)

Captura2

Captura3



Pero cuando me conecto pasando por el router, utilizando el mismo window , nada de nada el trafico iptv no pasa y estoy seguro que si lo consigo hacer pasar a esta maquina local , lo tendré aquí , porque es el mismo segmento de red optenida por DHCP (la conexión seria con el cable azul que vemos en la captura2)
 

Adjuntos

  • Captura1.JPG
    Captura1.JPG
    41.9 KB · Visitas: 46
  • Captura2.JPG
    Captura2.JPG
    85.1 KB · Visitas: 45
  • Captura3.JPG
    Captura3.JPG
    50.4 KB · Visitas: 42
Tienes el igmp snooping puesto en ambos bridges? Es decir, tanto del lado de allá, donde se está el HGU, como en el lado de acá, donde quieres recibirlo. En el lado de acá, en ese bridge iría tanto el puerto donde conectas el desco como la interfaz del EoIP.

Saludos!
 
  • Like
Reactions: ncs
Tienes el igmp snooping puesto en ambos bridges? Es decir, tanto del lado de allá, donde se está el HGU, como en el lado de acá, donde quieres recibirlo. En el lado de acá, en ese bridge iría tanto el puerto donde conectas el desco como la interfaz del EoIP.

Saludos!
Si , en los dos lados(mira captura4) , es que como ultimo recurso en el router tonto de aquí (vamos a llamarle el del extranjero) carge la configuración tuya del hap mini que publicastes unas paginas mas atrás a este que es un hap ac2, funciona perfectamente como vpn, pero nada de iptv



Pero yo creo que el problema esta en el router local que no deja pasar el iptv, como explico mas arriba , antes del router hay iptv después no
 

Adjuntos

  • Captura4.JPG
    Captura4.JPG
    187.5 KB · Visitas: 46
Si , en los dos lados(mira captura4) , es que como ultimo recurso en el router tonto de aquí (vamos a llamarle el del extranjero) carge la configuración tuya del hap mini que publicastes unas paginas mas atrás a este que es un hap ac2, funciona perfectamente como vpn, pero nada de iptv



Pero yo creo que el problema esta en el router local que no deja pasar el iptv, como explico mas arriba , antes del router hay iptv después no
Pues si te esperas unos días salimos de dudas, porque voy a tratar de montar un setup muy parecido. Solo que el mío va a ser más “chachi”: el lado tonto (full bridge, como si fuera un switch), va a ir del lado del HGU. Y la idea es que, sin tocarle, sacarle el jugo del IPTV. Él será el encargado de llamar a casa, al router padre que hará de servidor VPN.

Vamos, tal que le puedas regalar un mikrotik hEX a un colega y le digas, “toma, pínchalo en el router de telefónica, que lo le vamos a dar uso”, y todo lo que tengas que hacer en tu casa sea pinchar un segundo desco.

Saludos!
 
Ok, si necesitas hacer pruebas , aquí me tiene , yo por mi parte voy a continuar investigando .

Es que mi situación te va a sonar un poco rara, pero yo tengo un abono de movistar en mi casa de España que no esta habitada por nadie y que pago todo los meses.

Hasta ahora me he servido de un servidor tvheadend que instale allí y veo (o veía) lo que tenia contratado aquí, el problema es que han empezado a meter DRM y poco a poco se ve cada vez menos cadena.

Entonces intente tirar de app , pero resulta que en el salón tengo una tv grande y se ve como el culo, en la cocina se ve mas o menos bien.

Y como remate en el trabajo de mi mujer a llegado una colega nueva desde España , con un marido superinteligente que pagando al año lo que nosotros pagamos en un mes , tiene muchísimas mas cadenas que nosotros.



O sea que me veo dentro de una semana dándome de baja de movistar , poniendo a la venta mis mikrotik y comprando una conexión de esas.

Un saludo y gracias
 
Sobra decir que, cuando vayas, puedes montar el equipo en monopuesto y routear con el mikrotik. Con esa configuración, siempre te va a funcionar. Lo otro es para nota.

Saludos!
 
Sobra decir que, cuando vayas, puedes montar el equipo en monopuesto y routear con el mikrotik. Con esa configuración, siempre te va a funcionar. Lo otro es para nota.

Saludos!
Si, si claro, eso por supesto. Ya esta previsto, en agosto cuando baje, sera lo primero que haga.

Un saludo
 
Arriba