MANUAL: Mikrotik, tips & tricks

Muy interesante esa opción! Cuando tenga un ratito lo voy a probar, gracias!

S@lu2.

Cuando le meto variables al mensaje no me está funcionando bien el MarkdownV2, en cambio el HTML si que funciona bastante bien:

1627833238481.png
 
Truco: Activar el Hardware Offloading [aceleración por hardware] en equipos con switch chip MT7621 [hEX, hEX-S]
Este es el primer truco que debéis aprender los recién llegados a la marca y que hayáis optado por un equipo hEX [RB750Gr3] o hEX-S [RB760iGS]
Por defecto, el quick setup nos va a configurar nuestro equipo de manera correcta, pero dejará una interesante configuración sin activar: el hardware offloading o aceleración por hardware. Dado que nuestro equipo lleva un switch chip, podemos hacer uso de él para enrutar los paquetes que van al resto de puertos, sin llegar a pasar por la CPU del router, usando la aceleración por hardware del propio switch. Esto se traduce en un aumento de rendimiento más que notable. Para ello, lo único que tendremos que hacer es editar el bridge principal y desactivarle el protocolo de spanning tree, ya que este router no es compatible con STP/R-STP y hardware offloading al mismo tiempo, para este modelo de switch chip en concreto.

Hola pokoyo, no tengo claro si el modelo hAP ac2 es compatible con el hardware offloading.

1629188026084.png


Gracias!
 
Lo es. Mira la pestaña Bridge -> Ports y verás si lo tienes activo y funcionando. Los puertos que trabajen en ese modo tendrán una "H" delante. Si no me equivoco, el chipset que usa el hap-ac2 sí es compatible RSTP con hardware offloading, así que no tienes que tocar nada en la configuración del bridge.

Saludos!
 
Lo es. Mira la pestaña Bridge -> Ports y verás si lo tienes activo y funcionando. Los puertos que trabajen en ese modo tendrán una "H" delante. Si no me equivoco, el chipset que usa el hap-ac2 sí es compatible RSTP con hardware offloading, así que no tienes que tocar nada en la configuración del bridge.

Saludos!
Funcionando.
Gracias!
 
A ver, dale un export que lo veamos. Hay algunas ONT’s que solo permiten acceder a su interfaz web con la fibra desconectada; mira a ver si es eso.

Saludos!
 
A ver, dale un export que lo veamos. Hay algunas ONT’s que solo permiten acceder a su interfaz web con la fibra desconectada; mira a ver si es eso.

Saludos!

Es una Nokia g-010g-p, si que deja porque entre otras cosas te muestra la potencia de señal; ahí va el export:

Código:
/interface bridge
add name=bridge
/interface ethernet
set [ find default-name=ether1 ] comment=WAN
set [ find default-name=ether2 ] comment=LAN
/interface vlan
add interface=ether1 name=vlan1074 vlan-id=1074
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" group-key-update=1h mode=dynamic-keys supplicant-identity=MikroTik
/ip pool
add name=dhcp ranges=192.168.1.101-192.168.1.254
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge name=defconf
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=ether5
add bridge=bridge comment=defconf interface=wlan1
add bridge=bridge comment=defconf interface=wlan2
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN
add interface=vlan1074 list=WAN
/ip address
add address=192.168.1.1/24 comment=defconf interface=bridge network=192.168.1.0
add address=192.168.100.2/24 comment="ONT 192.168.100.1" interface=ether1 network=192.168.100.0
/ip cloud
set ddns-enabled=yes
/ip dhcp-client
add comment=defconf disabled=no interface=vlan1074 use-peer-dns=no
/ip dhcp-server network
add address=192.168.1.0/24 comment=defconf dns-server=192.168.1.1,192.168.1.1 gateway=192.168.1.1 netmask=24
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,1.1.1.1
/ip firewall filter
add action=accept chain=forward comment="defconf: accept in ipsec policy" disabled=yes ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" disabled=yes ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related
add action=accept chain=forward comment="defconf: accept established,related, untracked" connection-state=established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
add action=drop chain=forward comment="defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat out-interface=vlan1074
 
Te falla porque ese equipo no tiene la config original que monta por defecto, donde la regla de masquerade aplica a la lista WAN, no sobre la interfaz de la vlan concreta. Cámbialo o crea otra regla de masquerade similar a la que tienes pero sobre ether1.

Saludos!
 
Te falla porque ese equipo no tiene la config original que monta por defecto, donde la regla de masquerade aplica a la lista WAN, no sobre la interfaz de la vlan concreta. Cámbialo o crea otra regla de masquerade similar a la que tienes pero sobre ether1.

Saludos!

Perfecto, ya funciona!
 
Hola de nuevo,
Respecto al aviso por mail para nuevas IPs, me tocaba bastante las narices que en el aviso solamente apareciese la MAC del cliente, porque da poca información, sobre todo si en ese momento no tienes acceso al Mikrotik.

Lo he modificado añadiendo lo que veis en negrita, que corresponde con la columna "active host name" de la pestaña Leases, y nos da algo más de información ya que es cómo se identifica el dispositivo en la red.
Aunque no siempre tiene un valor, por ejemplo los teléfonos y las televisiones suelen identificarse por su marca.

Quedaría así:


:local recipient "alb3rcm@protonmail.ch"
/ip dhcp-server lease
:if (($leaseBound=1) && ([/ip dhcp-server lease find where dynamic mac-address=$leaseActMAC]!="")) do {
:do {
:tool e-mail send to=$recipient subject="NUEVA CONEXION [MAC: $leaseActMAC]" body="La siguiente dirección MAC [$leaseActMAC] y nombre [$"lease-hostname"] recibió la dirección IP [$leaseActIP] del servidor DCHP del router Mikrotik [$leaseServerName]"
:log info "Envío de alerta DHCP para la MAC $leaseActMAC"
} on-error={:log error "Error al enviar alerta por correo a $recipient"}
}


Espero que os sirva.
Saludos
 
Arriba