MANUAL: Mikrotik, tips & tricks

Para pegarme un tiro, efectivamente, conecté el cable de red a la tarjeta que no suelo usar y tenía la IP por DHCP pero las DNS puestas manualmente :oops:

Pues ese era tu problema, tu PC no estaba pasando por el servidor DNS del Mikrotik, y no se traía los dominios locales :)

Y ya que estamos, ¿se pueden utilizar varios dominios simultáneamente?

Puedes utilizar todos los que quieras. En IP >> DNS >> Static puedes definir los pares nombre.sufijo que desees (por ejemplo router.test y ont.test2), y siempre podrás hacer ping a router.test o a ont.test2 (especificando su sufijo).

Otra cosa es que en el DHCP le asignes el dominio local (.lan), de esta forma, puedes acceder a router.lan sin necesidad de especificar el sufijo, por ejemplo puedes hacer ping router, y ésto te resolverá router.lan porque el dominio local asignado por DHCP es .lan, pero especificando el sufijo, puedes acceder a los que desees.

Con respecto a la asignación del dominio local en el DHCP, yo creo que solo se puede asignar uno (de hecho en winbox no te deja añadir más de una linea). Que me corrija @pokoyo si me equivoco

Esa regla ya la he eliminado, que la creé para un challenge ssl y se me había olvidado. De todos modos... ¿cuál sería la forma correcta de establecerla sin secuestrar todo el tráfico al puerto 80?

Yo no veo problema en esa regla. Yo también tengo corriendo Let's Encrypt en una IP 192.168.33.30 y tengo una regla muy similar, sin mayor problema. Esta es mi regla:

Código:
add action=dst-nat chain=dstnat comment=Hassio-LetsEncrypt dst-address-list=public-ip dst-port=80 \
    protocol=tcp to-addresses=192.168.33.30 to-ports=80

Lo único que veo distinto es que tu especificas la interface como internet-vlan, y no termino de entender muy bien qué hace eso, pero no debería ser un problema.

Un saludo!
 
Última edición:
Para pegarme un tiro, efectivamente, conecté el cable de red a la tarjeta que no suelo usar y tenía la IP por DHCP pero las DNS puestas manualmente :oops:
Bien visto por @sermayoral, minipunto ;)

Esa regla ya la he eliminado, que la creé para un challenge ssl y se me había olvidado. De todos modos... ¿cuál sería la forma correcta de establecerla sin secuestrar todo el tráfico al puerto 80?
Al principio de este manual se describe, en el "HairpinNAT". Básicamente especificando que sólo secuestre el tráfico con destino a tu IP pública. Como sospecho tendrás IP dinámica, te toca hacer una pequeña trampa, usando el dominio que te regala mikrotik para resolver dicha IP pública "en caliente". Está todo descrito ahí.

Y ya que estamos, ¿se pueden utilizar varios dominios simultáneamente?

Suelo utilizar el .test bastante a menudo y no me vendría mal evitar editar cada vez el archivo hosts.
Sí, puedes poner los que quieras. No uses el ".local", que suele dar guerra con algunos dispositivos, puesto que ya lo usa mDNS. Por lo demás, puedes tener unos que se llamen .lan y otros que se llamen .test sin mayor problema.

Saludos!
 
Última edición:
Hola,

Antes que nada, agradecer a @pokoyo, una vez más, su aporte y esfuerzo por la comunidad.

Estoy aplicando algunos Tips&Tricks...concretamente me he puesto ahora con el de backup cloud y me encuentro una cosa curiosa:

Si ejecuto las órdenes de este script en CLI, la priemra me borra perfectamente y la segunda me crea el nuevo backup pero si lo hago desde este script...no funciona.

¿Qué puedo estar haciendo mal?

Saludos!

1612348686229.png
 
Hola,

Antes que nada, agradecer a @pokoyo, una vez más, su aporte y esfuerzo por la comunidad.

Estoy aplicando algunos Tips&Tricks...concretamente me he puesto ahora con el de backup cloud y me encuentro una cosa curiosa:

Si ejecuto las órdenes de este script en CLI, la priemra me borra perfectamente y la segunda me crea el nuevo backup pero si lo hago desde este script...no funciona.

¿Qué puedo estar haciendo mal?

Saludos!

Ver el adjunto 78091

De nada @wilotas

En un principio, no veo que estés haciendo nada mal. ¿Por qué crees que no funciona?

Saludos!
 
De nada @wilotas

En un principio, no veo que estés haciendo nada mal. ¿Por qué crees que no funciona?

Saludos!

Pues cuando hago el "print" del backup veo que no se me ha actualizado y sigue apareciendo el anterior.

Es raro, pensé si podía ser que sólo dejaran hacer 1 por día pero si lo lanzo manual...me cambia.
 
Pues cuando hago el "print" del backup veo que no se me ha actualizado y sigue apareciendo el anterior.

Es raro, pensé si podía ser que sólo dejaran hacer 1 por día pero si lo lanzo manual...me cambia.
Es un problema de como gestiona CLI los numeros. El "remove-file 0" no le gusta. Yo lo tengo puesto así:

Código:
/log info message="Cloud Backup Iniciado"
/system backup cloud upload-file action=create-and-upload password="lasuperclave" replace=[get ([find]->0) name]
/log info message="Cloud Backup Finalizado"

De esta manera creo el backup y elimino el previo.
 
Ha funcionado "a la perfección".

Curioso que si lo ejecutas línea a línea funcionara...pero he modificado le script como tú me has comentado y funciona.

Gracias @melkart
 
A mi me pasó lo mismo. Lo tenía en dos líneas, y desde la terminal iba de lujo. Y en cuanto lo puse en un script dejó de funcionar.
Me tocó romperme la cabeza hasta que descubrí en los foros de Mikrotik por dónde iban los tiros. Lo bueno es que al final aprendes ;)
 
Pues parece otra cagada más de la 6.48. Esto estaba funcionando hasta entonces, tengo backups mensuales programados que se notifican vía mail. El último bien hecho es del 26 de diciembre, juraría justo antes de meter esta versión.

Saludos!
 
Tomad, por si lo queréis en una sola línea, y algo más sencillo:
Código:
/system backup cloud upload-file action=create-and-upload password=MySuperP4ssW0rd! replace=[find name]
 
Pues parece otra cagada más de la 6.48. Esto estaba funcionando hasta entonces, tengo backups mensuales programados que se notifican vía mail. El último bien hecho es del 26 de diciembre, juraría justo antes de meter esta versión.

Saludos!
Yo me he pasado a la "longterm" 6.47.9. No estoy "a la última", pero va así como la seda. La "stable" (6.4:cool: está resultando en verdad un churro.
 
Bueno, la verdad que ya está funcionando como un reloj el backup.

Lanzo una cuestión respecto a terner 2 RB4011 y teniendo el backup diario del principal.

¿Cómo haríais para tener el segundo de respaldo importando el backup del primero?, me surge la duda hasta de cómo levantarlos estando en la misma red para no crear conflictos.

A ver si me ilumináis.

Gracias a todos!
 
Te lo explica en la wiki. Con el parámetro “secret-download-key”

saludos!
 
Te lo explica en la wiki. Con el parámetro “secret-download-key”

saludos!

Perdona @pokoyo , me he explicado un poco mal.

Sí, sé de esa instrucción para poder decargarlo pero el tema es un poco más complejo o me gustaría ser algo más ambicioso.

Si hago un backup todos los días, el secret-key cambia, así que es complicado automatizar la descargar en el segundo router. Además, tengo la duda de cómo "levantar" el segundo router si al final va a tener la misma config que el primero.

La idea sería tener los dos con la misma config y tener uno listo por si el otro falla...evitando la parte más manual.

Igual me estoy fumando un canuto...
 
Igual me estoy fumando un canuto...
jeje, creo que sí.

Lo primero es entender qué necesidad tienes, pero de normal no cambias configuración todos los días (al menos no deberías) como para necesitar ese backup diario. Y yo no aplicaría esa configuración a un segundo router del tirón como un proceso automatizado, el segundo router lo tendría sin configuración, en blanco, esperando a que el primero muera par cargar dicha configuración desde cloud. Dado que el secret key cambia, la cuestión es que te envíes un correo o notificación cuando se cree el backup con esa clave, tal que si el equipo muere, pinches el otro y uses esa clave para descargar el backup y aplicarlo.

Saludos!
 
Tomad, por si lo queréis en una sola línea, y algo más sencillo:
Código:
/system backup cloud upload-file action=create-and-upload password=MySuperP4ssW0rd! replace=[find name]
Voy a probar el script, que los backups los tengo un poco abandonados :rolleyes:
¡¡Muchas gracias por estos tips @pokoyo!!, cuando los reviso siempre encuentro algo que mejorar en mi configuración.
Saludos.
 
Es un problema de como gestiona CLI los numeros. El "remove-file 0" no le gusta. Yo lo tengo puesto así:

Código:
/log info message="Cloud Backup Iniciado"
/system backup cloud upload-file action=create-and-upload password="lasuperclave" replace=[get ([find]->0) name]
/log info message="Cloud Backup Finalizado"

De esta manera creo el backup y elimino el previo.
Gracias @melkart me has ahorrado mucho tiempo

Saludos
 
Hoy vamos a ver una pequeña utilidad.
Vamos a configurar el mode-button que llevan algunos modelos de Routerboard para que realice una acción.

1471_l.jpg1540_l.jpg

Primero crearemos un script con la acción a realizar. En este ejemplo le indicaremos que nos haga un reboot del equipo.
Vamos al menú System>Scripts

01-script.png

Código:
/system script
add dont-require-permissions=no name=mode-button-reboot owner=admin \
    policy=reboot source="/system reboot"

Después nos vamos a System>Routerboard y clickamos la pestaña Mode button. Marcamos la casilla enabled y ponemos el nombre del script que hemos creado en primer lugar.

02-Routerboard.png
03-mode-button.png

Código:
/system routerboard mode-button
set enabled=yes on-event=mode-button-reboot

Con estos pasos ya tenemos configurado el mode button para reiniciar el equipo.

Una utilidad sencilla pero muy práctica para poner en marcha acciones como hacer un reboot, shutdown, apagar/encender el wifi de nuestros equipos. Y por supuesto se puede añadir cualquier tipo de acción que podamos programar en un script.

Saludos.
 
Hoy vamos a ver una pequeña utilidad.
Vamos a configurar el mode-button que llevan algunos modelos de Routerboard para que realice una acción.

Ver el adjunto 82479Ver el adjunto 82482

Primero crearemos un script con la acción a realizar. En este ejemplo le indicaremos que nos haga un reboot del equipo.
Vamos al menú System>Scripts

Ver el adjunto 82485

Código:
/system script
add dont-require-permissions=no name=mode-button-reboot owner=admin \
    policy=reboot source="/system reboot"

Después nos vamos a System>Routerboard y clickamos la pestaña Mode button. Marcamos la casilla enabled y ponemos el nombre del script que hemos creado en primer lugar.

Ver el adjunto 82488
Ver el adjunto 82491

Código:
/system routerboard mode-button
set enabled=yes on-event=mode-button-reboot

Con estos pasos ya tenemos configurado el mode button para reiniciar el equipo.

Una utilidad sencilla pero muy práctica para poner en marcha acciones como hacer un reboot, shutdown, apagar/encender el wifi de nuestros equipos. Y por supuesto se puede añadir cualquier tipo de acción que podamos programar en un script.

Saludos.
Muy buena @stargate4you! Luego edito el hilo principal y lo subo para arriba. Gracias por compartirlo, no lo suelo usar porque tengo los equipos escondidos, pero para el AP me viene de lujo.

Saludos!
 
Hoy vamos a ver una pequeña utilidad.
Vamos a configurar el mode-button que llevan algunos modelos de Routerboard para que realice una acción.

Ver el adjunto 82479Ver el adjunto 82482

Primero crearemos un script con la acción a realizar. En este ejemplo le indicaremos que nos haga un reboot del equipo.
Vamos al menú System>Scripts

Ver el adjunto 82485

Código:
/system script
add dont-require-permissions=no name=mode-button-reboot owner=admin \
    policy=reboot source="/system reboot"

Después nos vamos a System>Routerboard y clickamos la pestaña Mode button. Marcamos la casilla enabled y ponemos el nombre del script que hemos creado en primer lugar.

Ver el adjunto 82488
Ver el adjunto 82491

Código:
/system routerboard mode-button
set enabled=yes on-event=mode-button-reboot

Con estos pasos ya tenemos configurado el mode button para reiniciar el equipo.

Una utilidad sencilla pero muy práctica para poner en marcha acciones como hacer un reboot, shutdown, apagar/encender el wifi de nuestros equipos. Y por supuesto se puede añadir cualquier tipo de acción que podamos programar en un script.

Saludos.

Esto luego no dará problemas en caso de necesitar hacer un netinstall, verdad?
Lo digo porque en mi caso el hap^2 si me permite hacer "mode button" pero en el 4011 no; y no se yo si el "mode button" es el resert o es otro

Saludos
 
Arriba