MANUAL: Mikrotik, manejo de APs usando CAPsMAN

Pues listo, eso quiere decir que CAPsMAN funciona. Ahora puedes probar a conectarte a ambas redes. Tu red privada debe de tener acceso al resto de los equipos de la red, mientras que la red de invitados, al no tener default forward, no debería ver al resto de los equipos de red conectados a esa misma wifi.

Una vez comprobado eso, lo único que te queda hacer en el hAP ac3 es poner sus interfaces inalámbricas a disposición de CAPsMAN. Para ello, simplemente vas a la pestaña Wireless y reseteas la configuración inalámbrica de cada una de las dos interfaces (ojo haz este paso por cable, para no quedarte fuera de la red) el botón del reset de la interfaz inalámbrica lo tienes dentro de cada interfaz física. Una vez reseteado, en la pantalla principal donde se listan las interfaces inalámbricas, tendrás un botón que pone “CAP” y simplemente pulsas en él para activar el modo cap de ese equipo. Como interfaces a controlar le pasas ambas (es una lista, añades tanto wlan1 como wlan2) y en el campo CAPsMAN address pones la IP 127.0.0.1. Una vez hecho, en la pestaña Wireless aparecerán unas líneas en rojo indicando que esas dos interfaces ahora se manejan vía CAPsMAN y, si todo ha ido bien, tendrás no dos, sino cinco interfaces nuevas en la pestaña “CAP Interface” de CAPsMAN. Las dos que tenías del hAP mini, más las dos nuevas (normal e invitados) para la red de 2,4GHz del hAP ac3, más la red normal de 5HGz en este último equipo.

Prueba y me dices.

Saludos!
 

Adjuntos

  • capsman_ac3_B.png
    capsman_ac3_B.png
    117.9 KB · Visitas: 48
Ahí están las de 2,4, pero no la de 5GHz. Metiste ambas interfaces (wlan1 y wlan2) en la lista de interfaces a manejar por CAPsMAN, cuando configuraste el hAP ac3 como CAP? Creo que solo metiste wlan1.

Saludos!
 
Ahí están las de 2,4, pero no la de 5GHz. Metiste ambas interfaces (wlan1 y wlan2) en la lista de interfaces a manejar por CAPsMAN, cuando configuraste el hAP ac3 como CAP? Creo que solo metiste wlan1.

Saludos!
Ahora ya está solucionado, muchas gracias de nuevo.
A ver que me pongo a mirar ahora :)
 
Ahora enreda con ello, a ver qué tal resultado te da. Puedes ver a qué red se conecta cada cliente desde CAPsMAN, en la última pestaña Registration Table. Asegúrate de que los equipos que soportan 5GHz, prefieren esa red frente a la otra.

Saludos!
 
Hola.
Tengo un pequeño problema con el hap mini.
Cuando por la mañana entro en la cocina (lugar donde esta situado el mini) se me conecta el movil o la tablet al wifi pero no deja navegar o es exageradamente lento.es
Como si quedara en suspensión...hay alguna solución?
Tal vez tenga que ir reiniciándose la wifi de vez en cuando?
Se puede hacer de forma automática??
Gracias y saludos
 
Ese es el que tenías conectado a un PLC, ¿verdad? Si el PLC se queda en modo ahorro, es posible que te de la lata. Lo del reinicio del mikrotik quítatelo de la cabeza, grábate a fuego esto que te voy a comentar: salvo error catastrófico (llenes una memoria y revientes la cpu de proceso) rara vez, por no decir jamás, vas a conseguir que un reinicio arregle un mikrotik. Mucho menos la wifi, si está en modo cap. De tener algún problema, lo tiene de configuración.

Pásame un export de cómo está ese equipo ahora mismo, si quieres, y lo reviso.

Saludos.
 
te pongo una captura del bridge del AC3....salen interfaces desconocidas
 

Adjuntos

  • captura_bridge_ac3.jpg
    captura_bridge_ac3.jpg
    183.9 KB · Visitas: 34
Pásame un export del capsman. La configuración del hAP mini es correcta. Yo crearía dos reglas de provisioning distintas (una para cada cAP) para la red de 2,4 plantando la del equipo que está más cerca del teléfono inalámbrico en el canal 11 u la del hAP ac3 en el canal 6, si no están muy saturados en tu zona. Por otro lado, bajaría la potencia de los APs en esa banda, para que no generen interferencias con el teléfono inalámbrico.

Si quieres pásame un export del CAPsMAN y lo apañamos rápido.

Saludos!
 
Pásame un export del capsman. La configuración del hAP mini es correcta. Yo crearía dos reglas de provisioning distintas (una para cada cAP) para la red de 2,4 plantando la del equipo que está más cerca del teléfono inalámbrico en el canal 11 u la del hAP ac3 en el canal 6, si no están muy saturados en tu zona. Por otro lado, bajaría la potencia de los APs en esa banda, para que no generen interferencias con el teléfono inalámbrico.

Si quieres pásame un export del CAPsMAN y lo apañamos rápido.

Saludos!
Para que sea solo de CAPsMAN como seria el comando ??
por cierto.....el fijo esta al lado del hAP 3
 

Adjuntos

  • CAPsMAN.txt
    3 KB · Visitas: 25
Te paso cómo lo haría yo.

Primero, crea los canales individuales, puesto que no vamos a dejar que sean los AP's los que elijan dichos canales. Vamos a plantarle el canal 11 al hap-mini, que es el que más alejado está en esa banda de la frecuencia del teléfono inalámbrico, y el canal 6 en el hap-ac3. La configuración del hap-ac3 de 5ghz no la voy a tocar.

Primero, creamos los canales independientes. Bajamos la potencia a la mitad de los dBm's de como se emiten por defecto (se emiten con 20dBm's, pues los dejamos en 10dBm's). Si ves que se quedan cortos, súbelos a 15, pero cuanto más bajo opere el hap-mini mejor, dado que está pegado el inalámbrico, por lo que me cuentas.
Código:
/caps-man channel
add band=2ghz-g/n control-channel-width=20mhz extension-channel=disabled \
    frequency=2412 name=channel-1 tx-power=10
add band=2ghz-g/n control-channel-width=20mhz extension-channel=disabled \
    frequency=2437 name=channel-6 tx-power=10
add band=2ghz-g/n control-channel-width=20mhz extension-channel=disabled \
    frequency=2462 name=channel-11 tx-power=10

Luego, metemos reglas de configuración (además de las que tienes), específicas por canal. No las vamos a usar todas, pero déjo también la del canal 1 por si las moscas la usaras en un futuro.
Código:
/caps-man configuration
add channel=channel-1 country=spain datapath=home-dp mode=ap name=\
    home-wifi-2ghz-ch1-cfg rates=gn-only security=home-sp ssid=MikroTik
add channel=channel-6 country=spain datapath=home-dp mode=ap name=\
    home-wifi-2ghz-ch6-cfg rates=gn-only security=home-sp ssid=MikroTik
add channel=channel-11 country=spain datapath=home-dp mode=ap name=\
    home-wifi-2ghz-ch11-cfg rates=gn-only security=home-sp ssid=MikroTik
add channel=channel-1 country=spain datapath=guest-dp mode=ap name=\
    guest-wifi-2ghz-ch1-cfg rates=gn-only security=guest-sp ssid=guests
add channel=channel-6 country=spain datapath=guest-dp mode=ap name=\
    guest-wifi-2ghz-ch6-cfg rates=gn-only security=guest-sp ssid=guests
add channel=channel-11 country=spain datapath=guest-dp mode=ap name=\
    guest-wifi-2ghz-ch11-cfg rates=gn-only security=guest-sp ssid=guests

Ahora deshabilitamos la regla vieja de provisioning de la wifi de 2,4GHz que, según tu configuración, es la primera regla:
Código:
caps-man provisioning set 0 disabled=yes

Por último, creamos nuevas reglas de provisión específicas por AP. Para ello, especificamos la MAC address: cambia los valores que ves ahí [00:11:22:AA:BB:CC que asigno la hap-mini y 33:44:55:DD:EE:FF que asigno al hpa-ac3] por las direcciones MAC de la wifi de 2'4GHz para cada equipo. En la pestaña "Radio" podrás ver la dirección MAC del hap-mini (única, porque sólo tiene un radio) y las dos del hap-ac3 (doble banda=dos radios), la primera de las dos para ese equipo es la de 2,4Ghz.
Código:
/caps-man provisioning
add action=create-dynamic-enabled comment=hap-mini hw-supported-modes=gn \
    master-configuration=home-wifi-2ghz-ch11-cfg name-format=prefix-identity \
    name-prefix=2ghz radio-mac=00:11:22:AA:BB:CC slave-configurations=\
    guest-wifi-2ghz-ch11-cfg
add action=create-dynamic-enabled comment=hap-ac3 hw-supported-modes=gn \
    master-configuration=home-wifi-2ghz-ch6-cfg name-format=prefix-identity \
    name-prefix=2ghz radio-mac=33:44:55:DD:EE:FF slave-configurations=\
    guest-wifi-2ghz-ch6-cfg

Por último, y para borrar el jaleo de interfaces antiguas que tienes en el hap-ac3, apaga y enciende capsman o pégale directamente un reinicio. Ojo, que la wifi de 5GHz tarda en levantar.

Saludos!
 
Te paso cómo lo haría yo.

Primero, crea los canales individuales, puesto que no vamos a dejar que sean los AP's los que elijan dichos canales. Vamos a plantarle el canal 11 al hap-mini, que es el que más alejado está en esa banda de la frecuencia del teléfono inalámbrico, y el canal 6 en el hap-ac3. La configuración del hap-ac3 de 5ghz no la voy a tocar.

Primero, creamos los canales independientes. Bajamos la potencia a la mitad de los dBm's de como se emiten por defecto (se emiten con 20dBm's, pues los dejamos en 10dBm's). Si ves que se quedan cortos, súbelos a 15, pero cuanto más bajo opere el hap-mini mejor, dado que está pegado el inalámbrico, por lo que me cuentas.
Código:
/caps-man channel
add band=2ghz-g/n control-channel-width=20mhz extension-channel=disabled \
    frequency=2412 name=channel-1 tx-power=10
add band=2ghz-g/n control-channel-width=20mhz extension-channel=disabled \
    frequency=2437 name=channel-6 tx-power=10
add band=2ghz-g/n control-channel-width=20mhz extension-channel=disabled \
    frequency=2462 name=channel-11 tx-power=10

Luego, metemos reglas de configuración (además de las que tienes), específicas por canal. No las vamos a usar todas, pero déjo también la del canal 1 por si las moscas la usaras en un futuro.
Código:
/caps-man configuration
add channel=channel-1 country=spain datapath=home-dp mode=ap name=\
    home-wifi-2ghz-ch1-cfg rates=gn-only security=home-sp ssid=MikroTik
add channel=channel-6 country=spain datapath=home-dp mode=ap name=\
    home-wifi-2ghz-ch6-cfg rates=gn-only security=home-sp ssid=MikroTik
add channel=channel-11 country=spain datapath=home-dp mode=ap name=\
    home-wifi-2ghz-ch11-cfg rates=gn-only security=home-sp ssid=MikroTik
add channel=channel-1 country=spain datapath=guest-dp mode=ap name=\
    guest-wifi-2ghz-ch1-cfg rates=gn-only security=guest-sp ssid=guests
add channel=channel-6 country=spain datapath=guest-dp mode=ap name=\
    guest-wifi-2ghz-ch6-cfg rates=gn-only security=guest-sp ssid=guests
add channel=channel-11 country=spain datapath=guest-dp mode=ap name=\
    guest-wifi-2ghz-ch11-cfg rates=gn-only security=guest-sp ssid=guests

Ahora deshabilitamos la regla vieja de provisioning de la wifi de 2,4GHz que, según tu configuración, es la primera regla:
Código:
caps-man provisioning set 0 disabled=yes

Por último, creamos nuevas reglas de provisión específicas por AP. Para ello, especificamos la MAC address: cambia los valores que ves ahí [00:11:22:AA:BB:CC que asigno la hap-mini y 33:44:55:DD:EE:FF que asigno al hpa-ac3] por las direcciones MAC de la wifi de 2'4GHz para cada equipo. En la pestaña "Radio" podrás ver la dirección MAC del hap-mini (única, porque sólo tiene un radio) y las dos del hap-ac3 (doble banda=dos radios), la primera de las dos para ese equipo es la de 2,4Ghz.
Código:
/caps-man provisioning
add action=create-dynamic-enabled comment=hap-mini hw-supported-modes=gn \
    master-configuration=home-wifi-2ghz-ch11-cfg name-format=prefix-identity \
    name-prefix=2ghz radio-mac=00:11:22:AA:BB:CC slave-configurations=\
    guest-wifi-2ghz-ch11-cfg
add action=create-dynamic-enabled comment=hap-ac3 hw-supported-modes=gn \
    master-configuration=home-wifi-2ghz-ch6-cfg name-format=prefix-identity \
    name-prefix=2ghz radio-mac=33:44:55:DD:EE:FF slave-configurations=\
    guest-wifi-2ghz-ch6-cfg

Por último, y para borrar el jaleo de interfaces antiguas que tienes en el hap-ac3, apaga y enciende capsman o pégale directamente un reinicio. Ojo, que la wifi de 5GHz tarda en levantar.

Saludos!
Lo probare, pero un comentario...el teléfono inalámbrico esta al lado del hAP ac3....cambia algo eso ??
Muchas gracias por la ayuda
 
sí, dale la vuelta al pastel con las reglas de provisioning. Asegurate de que el canal 11, frecuencia más alta en 2,4 (2462) se lo asignas al equipo que esté al lado del teléfono inalámbrico. Si quieres puedes dejar ese canal en 10dBm y el 1 y el 6 en 17dBm, como lo tenías al principio. Lo que interesa es que el equipo que está al lado del teléfono no emita con demasiada potencia en esa banda, que no chille.

Saludos!
 
Última edición:
sigue pasando...cada10 segundos aprox. se corta un segundo o dos la conversacion , creo que el problema es que esta demasiado cerca el router de la base del telefono inalambrico.
probare de comprar un cable telefonico normal un poco mas largo para probarlo desde mas lejos del router.
Igual el problema es que tengo los dos routers ( zte f679 y mikrotik) y la base del teléfono todos en 30 cm.....aunque cuando utilizo el inalámbrico estoy mas lejos y me voy moviendo por el piso.

saludos y gracias
 
Última edición:
sigue pasando...cada10 segundos aprox. se corta un segundo o dos la conversacion , creo que el problema es que esta demasiado cerca el router de la base del telefono inalambrico.
probare de comprar un cable telefonico normal un poco mas largo para probarlo desde mas lejos del router.
Igual el problema es que tengo los dos routers ( zte f679 y mikrotik) y la base del teléfono todos en 30 cm.....aunque cuando utilizo el inalámbrico estoy mas lejos y me voy moviendo por el piso.

saludos y gracias
Sí, puede ser. Ya ves que el hAP-ac3 lleva unas señoras antenas.

También puedes poner ese router un pelín más lejos, con simplemente tener un cable ethernet un pelín más largo.

Saludos!
 
Arriba