MANUAL: Mikrotik, Internet en casa con datos móviles

No, no está conectada. Está encendida, pero no tienes IP pública en esa interfaz, es normal que no navegues.
Dale un pantallazo a la config del APN y de la interfaz LTE, que algo nos falta o no tenemos bien configurado.

Saludos!
Sigue sin darme ip pero no se por que,he metido la sim en el teléfono para comprobar los datos de apn y en teoría son esos
Saludos
Edito:
He conseguido que me de la IP,poniendo la APN en interfaz lte 1 general,pero sigo sin poder navegar
 

Adjuntos

  • 3B0FB23C-11E0-444A-9B3A-4DCFD2C8588F.jpeg
    3B0FB23C-11E0-444A-9B3A-4DCFD2C8588F.jpeg
    260.6 KB · Visitas: 93
  • 5FE5D731-7F33-4CF3-8F67-BDA2547E8348.jpeg
    5FE5D731-7F33-4CF3-8F67-BDA2547E8348.jpeg
    782.7 KB · Visitas: 98
  • 23497BB9-0233-4B9B-970F-6609DBC98D26.jpeg
    23497BB9-0233-4B9B-970F-6609DBC98D26.jpeg
    174.5 KB · Visitas: 96
Última edición:
Ese pantallazo no me vale para nada. Necesito estos. Como puedes ver, cuando funciona correctamente, obtienes una IP en la interfaz LTE.

1642101217422.png


Saludos!
 
Ese pantallazo no me vale para nada. Necesito estos. Como puedes ver, cuando funciona correctamente, obtienes una IP en la interfaz LTE.

Ver el adjunto 90903

Saludos!
Como te he dicho ahora si que me da una IP pero no me da conexion
Edito
Sin tocar nada,me ha sacado de winbox y ahora no da otra vez la IP
 

Adjuntos

  • EEDC278E-831C-4DA0-96B1-4955AD216670.jpeg
    EEDC278E-831C-4DA0-96B1-4955AD216670.jpeg
    310.9 KB · Visitas: 91
Última edición:
Como te he dicho ahora si que me da una IP pero no me da conexion
Edito
Sin tocar nada,me ha sacado de winbox y ahora no da otra vez la IP
El usuario era “Vodafone”, con la V mayúscula, o eso pone la web del operador. Y sin contraseña.

Saludos!
 
El usuario era “Vodafone”, con la V mayúscula, o eso pone la web del operador. Y sin contraseña.

Saludos!
Ok,lo acabo de intentar con esa apn
En quick set internet me da la ip pero sigo sin conexión,he vuelto a hacer pint 8.8.8.8 y nada
Tienes alguna idea de que podría ser?
Lo tengo que dejar por hoy,si me dices que crees que debería probar,mañana lo hago
Gracias por tu tiempo de verdad
Saludos
 
Llegaste a probar con el APN por defecto?

Lo único que se me ocurre es que el APN esté mal creado. Y claro, sin ip en la LTE, como si no tuvieras nada.

En el MR200, ¿qué configuración tienes para el APN?

Saludos!
 
Llegaste a probar con el APN por defecto?

Lo único que se me ocurre es que el APN esté mal creado. Y claro, sin ip en la LTE, como si no tuvieras nada.

En el MR200, ¿qué configuración tienes para el APN?

Saludos!
Si,probé con esa
Yo también creo que puede ser ese el problema,he llamado a Vodafone Para que me confirmaran la apn y me dijeron que lo viera metiendo la sim en un móvil,así lo he hecho
en el mr m200 es ac.Vodafone y usuario y contraseña Vodafone Pero Me acabo de dar cuenta que en el tipo de autenticación en CHAP y no PAP como pone en todos los sitios,puede influir?
Un saludo
 
Si,probé con esa
Yo también creo que puede ser ese el problema,he llamado a Vodafone Para que me confirmaran la apn y me dijeron que lo viera metiendo la sim en un móvil,así lo he hecho
en el mr m200 es ac.Vodafone y usuario y contraseña Vodafone Pero Me acabo de dar cuenta que en el tipo de autenticación en CHAP y no PAP como pone en todos los sitios,puede influir?
Un saludo
Sí, claro que puede ser eso. De hecho, no hay mucho más que pueda ser, porque mira que hay pocos datos que puedan variar en la definición del APN.

Saludos!
 
Perdonar la ignorancia.
Para este tipo de conexiones es necesario visión libre de obstáculos con la antena, como si fuera un punto a punto ?
Tengo dos antenas en mi zona, una 150 metros bastante despejada, casi visión directa(orange) y otra a 1,5km, pero está en el otro extremo de la población (movistar)
Me parece mejor opción la tarifa de movistar
Un saludo!
 
Perdonar la ignorancia.
Para este tipo de conexiones es necesario visión libre de obstáculos con la antena, como si fuera un punto a punto ?
Tengo dos antenas en mi zona, una 150 metros bastante despejada, casi visión directa(orange) y otra a 1,5km, pero está en el otro extremo de la población (movistar)
Me parece mejor opción la tarifa de movistar
Un saludo!
No es necesario, pero cuanto más despejado tengas la visibilidad, mejor conexión tendrás. Date cuenta que son otras frecuencias, con más calado, diferentes de las que usas en una conexión wifi inalámbrica punto a punto. Aun así, aplican la mismas leyes físicas.

Saludos!
 
Hola!

Me gustaría hacer un añadido al post original, con una casuística que se me ha dado con otro post del foro. Son de estas cosas que no caes hasta que te toca lidiar con un chisme LTE. Nos vamos a basar en al siguiente foto:

1659778013091.png


Problema: cuando pones un dispositivo LTE en modo passthrough (modo en el que la IP pública se envía al siguiente equipo), no sólo pierdes la administración de ese equipo (ya hemos visto cómo solucionarlo, está explicado en el manual del primer post), sino que ese dispositivo, al hacer passthrough, se queda sin internet él mismo. Lo que a priori parece una ventaja (no nos tenemos que preocupar de la config de firewall de ese equipo, no lleva NAT, no está como tal accesible desde internet) tiene una gran pega: ¿qué pasa cuando tienes que actualizar ese equipo? Las actualizaciones de la routerboard son relativamente sencillas de meter, con bajar el fichero y subirlo al winbox nos vale. Pero, ¿qué pasa con el firmware del módem, que se actualiza vía OTA? Ahí la hemos cagado... ¿No sería más cómodo si ese equipo tuviera además una configuración que le permitiera acceder a internet en un momento dado? Como podréis intuir, los tiros van por aquí. Para esto, tenemos varias soluciones:
A) La perezosa: me la pela el doble NAT y tengo los dos equipos como router... Pshh...¿funciona?... el resto me da igual, me la pela.
B) La borrica: mantenemos el equipo en modo router con todas sus opciones aunque no lo usemos como tal. Cuando necesitemos acceder a internet, cambiamos el APN y dejamos a toda la familia sin internet, actualizamos, y andando... Bueno, y volvemos a poner el APN de tipo passthrough para que no nos chille la familia por dejarles sin Netflix
C) La elegante: que es la que os vengo a presentar. Simplemente añadiendo una ruta por defecto, solucionamos el tema en la SXT.

La pregunta es ¿a dónde apunto esa ruta por defecto? La SXT ha dejado de tener control de la IP pública, así que por mucho que la apuntemos a la VLAN, a la LTE o a cualquier otra interfaz, no vas a sacar nada en claro. A la IP a la que tenemos que apuntar es a la de administración del router interno, la que comparte en segmento con la SXT. Esas dos rutas están conectadas, así que si le metemos una ruta por defecto a la SXT diciendo que, lo que no encuentre, se lo tire al router que tiene debajo (suena raro, normalmente solemos ir para arriba), el router de abajo verá la petición y, como viene de un nodo que él considera LAN y que está directamente conectado, preguntará a su ruta por defecto, sacando el tráfico por la VLAN 25. Dicho tráfico dará la vuelta a la SXT, y saldrá por el canuto del passthrough.
Código:
/ip route
add gateway=192.168.190.2

Tan simple como eso. Si además de eso le metemos un DNS a la SXT en IP->DNS, y un par de reglas de firewall básicas, tendremos un equipo que podrá acceder a internet con total normalidad, haciendo un loopback a sí mismo (llamo al vecino que me devuelve el canuto que necesito par salir).

Os dejo una configuración básica de una SXT para que podáis usarla en ese modo, considerando que las IPs de administración de los equipos son la 192.168.190.1/30 (Chisme LTE) y 192.168.190.2/30 (Router)

Código:
###################################
####### VARIABLES A MODIFICAR #####
###################################
:local pin 1234
###################################
/interface vlan
add interface=ether1 name=vlan-lte vlan-id=25

/ip address
add address=192.168.190.1/30 interface=ether1

/ip firewall filter
add action=accept chain=input comment=\
  "aceptamos el trafico ya estableciodo o relacionado" connection-state=\
  established,related,untracked
add action=drop chain=input comment="rechazamos el trafico invalido" connection-state=\
  invalid
add action=accept chain=input comment="aceptamos el ping" protocol=icmp
add action=drop chain=input comment="rechazamos todo lo que no venga de red local" \
  src-address=!192.168.0.0/16

/ip route
add gateway=192.168.190.2

/ip dns
set servers=8.8.8.8,8.8.4.4

/interface lte apn
add copy-from=0 name=default-passthrough passthrough-interface=vlan-lte passthrough-mac=auto
:delay 30

/interface lte
set [ find ] apn-profiles=default-passthrough name=lte1 pin=$pin

Espero que os guste!
 
Última edición:
Hola!

Me gustaría hacer un añadido al post original, con una casuística que se me ha dado con otro post del foro. Son de estas cosas que no caes hasta que te toca lidiar con un chisme LTE. Nos vamos a basar en al siguiente foto:

Ver el adjunto 97755

Problema: cuando pones un dispositivo LTE en modo passthrough (modo en el que la IP pública se envía al siguiente equipo), no sólo pierdes la administración de ese equipo (ya hemos visto cómo solucionarlo, está explicado en el manual del primer post), sino que ese dispositivo, al hacer passthrough, se queda sin internet él mismo. Lo que a priori parece una ventaja (no nos tenemos que preocupar de la config de firewall de ese equipo, no lleva NAT, no está como tal accesible desde internet) tiene una gran pega: ¿qué pasa cuando tienes que actualizar ese equipo? Las actualizaciones de la routerboard son relativamente sencillas de meter, con bajar el fichero y subirlo al winbox nos vale. Pero, ¿qué pasa con el firmware del módem, que se actualiza vía OTA? Ahí la hemos cagado... ¿No sería más cómodo si ese equipo tuviera además una configuración que le permitiera acceder a internet en un momento dado? Como podréis intuir, los tiros van por aquí. Para esto, tenemos varias soluciones:
A) La perezosa: me la pela el doble NAT y tengo los dos equipos como router... Pshh...¿funciona?... el resto me da igual, me la pela.
B) La borrica: mantenemos el equipo en modo router con todas sus opciones aunque no lo usemos como tal. Cuando necesitemos acceder a internet, cambiamos el APN y dejamos a toda la familia sin internet, actualizamos, y andando... Bueno, y volvemos a poner el APN de tipo passthrough para que no nos chille la familia por dejarles sin Netflix
C) La elegante: que es la que os vengo a presentar. Simplemente añadiendo una ruta por defecto, solucionamos el tema en la SXT.

La pregunta es ¿a dónde apunto esa ruta por defecto? La SXT ha dejado de tener control de la IP pública, así que por mucho que la apuntemos a la VLAN, a la LTE o a cualquier otra interfaz, no vas a sacar nada en claro. A la IP a la que tenemos que apuntar es a la de administración del router interno, la que comparte en segmento con la SXT. Esas dos rutas están conectadas, así que si le metemos una ruta por defecto a la SXT diciendo que, lo que no encuentre, se lo tire al router que tiene debajo (suena raro, normalmente solemos ir para arriba), el router de abajo verá la petición y, como viene de un nodo que él considera LAN y que está directamente conectado, preguntará a su ruta por defecto, sacando el tráfico por la VLAN 25. Dicho tráfico dará la vuelta a la SXT, y saldrá por el canuto del passthrough.
Código:
/ip route
add gateway=192.168.190.2

Tan simple como eso. Si además de eso le metemos un DNS a la SXT en IP->DNS, y un par de reglas de firewall básicas, tendremos un equipo que podrá acceder a internet con total normalidad, haciendo un loopback a sí mismo (llamo al vecino que me devuelve el canuto que necesito par salir).

Os dejo una configuración básica de una SXT para que podáis usarla en ese modo, considerando que las IPs de administración de los equipos son la 192.168.190.1/30 (Chisme LTE) y 192.168.190.2/30 (Router)

Código:
###################################
####### VARIABLES A MODIFICAR #####
###################################
:local pin 1234
###################################
/interface vlan
add interface=ether1 name=vlan-lte vlan-id=25

/ip address
add address=192.168.190.1/30 interface=ether1

/ip firewall filter
add action=accept chain=input comment=\
  "aceptamos el trafico ya estableciodo o relacionado" connection-state=\
  established,related,untracked
add action=drop chain=input comment="rechazamos el trafico invalido" connection-state=\
  invalid
add action=accept chain=input comment="aceptamos el ping" protocol=icmp
add action=drop chain=input comment="rechazamos todo lo que no venga de red local" \
  src-address=!192.168.0.0/16

/ip route
add gateway=192.168.190.2

/ip dns
set servers=8.8.8.8,8.8.4.4

/interface lte apn
add copy-from=0 name=default-passthrough passthrough-interface=vlan-lte passthrough-mac=auto
:delay 30

/interface lte
set [ find ] apn-profiles=default-passthrough name=lte1 pin=$pin

Espero que os guste!
Hola Pokoyo,

Adquirí hace unos días un LHG LTE + HAP AC Lite, mirando por internet la mejor manera de configurarla y subsanar los problemas que me iban surgiendo llegue a ADSLZone, exactamente a este hilo "https://www.adslzone.net/foro/mikrotik.199/internet-4g-lte-mikrotik-rb-sxt-lte-kit.564640/" del compañero Danisevic

Asi que me leí ese hilo, ademas de este en el que te escribo y no fui capaz de hacerlo funcionar, al final lo intente con el archivo ZIP (LHG LTE + HAP AC Lite) que le pasaste al compañero Vorlander, exactamente este "https://www.adslzone.net/foro/threa...n-mikrotik-rb-sxt-lte-kit.564640/post-3570612" y funciono perfectamente, luego me di cuenta que me faltaba una cosilla por configurar de este manual y por ese motivo no funcionaba...

Una vez importado el ZIP y modificado el APN, PIN, etc... que obviamente no coincidían con los del compañero Vorlander, esta funcionando, con acceso a el LHG, etc...

A raíz de esto, leí tu ultimo comentario, el de poder tener la LHG con conexión a internet para actualizarla, pero no soy capaz a hacerlo funcionar, seguro que se me escapa algo, mas siendo nuevo en el mundo MikroTik

A ver si es posible que lo implementes en el archivo ZIP de configuración LHG o me eches un cable...
Gracias!
 
Export de ambos equipos, please. Aprended a realizar configuraciones y no esperéis que os pase un zip cada vez que tengáis un problema. Son ejemplos, no cosas para que andéis copiando y pegando, que luego pasan las cosas que describes.

El .rsc no es más que un set de instrucciones para configurar el equipo. Lo mismo puedes hacer tú mismo vía winbox o terminal.
Y, obviamente, cada configuración es un mundo, para un usuario concreto. No hay una configuración "estándar" que simplemente funcione, mucho menos tratándose de LTE.

Saludos!
 
Export de ambos equipos, please. Aprended a realizar configuraciones y no esperéis que os pase un zip cada vez que tengáis un problema. Son ejemplos, no cosas para que andéis copiando y pegando, que luego pasan las cosas que describes.

El .rsc no es más que un set de instrucciones para configurar el equipo. Lo mismo puedes hacer tú mismo vía winbox o terminal.
Y, obviamente, cada configuración es un mundo, para un usuario concreto. No hay una configuración "estándar" que simplemente funcione, mucho menos tratándose de LTE.

Saludos!
Asi es, completamente de acuerdo, empecé a configurarla según este manual, al no conseguirlo lo intente con el ZIP, luego me di cuenta de que por un pequeño detalle no funcionaba...

Aquí te dejo los EXPORT de ambos equipos...

LHG LTE

Código:
/interface vlan
add interface=ether1 name=internet vlan-id=100

/interface list
add name=WAN
add name=LAN

/interface lte apn
set [ find default=yes ] apn=movistar.es authentication=pap ip-type=ipv4-ipv6\
    name=Movistar password=movistar user=movistar
add apn=Movistar authentication=pap ip-type=ipv4-ipv6 name=orange \
    passthrough-interface=internet passthrough-mac=auto password=orange user=\
    orange
    
/interface lte
set [ find ] allow-roaming=no apn-profiles=orange band=1,3,7,20,8 name=lte1 \
    network-mode=lte pin=7425
    
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik

/ip hotspot profile
set [ find default=yes ] html-directory=hotspot

/interface list member
add interface=lte1 list=WAN
add list=LAN

/ip address
add address=192.168.78.1/24 interface=ether1 network=192.168.78.0
add address=10.108.34.187 interface=lte1 network=10.108.34.187

/system clock
set time-zone-name=Europe/Madrid

HAP AC Lite

Código:
/interface ethernet
set [ find default-name=ether5 ] poe-out=forced-on

/interface wireless
set [ find default-name=wlan1 ] band=2ghz-g/n country=spain disabled=no \
    distance=indoors installation=indoor mode=ap-bridge ssid="main 2.4g" \
    wireless-protocol=802.11
set [ find default-name=wlan2 ] band=5ghz-n/ac channel-width=20/40/80mhz-XXXX \
    country=spain disabled=no distance=indoors frequency=auto installation=\
    indoor mode=ap-bridge ssid="main 5g" wireless-protocol=802.11

/interface vlan
add interface=ether5 name=internet vlan-id=100

/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN

/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk mode=\
    dynamic-keys supplicant-identity=MikroTik wpa-pre-shared-key=12345678 \
    wpa2-pre-shared-key=12345678
add authentication-types=wpa-psk,wpa2-psk mode=dynamic-keys name=profile-guests \
    supplicant-identity=MikroTik wpa-pre-shared-key=12345678 \
    wpa2-pre-shared-key=12345678

/ip hotspot profile
set [ find default=yes ] html-directory=hotspot

/ip pool
add name=dhcp ranges=192.168.79.10-192.168.79.254

/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge name=defconf

/user group
set full policy="local,telnet,ssh,ftp,reboot,read,write,policy,test,winbox,passw\
    ord,web,sniff,sensitive,api,romon,dude,tikapp"

/interface bridge filter
add action=drop chain=forward in-interface=wlan3
add action=drop chain=forward out-interface=wlan3
add action=drop chain=forward in-interface=wlan4
add action=drop chain=forward out-interface=wlan4

/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=wlan1
add bridge=bridge comment=defconf interface=wlan2
add bridge=bridge comment=guestwf interface=wlan3
add bridge=bridge comment=guestwf interface=wlan4

/ip neighbor discovery-settings
set discover-interface-list=LAN

/interface list member
add comment=lan interface=bridge list=LAN
add comment=wan2 interface=ether1 list=WAN
add comment=wan1 interface=internet list=WAN

/interface wireless access-list
add ap-tx-limit=5000000 interface=wlan4
add ap-tx-limit=5000000 interface=wlan3

/ip address
add address=192.168.79.1/24 comment=defconf interface=ether2 network=\
    192.168.79.0
add address=192.168.78.2/24 comment=lhg-mgmnt interface=bridge network=\
    192.168.78.0

/ip dhcp-client
add comment=wan2-radio default-route-distance=2 disabled=no interface=ether1
add comment=wan1-lhg-lte disabled=no interface=internet

/ip dhcp-server network
add address=192.168.79.0/24 comment=defconf gateway=192.168.79.1

/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4

/ip dns static
add address=192.168.79.1 comment=defconf name=hap.lan
add address=192.168.78.1 comment=lhg name=lhg.lan

/ip firewall filter
add action=accept chain=input comment=\
    "defconf: accept established,related,untracked" connection-state=\
    established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
    invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
    "defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
    in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
    ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
    ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related
add action=accept chain=forward comment=\
    "defconf: accept established,related, untracked" connection-state=\
    established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" connection-state=\
    invalid
add action=drop chain=forward comment="defconf: drop all from WAN not DSTNATed" \
    connection-nat-state=!dstnat connection-state=new in-interface-list=WAN

/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=\
    out,none out-interface-list=WAN

/system clock
set time-zone-name=Europe/Madrid

/tool mac-server
set allowed-interface-list=LAN

/tool mac-server mac-winbox
set allowed-interface-list=LAN
 
OK, ¿qué ruta has tratado de crear para darle salida a internet a la LHG? No la veo en la config.

Saludos!
 
El direccionamiento (IP -> Address) de los equipos está mal hecho. Si tienes la 192.168.78.1/24 en la LHG (puedes hacer esa subred una /30 en lugar de /24 y así lo verás mejor; sólo hay dos IPs), en el router tienes que tener la 192.168.78.2/24 en la interfaz que lo une a la LHG, que sospecho será ether5 (se lo tienes dado al bridge). Además, no sé qué pinta la ruta add address=10.108.34.187 interface=lte1 network=10.108.34.187 que tienes en la LHG.

En ese caso, basta con que crees una ruta de tipo default router (destino = 0.0.0.0/0) y con gateway la 192.168.78.2 para que la LHG coja internet.

Saludos!
 
OK, ¿qué ruta has tratado de crear para darle salida a internet a la LHG? No la veo en la config.

Saludos!

Aquí te dejo como lo tengo ahora mismo, aunque sigue sin funcionar...

Código:
/interface vlan
add interface=ether1 name=internet vlan-id=100
add interface=ether1 name=vlan-lte vlan-id=25

/interface list
add name=WAN
add name=LAN

/interface lte apn
add apn=orangeworld authentication=pap ip-type=ipv4-ipv6 name=orange \
    passthrough-interface=internet passthrough-mac=auto password=orange user=\
    orange
add apn=internet name=default-passthrough passthrough-interface=vlan-lte \
    passthrough-mac=auto
    
/interface lte
set [ find ] allow-roaming=no apn-profiles=orange band=1,3,7,20,8 name=lte1 \
    network-mode=lte pin=7425
    
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik

/ip hotspot profile
set [ find default=yes ] html-directory=hotspot

/interface list member
add interface=lte1 list=WAN
add list=LAN

/ip address
add address=192.168.78.1/30 interface=ether1 network=192.168.78.0

/ip dns
set servers=8.8.8.8,8.8.4.4

/ip firewall filter
add action=accept chain=input comment=\
    "aceptamos el trafico ya estableciodo o relacionado" connection-state=\
    established,related,untracked
add action=drop chain=input comment="rechazamos el trafico invalido" \
    connection-state=invalid
add action=accept chain=input comment="aceptamos el ping" protocol=icmp
add action=drop chain=input comment=\
    "rechazamos todo lo que no venga de red local" src-address=!192.168.0.0/16
    
/ip route
add distance=1 gateway=192.168.78.2

/system clock
set time-zone-name=Europe/Madrid
 
Te sobra la vlan25. Y, los problemas de direccionamiento, si no los has corregido, sospecho que los sigues teniendo en el hAP-ac-lite.

Saludos!
 
Arriba