MANUAL: Mikrotik, Internet en casa con datos móviles

Introducción

Una buena conexión hoy en día es indispensable, para mi caso en particular, es prioritario ya que trabajo desde casa y es que el teletrabajo cada vez es más frecuente en las empresas.

Vivo en una zona que, aunque no es "muy rural", aún no dispongo de fibra y la conexión con ADSL es malísima teniendo una velocidad media de 4/0.5mb y con micro desconexiones.

Cansado de mi situación, me puse a buscar una compañía que ofreciera datos móviles “ilimitados”, ya sabemos que esta palabra no es real, ya que no sabemos qué tan “ilimitados” son. Después de analizar todas las compañías, me decanté por Movistar y su contrato infinito ya que hasta la fecha no existe o no he encontrado a alguien diciendo el límite máximo de este.

Así que contraté el servicio y me puse manos a la obra. :geek:

Equipos

- Mikrotik SXTLTE6 : La particularidad de esta antena es que permite CA (Carrier Aggregation) con lo que mejoramos la velocidad y la estabilidad de la conexión
- hAP ac lite TC : El motivo de usar este AP es que no me van a llegar más de 100mb de Internet 4G/LTE por mi zona, por lo que no requiero de un router 10/100/1000.

Diagrama

La distancia entre la torre y mi casa es de 1km con visión directa desde el tejado.

1605902828167.png


Para determinar la calidad de la señal hay que tener en cuenta lo siguiente (info de Internet)

Intensidad de señal
El valor de intensidad de la señal indica el nivel de la señal LTE recibida por el módem. Estos valores corresponden a las lecturas RSSI (Indicación de intensidad de señal recibida) de la conexión LTE. El valor se mide en dBm (dBm).

RSRP
RSRP (potencia de señal recibida de referencia): la potencia promedio de las señales piloto recibidas (señal de referencia) o el nivel de la señal recibida desde la estación base. El valor RSRP se mide en dBm (dBm).

RSRQ
RSRQ (Calidad de señal recibida de referencia): caracteriza la calidad de las señales piloto recibidas. El valor RSRQ se mide en dB (dB).

SINR
SINR (interferencia de señal + relación de ruido) también llamado CINR (portador a interferencia + relación de ruido) es la relación del nivel de señal al nivel de ruido (o simplemente la relación de señal a ruido). El valor SINR se mide en dB (dB). Es simple: cuanto mayor sea el valor, mejor será la calidad de la señal. Con valores SINR inferiores a 0, la velocidad de conexión será muy baja, ya que esto significa que hay más ruido en la señal recibida que la parte útil, y también existe la probabilidad de perder una conexión LTE.

CQI
CQI (Indicador de calidad del canal)
Para cada estación de abonado UE (Equipo de usuario) y cada bloque de frecuencia de la portadora, se forman indicadores de calidad de canal CQI (Indicador de calidad de canal). Dependiendo de la velocidad de transferencia de datos requerida por el UE, la estación base toma una decisión sobre el número de bloques de recursos asignados a un usuario en particular, y qué bloques de frecuencia asignar a los usuarios depende del indicador CQI. A los usuarios se les asignan aquellos bloques de recursos que tienen el CQI más alto y, por lo tanto, la mejor relación señal / ruido. Este parámetro puede tomar valores de 0 a 15. Cuanto mayor sea el valor, mejor (mayor será la velocidad que puede asignar una estación base LTE).

1605893595974.png


Para verificar la ubicación de las torres en base a la localización de mi casa, usé estas 2 aplicaciones:

https://www.cellmapper.net/ -> Verificar la ubicación de las torres por compañía y ver los parámetros teóricos de la calidad de la señal

https://www.opensignal.com/ -> La usé para verificar la ubicación de la antena desde el tejado, tiene como una especie de brújula donde te indica la torre a la que quieres apuntar.


Configuración SXTLTE6

La antena la configuraremos en modo BRIDGE, es decir entregaremos la IP pública al router hAP ac lite que será el que administre la red privada.

Quick Set: LTE (sólo existe está plantilla para este modelo de mikrotik).

1605903296160.png


Añadir APN (Movistar)
APN: movistar.es​
Authentication: PAP​
User: movistar​
Password: movistar​

Código:
/interface lte apn
set [ find default=yes ] apn=movistar.es authentication=pap name=Movistar \
    passthrough-interface=ether1 passthrough-mac=auto password=movistar \
    user=movistar

NOTA: En esta parte tuve el siguiente problema, por defecto al aplicar la plantilla el passthrough-interface venía cómo "none", esto provocaba que no me entregara la IP Pública al router hAP ac lite y por tanto no tenía Internet, así que para solucionarlo lo cambié de "none" a ether1.

Código:
/interface lte apn add apn=apn1 passthrough-interface=ether1
/interface lte set lte1 apn-profiles=apn1

Referencia: Manual:Interface/LTE

Seleccionar bandas. (info de Internet)

1605899736099.png


En base a esta documentación de las bandas LTE que se usan actualmente en España, vamos a forzar las bandas que nos den una mejor velocidad y estabilidad en la conexión de Internet.

Recordemos que la SXTLTE6 tiene CA (Carrier Aggregation), vale y qué es esto?

(info de Internet)
Carrier Aggregation o agregación de portadoras es una técnica para aumentar sustancialmente la capacidad de nuestra conexión incorporada tanto en LTE Advanced como en UMTS con la denominación DC-HSPA (Dual Channel HSPA). Los operadores intentan transmitir en el mayor número de bandas posibles incluso con la misma tecnología. Las bandas de alta frecuencia tienen una alta capacidad pero una mala cobertura. Las bandas de baja frecuencia tienen una mejor cobertura aunque una capacidad menor. Qué mejor que transmitir en varias bandas con distintas frecuencias y, efectivamente, eso es lo que hacen. Con la función «Carrier Aggregation» nuestro dispositivo puede conectarse simultáneamente en dos o más bandas, incluso de distintas antenas, sumando la capacidad de cada una de las conexiones.

Carrier Aggregation Band -> Aquí podéis ver la compatibilidad entre bandas para hacer CA y la comparativa del CA teórico que da un mejor rendimiento.

Aquí hay que ir jugando con las bandas, ya que depende de cada zona, imaginemos que la banda que nos va bien es la B3+B7, la configuración sería:

/interface lte set [ find ] band=3,7 name=lte1 network-mode=lte

Configuración hAP ac lite

Quick Set: Home AP Dual

Local Network y DHCP Server ya pones a tu gusto la IP que desees.

1605903849128.png


Con esta configuración, ENHORABUENA ya deberías de tener INTERNET ;)

Para dejar "fina" la configuración hice las siguientes "customizaciones"

- Usar PoE out del hAP ac para alimentar SXTLTE6. El puerto ether5 dispone de PoE out, así que para alimentar la SXTLTE6 me viene de "perillas" :giggle:.

Para ello realizamos esta configuración:​
1. Cambiar la WAN de la ether1 a la ether5​
2. Sacar del bridge la ether5​
3. Meter en el bridge la ether1​
4. Cambiar de ether1 a ether5 en el DHCP Client​

- Añadir DNS Google
/ip dns set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
- VLAN para poder administrar la SXTLTE6 (credits by @pokoyo )
Por lo visto, cuando configuras el passthrough a ether1, la SXT secuestra la dirección MAC de esa interfaz, canalizando todo vía la interfaz LTE. Es decir, te quedas sin administración.​
La solución pasa por comportarse como se comporta una operadora: entregarte el tráfico sobre una VLAN, por tanto sería montar una vlan para el tráfico de internet y el tráfico untagged para la administración.​

En la SXTLTE6:
  • Creamos una VLAN y se la asociamos a ether1. Por ejemplo, vlan 100 /interface vlan add interface=ether1 name=internet vlan-id=100
  • Cambiamos el passthrough de la interfaz lte, para que se haga ahora no sobre ether1, sino sobre la VLAN internet recién creada.
  • Creamos en IP -> Address, por ejempo 192.168.77.1/24 sobre ether1 /ip address add address=192.168.77.1/24 interface=ether1 network=192.168.77.0
En el hAP ac:
  • Damos de alta la vlan 100, en este caso sobre ether5 que es la interfaz que está conectada a la SXTLTE6 /interface vlan add interface=ether5 name=internet vlan-id=100 y fuera del bridge principal.
  • Cambiamos el cliente DHCP para que obtenga dirección sobre la interfaz "internet" en lugar de sobre "ether5". En este momento deberías obtener IP pública, tal y como lo hacías antes.
  • Metemos la nueva VLAN interfaz "internet" en la lista WAN /interface list member add interface=internet list=WAN. En esa lista debe tener ahora dos interfaces, ether5 e internet
  • Creamos en IP -> Address una IP del segmento de la que configuramos en la SXT, por ejemplo, 192.168.77.2/24, sobre la interfaz que nos conecta a la SXTLTE6, en este caso, ether5 /ip address add address=192.168.77.2/24 interface=ether5 network=192.168.77.0
Con esto ya podemos administrar la SXTLTE6 desde cualquier dispositivo.

Speed Test

Nada mal, no es fibra, no es una gran velocidad de lo que mucha gente está ya acostumbrada, pero creo que es una buena alternativa para aquellos que no disponen de fibra o disponen de una conexión de ADSL pésima.

1605902063593.png


Agradecer a @furny @stargate4you y sobre todo @pokoyo que me han ayudado para hacer posible esta configuración
Está configuración se llevo a través del siguiente hilo

Espero que os sirva de ayuda este manual.

Mikrotik FOREVER ¡¡¡¡ :D

Un saludo.
 
Última edición por un moderador:
Esto se merece un chinchetazo. Anclado queda, mil gracias por el aporte.

Saludos!
 
Enhorabuena @danisevic .
Y gracias por el manual, excelente trabajo. Cómo me alegro de ver que los proyectos salen adelante. Seguro que le servirá a mucha gente.
Powered by Mikrotik. ;)
Saludos.
 
Última edición:
Muy buen trabajo, @danisevic. Me ha encantado que te hayas esmerado especialmente en la parte de radio. Esto tiene aroma de un teleco, ¿no es así, colega? Si tengo necesidad de comprarme un LTE para este verano, ya me has resuelto el trabajo. Gracias!
 
  • Metemos la nueva interfaz "internet" ethernet en la lista WAN /interface list member add interface=ether5 list=WAN. En esa lista debe tener ahora dos interfaces, ether5 e internet

  • Creamos en IP -> Address, por ejempo 192.168.77.2/24 sobre ether1 /ip address add address=192.168.77.2/24 interface=ether5 network=192.168.77.0
Buenas!

Acabo de releerlo entero, con un café en la mano, y me gusta todavía más que cuando lo leí anoche en diagonal (sorry, se me alargó el día de curro, y me dieron las 11 currando). Al hacerlo, he visto un par de erratas en mis propios comentarios, te las comento, por si las quieres corregir.

Metemos la nueva interfaz "internet" ethernet en la lista WAN
Metemos la nueva interfaz vlan “internet” en la lista WAN

Creamos en IP -> Address, por ejempo 192.168.77.2/24 sobre ether1...
Creamos en IP -> Address una IP del segmento de la que configuramos en la SXT, por ejemplo, 192.168.77.2/24, sobre la interfaz que nos conecta a la SXT, en este caso, ether5...

Enhorabuena por el manual, está de narices. Verás qué contento se nos pone @huzoaaz cuando lo vea, que quería montar algo así para una zona rural.

Saludos!
 
NOTA: En esta parte tuve el siguiente problema, por defecto al aplicar la plantilla el passthrough-interface venía cómo "none", esto provocaba que no me entregara la IP Pública al router hAP ac lite y por tanto no tenía Internet, así que para solucionarlo lo cambié de "none" a ether1.

Para completar esta nota podrías añadir el código que pusiste en el otro hilo, si te parece bien y es apropiado.
Código:
[admin@MikroTik] > /interface lte apn add apn=apn1 passthrough-interface=ether1
[admin@MikroTik] > /interface lte set lte1 apn-profiles=apn1

Lo que está creciendo el foro de Mikrotik desde que tiene sección propia.
Saludos.
 
Última edición:
Buenos días,

No sabéis que 2 años más malos he pasado con un internet "infumable" para poder trabajar.

Espero que sirva de ayuda para la gente que se encuentre en mi misma situación. :)

@furny , tanto como la rama 100% teleco no, jejeje..... pero si soy del gremio tecnológico ;).

@pokoyo @stargate4you , manual actualizado con vuestros comentarios ;)(y)

Cualquier otro detalle me comentáis.

Gracias ¡¡

Un saludo
 
Última edición:
Buenos días,

Dando seguimiento a la velocidad/estabilidad de la conexión, precisamente justo después de la caída ayer de las web/app de Movistar, hoy tengo una velocidad e inestabilidad en la conexión (llevo 120 GB consumidos).

Lo mismo es casualidad o están trabajando en la torre o simplemente tengo que cambiar las bandas que estaba usando actualmente, ya os iré contando.

1606122077937.png


Un saludo
 
Te tocará jugar con las bandas y mirar a ver qué ha pasado. Quizá anden toqueteando, con el tema del despliegue del 5G.

Saludos!
 
Buenas tardes,

Pues sabía que iban a tocar algo del 5G por mi zona, pero no cuando jejeje, y parece que se han jodido la banda B3, ahora no me deja hacer CA B3+B7 y por tanto se conectaba sólo a B3 y esta era la que me me iba fatal.

He cambiado ahora a B7 solamente y por el momento todo bien

1606150974758.png


He estado haciendo más pruebas con otras bandas y ahora no me deja hacer CA con las bandas compatibles.

Espero que sea algo puntual, ya que la gracia de esta antena es tener CA para una mejor estabilidad y conexión.

NOTA: He actualizado el manual con otro link de interés para ver las bandas compatibles con CA y su rendimiento.

Un saludo.
 
Última edición:
Dejo un video referente al tema de conexión a través de datos.
Es de la casa Landatel, configuran un equipo wAP, equipo diferente a los que se mencionan en el manual pero igualmente interesante.


Saludos.
 
Buenas, ando trasteando con un nuevo router Mikrotik con funcionalidad LTE integrada (Chateau LTE12) y revisando configuración he visto algo muy interesante que podemos incluir para añadir a la configuración básica:


Hay ciertos operadores que están limitando tanto Tethering como poner las SIMs en Routers con capacidad 4G. En algunos casos, están detectando estas conexiones y limitándolas mediante la información del TTL. En la wiki de mikrotik se propone añadir una regla mangle que modifique los TTL de todos los paquetes que salen por la interfaz LTE1, de manera que evitas este control:

Código:
/ip firewall mangle
add action=change-ttl chain=postrouting new-ttl=set:65 out-interface=lte1 passthrough=yes

La verdad es que en los casos de uso que tengo yo (movistar) no se ha detectado que capen esto, pero no sé en otros operadores si lo están controlando así.
 
Buenas, ando trasteando con un nuevo router Mikrotik con funcionalidad LTE integrada (Chateau LTE12) y revisando configuración he visto algo muy interesante que podemos incluir para añadir a la configuración básica:


Hay ciertos operadores que están limitando tanto Tethering como poner las SIMs en Routers con capacidad 4G. En algunos casos, están detectando estas conexiones y limitándolas mediante la información del TTL. En la wiki de mikrotik se propone añadir una regla mangle que modifique los TTL de todos los paquetes que salen por la interfaz LTE1, de manera que evitas este control:

Código:
/ip firewall mangle
add action=change-ttl chain=postrouting new-ttl=set:65 out-interface=lte1 passthrough=yes

La verdad es que en los casos de uso que tengo yo (movistar) no se ha detectado que capen esto, pero no sé en otros operadores si lo están controlando así.
Muy bueno! Lo suyo sería ver con qué TTL salen de normal esos paquetes, y devolverle ese valor vía mangle. El mikrotik le quitará un salto al TTL, puesto que es un chisme más por donde tiene que pasar el paquete.

Gracias por el aporte, se agradece!

Saludos!
 
Wow super post, mega antena, no la conocia. Esto es para ponerlo YA jajajaja, gracias por este post, y lo del TTL lo he hecho en Rusia, tengo linea de MTS que es realmente ILIMITADA..... pero en tethering es de 3 GB. Si comparto el internet con el celular, pongo en mini ap como cliente, debo quitarle TTL y asi pasa como trafico puro que ha salido del "telefono"
 
Muy bueno! Lo suyo sería ver con qué TTL salen de normal esos paquetes, y devolverle ese valor vía mangle. El mikrotik le quitará un salto al TTL, puesto que es un chisme más por donde tiene que pasar el paquete.

Gracias por el aporte, se agradece!

Saludos!
Hola Pokoyo, perdona que te moleste de nuevo. ¿Es aquí donde debo instruirme?

P.D. Dado que he leído este hilo varias veces y esta materia es ajena a mis quehaceres cotidianos y para personal correctamente formado en ingeniería de telecomunicaciones ... en caso de que no pueda instalarlo por mis propios medios, algo más que evidente (soy de letras), ¿conocen o saben de alguna empresa que lo instale?

No es que me desentienda, soy bastante echado para alante, pero conozco mis limitaciones.

Gracias
 
Hola Pokoyo, perdona que te moleste de nuevo. ¿Es aquí donde debo instruirme?

P.D. Dado que he leído este hilo varias veces y esta materia es ajena a mis quehaceres cotidianos y para personal correctamente formado en ingeniería de telecomunicaciones ... en caso de que no pueda instalarlo por mis propios medios, algo más que evidente (soy de letras), ¿conocen o saben de alguna empresa que lo instale?

No es que me desentienda, soy bastante echado para alante, pero conozco mis limitaciones.

Gracias
Correcto, es este el manual. Y no te preocupes, que de los detalles técnicos de configuración me encargo yo. Si tú te atreves a localizar un punto donde anclar la antena y orientarla a la torre, el resto el mera configuración. Que el manual no te asuste, que es más fácil de lo que parece.

Si con la instalación tampoco te atreves, busca un técnico antenista o similar que te sepa poner la antena en un mástil y orientarla. Del resto, con un poco de paciencia, nos encargamos nosotros.

Saludos!
 
Correcto, es este el manual. Y no te preocupes, que de los detalles técnicos de configuración me encargo yo. Si tú te atreves a localizar un punto donde anclar la antena y orientarla a la torre, el resto el mera configuración. Que el manual no te asuste, que es más fácil de lo que parece.

Si con la instalación tampoco te atreves, busca un técnico antenista o similar que te sepa poner la antena en un mástil y orientarla. Del resto, con un poco de paciencia, nos encargamos nosotros.

Saludos!

Vale, perfecto. Entonces manos a la obra.

¿Y que router me recomiendas para un uso normal de Internet en una familia pequeña?

Gracias de nuevo
 
Un hAP-ac3, que tiene PoE out y puedes alimentar la antena sin necesidad de un inyector. Para la antena, busca el modelo LTE6 Kit, tanto de la SXT como de la LHG (elige la que creas que te viene mejor, la SXT es más pequeñita y te sobra si estás cerca de la antena, y la LHG tiene más ganancia, la oreja más grande, y es más parecida a una parabólica).

Saludos!
 
Buenas a todos,

Tiempo sin pasar por este hilo, jeje... sólo para comentaros que después de 8 meses, no he tenido ningún problema, sigo teniendo una conexión estable y con una velocidad decente. Estos Mikrotik están hechos para la guerra, no hay quien los tumbe :LOL:.

Me alegro que esté sirviendo de ayuda este post, eso si, esto no hubiera sido posible sin el maestro @pokoyo y la colaboración de @stargate4you, gracias a su paciencia y sabiduría pudimos sacar este "proyecto" adelante. Gracias¡¡¡

Un saludo :)

2021-08-05_18h07_09.png
 
Última edición:
Buenas a todos,

Tiempo sin pasar por este hilo, jeje... sólo para comentaros que después de 8 meses, no he tenido ningún problema, sigo teniendo una conexión estable y con una velocidad decente. Estos Mikrotik están hechos para la guerra, no hay quien los tumbe :LOL:.

Me alegro que esté sirviendo de ayuda este post, eso si, esto no hubiera sido posible sin el maestro @pokoyo y la colaboración de @stargate4you, gracias a su paciencia y sabiduría pudimos sacar este "proyecto" adelante. Gracias¡¡¡

Un saludo :)

Ver el adjunto 84864
Cómo jala esa SXT... la tienes afinada al máximo.

Gracias por la parte que me toca, me alegro un montón de que siga estable como una roca. Para la gente que tiene aún ADSL, desde luego es para pensárselo y mandar el cobre a freír espárragos.

Saludos!
 
Arriba