MANUAL: Mikrotik, integración con NordVPN (IKEv2 / Nordlynx)

Buen día compañeros, repito, tengo una fibra 250mb simétricos, uso mikrotik, con 2 tplink mesh, gracias a ustedes configuré wireguard y todo esta en perfectas condiciones, pero siempre tengo la necesidad de saber si puedo mejorar la red en algo, la pregunta es yo uso nordvpn y consigo velocidades desentes de 60 mb simetricos, les consulto si podre conseguir mejores velocidades con otro vpn digamos windscribe o alguna, de acuerdo a su experiencia?? y por supuesto que pueda conseguir la informacion de configuracion para wireguard.
Gracias, Buenas noches
Hola,
Yo tengo la misma configuración con mikrotik hEX y con 300Mb contratados llego a velocidades de 130Mb.
 
Hola.
Tengo configurado el nordvpn con el protocolo Nordlynx en el mikrotik hEX.
El problema es que Amazon Prime video no funciona bajo VPN, podéis pasar el comando que cree la excepción y el tráfico de Prime video no pase por la VPN.
Gracias
 
No sabría decirte cómo marcar los paquetes de ese servicio, así que lo más sencillo es que excepciones la TV o TV's donde veas prime y que esas consulten la tabla de rutas general "main", con una regla de routing.

Saludos!
 
Hoy he estado trasteando con los DNS y finalmente he movido todo lo relativo a éstos a un pihole sobre un contendor LXC de Proxmox. Va muy bien, la verdad.

Peeeeero, para mi horror he visto que al activar mi proveedor de VPN por IPSec (ProtonVPN), se saca de la manga un servidor DNS y me aparece en IP > DNS como un servidor dinámico. Creo que bajo ningún concepto quiero esto porque he visto que mi tráfico DNS se iba hacia a la VPN.

¿Observáis algo similar en NordVPN? ¿Hay alguna manera para evitarlo?


EDIT: este desvío de tráfico lo he visto con dnsleaktest
 
Hoy he estado trasteando con los DNS y finalmente he movido todo lo relativo a éstos a un pihole sobre un contendor LXC de Proxmox. Va muy bien, la verdad.

Peeeeero, para mi horror he visto que al activar mi proveedor de VPN por IPSec (ProtonVPN), se saca de la manga un servidor DNS y me aparece en IP > DNS como un servidor dinámico. Creo que bajo ningún concepto quiero esto porque he visto que mi tráfico DNS se iba hacia a la VPN.

¿Observáis algo similar en NordVPN? ¿Hay alguna manera para evitarlo?


EDIT: este desvío de tráfico lo he visto con dnsleaktest
Es IKEv2? si es así, modifica el mode-config para que no te de DNS y listo.

Saludos!
 
Muchas gracias.
Aunque no te lo creas, he estado buscando la opción por todas partes...
Funciona como es debido ahora.
Es una cabronada el mode-config, porque secuestra el dns del propio router, y aparece como de la nada. Me di cuenta con la primera conexión site to site que monté con ese protocolo, que le estaba mandando las peticiones dns al otro extremo, sin darme cuenta :p

Saludos!
 
Buenas noches, como sería la petición de curl para que liste los servidores P2P, por más que miro la otra página no consigo entender la sintaxis.

Gracias!
 
Buenas noches, como sería la petición de curl para que liste los servidores P2P, por más que miro la otra página no consigo entender la sintaxis.

Gracias!
Si quieres sacar los servidores P2P de un país concreto (por ejemplo españa), así:
Código:
curl --silent https://api.nordvpn.com/server | jq --raw-output '.[] | select(.country == "Spain" and .categories[].name == "P2P") | .domain'

Saludos!
 
Si quieres sacar los servidores P2P de un país concreto (por ejemplo españa), así:
Código:
curl --silent https://api.nordvpn.com/server | jq --raw-output '.[] | select(.country == "Spain" and .categories[].name == "P2P") | .domain'

Saludos!
Perfecto, muchas gracias!
 
Hola Mr. @pokoyo !

Yo estaba tratando de configurar un "BONUS TRACK: Integración con Nordlyxn (WireGuard)" como se describe, pero tengo una pregunta. Yo estoy utilizando un routing rule por ejemplo 3: la subred entera

add action=lookup-only src-address=192.168.88.0/24 interface=bridge table=nordvpn

Pero mi mikrotik maplite no tiene "bridge" y yo pongo "nordvpn" en cambio:

add action=lookup-only src-address=192.168.88.0/24 interface=nordvpn table=nordvpn

Esto no funciona. ¿Debería usar wlan1 o ether1 en su lugar?
¿O tengo que crear cualquier bridge para eso?
Muchas gracias!
 
Hola Mr. @pokoyo !

Yo estaba tratando de configurar un "BONUS TRACK: Integración con Nordlyxn (WireGuard)" como se describe, pero tengo una pregunta. Yo estoy utilizando un routing rule por ejemplo 3: la subred entera

add action=lookup-only src-address=192.168.88.0/24 interface=bridge table=nordvpn

Pero mi mikrotik maplite no tiene "bridge" y yo pongo "nordvpn" en cambio:

add action=lookup-only src-address=192.168.88.0/24 interface=nordvpn table=nordvpn

Esto no funciona. ¿Debería usar wlan1 o ether1 en su lugar?
Muchas gracias!
Deberías poner la interfaz que lleva ese segmento de red local.

Saludos!
 
Deberías poner la interfaz que lleva ese segmento de red local.

Saludos!

Entonces, ¿de esta manera nordlyxn funcionaría para todos los clientes conectados a wlan1 interface?

add action=lookup-only src-address=192.168.88.0/24 interface=wlan1 table=nordvpn
 
Entonces, ¿de esta manera nordlyxn funcionaría para todos los clientes conectados a wlan1 interface?

add action=lookup-only src-address=192.168.88.0/24 interface=wlan1 table=nordvpn
No me des miguitas, dame la config entera de ese equipo.

Saludos!
 
No me des miguitas, dame la config entera de ese equipo.

Saludos!

/interface wireguard
add name=nordvpn private-key="xxxxxxxxxxxx="

/ip address
add interface=nordvpn address=10.5.0.2/32

/interface wireguard peers
add allowed-address=0.0.0.0/0 endpoint-address=es163.nordvpn.com \
endpoint-port=51820 interface=nordvpn persistent-keepalive=25s \
public-key="IF1FGVSzrUznFVZ+dymIz+6bdlCgsuiT/d6cyapN8lw="

/interface list member
add interface=nordvpn list=WAN

/routing table
add fib name=nordvpn

/ip route
add dst-address=0.0.0.0/0 gateway=nordvpn table=nordvpn

/routing rule
add action=lookup-only-in-table src-address=192.168.88.0/24 interface=wlan1 table=nordvpn
 
/interface wireguard
add name=nordvpn private-key="xxxxxxxxxxxx="

/ip address
add interface=nordvpn address=10.5.0.2/32

/interface wireguard peers
add allowed-address=0.0.0.0/0 endpoint-address=es163.nordvpn.com \
endpoint-port=51820 interface=nordvpn persistent-keepalive=25s \
public-key="IF1FGVSzrUznFVZ+dymIz+6bdlCgsuiT/d6cyapN8lw="

/interface list member
add interface=nordvpn list=WAN

/routing table
add fib name=nordvpn

/ip route
add dst-address=0.0.0.0/0 gateway=nordvpn table=nordvpn

/routing rule
add action=lookup-only-in-table src-address=192.168.88.0/24 interface=wlan1 table=nordvpn
Las instrucciones del manual las conozco. Hablo del export del equipo al completo, para ver de dónde nace la subred que tratas de enrutar a la VPN

Saludos!
 
Las instrucciones del manual las conozco. Hablo del export del equipo al completo, para ver de dónde nace la subred que tratas de enrutar a la VPN

Saludos!
/interface wireless
set [ find default-name=wlan1 ] country=spain disabled=no mode=ap-bridge \
ssid=maplite wireless-protocol=802.11
/interface wireguard
add listen-port=63656 mtu=1420 name=nordvpn
/interface list
add name=WAN
add name=LAN
/interface lte apn
set [ find default=yes ] ip-type=ipv4 use-network-apn=no
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk mode=\
dynamic-keys supplicant-identity=MikroTik
/ip pool
add name=dhcp ranges=192.168.89.10-192.168.89.249
/ip dhcp-server
add address-pool=dhcp interface=wlan1 name=dhcp1
/routing table
add fib name=nordvpn
add fib name=nordvpn
/ip settings
set max-neighbor-entries=8192
/ipv6 settings
set disable-ipv6=yes max-neighbor-entries=8192
/interface list member
add interface=ether1 list=WAN
add list=LAN
add interface=nordvpn list=WAN
/interface ovpn-server server
set auth=sha1,md5
/interface wireguard peers
add allowed-address=0.0.0.0/0 endpoint-address=es163.nordvpn.com \
endpoint-port=51820 interface=nordvpn persistent-keepalive=25s \
public-key="IF1FGVSzrUznFVZ+dymIz+6bdlCgsuiT/d6cyapN8lw="
/ip address
add address=192.168.89.1/24 interface=wlan1 network=192.168.89.0
add address=10.5.0.2 interface=nordvpn network=10.5.0.2
/ip dhcp-client
add interface=ether1
/ip dhcp-server
add address-pool=*2 interface=ether1 name=dhcp2 relay=192.168.89.1
/ip dhcp-server network
add address=192.168.89.0/24 dns-server=8.8.8.8 gateway=192.168.89.1
/ip dns
set servers=8.8.8.8
/ip route
add disabled=yes distance=1 dst-address=0.0.0.0/0 gateway=nordvpn pref-src="" \
routing-table=nordvpn scope=30 suppress-hw-offload=no target-scope=10
add dst-address=0.0.0.0/0 gateway=nordvpn routing-table=nordvpn
/routing rule
add action=lookup-only-in-table interface=nordvpn src-address=192.168.89.0/24 \
table=nordvpn
add action=lookup-only-in-table interface=wlan1 src-address=192.168.89.0/24 \
table=nordvpn
/system clock
set time-zone-name=Europe/Madrid
 
Qué pasa si mueves la IP y el dhcp a una interfaz bridge y metes wlan1 como puerto?

Saludos!
 
Arriba