MANUAL: Mikrotik, configuraciones básicas ISPs

¿Has partido de un reset del equipo con la configuración del quick set? Porque esa configuración se basa en meterla encima de la base, si partes de otra cosa, puede salir cualquier churro.

Si crees que sí, que lo has hecho bien, pásanos un export de la configuración que la veamos.

Saludos!

Cuando dicen configuración del quickset, yo reseteo y dejo la red 192.168.88.0/24. Supongo que te refieres a eso, no?

No obstante, te subo la config una vez importada y que no me funciona.

Muchas gracias.

Saludos
 

Adjuntos

  • myconfig.txt
    8.1 KB · Visitas: 24
Cuando dicen configuración del quickset, yo reseteo y dejo la red 192.168.88.0/24. Supongo que te refieres a eso, no?

No obstante, te subo la config una vez importada y que no me funciona.

Muchas gracias.

Saludos
Hola, @derek_91 He estado estudiando tu configuración y lo que veo raro es la siguiente regla:

/ip dhcp-client
add comment=defconf disabled=no interface=ether1

Con esta regla estás pidiendo al HGU que te dé una dirección de su rango, y que se conecte como si el MK fuese un equipo de su LAN. Es decir, no funciona el pppoe, ni debería funcionar el resto, supongo. Debes eliminarla y dejarlo así:

/ip dhcp-client
add add-default-route=no disabled=no interface=Voip-vlan3 use-peer-ntp=no

Con esta regla se pide una dirección al DHCP, pero de la vlan3, que es la que maneja el VOIP.

Si lo que quisieras fuese poder acceder al HGU desde el MK, lo que deberías hacer en cambio es ponerle una dirección al ether1. No sé que rango usa el HGU, pero supongo que será el 192.168.1.0/24. Si es otro distinta, míralo en el HGU y lo pones de acuerdo. La regla sería:

/ip address
add address=192.168.1.2 interface=ether1 network=192.168.1.0

y accedes al HGU con la dirección suya por defecto, que supongo es 192.168.1.1

Otra cosa: supongo que tienes la HGU puesta en modo bridge, ¿no?. Si no, no te funciona nada. Tampoco te funcionaría el VOIP ni el IPTV si la pones en monopuesto.

Ya nos dices.

Suerte!!
 
Prueba lo que te comenta @furny y nos dices si te funciona. Es un error en la configuración publicada, creamos un nuevo cliente pppoe para la vlan6 y otro dhcp para la vlan3, pero no anulamos el de ether1 que crea la configuración por defecto. Me lo apunto para corregirlo.

Saludos!
 
Prueba lo que te comenta @furny y nos dices si te funciona. Es un error en la configuración publicada, creamos un nuevo cliente pppoe para la vlan6 y otro dhcp para la vlan3, pero no anulamos el de ether1 que crea la configuración por defecto. Me lo apunto para corregirlo.

Saludos!
Vaya! No caí en que el QuickSet creaba ese cliente por defecto, si no le pedíamos que creara un cliente pppoe. Lo siento. Como el quickset permite varias opciones, ¿no crees que deberíamos especificar de qué opciones hay que partir?. Al menos para la otra configuración para un único desco habría que tener en cuenta esto del cliente por defecto en ether1, si no quizás también para otras que usen cliente pppoe.
 
Vaya! No caí en que el QuickSet creaba ese cliente por defecto, si no le pedíamos que creara un cliente pppoe. Lo siento. Como el quickset permite varias opciones, ¿no crees que deberíamos especificar de qué opciones hay que partir?. Al menos para la otra configuración para un único desco habría que tener en cuenta esto del cliente por defecto en ether1, si no quizás también para otras que usen cliente pppoe.
La putada es que, después del script de arranque, tu ejecutas el quick set, que sobreescribe esa configuración original con lo que elijas en las opciones. Y estaba partiendo de que todo el mundo elegiría pppoe como su tipo de conexión para una conexión de telefónica. Pero sí, quizá sea mejor meter instrucciones para tratar de borrar ambos (la interfaz pppoe-out1, y el cliente dhcp sobre ether1) antes de meter nada más.

Saludos!
 
Hola, @derek_91 He estado estudiando tu configuración y lo que veo raro es la siguiente regla:

/ip dhcp-client
add comment=defconf disabled=no interface=ether1

Con esta regla estás pidiendo al HGU que te dé una dirección de su rango, y que se conecte como si el MK fuese un equipo de su LAN. Es decir, no funciona el pppoe, ni debería funcionar el resto, supongo. Debes eliminarla y dejarlo así:

/ip dhcp-client
add add-default-route=no disabled=no interface=Voip-vlan3 use-peer-ntp=no

Con esta regla se pide una dirección al DHCP, pero de la vlan3, que es la que maneja el VOIP.

Si lo que quisieras fuese poder acceder al HGU desde el MK, lo que deberías hacer en cambio es ponerle una dirección al ether1. No sé que rango usa el HGU, pero supongo que será el 192.168.1.0/24. Si es otro distinta, míralo en el HGU y lo pones de acuerdo. La regla sería:

/ip address
add address=192.168.1.2 interface=ether1 network=192.168.1.0

y accedes al HGU con la dirección suya por defecto, que supongo es 192.168.1.1

Otra cosa: supongo que tienes la HGU puesta en modo bridge, ¿no?. Si no, no te funciona nada. Tampoco te funcionaría el VOIP ni el IPTV si la pones en monopuesto.

Ya nos dices.

Suerte!!
He hecho el cambio que me comentaste, quitar la regla:

/ip dhcp-client
add comment=defconf disabled=no interface=ether1

y dejar la regla:

/ip dhcp-client
add add-default-route=no disabled=no interface=Voip-vlan3 use-peer-ntp=no

Pero sigue sin conectarse a pppoe. En el router movistar tengo la VLAN6 en modo puente.

Adjunto mi configuración eliminando la regla que me comentaste.

Saludos
 

Adjuntos

  • myConfig.txt
    8.1 KB · Visitas: 29
He hecho el cambio que me comentaste, quitar la regla:

/ip dhcp-client
add comment=defconf disabled=no interface=ether1

y dejar la regla:

/ip dhcp-client
add add-default-route=no disabled=no interface=Voip-vlan3 use-peer-ntp=no

Pero sigue sin conectarse a pppoe. En el router movistar tengo la VLAN6 en modo puente.

Adjunto mi configuración eliminando la regla que me comentaste.

Saludos

En modo puente no! Eliminada de la lista de la tabla de vlans del HGU!

Saludos!
 
En modo puente no! Eliminada de la lista de la tabla de vlans del HGU!

Saludos!

Entendí a @furny en el post #122 que tenía que ponerlo en modo puente. No obstante, he eliminado la VLAN6 del HGU y sigue sin conectar. El log de la conexión pppoe es el que muestro en la imagen.

Saludos!
 

Adjuntos

  • image.png
    image.png
    9.9 KB · Visitas: 14
Buenas noches a tod@s,

Por motivos laborales no he podido, hasta hoy, volver a retomar la configuración del MK con triple vlan Movistar y soporte multidecodificador.

De la última configuración que pude probar (previa a la que existe posteada a día de hoy) logré tener internet, VoIP (mediante ATA-SIP) y logré hacer funcionar uno de los decos (que tengo en la cocina) tanto video en directo como VOD, si bien no he logrado que funcione el deco del salón, solo operaba el video en directo, pero nada de VOD (habiendo realizado todas las probaturas habidas y por haber...intercambiando de "bocas" en el MK el cableado hacia salón y cocina...etc...

Así las cosas, he decidido partir de cero y realizar una nueva configuración desde Quick Set, partiendo del script posteado para Movistar Tiple VLAN con soporte multideco.

Os copio los errores que he recibido mientras introducía el script, por si podéis echarme una mano:

# Añadimos tres nuevas reglas al firewall para que funcionen las vlans,
# dos en el chain de input, para aceptar el tráfico de VoIP e IPTV
# y una en el chain de forward para prohibir el tráfico unicast que
# no esté ya nateado
/ip firewall filter
add action=accept chain=input comment="Accept vlan2 Iptv IGMP packets" \
in-interface=iptv-vlan2 protocol=igmp \
place-before=[find where chain=input and comment="defconf: drop invalid"]

no such item

add action=accept chain=input comment=\
"Accept vlan2 & 3 (Iptv & Voip) multicast & broadcast traffic" \
dst-address-type=!unicast in-interface-list=Vlan2&3 \
place-before=[find where chain=input and comment="defconf: drop invalid"]

no such item

# Configurar acceso a ONT Nokia
/ip address
add address=192.168.100.2/32 comment="Router's address from ONT. Nokia's ONT \
G010GP access through 192.168.100.1" interface=Gateway-e1 network=\
192.168.100.0

input does not match any value of interface

Desconozco si por error he omitido alguna configuración, he reseteado el router, instalado el paquete multicast y configurado Quick Set como Router con la IP 192.168.88.1 (MK), con DHCP activo, bridge y NAT.

Como siempre, agradecido por cualquier ayuda que me podáis prestar.

Saludos.-
 
Entendí a @furny en el post #122 que tenía que ponerlo en modo puente. No obstante, he eliminado la VLAN6 del HGU y sigue sin conectar. El log de la conexión pppoe es el que muestro en la imagen.

Saludos!
hummm... Vamos a ver. Yo no tengo HGU, pero por lo que tengo entendido, la cosa es así (corrígeme, @pokoyo, si me equivoco): con la HGU en monopuesto le pasas al siguiente equipo (el MK) la vlan6 (que en la tabla del HGU figura como "bridge" esa vlan) solamente. En modo bridge completo, las tres VLAN's pasan al MK. Creo que en últimos firmwares del HGU es más complicado, si no imposible, ponerlo en este modo. Hay quien carga un firmware antiguo para dejarlo en bridge total (o sea, como si fuera una ONT). La configuración que estas cargando es para que el MK se conecte a una ONT (o a una HGU en bridge total. Espero no haber dicho una barbaridad, pero creo que es así, ¿no?
Como he dicho una barbaridad (lo que es la ignorancia, al no tener una HGU), me corrijo a mi mismo (para no confundir a nadie más), gracias a la aclaración de @pokoyo.

O sea, que para estas configuraciones o conectas el MK directamente a la ONT, o pones la HGU como si fuese una ONT, borrando las tres VLAN's de la lista de interfaces de la HGU (NO poniendo las tres en bridge).

Perdonad la confusión.

Suerte!!
 
Última edición:
/ip firewall filter
add action=accept chain=input comment="Accept vlan2 Iptv IGMP packets" \
in-interface=iptv-vlan2 protocol=igmp \
place-before=[find where chain=input and comment="defconf: drop invalid"]

no such item

add action=accept chain=input comment=\
"Accept vlan2 & 3 (Iptv & Voip) multicast & broadcast traffic" \
dst-address-type=!unicast in-interface-list=Vlan2&3 \
place-before=[find where chain=input and comment="defconf: drop invalid"]

no such item
Buenas noches. Supongo que estás metiendo las reglas que aparecen aquí , en la primera página de este hilo, ¿no?.

Puede haber habido algún cambio en el nombre de la regla de "drop invalid", que por eso, creo, da el error. Lo único que habría que hacer sería meter esas dos reglas anteriores junto antes de la regla "drop invalid". O sea:

add action=accept chain=input comment="Accept vlan2 Iptv IGMP packets" \
in-interface=iptv-vlan2 protocol=igmp
add action=accept chain=input comment=\
"Accept vlan2 & 3 (Iptv & Voip) multicast & broadcast traffic" \
dst-address-type=!unicast in-interface-list=Vlan2&3

y justo después:

add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid
 
# Configurar acceso a ONT Nokia
/ip address
add address=192.168.100.2/32 comment="Router's address from ONT. Nokia's ONT \
G010GP access through 192.168.100.1" interface=Gateway-e1 network=\
192.168.100.0

input does not match any value of interface
Este error te da porque esta regla la has cogido tal cual de otro sitio, y la interfaz de entrada "ether1", en esta regla se llama "Gateway-e1", que es como la denomino yo en mis configuraciones. Si has partido de QuickSet, debe denominarse ether1, y la regla debería ser así:

/ip address
add address=192.168.100.2/32 comment="Router's address from ONT. Nokia's ONT \
G010GP access through 192.168.100.1" interface=ether1 network=\
192.168.100.0

Por cierto, que esta regla es para acceder a la ONT de Nokia desde el MK. Si esa no es tu ONT o no quieres acceder a la ONT, no te hace falta.
 
De la última configuración que pude probar (previa a la que existe posteada a día de hoy) logré tener internet, VoIP (mediante ATA-SIP) y logré hacer funcionar uno de los decos (que tengo en la cocina) tanto video en directo como VOD, si bien no he logrado que funcione el deco del salón, solo operaba el video en directo, pero nada de VOD (habiendo realizado todas las probaturas habidas y por haber...intercambiando de "bocas" en el MK el cableado hacia salón y cocina...etc...
No sé. Lo que te comenté de la configuración anterior (y la miré línea a línea), a menos que se me hubiera saltado algo, debería haberte funcionado. Si te funciona el VOD en un desco, es que el script funciona y crea regla NAT. Y si lo hace con uno, lo debería hacer con el otro desco. Es muy raro... Supongo que has intercambiado los dos descos ¿no? ¿Es siempre el mismo desco el que no te funciona, aunque lo pongas en la cocina? ¿son los dos descos iguales, de la misma marca? ¿te funcionan los dos con el router original de Movistar, supongo?. Fíjate si ambos descos obtienen su dirección del DHCP en "leases", en el rango del pool que hayas definido (en la config antigua, en el rango de 192.168.20.20x, en la del post de la primera página en 192.168.77.20x). Siento que te esté costando dar con la tecla, pero seguro que es una chorrada que se nos escapa...
Fíjate también, si en el "log" te dice que cambia la regla NAT el script, y la dirección de desco a la que lo cambia cuando pasas de usar uno a otro. Y si en en /ip firewall nat ha cambiado efectivamente la regla NAT de dirección de un desco al otro. Ya me dirás, a ver si damos con la tecla...
 
Buenas noches a tod@s,

Por motivos laborales no he podido, hasta hoy, volver a retomar la configuración del MK con triple vlan Movistar y soporte multidecodificador.

De la última configuración que pude probar (previa a la que existe posteada a día de hoy) logré tener internet, VoIP (mediante ATA-SIP) y logré hacer funcionar uno de los decos (que tengo en la cocina) tanto video en directo como VOD, si bien no he logrado que funcione el deco del salón, solo operaba el video en directo, pero nada de VOD (habiendo realizado todas las probaturas habidas y por haber...intercambiando de "bocas" en el MK el cableado hacia salón y cocina...etc...

Así las cosas, he decidido partir de cero y realizar una nueva configuración desde Quick Set, partiendo del script posteado para Movistar Tiple VLAN con soporte multideco.

Os copio los errores que he recibido mientras introducía el script, por si podéis echarme una mano:

# Añadimos tres nuevas reglas al firewall para que funcionen las vlans,
# dos en el chain de input, para aceptar el tráfico de VoIP e IPTV
# y una en el chain de forward para prohibir el tráfico unicast que
# no esté ya nateado
/ip firewall filter
add action=accept chain=input comment="Accept vlan2 Iptv IGMP packets" \
in-interface=iptv-vlan2 protocol=igmp \
place-before=[find where chain=input and comment="defconf: drop invalid"]

no such item

add action=accept chain=input comment=\
"Accept vlan2 & 3 (Iptv & Voip) multicast & broadcast traffic" \
dst-address-type=!unicast in-interface-list=Vlan2&3 \
place-before=[find where chain=input and comment="defconf: drop invalid"]

no such item

# Configurar acceso a ONT Nokia
/ip address
add address=192.168.100.2/32 comment="Router's address from ONT. Nokia's ONT \
G010GP access through 192.168.100.1" interface=Gateway-e1 network=\
192.168.100.0

input does not match any value of interface

Desconozco si por error he omitido alguna configuración, he reseteado el router, instalado el paquete multicast y configurado Quick Set como Router con la IP 192.168.88.1 (MK), con DHCP activo, bridge y NAT.

Como siempre, agradecido por cualquier ayuda que me podáis prestar.

Saludos.-
No partas del quick set solamente, que lo único que hace es aplicar una plantilla, pero no borra lo anterior. Si quieres que te funcione, parte de un reset completo + quick set.

Aparte de todo eso, los comandos van comentados precisamente para que no os dediquéis a copiar y pegar, sino que veáis lo que de está haciendo en cada paso. Si no tienes reglas previas en el firewall, el comando find no te va a funcionar. Si las interfaces no se llaman igual, obviamente hay que adaptar los nombres a las tuyas.
Por eso me basé en el estado de un router recién reseteado, para intentar hacer algo estándar para todo el mundo.

Saludos!
 
Buenas noches. Supongo que estás metiendo las reglas que aparecen aquí , en la primera página de este hilo, ¿no?.

Puede haber habido algún cambio en el nombre de la regla de "drop invalid", que por eso, creo, da el error. Lo único que habría que hacer sería meter esas dos reglas anteriores junto antes de la regla "drop invalid". O sea:

add action=accept chain=input comment="Accept vlan2 Iptv IGMP packets" \
in-interface=iptv-vlan2 protocol=igmp
add action=accept chain=input comment=\
"Accept vlan2 & 3 (Iptv & Voip) multicast & broadcast traffic" \
dst-address-type=!unicast in-interface-list=Vlan2&3

y justo después:

add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid

Buenos días @furny

OK, la configuración para el acceso a la ONT (que efectivamente es Nokia) la cogí de mi anterior configuración, de ahí el error por la diferencia en la nomenclatura de la interfaz. Ya la he modificado.

Sí, he seguido los pasos indicados en el primer post de @pocoyo para partir de una configuración con Triple VLAN y configuración multidecodificador, partiendo de Quick Set.

En cuanto a la regla "drop invalid", añado el par de reglas que indicas antes de la citada "drop invalid", pero no me queda claro si la última regla que comentas (add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid ) debo añadirla justo después de las dos reglas anteriores, o inmediatamente después de la regla que daba error y que indicaba en anterior post (drop chain).

El caso es que el deco del salón (con el HGU) funciona correctamente, sinceramente no sé que puede ocurrir. El otro deco de la cocina funcionaba bien con la anterior configuración (de la que saqué backup por si las moscas antes de realizar el reset para introducir la nueva configuración).

Entiendo que para habilitar el resto de bocas del MK para tener las 3 VLAN's accesibles desde las mismas (a excepción de la 5 que quedaría sólo para internet), debería seguir estos pasos que en anteriores post me facilitaste, la cual cito:

"Para ello, subes mi configuración y después con el Webfig o con Winbox entras en la pestaña de Bridge -> Ports. Pinchas en el botón "-" a la izquierda de los puertos 3 y 4, con eso los quitas del bridge-LAN. Después en esa misma pestaña, arriba a la izquierda, pulsas "add new", y
añades al bridge-IPTV en "interface" el ether3 y deseleccionas HW Offloading. Después "apply" y "ok". Después repites lo mismo para ether4. Y
ya está"

Como siempre, muy agradecido @furny y @pocoyo, sin vuestra ayuda me sería casi imposible poner en marcha el equipo.


Saludos.-
 
No partas del quick set solamente, que lo único que hace es aplicar una plantilla, pero no borra lo anterior. Si quieres que te funcione, parte de un reset completo + quick set.

Aparte de todo eso, los comandos van comentados precisamente para que no os dediquéis a copiar y pegar, sino que veáis lo que de está haciendo en cada paso. Si no tienes reglas previas en el firewall, el comando find no te va a funcionar. Si las interfaces no se llaman igual, obviamente hay que adaptar los nombres a las tuyas.
Por eso me basé en el estado de un router recién reseteado, para intentar hacer algo estándar para todo el mundo.

Saludos!

Buenos días @pocoyo

Efectivamente partí de un Reset completo del equipo y posterior Quick set. No me percaté del cambio de nombre del interface, en la anterior configuración tenía otro nombre y de ahí el error.

No, no dispongo de reglas firewall, al estar el router totalmente reseteado. Si son necesarias para esta nueva configuración, no se si podría exportar a este nuevo script las reglas de mi anterior configuración con la que al menos uno de los decos funcionaba correctamente, e igualmente internet y VOIP también operaban con normalidad.

Muchas gracias!
 
Buenos días @pocoyo

Efectivamente partí de un Reset completo del equipo y posterior Quick set. No me percaté del cambio de nombre del interface, en la anterior configuración tenía otro nombre y de ahí el error.

No, no dispongo de reglas firewall, al estar el router totalmente reseteado. Si son necesarias para esta nueva configuración, no se si podría exportar a este nuevo script las reglas de mi anterior configuración con la que al menos uno de los decos funcionaba correctamente, e igualmente internet y VOIP también operaban con normalidad.

Muchas gracias!
No partas de un reset sin configuración (no marques el “No default configuration”). Parte de un reset normal, que corre el script de carga inicial que deja el router con una configuración base estable, con un set de reglas de firewall decente.

Saludos!
 
No partas de un reset sin configuración (no marques el “No default configuration”). Parte de un reset normal, que corre el script de carga inicial que deja el router con una configuración base estable, con un set de reglas de firewall decente.

Saludos!

Ahí está la diferencia....yo hice un reset "a saco" sin aplicar configuración por defecto. Voy a resetearlo de nuevo, con configuración por defecto, aplico Quick set y os cuento.

Muchas gracias!!
 
hummm... Vamos a ver. Yo no tengo HGU, pero por lo que tengo entendido, la cosa es así (corrígeme, @pokoyo, si me equivoco): con la HGU en monopuesto le pasas al siguiente equipo (el MK) la vlan6 (que en la tabla del HGU figura como "bridge" esa vlan) solamente. En modo bridge completo, las tres VLAN's pasan al MK. Creo que en últimos firmwares del HGU es más complicado, si no imposible, ponerlo en este modo. Hay quien carga un firmware antiguo para dejarlo en bridge total (o sea, como si fuera una ONT). La configuración que estas cargando es para que el MK se conecte a una ONT (o a una HGU en bridge total. Espero no haber dicho una barbaridad, pero creo que es así, ¿no?

Suerte!!

En mi actual configuración tengo el mikrotik trabajando sin VLANes, pero por lo que entiendo esta nueva versión no puedo usarla con VLAN's, no? Tendría que usar una ONT aparte o hacer un downgrade del router de movistar.

Muchas gracias

Saludos!
 
Arriba