MANUAL: Mikrotik, configuraciones básicas ISPs

@vorlander esta sería la configuración que yo hice, y que funciona perfecto en O2 respetando al máximo la configuración del QuickSet:

Código:
# Dar de alta las vlans 3 voip y 6 internet.
/interface vlan
add interface=ether1 name=vlan3 vlan-id=3
add interface=ether1 name=vlan6 vlan-id=6

# Configurar la interfaz PPPoE para que use la VLAN 6 internet.
/interface pppoe-client
add add-default-route=yes disabled=no interface=vlan6 name=pppoe-out1 password=adslppp use-peer-dns=yes \
    user=adslppp@telefonicanetpa

# Añadimos a  la lista WAN el  interface PPPoE  para que el firewall/nat funcione correctamente.
/interface list member
add interface=pppoe-out1 list=WAN

# Crear un cliente dhcp para la vlan 3 del teléfono voip.
/ip dhcp-client
add add-default-route=no dhcp-options=hostname,clientid disabled=no interface=vlan3 use-peer-ntp=no

# Establecer la prioridad de las conexiones vlans.
/ip firewall mangle
add action=set-priority chain=postrouting new-priority=4 out-interface=vlan3
add action=set-priority chain=postrouting new-priority=1 out-interface-list=WAN passthrough=yes

# Enmascarar las conexiones PPPoE y vlan3 voip.
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=out,none \
    out-interface-list=WAN
add action=masquerade chain=srcnat comment="vlan3 voip configuration" out-interface=vlan3

# Puertos del servicio voip.
/ip firewall service-port
set sip disabled=yes ports=5060,5070

# Añadir la vlan 3 de voz protocolo RIP.
/routing rip interface
add interface=vlan3 passive=yes receive=v2

# Indicar la red en la que correrá RIP.
/routing rip network
add network=10.0.0.0/8

Ya me dices. Un saludo!!
Pero esto lo hago tras “formatear” el rb4011 ??

lo tengo que poner en modo router antes ??
he comprado un tlf voIP (yealink t42s) .... en que eth lo he de conectar o que ip le he de poner ??
 
Hola. Pues si no me equivoco el switch que viene con el 4011 es el RTL8367. Y si miráis en la tabla del manual sobre HW Offloading:


RouterBoard/[Switch Chip] ModelFeatures in Switch menuBridge STP/RSTPBridge MSTPBridge IGMP SnoopingBridge DHCP SnoopingBridge VLAN FilteringBonding
CRS3xx series+++++++
CRS1xx/CRS2xx series++-+ 2+ 1--
[QCA8337]++--+ 2--
[Atheros8327]++--+ 2--
[Atheros8227]++-----
[Atheros8316]++--+ 2--
[Atheros7240]++-----
[MT7621]+------
[RTL8367]+------
[ICPlus175D]+------
Para ese switch, me temo que el IGMP Snooping es incompatible con el HW Offloading. O sea, que en el bridge que lo actives (y es necesario activarlo si por esos puertos tienes tráfico multicast), No vas a tener HW Offloading. La solución es separar en dos bridges el tráfico: los de IPTV (con multicast, y si hay otros dispositivos o Wifi APs con IGMP Snooping) y los otros puertos "normales" con el HW Offloading activado. Según la tabla, lo mismo pasa con otras funciones, como vlan filtering, Spanning tree protocols, etc
Gracias por responder, entonces creo que tengo difícil solución para activar el hardware offloading ya que de un puerto del mikrotik va un cable de red a un switch donde tengo el nas, un pequeño servidor (donde a través del tvheadend puedo ver el canal autonómico por multicast) y un AP, además a través de la tabla que me has adjuntado también observo que no es compatible con el bonding que es lo siguiente que quería hacer con mi red.
Gracias por responderme
 
Gracias por responder, entonces creo que tengo difícil solución para activar el hardware offloading ya que de un puerto del mikrotik va un cable de red a un switch donde tengo el nas, un pequeño servidor (donde a través del tvheadend puedo ver el canal autonómico por multicast) y un AP, además a través de la tabla que me has adjuntado también observo que no es compatible con el bonding que es lo siguiente que quería hacer con mi red.
Gracias por responderme
Pues, si. Eso me temo. Y el bonding también restringe el HW Offloading, efectivamente. Piénsate cambiar la topología de la red y tirar algún cable mas. Los canales multicast en HD no requieren más de 8 Mbps cada uno, pero a algunos WiFi APs les sientan fatal y son la causa de cuelgues y errores en la red. Por ello es aconsejable separar el tráfico multicast del resto y que vaya en cable separado solo a los dispositivos que requieran ese tráfico.

suerte!!!
 
Con meter un segundo switch y un segundo cable valdría, ¿no? Lo digo porque eso es relativamente barato.

Saludos!
 
Con meter un segundo switch y un segundo cable valdría, ¿no? Lo digo porque eso es relativamente barato.

Saludos!
Desde el rb4011 va un cable ethernet (mi intención es tirar otro para hacer bonding) que va a un switch que tiene dos bonding (LACP para un nas y otro para un servidor donde tengo la mayoría de servicios instalados). Donde pondría el segundo swtich?
 
conectado a lo que sea que tengas con tráfico multicast, dejando el otro bridge con HW y sin tráfico multicast.

Saludos!
 
@furny

Estoy haciendo pruebas con un hAP lite y revisando algunas configuraciones de MovistarTV.
¿ Hace falta tener activado el upnp ? Es que no estoy seguro de si es necesario o no.

Código:
/ip upnp
set enabled=yes
/ip upnp interfaces
add interface=bridge type=internal
add interface=ether1 type=external

Y la configuración de los bridges es correcta ?

bridges_00.png
bridges_01.png

Te dejo un export hide-sensitive file=config_multiTV.

La estoy montando en un hAP lite pero al final irá en un hAP AC2 para un familiar.
Todavía no he podido probar la TV ya que yo tengo O2, pero la conexión a internet la hace perfectamente ya que los datos son los mismos, ahora mismo estoy conectado con el hAP lite con la configuración que te paso en una línea de O2.
Ya tengo los datos de la TV y metidos en la configuración ( borrados en el file ).

Gracias y felices fiestas.

Edito: He terminado de componer el rsc para el hAP AC2, a ver si se lo traga cuando lo tenga en mis manos. Subo el fichero también.
 

Adjuntos

  • config_multiTV.txt
    9.9 KB · Visitas: 16
  • hapac2_foro.txt
    9.8 KB · Visitas: 11
Última edición:
No, el UPnP no es necesario para nada. Es un protocolo de apertura de puertos automática, pero no es necesario (de hecho, por seguridad, poco recomendable de usar).

Saludos!
 
Uno de los más populares era o es el

Gigaset C530 IP​

Busca información a ver si te sirve. Es inalámbrico y puede funcionar con línea analógica y voip.
Saludos.
70€ y creo que ya esta descatalogado... :( Esto de quitar la basura de movistar por completo es tela de caro... jajajaja!

RB4011 + ToIP + ONT = Un riñon!
 
70€ y creo que ya esta descatalogado... :( Esto de quitar la basura de movistar por completo es tela de caro... jajajaja!

RB4011 + ToIP + ONT = Un riñon!
Si tenéis un iPhone, recomiendo usar un softphone, en concreto sessiontalk. Va estupendamente.
 
@furny

Estoy haciendo pruebas con un hAP lite y revisando algunas configuraciones de MovistarTV.
¿ Hace falta tener activado el upnp ? Es que no estoy seguro de si es necesario o no.

Código:
/ip upnp
set enabled=yes
/ip upnp interfaces
add interface=bridge type=internal
add interface=ether1 type=external

Y la configuración de los bridges es correcta ?

Ver el adjunto 76186
Ver el adjunto 76189

Te dejo un export hide-sensitive file=config_multiTV.

La estoy montando en un hAP lite pero al final irá en un hAP AC2 para un familiar.
Todavía no he podido probar la TV ya que yo tengo O2, pero la conexión a internet la hace perfectamente ya que los datos son los mismos, ahora mismo estoy conectado con el hAP lite con la configuración que te paso en una línea de O2.
Ya tengo los datos de la TV y metidos en la configuración ( borrados en el file ).

Gracias y felices fiestas.

Edito: He terminado de componer el rsc para el hAP AC2, a ver si se lo traga cuando lo tenga en mis manos. Subo el fichero también.
Hola. Efectivamente, como dice @pokoyo, para la configuración, el UpNp no hace falta para nada. Si yo lo he subido a alguna configuración, ha sido por error. Yo lo tengo deshabilitado y solo lo habilito cuando lo necesita mi hijo para algún juego de la PS4, en contadas ocasiones, y lo vuelvo a deshabilitar de inmediato. Es una forma cómoda, pero un tanto chusca de abrir puertos automáticamente, no me fío mucho de él.

Te he echado un vistazo a la configuración y a primera vista no he visto nada raro. Si no has detectado problemas, me cuesta más fijarme en errores así, genéricos, (jejeje, no soy tan avezado).
Pero si que te hago una recomendación: y es que en el firewall pongas en la cadena de input, justo después de aceptar las conexiones established, relate, untracked, las 2 reglas de vlan 2 y 3, antes de las reglas de vpn y del resto. Es que por esas reglas se procesan un montón de paquetes, y cuanto antes pasen el firewall, mejor. (ese debe ser el criterio, salvo excepciones por motivos de lógica u otras prioridades: que las reglas que procesen más paquetes vayan antes de las que procesen menos, para acelerar al máximo y descargar la CPU. En routers más básicos, como el hAP lite puede hacer una diferencia).

Suerte!!!
 
Tambien lo había pensado... usar un android viejo como telefono de casa... pero imagino que los telefonos voip irán mejor, no?
Sí, podría funcionar mejor. Pero el iPhone yo siempre lo llevo a cuestas (no es el caso de mi mujer, por ejemplo ;-) ), y el de casa, no.
 
Hola,

Tengo una duda para la configuración de
Movistar Triple VLAN (Grupo Telefónica, España) [by @furny]
Configuración multi desco, multi-bridge, partiendo de la configuración base del quick set.


En que boca del Router se conectan los pcs?

Entiendo que la boca número dos del router es para conectar los dos codificadores, ¿ o también el Swith con el resto de equipos de la red?

muchas gracias
 
Que llevas una VPN levantada con tu casa 24/7? o como va eso del telefono en remoto?
No, no. ¡Qué va, jajaja!. No la llevo 24/7. Solo si estoy fuera y estoy esperando una llamada o algo así, y no he hecho (o nos quiero hacer) el desvío de llamada. La VPN se mantiene si estás parado, pero si te mueves, y hay interrupciones en la conexión de datos, se cae. Normalmente no es práctico par recibir llamadas, te lo ponía como ejemplo extremo. Pero sí es útil para llamar desde donde quieras usando la línea fija.
 
Hola,

Tengo una duda para la configuración de
Movistar Triple VLAN (Grupo Telefónica, España) [by @furny]
Configuración multi desco, multi-bridge, partiendo de la configuración base del quick set.


En que boca del Router se conectan los pcs?

Entiendo que la boca número dos del router es para conectar los dos codificadores, ¿ o también el Swith con el resto de equipos de la red?

muchas gracias
Hola.

En esta configuración se soportan varios descos en el bridge-iptv. En la configuración subida en el manual, a este bridge-iptv se le asigna el puerto ether2. Si sólo asignas ese puerto al bridge-iptv, deberás conectar un switch al mismo y de ahí dos cables a cada desco. Los puertos ether3, 4 y 5 están asignados al bridge normal, que NO tiene IPTV, y ahí conectas PCs o lo que quieras, salvo descos.
Otra alternativa, si no quieres usar un switch para los descos, es asignar ether3, por ejemplo, al bridge-IPTV, y conectar un desco a ether2 y el segundo desco a ether3. Para ello, vas a Bridge->Ports, desasignas ether3 del bridge1 y lo asignas pulsando en "Add new" al bridge-IPTV. Así te quedarán solo dos bocas (4 y 5) para el bridge principal, pero puedes ampliar la conectividad de dispositivos poniendo switches a una o ambas bocas, si lo necesitas.

Suerte!!!
 
Hola.

En esta configuración se soportan varios descos en el bridge-iptv. En la configuración subida en el manual, a este bridge-iptv se le asigna el puerto ether2. Si sólo asignas ese puerto al bridge-iptv, deberás conectar un switch al mismo y de ahí dos cables a cada desco. Los puertos ether3, 4 y 5 están asignados al bridge normal, que NO tiene IPTV, y ahí conectas PCs o lo que quieras, salvo descos.
Otra alternativa, si no quieres usar un switch para los descos, es asignar ether3, por ejemplo, al bridge-IPTV, y conectar un desco a ether2 y el segundo desco a ether3. Para ello, vas a Bridge->Ports, desasignas ether3 del bridge1 y lo asignas pulsando en "Add new" al bridge-IPTV. Así te quedarán solo dos bocas (4 y 5) para el bridge principal, pero puedes ampliar la conectividad de dispositivos poniendo switches a una o ambas bocas, si lo necesitas.

Suerte!!!
Muchas gracias.

Olvidé preguntarte que en tu script no veo donde se pone la puerta de enlace de Movistar tv.

En el hgu tiene dirección ip, máscara de red y puerta de enlace, pero en tu script solo están los dos primeros parámetros.

muchas gracias
 
Arriba