MANUAL: Mikrotik, configuraciones básicas ISPs

@vdias Aquí te subo una configuración actualizada, basada en la mía actual. Espero que te corra bien. Si tienes problemas, me lo dices.

Suerte!!
 

Adjuntos

  • furny3vlanMdesco1Brige.txt
    8.3 KB · Visitas: 85
Tengo un familiar que tiene Movistar TV con los siguientes equipos:

ONT Huawei HG8240 - conexión teléfono fijo
Router Comtrend VG-8050
Desco Zyxel STB-2112T Nano v2

Se encuentran que tienen los móviles y portátiles con un wifi más moderno de lo que les suministra el router Comtrend (sólo banda 2.4 con b/g/n). Supongo que estos equipos serán de los primeros que montaba Movistar para fibra. Los chavales se quejan a menudo de lo mal que funciona el wifi y de ahí la principal razón para proponerles un cambio.

Mi intención es ponerle un Mikrotik hAP AC2 en sustitución del Comtrend. ¿ Qué os parece ?
Pronto les subirán también la velocidad de 600 Mb a 1 GB.

Cómo yo no tengo televisión porque estoy en O2 tengo unas pequeñas dudas.

. Los datos de la IPTV : ¿ los puedo obtener de un backup del Comtrend directamente buscándolos con un editor o en algún menú del router ? ( La web de Noltari no funciona )
. Si un día les cambian el desco por avería o sustitución : ¿ Se tendría que cambiar algo en la configuración del Mikrotik ?
. Buscando información sobre el tema veo que algunos tocaban la configuración de los descos para ponerlos en marcha, pero creo que esto no es necesario con la configuración de @furny para 1 desco. ¿ Es así ?. Sólo desconectarlos del todo y esperar 5-10 min a que cargue todos los datos por si sólo.
. Añadir el paquete Multicast.

Creo que agradecerán el cambio. Les cargaría yo la configuración, dejando todo en funcionamiento y esperando que todo funcione como una roca, para no estar desplazándome de "urgencias" porque algo no funcione. ¿ Cómo lo veis ?

Saludos.
 
Como hardware, yo me tiraría a por el hAP ac3, que lo tienes por 100€, y es un modelo nuevo de este año. Por la diferencia de precio, ni me lo pensaba. Doy fe de que es un equipo muy redondo para uso doméstico.

Con respecto al IPTV / Multicast, @furny es tu hombre; sabe más que yo de estas cosas.

Saludos!
 
ONT Huawei HG8240 - conexión teléfono fijo
Router Comtrend VG-8050
Desco Zyxel STB-2112T Nano v2
Hola. Voy respondiéndote. Los equipos no son tan viejos. De hecho, la ONT está muy bien, es la que yo tengo puesta ahora y creo que es de las mas fiables. El router, en cambio, es patata total. Yo lo tuve hace tiempo y me lo cambiaron por un Comtrend más viejo, pero que funcionaba mejor. El desco, lo he visto por ahí en otras casas, pero no he cacharraeado con ese modelo, pero no me parece un problema. Respecto del router, si quieres wifi integrado, coincido con la recomendación de @pokoyo, el hAP ac3. Pero depende de la ubicación física donde vaya a estar el router. Si está en un sótano oscuro, donde la acometida de FO y lejos de los usuarios, mejor no poner allí el wifi, es mejor una solución de router por un lado y APs por otros. Son mis manías...
 
. Los datos de la IPTV : ¿ los puedo obtener de un backup del Comtrend directamente buscándolos con un editor o en algún menú del router ? ( La web de Noltari no funciona
Pues están por algún sitio cuando haces el backup, pero no recuerdo muy bien como. Yo los saqué con Noltari, pasándole el backup del config y me lo dio estupendamente. Siento no poderte dar más detalles, pero buscaré a ver...
 
Si un día les cambian el desco por avería o sustitución : ¿ Se tendría que cambiar algo en la configuración del Mikrotik ?
Si es el desco lo que te cambia Movistar, nada. No hay problema. El MK pilla el nuevo desco estupendamente con nuestra última configuración.
 
. Buscando información sobre el tema veo que algunos tocaban la configuración de los descos para ponerlos en marcha, pero creo que esto no es necesario con la configuración de @furny para 1 desco. ¿ Es así ?. Sólo desconectarlos del todo y esperar 5-10 min a que cargue todos los datos por si sólo.
Correcto. No hay que tocar nada del desco (aunque es posible, y en algunos modelos los he toqueteado, para aprender)
 
Añadir el paquete Multicast.

Creo que agradecerán el cambio. Les cargaría yo la configuración, dejando todo en funcionamiento y esperando que todo funcione como una roca, para no estar desplazándome de "urgencias" porque algo no funcione. ¿ Cómo lo veis ?
El paquete multicast es imprescindible. Si tienes dificultades, ya sabes donde estamos. Miraré lo de Noltari, a ver si averiguo algo.

Saludos!!
 
@furny
Muchas gracias por tus explicaciones y experiencia. El router irá debajo de la TV en un mueble clásico de comedor. Cómo no se quieren gastar mucho tiraremos por el hAP AC2 para comenzar. Me lo voy a tomar con tranquilidad antes de liarme con el asunto, por eso tenía algunas dudas. Sacando el backup del Comtrend casi seguro que saldrán los datos del IPTV. Seguramente Noltari haría una lectura del backup, dando la facilidad de lectura a muchos usuarios como fue tu caso.
Muchas gracias de nuevo.
Saludos.
 
@furny
Mira lo que he encontrado en Google.

Dependiendo del router, el archivo de configuración variará y los datos se encontrarán en diferentes sitios. Lo mejor es que abras el archivo con un editor de código (Atom, Notepad++…) y utilices su buscador.

En el caso del Comtrend, busca la etiqueta <WANConnectionDevice instance=»1″> (sólo hay una en todo el archivo). Dentro de ella encontrarás la etiqueta <WANIPConnection instance=»1″> y en su interior podrás ver las 3 etiquetas que nos interesan, una detrás de otra:

  • Dirección IP: <ExternalIPAddress>xx.xx.xx.xx</ExternalIPAddress>.
  • Máscara de subred: <SubnetMask>xx.xx.xx.xx</SubnetMask>.
  • Puerta de enlace predeterminada: <DefaultGateway>xx.xx.xx.xx</DefaultGateway>
El servidor DNS lo podemos encontrar buscando la etiqueta <PriDns>xx.xx.xx.xx</PriDns> (solo hay una, así que es fácil de encontrar). Como he dicho antes, esta IP es compartida y puedes utilizar directamente la 172.26.23.3

Ya tengo algo con lo que orientarme.
Saludos.
 
Buenas, a ver si podeis orientarme :

Tengo un Mirkotik 4011 , como AP Wifi uso una AP Nano HD , y como ONT tengo un

Ubiquiti Ufiber Nano G

https://www.landashop.com/ubn-uf-nano.html
La cuestion es que no consigo hacer funcionar la VOIP


He visto los scripts del post iniil pero soy un manco y me da error todo lo que pruebo, adeás de dejarme sin internet (por suerte hice un backup de la configuracion mia para poder restaurar9

Poeios hacer un paso a paso para inutiles como yo ??

Donde pongo los comandos, y como los ejecuto (algunos al ser muy largos parece que se cortan al ejdcutar y solo me dan errores.

Si intento hacerlo como script y ejecutarlo parece que tampoco me funciona.

EL AP lo tengo en el puerto 4 , y el GPON lo tengo en el puerto 10
 
@vdias Aquí te subo una configuración actualizada, basada en la mía actual. Espero que te corra bien. Si tienes problemas, me lo dices.

Suerte!!
Hola, he aplicado esta configuración y me funciona perfecto. La duda que tengo es que la configuración del primer post activa el Hardware offloafing pero también tendría la posibilidad de seguir viendo los canales por vlc (sólo es por un canal autonómico que no se sintoniza donde resido)?? Es mucha mejora el activarlo (tengo un servidor activo tirando varios servicios)?? Tengo router mikrotik 4011 y ont Huawei ademas de descodificador.

edito: con la configuración actual tengo algunas pixelaciones cuando veo tv en directo, se podría mejorar?

Agradeceros todos los manuales y el tiempo que dedicáis ayudar a los demás, da gusto el foro.

Enviado desde mi CLT-L09 mediante Tapatalk
 
Hola, he aplicado esta configuración y me funciona perfecto. La duda que tengo es que la configuración del primer post activa el Hardware offloafing pero también tendría la posibilidad de seguir viendo los canales por vlc (sólo es por un canal autonómico que no se sintoniza donde resido)?? Es mucha mejora el activarlo (tengo un servidor activo tirando varios servicios)?? Tengo router mikrotik 4011 y ont Huawei ademas de descodificador.

edito: con la configuración actual tengo algunas pixelaciones cuando veo tv en directo, se podría mejorar?

Agradeceros todos los manuales y el tiempo que dedicáis ayudar a los demás, da gusto el foro.

Enviado desde mi CLT-L09 mediante Tapatalk

Hola @pantic. El hardware offloading solo se tiene que activar en los hEX y hEX-S (renunciando a la detección de ciclos en redes, conocido como Spanning Tree) porque esos routers no permiten hacer las dos cosas al mismo tiempo. En el caso de la RB4011 no hay que activar el Hardware Offloading porque ya lo tiene habilitado. Su hardware si que permite hacer las dos cosas en paralelo (es un equipo mucho más potente), así que nada de qué preocuparte ☺️
 
Hola @pantic. El hardware offloading solo se tiene que activar en los hEX y hEX-S (renunciando a la detección de ciclos en redes, conocido como Spanning Tree) porque esos routers no permiten hacer las dos cosas al mismo tiempo. En el caso de la RB4011 no hay que activar el Hardware Offloading porque ya lo tiene habilitado. Su hardware si que permite hacer las dos cosas en paralelo (es un equipo mucho más potente), así que nada de qué preocuparte
Hola, comentaba lo de activar el hardware offloading porque para enviar al vlc el bridge tiene que tener igmp snooping activado y creo que no es compatible pero entiendo que dada la potencia del rb4011 tampoco es estrictamente necesario tenerlo activado verdad?? Entonces dejo así la configuración y no la toco :)

Enviado desde mi CLT-L09 mediante Tapatalk
 
hay alguna configuración ya hecha para un rb4011 con o2 que incluya voip ?? ..... yo llevo ya días peleándome con el rb4011 y cuando no me falla una cosa me falla otra (se que es culpa mía, no del router) , pero no doy para mas :-(
 
hay alguna configuración ya hecha para un rb4011 con o2 que incluya voip ?? ..... yo llevo ya días peleándome con el rb4011 y cuando no me falla una cosa me falla otra (se que es culpa mía, no del router) , pero no doy para mas :-(
Resetea el router a valores de fábrica y ejecuta la configuración de @stargate4you para O2 que tienes al principio de este manual. Es tan simple como eso.

Saludos.
 
hay alguna configuración ya hecha para un rb4011 con o2 que incluya voip ?? ..... yo llevo ya días peleándome con el rb4011 y cuando no me falla una cosa me falla otra (se que es culpa mía, no del router) , pero no doy para mas :-(

Yo tengo O2 funcionando a la perfección, solo que con un RB750Gr3, pero eso es lo de menos.

Como indica @pokoyo, solo es hacer un reset de fábrica, montar un quickset básico y seguir la configuración de @stargate4you del comienzo del post. Te voy a pasar la que puse aquí, que respeta aun más la configuración del QuickSet, ya que la del post es cierto que tuve que modificar algo porque distaba un poco de lo que genera el QuickSet:
 
@vorlander esta sería la configuración que yo hice, y que funciona perfecto en O2 respetando al máximo la configuración del QuickSet:

Código:
# Dar de alta las vlans 3 voip y 6 internet.
/interface vlan
add interface=ether1 name=vlan3 vlan-id=3
add interface=ether1 name=vlan6 vlan-id=6

# Configurar la interfaz PPPoE para que use la VLAN 6 internet.
/interface pppoe-client
add add-default-route=yes disabled=no interface=vlan6 name=pppoe-out1 password=adslppp use-peer-dns=yes \
    user=adslppp@telefonicanetpa

# Añadimos a  la lista WAN el  interface PPPoE  para que el firewall/nat funcione correctamente.
/interface list member
add interface=pppoe-out1 list=WAN

# Crear un cliente dhcp para la vlan 3 del teléfono voip.
/ip dhcp-client
add add-default-route=no dhcp-options=hostname,clientid disabled=no interface=vlan3 use-peer-ntp=no

# Establecer la prioridad de las conexiones vlans.
/ip firewall mangle
add action=set-priority chain=postrouting new-priority=4 out-interface=vlan3
add action=set-priority chain=postrouting new-priority=1 out-interface-list=WAN passthrough=yes

# Enmascarar las conexiones PPPoE y vlan3 voip.
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=out,none \
    out-interface-list=WAN
add action=masquerade chain=srcnat comment="vlan3 voip configuration" out-interface=vlan3

# Puertos del servicio voip.
/ip firewall service-port
set sip disabled=yes ports=5060,5070

# Añadir la vlan 3 de voz protocolo RIP.
/routing rip interface
add interface=vlan3 passive=yes receive=v2

# Indicar la red en la que correrá RIP.
/routing rip network
add network=10.0.0.0/8

Ya me dices. Un saludo!!
 
Hola, comentaba lo de activar el hardware offloading porque para enviar al vlc el bridge tiene que tener igmp snooping activado y creo que no es compatible pero entiendo que dada la potencia del rb4011 tampoco es estrictamente necesario tenerlo activado verdad?? Entonces dejo así la configuración y no la toco :)

Enviado desde mi CLT-L09 mediante Tapatalk
Hola. Pues si no me equivoco el switch que viene con el 4011 es el RTL8367. Y si miráis en la tabla del manual sobre HW Offloading:


RouterBoard/[Switch Chip] ModelFeatures in Switch menuBridge STP/RSTPBridge MSTPBridge IGMP SnoopingBridge DHCP SnoopingBridge VLAN FilteringBonding
CRS3xx series+++++++
CRS1xx/CRS2xx series++-+ 2+ 1--
[QCA8337]++--+ 2--
[Atheros8327]++--+ 2--
[Atheros8227]++-----
[Atheros8316]++--+ 2--
[Atheros7240]++-----
[MT7621]+------
[RTL8367]+------
[ICPlus175D]+------
Para ese switch, me temo que el IGMP Snooping es incompatible con el HW Offloading. O sea, que en el bridge que lo actives (y es necesario activarlo si por esos puertos tienes tráfico multicast), No vas a tener HW Offloading. La solución es separar en dos bridges el tráfico: los de IPTV (con multicast, y si hay otros dispositivos o Wifi APs con IGMP Snooping) y los otros puertos "normales" con el HW Offloading activado. Según la tabla, lo mismo pasa con otras funciones, como vlan filtering, Spanning tree protocols, etc
 
Arriba