MANUAL: Mikrotik, configuraciones básicas ISPs - RouterOS v7

Buenas!

Según veo en el post inicial, la única forma de tener teléfono es con Movistar/O2, ¿no?

Tengo dos líneas en un domicilio y me gustaría aprovechar para montar un failover, pero entiendo que si las dos están con movistar, de poco me va a servir...

Saludos!
No te sigo con lo del teléfono. Y sí, hacer failover con dos líneas de la misma compañía, que probablemente estén en la CTO… pues mal failover vas a hacer.

Saludos!
 
Me intento explicar mejor. Ahora mismo tengo dos líneas, ambas con Movistar. Necesito los teléfonos fijos de ambas líneas operativos.

Leyendo el post del failover, se me ocurrió que en vez de tener la segunda línea muerta de risa (más allá del fijo), podía cambiarla de movistar a otro operador (que utilice otro CTO) y montar un failover. Pero revisando la primera página, veo que solo tenemos configuraciones que soporten teléfono con Movistar/O2. Por lo tanto, creo que lo que busco no es posible, ¿no? Es decir, si cambio la segunda línea de movistar a (por ejemplo, masmovil), perdería el fijo en esta segunda línea o no podría usar el mikrotik.

Saludos!
 
Me intento explicar mejor. Ahora mismo tengo dos líneas, ambas con Movistar. Necesito los teléfonos fijos de ambas líneas operativos.

Leyendo el post del failover, se me ocurrió que en vez de tener la segunda línea muerta de risa (más allá del fijo), podía cambiarla de movistar a otro operador (que utilice otro CTO) y montar un failover. Pero revisando la primera página, veo que solo tenemos configuraciones que soporten teléfono con Movistar/O2. Por lo tanto, creo que lo que busco no es posible, ¿no? Es decir, si cambio la segunda línea de movistar a (por ejemplo, masmovil), perdería el fijo en esta segunda línea o no podría usar el mikrotik.

Saludos!
Si las dos líneas son fibra (necesitas el teléfono y tienes contratado internet porque es lo que hay), obviamente úsala como failover. O, incluso puedes balancearlas, para usar ambas y así aprovecharlas. Quizá no sea el mejor setup del mundo, pero por lo menos las aprovechas.

Lo que comentas del teléfono no es así. Lo que pasa es que pocas compañías te faicilitan los datos de su conexión para que uses el teléfono fuera de su CPE (su router). Pero si no tienes problemas a tener delante del mikrotik un CPE de cualquier otra compañía, problema para usar el teléfono ninguno: el teléfono iría conectado a su router, y el mikrotik debajo usando esa conexión a internet como failover, balanceo o lo que quieras hacer con ella. Vamos, que es indiferente que haya o no configuraciones en la V7. Tu busca la compañía que más te guste o mejor te encaje, y ya vemos cómo aprovecharlo.

Saludos!
 
Lo que comentas del teléfono no es así. Lo que pasa es que pocas compañías te faicilitan los datos de su conexión para que uses el teléfono fuera de su CPE (su router). Pero si no tienes problemas a tener delante del mikrotik un CPE de cualquier otra compañía, problema para usar el teléfono ninguno: el teléfono iría conectado a su router, y el mikrotik debajo usando esa conexión a internet como failover, balanceo o lo que quieras hacer con ella. Vamos, que es indiferente que haya o no configuraciones en la V7. Tu busca la compañía que más te guste o mejor te encaje, y ya vemos cómo aprovecharlo.
Buenas tardes

Te refieres a tener el CPE de operadora en modo Bridge? Tengo entendido que se pierde la línea telefónica también, por lo que leí solo se podría mantener si se hace por DMZ en el router de operador, pero tengo entendido que ponerlo en DMZ no es lo mismo que tenerlo en bridge, que tendría mas limitaciones. ¿Qué hay de cierto en todo esto? yo renové un poco mas con mi operadora actual para poder dar margen a que terminaran de poner DIGI y saber como hacer para no perder la telefonía fija en casa. En mi zona ahora puedo tener DIGI y la red de Orange (Orange, Jazztel, ... ) no tengo otras.
 
La verdad es que echando un vistazo es un poco desolador... ¿Qué ha pasado en los últimos años que ahora todo tiene permanencia? Quitando O2 (que no tiene contestador), Pepe (que no tiene fijo...) y Vodafone/Lowi que no tienen fibra donde vivo, todo el grupo MasMovil y Orange te quieren atar durante 12 meses.
 
La verdad es que echando un vistazo es un poco desolador... ¿Qué ha pasado en los últimos años que ahora todo tiene permanencia? Quitando O2 (que no tiene contestador), Pepe (que no tiene fijo...) y Vodafone/Lowi que no tienen fibra donde vivo, todo el grupo MasMovil y Orange te quieren atar durante 12 meses.
Si ya tienes fijo, Pepe sí tiene fijo. Te lo portan a una SIM y lo tienes como si de un móvil se tratase. Más info, aquí: https://www.pepephone.com/internet-en-casa/solo-fijo

Saludos!
 
Hola,

creo que ya sabéis de qué va esto. Vamos a intentar recopilar las configuraciones básicas para echar a andar un mikrotik en las principales compañías proveedoras de internet en España, esta vez para la nueva versión de RouterOS v7, ahora que está considerada versión estable.
El post no es cosa mía, es cosa de todos, así que id compartiendo las configuraciones si os gusta ver este tipo de posts cuando os compráis un mikrotik y buscáis información a la desesperada. Es decir, esto no es sólo cosa mía, lo hacemos entre todos. De vuestra colaboración dependerá lo completo o incompleto que esté dicho post.

Como ya sabéis, todos estos setups parten de la configuración por defecto que monta el router vía el script de auto-configuración después de un reset sin marcar la opción del no default configuration.



Pepephone / MasMóvil / guuk. / Fibra Neba (sin teléfono) [by @pokoyo]

Conexión WAN: ONT Nokia G-010-G-P (Antigua ONT de Neba)​
Tipo de conexión WAN: DHCP​
VLAN Internet: 20​
VLAN Teléfono: N/A​
VLAN TV: N/A​

Configuración
Código:
# Damos de alta la vlan correspondiente, asociada al puerto físico que haga de WAN. Suponemos ONT / Router en bridge, conectada a ether1
/interface/vlan
add interface=ether1 name=internet vlan-id=20

# Creamos (o editamos el existente) cliente DHCP y la asignamos a esa nueva interfaz vlan
/ip/dhcp-client
add interface=internet

# Modificamos la lista WAN con la nueva interfaz de acceso a internet,
# para que apliquen correctamente las reglas de Firewall / NAT sobre ella
/interface/list/member
set [find where interface=ether1 and list=WAN] interface=internet



Movistar, O2 (Internet) [based on @stargate4you, updated by @pokoyo]
Conexión WAN:
ONT Huawei EG8120L
Tipo de conexión WAN: PPPoE: usuario (adslppp@telefonicanetpa) y contraseña (adslppp)
VLAN Internet: 6
VLAN Teléfono: N/A
VLAN TV: N/A

Configuración
Código:
# Dar de alta las vlan de internet. Suponemos ONT/Router bridge en ether1
/interface/vlan
add interface=ether1 name=vlan6-internet vlan-id=6

# Configurar la interfaz PPPoE para que use la vlan de internet
/interface/pppoe-client
add add-default-route=yes disabled=no interface=vlan6-internet \
name=internet use-peer-dns=yes user=adslppp@telefonicanetpa \
password=adslppp

# Modificamos la lista WAN con la nueva interfaz de acceso a internet,
# para que apliquen correctamente las reglas de Firewall / NAT sobre ella
/interface/list/member
set [find where interface=ether1 and list=WAN] interface=internet



Movistar, O2 (Internet + VoIP) [original from @stargate4you, updated by @pokoyo]
Conexión WAN:
ONT Huawei EG8120L
Tipo de conexión WAN: PPPoE: usuario (adslppp@telefonicanetpa) y contraseña (adslppp)
VLAN Internet: 6
VLAN Teléfono: 3
VLAN TV: N/A

Configuración
Código:
# Dar de alta las vlans 3 voip y 6 internet. Suponemos ONT/Router modo bridge, en ether1
/interface/vlan
add interface=ether1 name=vlan3-telefono vlan-id=3
add interface=ether1 name=vlan6-internet vlan-id=6

# Configurar la interfaz PPPoE para que use la vlan 6 internet
/interface/pppoe-client
add add-default-route=yes disabled=no interface=vlan6-internet \
name=internet use-peer-dns=yes user=adslppp@telefonicanetpa \
password=adslppp

# Modificamos la lista WAN con la nueva interfaz de acceso a internet,
# para que apliquen correctamente las reglas de Firewall / NAT sobre ella
/interface/list/member
set [find where interface=ether1 and list=WAN] interface=internet

# Crear un cliente DHCP para la vlan del teléfono, sin ruta por defecto.
# La ruta necesaria con distancia 120 la creará RIP, dinámicamente.
/ip/dhcp-client
add interface=vlan3-telefono add-default-route=no \
use-peer-ntp=no use-peer-dns=no

# Aceptar el tráfico en el input del firewall, para que RIP funcione.
# Origen la vlan3-telefono, destino la dirección multicast 224.0.0.9,
# puerto 520 y tipo de tráfico UDP (RIPv2, RFC-2453). La colocamos
# delante de la regla general de DROP que hay en el chain de input.
/ip/firewall/filter
add action=accept chain=input comment="voip: accept rip multicast traffic" \
in-interface=vlan3-telefono dst-address=224.0.0.9 dst-port=520 protocol=udp \
place-before=[find where comment="defconf: drop all not coming from LAN"]

# Aplicar masquerade a la salida del VoIP, además de la lista WAN,
# que ya la trae por defecto. Esta regla iría justo debajo del otro masquerade.
/ip/firewall/nat
add action=masquerade chain=srcnat comment="voip: masq voip" \
out-interface=vlan3-telefono

# Establecer la prioridad de las conexiones vlans (OPCIONAL)
/ip/firewall/mangle
add action=set-priority chain=postrouting new-priority=4 \
out-interface=vlan3-telefono
add action=set-priority chain=postrouting new-priority=1 \
out-interface=internet

# Creamos la instancia RIP para voip, para obtener las rutas dinámicas correspondientes a este servicio
/routing/rip/instance
add afi=ipv4 disabled=no name=rip
/routing rip interface-template
add instance=rip interfaces=vlan3-telefono mode=passive



Digimobil (Internet IPv4 + IPv6, Fibra Neba / SMART) [original from @diamuxin, updated by @pokoyo]
Conexión WAN:
ONT Huawei EchoLife HG8010H
Tipo de conexión WAN: PPPoE: Usuario (XXXXXXXX) y contraseña (YYYYYYYY) proporcionados por la operadora
VLAN Internet: 20
VLAN Teléfono: N/A
VLAN TV: N/A

Configuración
Código:
# Añadimos la VLAN del servicio de internet a la interfaz ether1
/interface/vlan
add interface=ether1 name=vlan20-internet vlan-id=20

# Creamos la conexión PPPoE, sobre la vlan previamente creada.
# Usuario y contraseña proporcionado por Digimobil desde atención al cliente previa solicitud.
# Usuario: XXXXXXXXX
# Contraseña: YYYYYYYYY
/interface/pppoe-client
add add-default-route=yes disabled=no interface=vlan20-internet \
name=internet use-peer-dns=yes user=XXXXXXXXX@digi \
password=YYYYYYYYY

# Modificamos la lista WAN con la nueva interfaz de acceso a internet,
# para que apliquen correctamente las reglas de Firewall / NAT sobre ella
/interface/list/member
set [find where interface=ether1 and list=WAN] interface=internet


################################
# Configuración IPv6 (OPCIONAL)
################################
# Activamos el cliente DHCP para solicitar la delegación de prefijos en la interfaz pppoe
/ipv6/dhcp-client
add add-default-route=no interface=internet pool-name=pool6 request=address,prefix

# Asignamos el pool6 de direcciones, creado automáticamente, a la interfaz bridge local
/ipv6/address
add from-pool=pool6 interface=bridge

# Reiniciamos la interfaz del PPPoE, para que nos empiece a entregar las direcciones IPv6
/interface/pppoe-client
set [find where name=internet] disabled=yes
/delay 5
/interface/pppoe-client
set [find where name=internet] disabled=no



Vodafone / Lowi Neba (Internet) [original from @Dexter91 & @ectoplasma, updated by @pokoyo]
Conexión WAN:
ONT Nokia G-010G-P
Tipo de conexión WAN: PPPoE: Usuario (XXXXXXXX) y contraseña (YYYYYYYY) extraidos del router de la operadora. Info aquí
VLAN Internet: 24 / 20
VLAN Teléfono: N/A
VLAN TV: N/A

Configuración
Código:
# Añadimos la VLAN del servicio de internet (24 normalmente, aunque también puede venir por la 20)
/interface/vlan
add interface=ether1 name=vlan2x-internet vlan-id=24

# Configurar la interfaz PPPoE para que use la vlan2x-internet
# Usuario y contraseña extraídos de los equipos originales de Vodafone / Lowi
# Usuario: XXXXXXXXX
# Contraseña: YYYYYYYYY
/interface/pppoe-client
add add-default-route=yes disabled=no interface=vlan2x-internet \
name=internet use-peer-dns=yes user=XXXXXXXXX \
password=YYYYYYYYY

# Modificamos la lista WAN con la nueva interfaz de acceso a internet,
# para que apliquen correctamente las reglas de Firewall / NAT sobre ella
/interface/list/member
set [find where interface=ether1 and list=WAN] interface=internet


...

Id enviándolas, y las vamos publicando.

Gracias, un saludo!

Después de estar intentando constantemente como hacer funcionar la TV, no consigo que me falla fluida, faltan logos, y va súper lento. Veo que en la v7 no hay el rip network, pero no vi equivalente en la v7. Os suena que puede fallar?

Muchas gracias!
 
Hola a todos
He intentado configurar la tripe VLAN de Movistar pero con la TV no lo he conseguido para que funcione mi unico DECO... He copiado y comprendido lo que teoricamente es necesario hacer para que funcione, pero no lo he conseguido. A ver si podeis ayudarme. Gracias

Adjunto Export de la configuracion y he quitado cosas como el capsman o el firewall IPV6 que esta por defecto.

Código:
# jun/06/2022 18:22:51 by RouterOS 7.2.3
# software id = SBTM-87AV
#
# model = RB4011iGS+
# serial number = xxxxxxxxx
/caps-man channel
add band=2ghz-g/n name=channel_2ghz
add band=5ghz-a/n/ac extension-channel=XXXX name=channel_5ghz
/interface bridge
add admin-mac=2C:C8:1B:AB:F5:72 auto-mac=no comment=defconf name=bridge \
    vlan-filtering=yes
/interface ethernet
set [ find default-name=sfp-sfpplus1 ] speed=1Gbps
/interface wireguard
add listen-port=13231 mtu=1420 name=wireguard-rw
add listen-port=13232 mtu=1420 name=wireguard-sts-seixo
add listen-port=13233 mtu=1420 name=wireguard-sts-seixo-eoip-iptv
/interface eoip
add local-address=172.16.0.1 mac-address=FE:15:59:EA:A4:DC name=\
    eoip-tunnel-over-wg-sts-seixo-iptv remote-address=172.16.0.2 tunnel-id=0
/interface vlan
add interface=sfp-sfpplus1 name="vlan2 - IPTV" vlan-id=2
add interface=sfp-sfpplus1 name="vlan3 - VoIP" vlan-id=3
add interface=sfp-sfpplus1 name="vlan6 - Internet" vlan-id=6
add interface=sfp-sfpplus1 name="vlan20 - NEBA" vlan-id=20
add interface=bridge name="vlan96 - GuestWiFi" vlan-id=96
add interface=bridge name="vlan97 - Stell" vlan-id=97
add interface=bridge name="vlan98 - IoT" vlan-id=98
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
add name="IPTV & VoIP"
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip dhcp-server option
add code=240 name=decos-movistar value=\
    "':::::239.0.2.10:22222:v6.0:239.0.2.30:22222'"
/ip pool
add name=default-dhcp ranges=192.168.13.150-192.168.13.254
add name="pool - vlan96" ranges=192.168.96.2-192.168.96.254
add name="pool - vlan97" ranges=192.168.97.2-192.168.97.254
add name="pool - vlan98" ranges=192.168.98.2-192.168.98.254
add name=iptv-pool ranges=192.168.77.195-192.168.77.200
/ip dhcp-server
add address-pool=default-dhcp interface=bridge name=defconf
add address-pool="pool - vlan96" interface="vlan96 - GuestWiFi" name=vlan96
add address-pool="pool - vlan97" interface="vlan97 - Stell" name=vlan97
add address-pool="pool - vlan98" interface="vlan98 - IoT" name=vlan98
add address-pool=iptv-pool interface=ether1 name=iptv-dhcp-server
/port
set 0 name=serial0
set 1 name=serial1
/routing rip instance
add afi=ipv4 disabled=no name=rip
/interface bridge port
add bridge=bridge interface=ether2
add bridge=bridge interface=ether3
add bridge=bridge interface=ether4 pvid=97
add bridge=bridge interface=ether5
add bridge=bridge interface=ether6
add bridge=bridge interface=ether7
add bridge=bridge interface=ether8
add bridge=bridge interface=ether9
add bridge=bridge interface=ether10
add disabled=yes interface=ether1
add bridge=bridge interface=eoip-tunnel-over-wg-sts-seixo-iptv
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface bridge vlan
add bridge=bridge tagged=bridge vlan-ids=96
add bridge=bridge tagged=bridge vlan-ids=97
add bridge=bridge tagged=bridge vlan-ids=98
/interface detect-internet
set detect-interface-list=all
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=sfp-sfpplus1 list=WAN
add interface="vlan20 - NEBA" list=WAN
add interface=wireguard-rw list=LAN
add interface=wireguard-sts-seixo list=LAN
add interface="PPPoE Client - Vlan6" list=WAN
add interface="vlan2 - IPTV" list="IPTV & VoIP"
add interface="vlan3 - VoIP" list="IPTV & VoIP"
add interface=ether1 list=LAN
/interface ovpn-server server
set auth=sha1,md5
/ip address
add address=192.168.13.1/24 comment=defconf interface=bridge network=\
    192.168.13.0
add address=192.168.96.1/24 interface="vlan96 - GuestWiFi" network=\
    192.168.96.0
add address=192.168.1.1/29 comment=\
    "SFP Network || IP MODULO SFP 192.168.1.57 ||" disabled=yes interface=\
    sfp-sfpplus1 network=192.168.1.0
add address=192.168.14.1/29 interface=wireguard-rw network=192.168.14.0
add address=192.168.97.1/24 interface="vlan97 - Stell" network=\
    192.168.97.0
add address=192.168.98.1/24 interface="vlan98 - IoT" network=192.168.98.0
add address=172.16.1.1/30 interface=wireguard-sts-seixo network=172.16.1.0
add address=192.168.100.2/30 comment=\
    "SFP Network || ONT Nokia/Alcatel 192.168.100.1" interface=sfp-sfpplus1 \
    network=192.168.100.0
add address=172.16.0.1/30 interface=wireguard-sts-seixo-eoip-iptv network=\
    172.16.0.0
add address=10.139.42.194/9 comment="My Telefonica's IPTV address" interface=\
    "vlan2 - IPTV" network=10.128.0.0
add address=192.168.77.1/24 comment="IPTV subnet" interface=ether1 network=\
    192.168.77.0
/ip cloud
set ddns-enabled=yes ddns-update-interval=12h
/ip dhcp-client
add comment=defconf disabled=yes interface="vlan20 - NEBA"
add add-default-route=no interface="vlan3 - VoIP" use-peer-dns=no \
    use-peer-ntp=no
/ip dhcp-server lease
add address=192.168.13.50 client-id=1:c8:5b:76:d:be:f9 comment=\
    "Laptop Family Valero & Torres" mac-address=C8:5B:76:0D:BE:F9 server=\
    defconf
/ip dhcp-server network
add address=192.168.13.0/24 comment=defconf dns-server=\
    8.8.8.8,62.36.225.150,62.37.228.20,1.1.1.1,192.168.13.1 gateway=\
    192.168.13.1
add address=192.168.77.0/24 dhcp-option=decos-movistar dns-server=172.26.23.3 \
    gateway=192.168.77.1 netmask=24
add address=192.168.96.0/24 dns-server=8.8.8.8,62.36.225.150,1.1.1.1 gateway=\
    192.168.96.1
add address=192.168.97.0/24 dns-server=8.8.8.8,62.36.225.150,1.1.1.1 gateway=\
    192.168.97.1
add address=192.168.98.0/24 dns-server=8.8.8.8,62.36.225.150,1.1.1.1 gateway=\
    192.168.98.1
/ip dhcp-server vendor-class-id
add name=decos-movistar vid="[IAL]"
/ip dns
set servers=8.8.8.8,1.1.1.1,9.9.9.9
/ip dns static
add address=192.168.13.1 comment=defconf name=mk-estribela.lan
add address=192.168.3.1 name=mk-seixo.lan
/ip firewall address-list
add address=f0260e0d65eb.sn.mynetname.net list=public-ip
/ip firewall filter
add action=accept chain=input comment=\
    "defconf: accept established,related,untracked" connection-state=\
    established,related,untracked
add action=accept chain=input comment=\
    "Accept vlan2 & 3  (Iptv & Voip) multicast & broadcast traffic" \
    dst-address-type=!unicast in-interface-list="IPTV & VoIP"
add action=accept chain=input comment="Accept vlan2 Iptv IGMP packets" \
    in-interface="vlan2 - IPTV" protocol=igmp
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
    invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment="vpn: allow wireguard-rw" dst-port=\
    13231 protocol=udp
add action=accept chain=input comment="vpn: allow wireguard-sts-seixo" \
    dst-port=13232-13233 protocol=udp
add action=accept chain=input comment=\
    "defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=accept chain=input comment="VoIP: accept rip multicast traffic" \
    dst-address=224.0.0.9 dst-port=520 in-interface="vlan3 - VoIP" protocol=\
    udp
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
    in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
    ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
    ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related hw-offload=yes
add action=accept chain=forward comment=\
    "defconf: accept established,related, untracked" connection-state=\
    established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
    connection-state=invalid
add action=drop chain=forward comment=\
    "defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
    connection-state=new in-interface-list=WAN
add action=drop chain=forward comment=\
    "Drop all new unicast traffic from vlan3 & 2 (Voip & Iptv) not DSTNATed" \
    connection-nat-state=!dstnat connection-state=new dst-address-type=\
    unicast in-interface-list="IPTV & VoIP"
add action=drop chain=forward comment=\
    "block Guest WiFi - Stell - IoT other networks" dst-address=\
    192.168.0.0/16 src-address=192.168.96.0/20
add action=drop chain=forward comment=\
    "block LAN accesing Guest WiFi - Stell - IoT" dst-address=\
    192.168.96.0/20 src-address=192.168.13.0/24
/ip firewall mangle
add action=set-priority chain=postrouting new-priority=5 out-interface=\
    "vlan3 - VoIP" passthrough=yes
add action=set-priority chain=postrouting new-priority=4 out-interface=\
    "vlan2 - IPTV" passthrough=yes
add action=set-priority chain=postrouting new-priority=1 out-interface=\
    "PPPoE Client - Vlan6"
/ip firewall nat
add action=masquerade chain=srcnat comment=Hairpin-NAT dst-address=\
    192.168.13.0/24 src-address=192.168.13.0/24
add action=masquerade chain=srcnat comment="defconf: masquerade" \
    ipsec-policy=out,none out-interface-list=WAN
add action=dst-nat chain=dstnat comment=\
    "VOD Movistar 1 Desco -- 192.168.77.196" dst-address-type=local \
    in-interface="vlan2 - IPTV" to-addresses=192.168.77.196
add action=dst-nat chain=dstnat comment="HTTPS qBitorrent" dst-address-list=\
    public-ip dst-port=8080 protocol=tcp src-port="" to-addresses=\
    192.168.13.50 to-ports=8080
add action=masquerade chain=srcnat comment="voip: masq voip" out-interface=\
    "vlan3 - VoIP"
/ip route
add disabled=no distance=1 dst-address=192.168.3.0/24 gateway=\
    wireguard-sts-seixo pref-src=0.0.0.0 routing-table=main scope=30 \
    suppress-hw-offload=no target-scope=10
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www-ssl certificate=mk-estribela.valero-torres.es disabled=no
set api disabled=yes
set api-ssl disabled=yes
/routing igmp-proxy
set query-interval=30s quick-leave=yes
/routing igmp-proxy interface
add alternative-subnets=0.0.0.0/0 interface="vlan2 - IPTV" upstream=yes
add interface=ether1
/routing rip interface-template
add disabled=no instance=rip interfaces="vlan2 - IPTV,vlan3 - VoIP" mode=\
    passive source-addresses=""
/system clock
set time-zone-name=Europe/Madrid
/system identity
set name=mk-estribela
/system routerboard settings
set auto-upgrade=yes
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
 
Hola a todos
He intentado configurar la tripe VLAN de Movistar pero con la TV no lo he conseguido para que funcione mi unico DECO... He copiado y comprendido lo que teoricamente es necesario hacer para que funcione, pero no lo he conseguido. A ver si podeis ayudarme. Gracias

Adjunto Export de la configuracion y he quitado cosas como el capsman o el firewall IPV6 que esta por defecto.

Código:
# jun/06/2022 18:22:51 by RouterOS 7.2.3
# software id = SBTM-87AV
#
# model = RB4011iGS+
# serial number = xxxxxxxxx
/caps-man channel
add band=2ghz-g/n name=channel_2ghz
add band=5ghz-a/n/ac extension-channel=XXXX name=channel_5ghz
/interface bridge
add admin-mac=2C:C8:1B:AB:F5:72 auto-mac=no comment=defconf name=bridge \
    vlan-filtering=yes
/interface ethernet
set [ find default-name=sfp-sfpplus1 ] speed=1Gbps
/interface wireguard
add listen-port=13231 mtu=1420 name=wireguard-rw
add listen-port=13232 mtu=1420 name=wireguard-sts-seixo
add listen-port=13233 mtu=1420 name=wireguard-sts-seixo-eoip-iptv
/interface eoip
add local-address=172.16.0.1 mac-address=FE:15:59:EA:A4:DC name=\
    eoip-tunnel-over-wg-sts-seixo-iptv remote-address=172.16.0.2 tunnel-id=0
/interface vlan
add interface=sfp-sfpplus1 name="vlan2 - IPTV" vlan-id=2
add interface=sfp-sfpplus1 name="vlan3 - VoIP" vlan-id=3
add interface=sfp-sfpplus1 name="vlan6 - Internet" vlan-id=6
add interface=sfp-sfpplus1 name="vlan20 - NEBA" vlan-id=20
add interface=bridge name="vlan96 - GuestWiFi" vlan-id=96
add interface=bridge name="vlan97 - Stell" vlan-id=97
add interface=bridge name="vlan98 - IoT" vlan-id=98
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
add name="IPTV & VoIP"
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip dhcp-server option
add code=240 name=decos-movistar value=\
    "':::::239.0.2.10:22222:v6.0:239.0.2.30:22222'"
/ip pool
add name=default-dhcp ranges=192.168.13.150-192.168.13.254
add name="pool - vlan96" ranges=192.168.96.2-192.168.96.254
add name="pool - vlan97" ranges=192.168.97.2-192.168.97.254
add name="pool - vlan98" ranges=192.168.98.2-192.168.98.254
add name=iptv-pool ranges=192.168.77.195-192.168.77.200
/ip dhcp-server
add address-pool=default-dhcp interface=bridge name=defconf
add address-pool="pool - vlan96" interface="vlan96 - GuestWiFi" name=vlan96
add address-pool="pool - vlan97" interface="vlan97 - Stell" name=vlan97
add address-pool="pool - vlan98" interface="vlan98 - IoT" name=vlan98
add address-pool=iptv-pool interface=ether1 name=iptv-dhcp-server
/port
set 0 name=serial0
set 1 name=serial1
/routing rip instance
add afi=ipv4 disabled=no name=rip
/interface bridge port
add bridge=bridge interface=ether2
add bridge=bridge interface=ether3
add bridge=bridge interface=ether4 pvid=97
add bridge=bridge interface=ether5
add bridge=bridge interface=ether6
add bridge=bridge interface=ether7
add bridge=bridge interface=ether8
add bridge=bridge interface=ether9
add bridge=bridge interface=ether10
add disabled=yes interface=ether1
add bridge=bridge interface=eoip-tunnel-over-wg-sts-seixo-iptv
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface bridge vlan
add bridge=bridge tagged=bridge vlan-ids=96
add bridge=bridge tagged=bridge vlan-ids=97
add bridge=bridge tagged=bridge vlan-ids=98
/interface detect-internet
set detect-interface-list=all
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=sfp-sfpplus1 list=WAN
add interface="vlan20 - NEBA" list=WAN
add interface=wireguard-rw list=LAN
add interface=wireguard-sts-seixo list=LAN
add interface="PPPoE Client - Vlan6" list=WAN
add interface="vlan2 - IPTV" list="IPTV & VoIP"
add interface="vlan3 - VoIP" list="IPTV & VoIP"
add interface=ether1 list=LAN
/interface ovpn-server server
set auth=sha1,md5
/ip address
add address=192.168.13.1/24 comment=defconf interface=bridge network=\
    192.168.13.0
add address=192.168.96.1/24 interface="vlan96 - GuestWiFi" network=\
    192.168.96.0
add address=192.168.1.1/29 comment=\
    "SFP Network || IP MODULO SFP 192.168.1.57 ||" disabled=yes interface=\
    sfp-sfpplus1 network=192.168.1.0
add address=192.168.14.1/29 interface=wireguard-rw network=192.168.14.0
add address=192.168.97.1/24 interface="vlan97 - Stell" network=\
    192.168.97.0
add address=192.168.98.1/24 interface="vlan98 - IoT" network=192.168.98.0
add address=172.16.1.1/30 interface=wireguard-sts-seixo network=172.16.1.0
add address=192.168.100.2/30 comment=\
    "SFP Network || ONT Nokia/Alcatel 192.168.100.1" interface=sfp-sfpplus1 \
    network=192.168.100.0
add address=172.16.0.1/30 interface=wireguard-sts-seixo-eoip-iptv network=\
    172.16.0.0
add address=10.139.42.194/9 comment="My Telefonica's IPTV address" interface=\
    "vlan2 - IPTV" network=10.128.0.0
add address=192.168.77.1/24 comment="IPTV subnet" interface=ether1 network=\
    192.168.77.0
/ip cloud
set ddns-enabled=yes ddns-update-interval=12h
/ip dhcp-client
add comment=defconf disabled=yes interface="vlan20 - NEBA"
add add-default-route=no interface="vlan3 - VoIP" use-peer-dns=no \
    use-peer-ntp=no
/ip dhcp-server lease
add address=192.168.13.50 client-id=1:c8:5b:76:d:be:f9 comment=\
    "Laptop Family Valero & Torres" mac-address=C8:5B:76:0D:BE:F9 server=\
    defconf
/ip dhcp-server network
add address=192.168.13.0/24 comment=defconf dns-server=\
    8.8.8.8,62.36.225.150,62.37.228.20,1.1.1.1,192.168.13.1 gateway=\
    192.168.13.1
add address=192.168.77.0/24 dhcp-option=decos-movistar dns-server=172.26.23.3 \
    gateway=192.168.77.1 netmask=24
add address=192.168.96.0/24 dns-server=8.8.8.8,62.36.225.150,1.1.1.1 gateway=\
    192.168.96.1
add address=192.168.97.0/24 dns-server=8.8.8.8,62.36.225.150,1.1.1.1 gateway=\
    192.168.97.1
add address=192.168.98.0/24 dns-server=8.8.8.8,62.36.225.150,1.1.1.1 gateway=\
    192.168.98.1
/ip dhcp-server vendor-class-id
add name=decos-movistar vid="[IAL]"
/ip dns
set servers=8.8.8.8,1.1.1.1,9.9.9.9
/ip dns static
add address=192.168.13.1 comment=defconf name=mk-estribela.lan
add address=192.168.3.1 name=mk-seixo.lan
/ip firewall address-list
add address=f0260e0d65eb.sn.mynetname.net list=public-ip
/ip firewall filter
add action=accept chain=input comment=\
    "defconf: accept established,related,untracked" connection-state=\
    established,related,untracked
add action=accept chain=input comment=\
    "Accept vlan2 & 3  (Iptv & Voip) multicast & broadcast traffic" \
    dst-address-type=!unicast in-interface-list="IPTV & VoIP"
add action=accept chain=input comment="Accept vlan2 Iptv IGMP packets" \
    in-interface="vlan2 - IPTV" protocol=igmp
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
    invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment="vpn: allow wireguard-rw" dst-port=\
    13231 protocol=udp
add action=accept chain=input comment="vpn: allow wireguard-sts-seixo" \
    dst-port=13232-13233 protocol=udp
add action=accept chain=input comment=\
    "defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=accept chain=input comment="VoIP: accept rip multicast traffic" \
    dst-address=224.0.0.9 dst-port=520 in-interface="vlan3 - VoIP" protocol=\
    udp
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
    in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
    ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
    ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related hw-offload=yes
add action=accept chain=forward comment=\
    "defconf: accept established,related, untracked" connection-state=\
    established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
    connection-state=invalid
add action=drop chain=forward comment=\
    "defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
    connection-state=new in-interface-list=WAN
add action=drop chain=forward comment=\
    "Drop all new unicast traffic from vlan3 & 2 (Voip & Iptv) not DSTNATed" \
    connection-nat-state=!dstnat connection-state=new dst-address-type=\
    unicast in-interface-list="IPTV & VoIP"
add action=drop chain=forward comment=\
    "block Guest WiFi - Stell - IoT other networks" dst-address=\
    192.168.0.0/16 src-address=192.168.96.0/20
add action=drop chain=forward comment=\
    "block LAN accesing Guest WiFi - Stell - IoT" dst-address=\
    192.168.96.0/20 src-address=192.168.13.0/24
/ip firewall mangle
add action=set-priority chain=postrouting new-priority=5 out-interface=\
    "vlan3 - VoIP" passthrough=yes
add action=set-priority chain=postrouting new-priority=4 out-interface=\
    "vlan2 - IPTV" passthrough=yes
add action=set-priority chain=postrouting new-priority=1 out-interface=\
    "PPPoE Client - Vlan6"
/ip firewall nat
add action=masquerade chain=srcnat comment=Hairpin-NAT dst-address=\
    192.168.13.0/24 src-address=192.168.13.0/24
add action=masquerade chain=srcnat comment="defconf: masquerade" \
    ipsec-policy=out,none out-interface-list=WAN
add action=dst-nat chain=dstnat comment=\
    "VOD Movistar 1 Desco -- 192.168.77.196" dst-address-type=local \
    in-interface="vlan2 - IPTV" to-addresses=192.168.77.196
add action=dst-nat chain=dstnat comment="HTTPS qBitorrent" dst-address-list=\
    public-ip dst-port=8080 protocol=tcp src-port="" to-addresses=\
    192.168.13.50 to-ports=8080
add action=masquerade chain=srcnat comment="voip: masq voip" out-interface=\
    "vlan3 - VoIP"
/ip route
add disabled=no distance=1 dst-address=192.168.3.0/24 gateway=\
    wireguard-sts-seixo pref-src=0.0.0.0 routing-table=main scope=30 \
    suppress-hw-offload=no target-scope=10
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www-ssl certificate=mk-estribela.valero-torres.es disabled=no
set api disabled=yes
set api-ssl disabled=yes
/routing igmp-proxy
set query-interval=30s quick-leave=yes
/routing igmp-proxy interface
add alternative-subnets=0.0.0.0/0 interface="vlan2 - IPTV" upstream=yes
add interface=ether1
/routing rip interface-template
add disabled=no instance=rip interfaces="vlan2 - IPTV,vlan3 - VoIP" mode=\
    passive source-addresses=""
/system clock
set time-zone-name=Europe/Madrid
/system identity
set name=mk-estribela
/system routerboard settings
set auto-upgrade=yes
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
Despues de revisarlo otra vez, me faltaba una regla de NAT por definir... No se porque se me escapo las 5 primeras veces que loe he revisado.... pero ya lo he encontrado ya aplicado y ahora funciona

Código:
/ip firewall nat
add action=masquerade chain=srcnat comment=\
    "masq. vlan2 & vlan3 (Iptv & Voip)" out-interface-list=Vlan2&3
 
Despues de revisarlo otra vez, me faltaba una regla de NAT por definir... No se porque se me escapo las 5 primeras veces que loe he revisado.... pero ya lo he encontrado ya aplicado y ahora funciona

Código:
/ip firewall nat
add action=masquerade chain=srcnat comment=\
"masq. vlan2 & vlan3 (Iptv & Voip)" out-interface-list=Vlan2&3

Te funciona el VOD con esa configuración?
 
Te funciona el VOD con esa configuración?
Si, todo funcionando correctamente. Aun que la he editado para añadir el puerto del DECO a un Brigde. Esto lo hago para poder asignar el puerto del Deco a ese Brigde y no tener que modificar el cliente DHCP, IGPM Proxy cada vez que lo cambio de lugar. "Casa cableada"
Info, solo es un DECO
 
Si, todo funcionando correctamente. Aun que la he editado para añadir el puerto del DECO a un Brigde. Esto lo hago para poder asignar el puerto del Deco a ese Brigde y no tener que modificar el cliente DHCP, IGPM Proxy cada vez que lo cambio de lugar. "Casa cableada"
Info, solo es un DECO

Tienes puesto el HGU en algún sitio? O es solo el Mikrotik y ya está.
 
El HGU esta en su caja y ya guardado en el trastero :)
Mi SETUP es || ONT Nokia g-010g-p --> Mikrotik --> Deco
Buenas, no fuí capaz a hacer todo funcionar. El cambio de canales es algo lento, y el videoclub no me funciona. Sería posible contactar contigo directamente por otro sitio para poder ver contigo, donde puedo tener el fallo?

Muchas gracias!
 
Te podría ayudar... pero mis horarios son complicados. Si lo prefieres te paso el export de mi configuración y seria aplicarla.
 
Te podría ayudar... pero mis horarios son complicados. Si lo prefieres te paso el export de mi configuración y seria aplicarla.
Pues si puedes, te lo agradecería. Entiendo que serían las reglas de FW, y saber que versión tienes de RouterOS.

Muchas gracias!
 
La configuración funciona al 100% bien para la TV y para el 99 % de las sitios WEB.... pero algunos no funciona como la el servicio de actualización del Nod32 que me dice que esta cerrado algun puerto.
Si aplico la configuración que Pocoyo publico con solamente la VoIP todo funciona bien pero no tengo la TV... Alguna idea Pocoyo?
 
La configuración funciona al 100% bien para la TV y para el 99 % de las sitios WEB.... pero algunos no funciona como la el servicio de actualización del Nod32 que me dice que esta cerrado algun puerto.
Si aplico la configuración que Pocoyo publico con solamente la VoIP todo funciona bien pero no tengo la TV... Alguna idea Pocoyo?
En la v7, he conseguido haciendo mezcla de config entre parte de la tuya y la de pocoyo, pero no me funciona el Videoclub y el cambio de canales es lento, no se si hay alguna manera de optimizarlo.
 
He vuelto aplicar la configuración desde un anterior BACKUP y ahora me va todo con el DECO como URL's o servicios "Nod32" al 100%. Los cambios son mínimos respecto al export que he dejado antes primero que he echo fue quitar del Interface List la interfaz Eth1 "Sin definir en ninguna lista"

Dejo aquí mis reglas de Firewall

Código:
[xxxxx@xxxxx] /ip/firewall/filter> print
Flags: X - disabled, I - invalid; D - dynamic
 0  D ;;; special dummy rule to show fasttrack counters
      chain=forward action=passthrough

 1    ;;; defconf: accept established,related,untracked
      chain=input action=accept connection-state=established,related,untracked

 2    ;;; defconf: drop invalid
      chain=input action=drop connection-state=invalid log=no log-prefix=""

 3    ;;; defconf: accept ICMP
      chain=input action=accept protocol=icmp

 4    ;;; vpn: allow wireguard-rw
      chain=input action=accept protocol=udp dst-port=13231 log=no log-prefix=""

 5    ;;; vpn: allow wireguard-sts-seixo
      chain=input action=accept protocol=udp dst-port=13232-13233 log=no log-prefix=""

 6    ;;; defconf: accept to local loopback (for CAPsMAN)
      chain=input action=accept dst-address=127.0.0.1

 7    ;;; IPTV : Accept vlan2 - Iptv IGMP packets
      chain=input action=accept protocol=igmp in-interface=vlan2 - IPTV

 8    ;;; IPTV : Accept vlan2  - IPTV  multicast & broadcast traffic
      chain=input action=accept dst-address-type=!unicast in-interface=vlan2 - IPTV log=no log-prefix=""

 9    ;;; VoIP: accept rip multicast traffic
      chain=input action=accept protocol=udp dst-address=224.0.0.9 in-interface=vlan3 - VoIP dst-port=520 log=no log-prefix=""

10    ;;; defconf: drop all not coming from LAN
      chain=input action=drop in-interface-list=!LAN log=no log-prefix=""

11    ;;; defconf: accept in ipsec policy
      chain=forward action=accept ipsec-policy=in,ipsec

12    ;;; defconf: accept out ipsec policy
      chain=forward action=accept ipsec-policy=out,ipsec

13    ;;; defconf: fasttrack
      chain=forward action=fasttrack-connection hw-offload=yes connection-state=established,related

14    ;;; defconf: accept established,related, untracked
      chain=forward action=accept connection-state=established,related,untracked

15    ;;; defconf: drop invalid
      chain=forward action=drop connection-state=invalid log=no log-prefix=""

16    ;;; defconf: drop all from WAN not DSTNATed
      chain=forward action=drop connection-state=new connection-nat-state=!dstnat in-interface-list=WAN log=no log-prefix=""

17    ;;; block Guest WiFi - STELLANTIS - IoT other networks
      chain=forward action=drop src-address=192.168.96.0/20 dst-address=192.168.0.0/16 log=no log-prefix=""

18    ;;; block LAN accesing Guest WiFi - STELLANTIS - IoT
      chain=forward action=drop src-address=192.168.13.0/24 dst-address=192.168.96.0/20 log=no log-prefix=""

Código:
[xxxxx@xxxxx] /ip/firewall/nat> print
Flags: X - disabled, I - invalid; D - dynamic
 0    ;;; Hairpin-NAT
      chain=srcnat action=masquerade src-address=192.168.13.0/24 dst-address=192.168.13.0/24

 1    ;;; defconf: masquerade
      chain=srcnat action=masquerade out-interface-list=WAN ipsec-policy=out,none

 2    ;;; HTTPS qBitorrent
      chain=dstnat action=dst-nat to-addresses=192.168.13.50 to-ports=8080 protocol=tcp dst-address-list=public-ip src-port="" dst-port=8080

 3    ;;; VoIP: masquerade vlan3 - VoIP
      chain=srcnat action=masquerade out-interface=vlan3 - VoIP log=no log-prefix=""

 4    ;;; IPTV : masquerade valn2 - IPTV
      chain=srcnat action=masquerade out-interface=vlan2 - IPTV log=no log-prefix=""

 5    ;;; VOD Movistar 1 Desco
      chain=dstnat action=dst-nat to-addresses=192.168.77.195 dst-address-type=local in-interface=vlan2 - IPTV log=no log-prefix=""

Código:
[xxxxx@xxxxx] /ip/firewall/mangle> print
Flags: X - disabled, I - invalid; D - dynamic
 0  D ;;; special dummy rule to show fasttrack counters
      chain=prerouting action=passthrough

 1  D ;;; special dummy rule to show fasttrack counters
      chain=forward action=passthrough

 2  D ;;; special dummy rule to show fasttrack counters
      chain=postrouting action=passthrough

 3    chain=postrouting action=set-priority new-priority=5 passthrough=yes out-interface=vlan3 - VoIP log=no log-prefix=""

 4    chain=postrouting action=set-priority new-priority=4 passthrough=yes out-interface=vlan2 - IPTV log=no log-prefix=""

 5    chain=postrouting action=set-priority new-priority=1 out-interface=PPPoE Client - Vlan6
 
Algo le pasa a esta configuración para que funcione la TV de Movistar. Restauro la configuración a un estado que VoIP + Internet funciona y aplico la configuración de la IPTV y que todo funciona de maravilla... pero si reinicio el MK, el internet deja de funciona correctamente...

No se lo que puede estar pasando. Alguien que le pase algo similar y nos pueda echar una mano ?
 
Última edición:
Arriba