MANUAL: Mikrotik, configuraciones básicas ISPs - RouterOS v7

Siguiendo esta guía tuya https://www.adslzone.net/foro/mikrotik.199/manual-mikrotik-bridge-vlan-filtering.564505/ he conseguido filtrar las vlan y que el livebox sincronice, así que ya tengo el teléfono. He añadido un adress, pool, network y server dhcp para la vlan del livebox y listo.
Vale, eso está perfecto. Pero no me gusta, me explico: volvemos a la situación inicial, donde tenemos que inventarnos un DHCP para esa VLAN sólo para que la coja el livebox. Lo suyo sería que el propio livebox fuera capaz de obtener IP pública, como si estuviera conectado directamente a la ONT, y que funcionase como router, no como AP.

Una pregunta, si conseguimos lo anterior, ¿te vendría bien tener el desco pinchado al livebox? Porque no ahorraríamos bastante config. Es decir, por ejemplo, tener ether1 y ether2 en un bridge como WAN. La ONT conectada a ether1, el livebox a ether2, y el desco colgando del livebox, que ahora tendría todos los servicios. Tus puertos LAN irían del 3 al 10.

Saludos!
 
Vale, eso está perfecto. Pero no me gusta, me explico: volvemos a la situación inicial, donde tenemos que inventarnos un DHCP para esa VLAN sólo para que la coja el livebox. Lo suyo sería que el propio livebox fuera capaz de obtener IP pública, como si estuviera conectado directamente a la ONT, y que funcionase como router, no como AP.

Una pregunta, si conseguimos lo anterior, ¿te vendría bien tener el desco pinchado al livebox? Porque no ahorraríamos bastante config. Es decir, por ejemplo, tener ether1 y ether2 en un bridge como WAN. La ONT conectada a ether1, el livebox a ether2, y el desco colgando del livebox, que ahora tendría todos los servicios. Tus puertos LAN irían del 3 al 10.

Saludos!
Claro, es es la configuración que estaba buscando.

Enviado desde mi SM-N986B mediante Tapatalk
 
Venga, pues entonces recapitulamos, que el tema es muchísimo más simple. Dale reset al equipo, déjale que cargue la config por defecto y, sobre esa, aplica esta, a ver cómo respira.
Código:
# Damos de alta un bridge para la WAN, donde conectaremos
# ONT y router de operadora
/interface bridge
add name=bridge-wan vlan-filtering=yes

# Metemos ether1 y ether2 en el bridge-wan
/interface bridge port
add bridge=bridge-wan interface=ether1
set [find interface=ether2] bridge=bridge-wan

# Damos de alta las VLANs que usará el bridge-wan
/interface vlan
add interface=bridge-wan name=internet vlan-id=832 arp=proxy-arp
add interface=bridge-wan name=iptv vlan-id=838 arp=proxy-arp

# Filtramos las VLANS en el bridge-wan
# Marcamos todo taggeado, en ambos puertos
/interface bridge vlan
add bridge=bridge-wan tagged=bridge-wan,ether1,ether2 vlan-ids=832
add bridge=bridge-wan tagged=bridge-wan,ether1,ether2 vlan-ids=838

# Redefinimos la interfaz WAN, apuntando a nuestra interfaz 'internet'
/interface list member
set [find list=WAN] interface=internet

# Modificamos el cliente DHCP, para obtener IP pública por la vlan de 'internet'
/ip dhcp-client
set 0 interface=internet

El livebox estaría conectado a ether2 y en modo router, es decir, usando su puerto WAN.

Saludos!
 
Venga, pues entonces recapitulamos, que el tema es muchísimo más simple. Dale reset al equipo, déjale que cargue la config por defecto y, sobre esa, aplica esta, a ver cómo respira.
Código:
# Damos de alta un bridge para la WAN, donde conectaremos
# ONT y router de operadora
/interface bridge
add name=bridge-wan vlan-filtering=yes

# Metemos ether1 y ether2 en el bridge-wan
/interface bridge port
add bridge=bridge-wan interface=ether1
set [find interface=ether2] bridge=bridge-wan

# Damos de alta las VLANs que usará el bridge-wan
/interface vlan
add interface=bridge-wan name=internet vlan-id=832 arp=proxy-arp
add interface=bridge-wan name=iptv vlan-id=838 arp=proxy-arp

# Filtramos las VLANS en el bridge-wan
# Marcamos todo taggeado, en ambos puertos
/interface bridge vlan
add bridge=bridge-wan tagged=bridge-wan,ether1,ether2 vlan-ids=832
add bridge=bridge-wan tagged=bridge-wan,ether1,ether2 vlan-ids=838

# Redefinimos la interfaz WAN, apuntando a nuestra interfaz 'internet'
/interface list member
set [find list=WAN] interface=internet

# Modificamos el cliente DHCP, para obtener IP pública por la vlan de 'internet'
/ip dhcp-client
set 0 interface=internet

El livebox estaría conectado a ether2 y en modo router, es decir, usando su puerto WAN.

Saludos!
Hola, hecho.

Tengo internet en la lan (puertos del 3-10) pero no en el Livebox (ni ningún cacharro conectado a él) que sigue sin sincronizar ni tener internet.
He probado a resetear el livebox a valores de fabrica y tampoco funciona.
 
Edita las dos interface VLAN y quita el proxy-arp de ellas, a ver qué hace. Si no funciona, mándame la config tal y como la tengas en un export.

Saludos!
 
Sigue igual y cada dos por tres pierdo los DNS y tengo que reiniciar el router
 

Adjuntos

  • KDL.zip
    1.6 KB · Visitas: 25
Entro un momento para decir que clonar la mac del livebox en la interface wan del mikrotik hizo la magia y ahora puedo tener el livebox en modo router y el teléfono funcionando.

La pega es que la TV (conectada a livebox) sigue igual, no se ven los canales IP, sólo los OTT y el caso es que me dice que está disponible (también me lo decia en elmodo AP).
Livebox.jpg


Dejo la configuración para que le echéis un vistazo a ver que se os ocurre.
 

Adjuntos

  • KDL.zip
    2.2 KB · Visitas: 28
Sigues metiendo vlans en el bridge como puertos, y ya te comenté que es el principal error de la config que copiaste de github. Por ahí no vas bien, incluso si te llegase a funcionar.

Prueba eso mismo, pero con la segunda configuración que te mandé, la del bridge-wan. La simplifico aún más, porque en esa config el filtrado no es necesario, ya que todo va "tagged". Al igual que antes, si el "proxy-arp" sobre las VLANs no te funciona correctamente, quítales esa opción (aunque estoy casi convencido de que en este setup es necesario ese flag).
Código:
# Damos de alta un bridge para la WAN, donde conectaremos
# ONT y router de operadora
/interface bridge
add name=bridge-wan igmp-snooping=yes \
  admin-mac=XXXXXXXXXXXXXX auto-mac=no

# Metemos ether1 y ether2 en el bridge-wan
/interface bridge port
add bridge=bridge-wan interface=ether1
set [find interface=ether2] bridge=bridge-wan

# Damos de alta las VLANs que usará el bridge-wan
/interface vlan
add interface=bridge-wan name=internet vlan-id=832 arp=proxy-arp
add interface=bridge-wan name=iptv vlan-id=838 arp=proxy-arp

# Redefinimos la interfaz WAN, apuntando a nuestra interfaz 'internet'
/interface list member
set [find list=WAN] interface=internet

# Modificamos el cliente DHCP, para obtener IP pública por la vlan de 'internet'
/ip dhcp-client
set 0 interface=internet

Saludos!
 
Nada, imposible, tengo internet pero el livebox sigue sin funcionar con esta configuración (ni cambiando lo de proxy-arp). Creo que por la razón que sea el livebox no obtiene la ip pública.
 
Última edición:
Nada, imposible, tengo internet pero el livebox sigue sin funcionar con esta configuración (ni cambiando lo de proxy-arp). Creo que por la razón que sea el livebox no obtiene la ip pública.
Mete esta, a ver qué hace

Código:
# Damos de alta un bridge para la WAN, donde conectaremos
# ONT y router de operadora
/interface bridge
add name=bridge-wan igmp-snooping=yes vlan-filtering=no

# Metemos ether1 y ether2 en el bridge-wan
/interface bridge port
add bridge=bridge-wan interface=ether1 pvid=832 admit-only-untagged-and-priority-tagged
set [find interface=ether2] bridge=bridge-wan frame-types=admit-only-vlan-tagged

# Damos de alta las VLANs que usará el bridge-wan
/interface vlan
add interface=bridge-wan name=internet vlan-id=832 arp=proxy-arp
add interface=bridge-wan name=iptv vlan-id=838 arp=proxy-arp

# Filtramos las VLANS en el bridge-wan. La 832 (internet) irá untagged a ether1
# y marcamos todo taggeado a ether2 = livebox
/interface bridge vlan
add bridge=bridge-wan tagged=bridge-wan,ether2 vlan-ids=832
add bridge=bridge-wan tagged=bridge-wan,ether2 vlan-ids=838

# Redefinimos la interfaz WAN, apuntando a nuestra interfaz del bridge
/interface list member
set [find list=WAN] interface=bridge-wan

# Modificamos el cliente DHCP, para obtener IP pública el bridge
/ip dhcp-client
set 0 interface=bridge-wan

# Y por último, activamos el vlan filtering en el bridge
/interface bridge
set [find name=bridge-wan] vlan-filtering=yes
 
Mete esta, a ver qué hace

Código:
# Damos de alta un bridge para la WAN, donde conectaremos
# ONT y router de operadora
/interface bridge
add name=bridge-wan igmp-snooping=yes vlan-filtering=no

# Metemos ether1 y ether2 en el bridge-wan
/interface bridge port
add bridge=bridge-wan interface=ether1 pvid=832 admit-only-untagged-and-priority-tagged
set [find interface=ether2] bridge=bridge-wan frame-types=admit-only-vlan-tagged

# Damos de alta las VLANs que usará el bridge-wan
/interface vlan
add interface=bridge-wan name=internet vlan-id=832 arp=proxy-arp
add interface=bridge-wan name=iptv vlan-id=838 arp=proxy-arp

# Filtramos las VLANS en el bridge-wan. La 832 (internet) irá untagged a ether1
# y marcamos todo taggeado a ether2 = livebox
/interface bridge vlan
add bridge=bridge-wan tagged=bridge-wan,ether2 vlan-ids=832
add bridge=bridge-wan tagged=bridge-wan,ether2 vlan-ids=838

# Redefinimos la interfaz WAN, apuntando a nuestra interfaz del bridge
/interface list member
set [find list=WAN] interface=bridge-wan

# Modificamos el cliente DHCP, para obtener IP pública el bridge
/ip dhcp-client
set 0 interface=bridge-wan

# Y por último, activamos el vlan filtering en el bridge
/interface bridge
set [find name=bridge-wan] vlan-filtering=yes
No, con esta configuración no funciona nada, no tengo internet y el livebox no se entera.

Espero no estar dandote mucho la tabarra.
 
No, con esta configuración no funciona nada, no tengo internet y el livebox no se entera.

Espero no estar dandote mucho la tabarra.
Nada, tabarra ninguna. Si la putada es que no me ha tocado montar ninguna conexión de Orange con Mikrotik, así que no tengo mucha idea de cómo maneja las VLANs ese operador. Pero descuida, que daremos con la tecla.

Una pregunta tonta. ¿Tienes algún switch perdido por algún rincón de casa? Por ponerlo entre la ONT y ambos routers, y ver cómo se comportan.

Saludos!
 
Nada, tabarra ninguna. Si la putada es que no me ha tocado montar ninguna conexión de Orange con Mikrotik, así que no tengo mucha idea de cómo maneja las VLANs ese operador. Pero descuida, que daremos con la tecla.

Una pregunta tonta. ¿Tienes algún switch perdido por algún rincón de casa? Por ponerlo entre la ONT y ambos routers, y ver cómo se comportan.

Saludos!
Hola, ya lo he hecho .

Así funciona todo con una salvedad, cuando reinicio el Livebox no puede haber otra conexión en el switch o no conecta. Es desconectar el mkt del switch y enseguida conecta el Livebox. Funciona la TV, etc...

Lo que no he probado es a tenerlo tiempo para ver como se comportan los dos juntos.

Enviado desde mi SM-N986B mediante Tapatalk
 
Hola, ya lo he hecho .

Así funciona todo con una salvedad, cuando reinicio el Livebox no puede haber otra conexión en el switch o no conecta. Es desconectar el mkt del switch y enseguida conecta el Livebox. Funciona la TV, etc...

Lo que no he probado es a tenerlo tiempo para ver como se comportan los dos juntos.

Enviado desde mi SM-N986B mediante Tapatalk
Vale, eso nos da una información muy, muy importante: el CPE se está validando, muy probablemente, por dirección MAC (como ya comprobaste tú el otro día cuando clonaste la dirección).

En ese caso, tenemos dos opciones de configuración claras: DMZ o livebox como AP.

En DMZ, significa que tu ONT va conectada al livebox, del cual partirían desco y teléfono (lado operador), más una DMZ al router mikrotik. No es el mejor setup, pero sí uno muy simple y que siempre va a funcionar. Vas a tener doble NAT, pero la primera te la “saltas” al abrirle todos los puertos con la DMZ a la IP del Mikrotik.

La segunda es pasar el manejo de las VLANs al Mikrotik, conectado directamente a la ONT, clonando la MAC del Livebox en la interfaz ether1 que nos haga de WAN, y pasando el livebox a modo AP. En este modo necesitaríamos conocer las rutas que maneja el router de Oranga (estáticas o dinámicas), para darlas de alta en el Mikrotok y hacer que cuando el AP solicite un camino que se entrega por la vlan de video, sea capaz de encontrarlo en el router Mikrotik.

El primer setup es super sencillo, y, aunque no es perfecto, te animo a probarlo. El segundo, es por el que tenemos que pelear y acabar sacando, porque es el realmente interesante.

Saludos!
 
Vale, eso nos da una información muy, muy importante: el CPE se está validando, muy probablemente, por dirección MAC (como ya comprobaste tú el otro día cuando clonaste la dirección).

En ese caso, tenemos dos opciones de configuración claras: DMZ o livebox como AP.

En DMZ, significa que tu ONT va conectada al livebox, del cual partirían desco y teléfono (lado operador), más una DMZ al router mikrotik. No es el mejor setup, pero sí uno muy simple y que siempre va a funcionar. Vas a tener doble NAT, pero la primera te la “saltas” al abrirle todos los puertos con la DMZ a la IP del Mikrotik.

La segunda es pasar el manejo de las VLANs al Mikrotik, conectado directamente a la ONT, clonando la MAC del Livebox en la interfaz ether1 que nos haga de WAN, y pasando el livebox a modo AP. En este modo necesitaríamos conocer las rutas que maneja el router de Oranga (estáticas o dinámicas), para darlas de alta en el Mikrotok y hacer que cuando el AP solicite un camino que se entrega por la vlan de video, sea capaz de encontrarlo en el router Mikrotik.

El primer setup es super sencillo, y, aunque no es perfecto, te animo a probarlo. El segundo, es por el que tenemos que pelear y acabar sacando, porque es el realmente interesante.

Saludos!
Hola, perdona la tardanza pero he andado liado.

1.- Mi gozo en un pozo, con el switch detras de la ONT y delante de los dos routers acaban desconectandose y dando problemas.

2.- El DMZ ya lo tuve hace años con ONO y sus famosos cable modems-routers hasta que se conseguía dejarlos en modo bridge. Se que va a funcionar pero no es lo más bonito (por así decirlo).

3.- Sinceramente la opción que me gustaría hacer funcionar es la de tener el mikrotik como router y el livebox como AP y switch con el teléfono y la tv funcionando. En principio me funciona todos menos los canales IPTV que se quedan en negro. He probado a meter sin tocar nada la configuración de la usuaria @noemi-abril (con la misma versión de RouterOs, incluso) y tampoco me funciona (alguna vez funciona algún canal).

Pdta. ¿Es necesaria esta instrucción en la configuración?, cada vez que la activo me baja drásticamente la velocidad?

Código:
/interface bridge settings
set use-ip-firewall-for-pppoe=yes use-ip-firewall-for-vlan=yes
 
Hola, perdona la tardanza pero he andado liado.

1.- Mi gozo en un pozo, con el switch detras de la ONT y delante de los dos routers acaban desconectandose y dando problemas.

2.- El DMZ ya lo tuve hace años con ONO y sus famosos cable modems-routers hasta que se conseguía dejarlos en modo bridge. Se que va a funcionar pero no es lo más bonito (por así decirlo).

3.- Sinceramente la opción que me gustaría hacer funcionar es la de tener el mikrotik como router y el livebox como AP y switch con el teléfono y la tv funcionando. En principio me funciona todos menos los canales IPTV que se quedan en negro. He probado a meter sin tocar nada la configuración de la usuaria @noemi-abril (con la misma versión de RouterOs, incluso) y tampoco me funciona (alguna vez funciona algún canal).

Pdta. ¿Es necesaria esta instrucción en la configuración?, cada vez que la activo me baja drásticamente la velocidad?

Código:
/interface bridge settings
set use-ip-firewall-for-pppoe=yes use-ip-firewall-for-vlan=yes
No, en absoluto es necesaria. Es otro error gordo, de hecho.

Para usarlo en el modo que quieres, hay una pieza que me falta: cómo funciona el enrutado del multicast de Orange.

Dale una oportunidad al DMZ. Incluso puedes llegar a ahorrarte el doble NAT, si el router de Orange te permite meter una ruta estática al mikrotik.

Saludos!
 
No, en absoluto es necesaria. Es otro error gordo, de hecho.

Para usarlo en el modo que quieres, hay una pieza que me falta: cómo funciona el enrutado del multicast de Orange.

Dale una oportunidad al DMZ. Incluso puedes llegar a ahorrarte el doble NAT, si el router de Orange te permite meter una ruta estática al mikrotik.

Saludos!
Esto es todo lo que permite el Livebox 6+

Probaré el DMZ.







Enviado desde mi SM-N986B mediante Tapatalk
 
Bueno, pues ya está colocado el Livebox como principal haciendo DMZ a la IP del mikrotik y todo está funcionando, y sin doble NAT aparentemente (por lo menos la PS4 no se queja, NAT tipo2).

Por poner una pega los aparatos que se conectan al Livebox no se pueden ver con el resto y pierdo el uso de pihole que tengo instalado en la subred del mikrotik. De momento lo he solucionado (el que mas me interesa es mi portatil) usando wireguard. ¿Hay alguna posibilidad de que los equipos se vean entre si sin pasar por una VPN?
 
Sí, si el livebox te permite meter una ruta estática. ¿Puedes?

Saludos!
 
Arriba