MANUAL: Mikrotik, configuraciones básicas ISPs - RouterOS v7

Jejeje para gustos colores. Pero esto es como el que se compra un Mac y lo tiene corriendo Windows :eek::p:D

Saludos!
OpenWRT solo lo cargaría en un viejo router Netgear modelo: R7500 Nighthawk X4 AC2350 WiFi Router, como para luego usarlo como AP. Pero lei q no le funciona la banda de 5ghz usando openWRT. :(

Lo fuerte de MK es routerOS, jamas le cargaría openWRT.


Sldos.
 
Última edición:
Muy buenas,

Si me permitís la sugerencia, he visto que en este hilo no está puesta la config para la Triple VLAN de Movistar, tengo entendido que había una pequeña variación para V7. Estaría bien tenerlo reflejado al igual que el hilo original de configuraciones. Gracias.

S@lu2.
 
Última edición:
Muy buenas,

Si me permitís la sugerencia, he visto que en este hilo no está puesta la config para la Triple VLAN de Movistar, tengo entendido que había una pequeña variación para V7. Estaría bien tenerlo reflejado al igual que el hilo original de configuraciones. Gracias.

S@lu2.
Teníamos pendiente rehacerlas compi, pero como no acabo de dar con una solución al tema del ALG para RTSP, me da que vamos a acabar montando la misma config, pero con las pequeñas variaciones de RIP.
Una pena, porque ya estaría bien que se curraran un helper para RTSP y olvidarnos del script, que trabaja matando moscas a cañonazos (con todos mis respetos para toniros) alternando una DMZ por cada desco.

Saludos!
 
ya estaría bien que se curraran un helper para RTSP y olvidarnos del script


It's not directly listed in IP>Firewall>Service Ports under 7.2rc3.

But have you tried using the "sip" ALG there with your RTSP port listed? ALG really deals with SDP, so the "sip" ALG may not care it's actually RTSP. Hard to know, but might be possible.

Alternatively, Mikrotik does support UPnP which some/most cameras support, that combined with scripts/firewall rules might also work to deal with multiple subnets of cameras. In UPnP, you can control the "internal"/"external" interface – and nothing says the "external" UPnP interface has to be a WAN.

Un hilo del foro oficial de Mikrotik donde piden la incorporación de RTSP helper para RouterOS, por si te sirve de ayuda o te da alguna nueva idea al respecto.
Saludos.
 



Un hilo del foro oficial de Mikrotik donde piden la incorporación de RTSP helper para RouterOS, por si te sirve de ayuda o te da alguna nueva idea al respecto.
Saludos.
Jejejeje, el que sea me ha leído la mente. Esas dos cosas son justo las que ya hemos intentado probar, verdad @roolezz? El compi y yo hemos estado de probeteo, para ver si de alguna manera le hacíamos la rosca al tema y nos quitábamos el script. Y juraría que ha probado ambas.

Me queda la duda de cómo probamos el UPnP, pero sospecho que le dio todas las vueltas posibles, jugando con la interfaz externa/interna. Esta quizás sea la mejor baza, porque el SIP ALG no detecta la petición al 554 como para abrir el puerto que manda el protocolo cuando responde.

No obstante, seguiremos investigando, me parece que estos cabrones puedan tener alto embebido que haga lo mismo, y de ahí que pasen cuando la gente les pide que implementen eso.

Saludos!
 
He puesto la version 7 en mi RB951G-2HnD, que he prejubilado por el rb750gr3 y tengo la triple Vlan de Vomistar , funciona todo, se ve la tele , pero no se ve el videoclub ni los menus del deco ,
sobre el telefono por ip , no puedo decir ya que mis telefonos estan conectados a la ONT.
si necesitas que haga de conejillo de indias , me lo decís y pruebo lo que me digais.
Por que entiendo que no funciona lo del menu y el videoclub no ? o he hecho algo mal yo?
 
He puesto la version 7 en mi RB951G-2HnD, que he prejubilado por el rb750gr3 y tengo la triple Vlan de Vomistar , funciona todo, se ve la tele , pero no se ve el videoclub ni los menus del deco ,
sobre el telefono por ip , no puedo decir ya que mis telefonos estan conectados a la ONT.
si necesitas que haga de conejillo de indias , me lo decís y pruebo lo que me digais.
Por que entiendo que no funciona lo del menu y el videoclub no ? o he hecho algo mal yo?
Postea el export; que lo veamos, a ver qué pinta tiene y si nos puede valer para documentarlo.

Saludos!
 
Jejejeje, el que sea me ha leído la mente. Esas dos cosas son justo las que ya hemos intentado probar, verdad @roolezz? El compi y yo hemos estado de probeteo, para ver si de alguna manera le hacíamos la rosca al tema y nos quitábamos el script. Y juraría que ha probado ambas.

Me queda la duda de cómo probamos el UPnP, pero sospecho que le dio todas las vueltas posibles, jugando con la interfaz externa/interna. Esta quizás sea la mejor baza, porque el SIP ALG no detecta la petición al 554 como para abrir el puerto que manda el protocolo cuando responde.

No obstante, seguiremos investigando, me parece que estos cabrones puedan tener alto embebido que haga lo mismo, y de ahí que pasen cuando la gente les pide que implementen eso.

Saludos!
@pokoyo, así es. Yo le he dado todas las vueltas habidas y por haber...pero sigue faltando el helper para poder desechar el script que ahora mismo tenemos para VOD. Creo que hasta que MK no lo implemente, no nos queda más que tirar de la config que ahora mismo tenemos para Movistar Triple Vlan, con los pequeños cambios de RIP para v7.

Ojalá y MK escuche las peticiones del hilo al que el compi @stargate4you hace mención!! Sería nuestra "tabla de salvación". No obstante sigo cacharreando y leyendo por si se me ocurriese alguna solución, y por supuesto a vuestra disposición para cuantas pruebas estiméis.

Ahora mismo tengo el MK en bridge "colgando" del HGU (una p***) pero es la única forma que no pixele la TV, ya que con el MK eran constantes las pixelaciones en TV directo...

Saludos!
 
Postea el export; que lo veamos, a ver qué pinta tiene y si nos puede valer para documentarlo.

Saludos!
Esta tarde lo pongo y pruebo un rato que no pixele la tele , que mi prueba fueron un minuto, y os paso el export .
Para el export tengo un montón de código por las direcciones estáticas , y los puertos abiertos, eso lo quito no ?
 
Esta tarde lo pongo y pruebo un rato que no pixele la tele , que mi prueba fueron un minuto, y os paso el export .
Para el export tengo un montón de código por las direcciones estáticas , y los puertos abiertos, eso lo quito no ?
Los leases quítalos, pero el NAT déjalo.

Saludos!
 
Postea el export; que lo veamos, a ver qué pinta tiene y si nos puede valer para documentarlo.

Saludos!
Vale , ya he probado un rato mas el router con la version 7 en la tele ,
se ven unos canales, si y otros no , hay mas que no, que que si . Y no tiene menu
pongo el export igualmente?
 
He puesto la configuración básica de ISP , de OS6 con la triple vlan con ether 2 separado , en el router que tengo OS 7 y funciona perfectamente, la tele y el vídeo club.

lo unico que esto no lo he puesto
/routing rip interface
add interface=voip-vlan3 passive=yes receive=v2
add interface=iptv-vlan2 passive=yes receive=v2
/routing rip network
add network=10.0.0.0/8
add network=172.26.0.0/16

y he puesto en su lugar
/routing/rip/instance
add afi=ipv4 disabled=no name=rip
/routing rip interface-template
add instance=rip interfaces=vlan3-telefono,vlan2-iptv mode=passive

Si quereis subo el export
Cuando decis que no subis la configuracion del ISP en V7.0 con triple Vlan , por que es?
 
Última edición:
Hola!!
A mi no se muy bien por que no me pasa el router de 112 megas de los 600 contratados! he probado todas las configuraciones que he visto por el foro pero nada....a alguien le ha pasado algo parecido?

Ahora mismo tengo esto:

admin@MikroTik] > export
# feb/02/2022 23:10:51 by RouterOS 7.1.1
# software id = 7SIA-A5XH
#
# model = RB4011iGS+5HacQ2HnD
# serial number = FXXXXXXXXXXX
/interface bridge
add igmp-snooping=yes name=LAN_Bridge
/interface ethernet
set [ find default-name=ether1 ] comment=WAN mac-address=XX:XX:XX:XX:XX:XX(La del anterior Router Vodafone) \
name=ether1-WAN
set [ find default-name=ether2 ] comment=LAN
/interface vlan
add interface=ether1-WAN name=vlan24 vlan-id=24
/interface pppoe-client
add add-default-route=yes disabled=no interface=vlan24 max-mru=1492 \
max-mtu=1492 name=pppoe-out1 use-peer-dns=yes user=\
VFAFXXXXXXXXXXXXXXX@vodafone
/interface list
add name=LAN
add name=WAN
/ip pool
add name=dhcp ranges=192.168.1.101-192.168.1.250
add name=TIVO ranges=192.168.0.251-192.168.0.253
/ip dhcp-server
add address-pool=dhcp interface=LAN_Bridge name=dhcp1
/port
set 0 name=serial0
set 1 name=serial1
/ppp profile
set *FFFFFFFE dns-server=192.168.3.250 local-address=192.168.3.250 \
remote-address=TIVO
/interface bridge port
add bridge=LAN_Bridge interface=ether2
add bridge=LAN_Bridge interface=ether3
add bridge=LAN_Bridge interface=ether4
add bridge=LAN_Bridge interface=ether5
add bridge=LAN_Bridge interface=ether6
add bridge=LAN_Bridge interface=ether7
add bridge=LAN_Bridge interface=ether8
add bridge=LAN_Bridge interface=ether9
add bridge=LAN_Bridge interface=ether10
add bridge=LAN_Bridge interface=sfp-sfpplus1
/interface list member
add interface=LAN_Bridge list=LAN
add interface=pppoe-out1 list=WAN
/interface pptp-server server
set authentication=mschap2 enabled=yes
/ip address
add address=192.168.1.1/16 interface=LAN_Bridge network=192.168.0.0
/ip dhcp-client
add add-default-route=no interface=vlan24 use-peer-ntp=no
/ip dhcp-server network
add address=192.168.0.0/16 dns-server=8.8.8.8,1.1.1.1 gateway=192.168.1.1 \
netmask=16
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,1.1.1.1
/ip dns static
add address=192.168.1.1 name=router
/ip firewall filter
add action=accept chain=input comment=\
"defconf: accept established,related,untracked" connection-state=\
established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" \
connection-state=invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
"defconf: accept to local loopback (for CAPsMAN)" dst-address=\
127.0.0.1
add action=drop chain=input comment=\
"defconf: drop all not coming from LAN" in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
connection-state=established,related hw-offload=yes
add action=accept chain=forward comment=\
"defconf: accept established,related, untracked" connection-state=\
established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
connection-state=invalid
add action=drop chain=forward comment=\
"defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="default configuration" \
out-interface=pppoe-out1
/ip firewall service-port
set ftp disabled=yes
/ip upnp
set enabled=yes
/ip upnp interfaces
add interface=ether2 type=internal
add interface=pppoe-out1 type=external
/system clock
set time-zone-name=Europe/Madrid
[admin@MikroTik] >
 
.
He puesto la configuración básica de ISP , de OS6 con la triple vlan con ether 2 separado , en el router que tengo OS 7 y funciona perfectamente, la tele y el vídeo club.

lo unico que esto no lo he puesto
/routing rip interface
add interface=voip-vlan3 passive=yes receive=v2
add interface=iptv-vlan2 passive=yes receive=v2
/routing rip network
add network=10.0.0.0/8
add network=172.26.0.0/16

y he puesto en su lugar
/routing/rip/instance
add afi=ipv4 disabled=no name=rip
/routing rip interface-template
add instance=rip interfaces=vlan3-telefono,vlan2-iptv mode=passive

Si quereis subo el export
Cuando decis que no subis la configuracion del ISP en V7.0 con triple Vlan , por que es?
Porque la quiero rehacer desde cero. Y porque como has podido comprobar tú mismo, es la de la V6x, pero cambiando los comandos de RIP, no cambia nada más.

Saludos!
 
Hola!!
A mi no se muy bien por que no me pasa el router de 112 megas de los 600 contratados! he probado todas las configuraciones que he visto por el foro pero nada....a alguien le ha pasado algo parecido?

Ahora mismo tengo esto:

admin@MikroTik] > export
# feb/02/2022 23:10:51 by RouterOS 7.1.1
# software id = 7SIA-A5XH
#
# model = RB4011iGS+5HacQ2HnD
# serial number = FXXXXXXXXXXX
/interface bridge
add igmp-snooping=yes name=LAN_Bridge
/interface ethernet
set [ find default-name=ether1 ] comment=WAN mac-address=XX:XX:XX:XX:XX:XX(La del anterior Router Vodafone) \
name=ether1-WAN
set [ find default-name=ether2 ] comment=LAN
/interface vlan
add interface=ether1-WAN name=vlan24 vlan-id=24
/interface pppoe-client
add add-default-route=yes disabled=no interface=vlan24 max-mru=1492 \
max-mtu=1492 name=pppoe-out1 use-peer-dns=yes user=\
VFAFXXXXXXXXXXXXXXX@vodafone
/interface list
add name=LAN
add name=WAN
/ip pool
add name=dhcp ranges=192.168.1.101-192.168.1.250
add name=TIVO ranges=192.168.0.251-192.168.0.253
/ip dhcp-server
add address-pool=dhcp interface=LAN_Bridge name=dhcp1
/port
set 0 name=serial0
set 1 name=serial1
/ppp profile
set *FFFFFFFE dns-server=192.168.3.250 local-address=192.168.3.250 \
remote-address=TIVO
/interface bridge port
add bridge=LAN_Bridge interface=ether2
add bridge=LAN_Bridge interface=ether3
add bridge=LAN_Bridge interface=ether4
add bridge=LAN_Bridge interface=ether5
add bridge=LAN_Bridge interface=ether6
add bridge=LAN_Bridge interface=ether7
add bridge=LAN_Bridge interface=ether8
add bridge=LAN_Bridge interface=ether9
add bridge=LAN_Bridge interface=ether10
add bridge=LAN_Bridge interface=sfp-sfpplus1
/interface list member
add interface=LAN_Bridge list=LAN
add interface=pppoe-out1 list=WAN
/interface pptp-server server
set authentication=mschap2 enabled=yes
/ip address
add address=192.168.1.1/16 interface=LAN_Bridge network=192.168.0.0
/ip dhcp-client
add add-default-route=no interface=vlan24 use-peer-ntp=no
/ip dhcp-server network
add address=192.168.0.0/16 dns-server=8.8.8.8,1.1.1.1 gateway=192.168.1.1 \
netmask=16
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,1.1.1.1
/ip dns static
add address=192.168.1.1 name=router
/ip firewall filter
add action=accept chain=input comment=\
"defconf: accept established,related,untracked" connection-state=\
established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" \
connection-state=invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
"defconf: accept to local loopback (for CAPsMAN)" dst-address=\
127.0.0.1
add action=drop chain=input comment=\
"defconf: drop all not coming from LAN" in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
connection-state=established,related hw-offload=yes
add action=accept chain=forward comment=\
"defconf: accept established,related, untracked" connection-state=\
established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
connection-state=invalid
add action=drop chain=forward comment=\
"defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="default configuration" \
out-interface=pppoe-out1
/ip firewall service-port
set ftp disabled=yes
/ip upnp
set enabled=yes
/ip upnp interfaces
add interface=ether2 type=internal
add interface=pppoe-out1 type=external
/system clock
set time-zone-name=Europe/Madrid
[admin@MikroTik] >
No me metáis con calzador comentarios que no vienen a cuento en hilos que no tratan en absoluto del tema que tratáis. Y, menos aún, os dediquéis a dejarme comentarios similares en varios hilos.
Si tienes un problema concreto y buscas mi atención y la del resto del foro, abre un hilo dedicado al problema. Sino es muy fácil que este comentario se diluya entre el tema del hilo principal, y lo único que conseguís es que alguien que venga al hilo buscando algo concreto, tenga que leerse varias páginas de temas que no vienen a cuento.

No te lo tomes a mal, te ha tocado a ti, pero esto va por todos. O seguimos una estructura y un orden, o tendré que empezar a borrar comentarios para organizarlo yo mismo. Y es algo que preferiría no tener que hacer.

Saludos!
 
.

Porque la quiero rehacer desde cero. Y porque como has podido comprobar tú mismo, es la de la V6x, pero cambiando los comandos de RIP, no cambia nada más.

Saludos!
Si necesitas el export que puse o algo dímelo y si quieres hacer alguna prueba me dices. Por las tardes noches puedo normalmente.
Mi pregunta de novato , era si la del ISP 6.x funcionaba , yo pensaba que no habíais conseguido que funcionara y por eso no estaba puesta . No se si me explico bien
 
Si necesitas el export que puse o algo dímelo y si quieres hacer alguna prueba me dices. Por las tardes noches puedo normalmente.
Mi pregunta de novato , era si la del ISP 6.x funcionaba , yo pensaba que no habíais conseguido que funcionara y por eso no estaba puesta . No se si me explico bien
No, la config vieja de triple play está funcionando desde las primeras betas de la v7. Simplemente, hay que adaptar los comandos de RIP.

Cuando tengamos algo nuevo más decene que la config vieja, lo postearemos aquí.

Saludos!
 
No me metáis con calzador comentarios que no vienen a cuento en hilos que no tratan en absoluto del tema que tratáis. Y, menos aún, os dediquéis a dejarme comentarios similares en varios hilos.
Si tienes un problema concreto y buscas mi atención y la del resto del foro, abre un hilo dedicado al problema. Sino es muy fácil que este comentario se diluya entre el tema del hilo principal, y lo único que conseguís es que alguien que venga al hilo buscando algo concreto, tenga que leerse varias páginas de temas que no vienen a cuento.

No te lo tomes a mal, te ha tocado a ti, pero esto va por todos. O seguimos una estructura y un orden, o tendré que empezar a borrar comentarios para organizarlo yo mismo. Y es algo que preferiría no tener que hacer.

Saludos!
Mil perdones....no me dejo crear un nuevo o hilo al ser mi primer mensaje y trate de consultarlo en este de configuración por si a alguien le había pasado
 
Arriba