MANUAL: Mikrotik, configuraciones básicas ISPs - RouterOS v7

Vale genial, entonces si pruebas ONT+Router DIGI, cuando te sincronice, a ver si te funciona el teléfono (se me ocurre que si teniéndolo contratado y no lo usas puede que se haya deshabilitado en algún reinicio).

Si levanta tono, entonces conectas de nuevo ONT+MikroTik con la misma config de este hilo y haces dos pruebas, una con el SIP activado (por defecto) y si no, prueba a desactivarlo y sincroniza de nuevo.

Ya no se me ocurre nada más.

S@lu2.
Pues nada, nuestro gozo en un pozo. He conectado el router de DIGI directo a la ONT y voilá habemus VoIP. Os pongo los datos por si os sirve de ayuda en alguna configuración, en plan DNS o puerta de enlace, no sé.
Os pongo también un export por si a mi se me ha pasado algo:

Código:
# jul/06/2022 16:57:59 by RouterOS 7.2.3
# software id = Y9V7-43DB
#
# model = RB750Gr3
# serial number = CC210B348613
/interface bridge
add admin-mac=C4:AD:34:C6:C9:3C auto-mac=no comment=defconf name=bridge
/interface wireguard
add listen-port=12345 mtu=1420 name=wireguard-rw
add listen-port=12346 mtu=1420 name=wireguard-sts
/interface vlan
add interface=ether5 name=vlan-wan-fake vlan-id=20
add interface=ether1 mtu=1492 name=vlan20-internet vlan-id=20
/interface pppoe-client
add add-default-route=yes disabled=no interface=vlan20-internet name=internet use-peer-dns=yes user=*********@digi
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface lte apn
set [ find default=yes ] ip-type=ipv4 use-network-apn=no
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp ranges=172.193.3.2-172.193.3.254
add name=vpn ranges=192.168.89.2-192.168.89.255
add name=vpn-pool-ramon ranges=172.193.5.2-172.193.5.254
/ip dhcp-server
add address-pool=dhcp interface=bridge name=defconf
/port
set 0 name=serial0
/ppp profile
add change-tcp-mss=yes dns-server=172.193.3.17,172.193.3.1 interface-list=LAN local-address=172.193.5.1 name=vpn-profile-ramon remote-address=vpn-pool-ramon use-encryption=\
    yes
add local-address=10.0.1.1 name=pppoe-fake remote-address=10.0.1.2
set *FFFFFFFE local-address=192.168.89.1 remote-address=vpn
/interface bridge port
add bridge=bridge comment=defconf ingress-filtering=no interface=ether2
add bridge=bridge comment=defconf ingress-filtering=no interface=ether3
add bridge=bridge comment=defconf ingress-filtering=no interface=ether4
add bridge=bridge comment=defconf ingress-filtering=no interface=ether5
/ip neighbor discovery-settings
set discover-interface-list=LAN
/ipv6 settings
set disable-ipv6=yes max-neighbor-entries=8192
/interface l2tp-server server
set authentication=mschap2 default-profile=vpn-profile-ramon enabled=yes use-ipsec=yes
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=prueba interface=wireguard-rw list=LAN
add interface=wireguard-sts list=LAN
add interface=internet list=WAN
/interface ovpn-server server
set auth=sha1,md5
/interface pppoe-server server
add default-profile=pppoe-fake disabled=no interface=vlan-wan-fake service-name=pppoe-server-fake
/interface pptp-server server
# PPTP connections are considered unsafe, it is suggested to use a more modern VPN protocol instead
set enabled=yes
/interface sstp-server server
set default-profile=default-encryption enabled=yes
/interface wireguard peers
add allowed-address=172.193.50.2/32 comment=iPhoneRW interface=wireguard-rw public-key="cTO2uNFojzcAZ4eSH9POuKabL+2nJrsGlAc5FPzD4UU="
add allowed-address=172.193.50.3/32 comment=MacBookRW interface=wireguard-rw public-key="pPYrGiL1ZZrRD+M34iRT9KTWRSZvcVhzRXpyn5AI8zQ="
add allowed-address=171.191.1.2/32,172.193.4.0/24 endpoint-port=12346 interface=wireguard-sts persistent-keepalive=5s public-key=\
    "******"
/ip address
add address=172.193.3.1/24 comment=defconf interface=bridge network=172.193.3.0
add address=172.193.50.1/24 interface=wireguard-rw network=172.193.50.0
add address=171.191.1.1/30 interface=wireguard-sts network=171.191.1.0
/ip cloud
set ddns-enabled=yes
/ip dhcp-client
add comment=defconf interface=ether1
add add-default-route=no interface=bridge use-peer-dns=no use-peer-ntp=no
/ip dhcp-server lease
add address=172.193.3.11 client-id=1:b0:5a:da:87:6b:a3 mac-address=B0:5A:DA:87:6B:A3 server=defconf
add address=172.193.3.243 client-id=1:e0:63:da:6d:51:d5 mac-address=E0:63:DA:6D:51:D5 server=defconf
add address=172.193.3.17 client-id=1:b8:27:eb:2f:4a:4e mac-address=B8:27:EB:2F:4A:4E server=defconf
add address=172.193.3.4 client-id=1:dc:cd:2f:69:62:fd mac-address=DC:CD:2F:69:62:FD server=defconf
add address=172.193.3.33 client-id=1:b8:bc:5b:9b:29:be mac-address=B8:BC:5B:9B:29:BE server=defconf
add address=172.193.3.3 client-id=1:98:9e:63:25:43:66 mac-address=98:9E:63:25:43:66 server=defconf
add address=172.193.3.19 client-id=1:9a:1f:1e:94:9c:1f mac-address=9A:1F:1E:94:9C:1F server=defconf
/ip dhcp-server network
add address=172.193.3.0/24 comment=defconf dns-server=172.193.3.17,1.1.1.1,172.193.3.1 gateway=172.193.3.1 netmask=24
/ip dns
set allow-remote-requests=yes servers=172.193.3.1,8.8.8.8
/ip dns static
add address=172.193.3.1 comment=defconf name=router.lan
/ip firewall filter
add action=accept chain=input comment="defconf: accept established,related,untracked" connection-state=established,related,untracked
add action=accept chain=input comment="allow IPsec" dst-port=4500,500 protocol=udp
add action=accept chain=input comment="allow l2tp" dst-port=1701 protocol=udp
add action=accept chain=input comment="allow IPsec NAT" dst-port=4500 protocol=udp
add action=accept chain=input comment="allow IKE" dst-port=500 protocol=udp
add action=accept chain=input comment="allow l2tp" dst-port=1701 protocol=udp
add action=accept chain=input comment="allow pptp" dst-port=1723 protocol=tcp
add action=accept chain=input comment="allow sstp" dst-port=443 protocol=tcp
add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment="defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=accept chain=input comment="vpn: allow wireguard-rw" dst-port=12345 protocol=udp
add action=accept chain=input src-address=172.193.50.0/24
add action=accept chain=input comment="vpn: allow wireguard-sts" dst-port=12346 protocol=udp
add action=accept chain=input src-address=171.191.1.0/24
add action=drop chain=input comment="defconf: drop all not coming from LAN" in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related hw-offload=yes
add action=accept chain=forward comment="defconf: accept established,related, untracked" connection-state=established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
add action=drop chain=forward comment="defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=out,none out-interface-list=WAN
add action=masquerade chain=srcnat comment="masq. vpn traffic" src-address=192.168.89.0/24
add action=masquerade chain=srcnat comment="masq. vpn traffic" src-address=172.193.5.0/24
add action=dst-nat chain=dstnat dst-port=51820 in-interface-list=WAN protocol=udp to-addresses=172.193.3.17 to-ports=51820
add action=dst-nat chain=dstnat dst-port=22 in-interface-list=WAN protocol=tcp to-addresses=172.193.3.17 to-ports=22
add action=masquerade chain=srcnat src-address=172.193.50.0/24
add action=masquerade chain=srcnat comment="masq. wireguard traffic" src-address=172.193.50.0/24
/ip route
add dst-address=172.193.4.0/24 gateway=171.191.1.2
/ip service
set www address=172.193.3.0/24,172.193.5.0/24,172.193.50.0/24
set winbox address=172.193.3.0/24,172.193.5.0/24,172.193.50.0/24
/ipv6 address
# address pool error: pool not found: pool6 (4)
add from-pool=pool6 interface=bridge
/ipv6 dhcp-client
add interface=internet pool-name=pool6 request=address,prefix
/ppp secret
add name=vpn
add name=usuario service=l2tp
add name=Letiphone service=l2tp
add name=RamonIpad service=l2tp
add name=MacBook service=l2tp
add name=*********@digi profile=pppoe-fake service=pppoe
/system clock
set time-zone-name=Europe/Madrid
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN

1657119376970.png
 
@Dexter91

No tiene nada que ver, pero la VLAN 20 que tienes creada sobre ether1 no debería tener el MTU a 1492. Las VLANs, siempre a 1500. Ya lo hace el cliente PPPoE lo de ponerlo a 1492.

Saludos!
 
No vas a tener problema... Si es Neba, usaras Vlan20 y Cliente DHCP para obtener ip del proveedor. "Euskatel + R + Telecable son del Grupo MasMovil y tienen la misma configuración."
La TV es Agile TV y es darle solamente internet, no necesita nada mas.
Gracias

Al final me pusieron un router con entrada de fibra y necesito una ONT, cual me recomendáis?

Al final la fibra es de Más Movil
 
Última edición:
Modo off-topic ON

En contestación a @falele_

falele_ dijo:
Buenos días.
Yo como no sé mucho de programar configuraciones os voy a dar un consejo.

No os centréis en copiar y pegar configuraciones, intentad entender qué hace cada orden y prestad especial atención a las que pone “name=“ ya que suelen referenciarse posteriormente y si no pones el nombre exactamente igual no te va a funcionar.

Y no solo por eso. Con este router se pueden hacer muchas cosa y la gente es muy lista.

Saludos
 
No tenemos configuración para Movistar + TV ?
El teléfono me da igual por que no utilizo el fijo…

gracias
 
Estoy buscando el comentario donde mencionas que es posible entrar al ONT nano G desde el Mikrotik enrutando la IP del ONT. Pero no lo veo. Eso es en el apartado de Route List? O en Address List?
 
@FoxyCTG21
Lo tienes en el hilo de tips and tricks.

Truco: Acceder a la ONT o el router que tengo conectado el puerto WAN [ether1]
Muchas veces tenemos la necesidad de acceder al router u ONT que usamos como WAN. Sin embargo, si estamos conectados al router mikrotik y estamos en otro segmento, no llegaremos a dicho equipo. La manera de hacerlo es muy sencilla.

Primero, creamos una IP del rango del equipo conectado al WAN, y se la asignamos a ether1. En mi caso tengo una ONT a la cual accedo con la dirección 192.168.100.1, de tal manera que he configurado la dirección 192.168.100.2 sobre ether1:
Código:
/ip address add address=192.168.100.2/24 interface=ether1 network=192.168.100.0

Y, a continuación, especifiamos que la interfaz física ether1 la considere como un puerto WAN (además de la VLAN o cliente PPPoE que use vuestra configuración original, la cual ya estará dada de alta como perteneciente a la lista WAN)
Código:
/interface list member add interface=ether1 list=WAN

Con estos dos sencillos pasos, ahora podremos abrir un navegador y, desde cualquier dispositivo conectado a nuestro router mikrotik, acceder a la dirección 192.168.100.1 [adaptarlo según necesidad de cada uno]

Saludos.
 
@FoxyCTG21
Lo tienes en el hilo de tips and tricks.

Truco: Acceder a la ONT o el router que tengo conectado el puerto WAN [ether1]
Muchas veces tenemos la necesidad de acceder al router u ONT que usamos como WAN. Sin embargo, si estamos conectados al router mikrotik y estamos en otro segmento, no llegaremos a dicho equipo. La manera de hacerlo es muy sencilla.

Primero, creamos una IP del rango del equipo conectado al WAN, y se la asignamos a ether1. En mi caso tengo una ONT a la cual accedo con la dirección 192.168.100.1, de tal manera que he configurado la dirección 192.168.100.2 sobre ether1:
Código:
/ip address add address=192.168.100.2/24 interface=ether1 network=192.168.100.0

Y, a continuación, especifiamos que la interfaz física ether1 la considere como un puerto WAN (además de la VLAN o cliente PPPoE que use vuestra configuración original, la cual ya estará dada de alta como perteneciente a la lista WAN)
Código:
/interface list member add interface=ether1 list=WAN

Con estos dos sencillos pasos, ahora podremos abrir un navegador y, desde cualquier dispositivo conectado a nuestro router mikrotik, acceder a la dirección 192.168.100.1 [adaptarlo según necesidad de cada uno]

Saludos.
Gracias, ya decia yo que lo habia visto en alguna parte...
 
Si, DHCP. Sería igual que el de Pepephone / MasMóvil / guuk. / Fibra Neba pero con la VLAN 10
Añadida. Si nos puedes dar más detalles de los equipos que usas para la parte WAN, te lo agradezco, por completar este apartado:

Conexión WAN: TBC
Tipo de conexión WAN: DHCP
VLAN Internet: 10
VLAN Teléfono: N/A
VLAN TV: N/A

Saludos!
 
Añadida. Si nos puedes dar más detalles de los equipos que usas para la parte WAN, te lo agradezco, por completar este apartado:

Conexión WAN: TBC
Tipo de conexión WAN: DHCP
VLAN Internet: 10
VLAN Teléfono: N/A
VLAN TV: N/A

Saludos!
La conexión WAN es con el Router proporcionado por Euskaltel, un ZTE F6640 configurando como Bridge porque no he conseguido sacar los datos para configurar la ONT de Nokia que tengo por casa.
 
Se surge una duda, tengo internet en marcha con el Mikrotik pero ahora no consigo que se vea la TV.

Se podría hacer algo?

Se os ocurre algo?

Edito: he visto en el Router que tiene una otra configuracion WAN de multicast en la VLAN 50, puede tener que ver con la TV?
 
Última edición:
Se surge una duda, tengo internet en marcha con el Mikrotik pero ahora no consigo que se vea la TV.

Se podría hacer algo?

Se os ocurre algo?

Edito: he visto en el Router que tiene una otra configuracion WAN de multicast en la VLAN 50, puede tener que ver con la TV?
Toda la pinta tiene.

Saludos!
 
Toda la pinta tiene.

Saludos!
Haré pruebas cuando vuelva a casa y os cuento, por si saco algo en claro.

Una vez creada la VLAN 50, cuales serian los siguientes pasas? Tendría que añadir la VLAN 50 al eth1 de la WAN?

Tengo un Bridge para la LAN con los puertos 2-3-4-5 y el puerto uno es para la WAN.

Estoy un poco perdido de cómo hacerlo, pero trasteare una vez realizar un backup.
 
Arriba