MANUAL: Mikrotik, configuraciones básicas ISPs - RouterOS v7

@pokoyo
Ahí va la configuración para el server PPPoE fake para Digi.
En el ejemplo se utiliza el puerto ether5 para conectar el router proporcionado por Digi.
RouterOS v7.

Código:
/interface vlan
add interface=ether5 name=vlan20_digi_fake vlan-id=20

/ip pool
add name=pool_digi_fake ranges=10.0.1.200-10.0.1.250

/ppp profile
add local-address=10.0.1.1 name=server-digi-fake remote-address=pool_digi_fake

/ppp secret
add name=usuario@digi password=P4ssWord profile=server-digi-fake service=pppoe

/interface pppoe-server server
add default-profile=server-digi-fake disabled=no interface=vlan20_digi_fake service-name=service_digi_fake

Cualquier rectificación o añadido adelante por mi parte.
Saludos.
Genial. Te lo tuneo un poco para meter usuario y password en variables de entorno y me lo llevo al manual de configuraciones básicas de los ISP para la v7.

Mil gracias compi!
 
Genial. Te lo tuneo un poco para meter usuario y password en variables de entorno y me lo llevo al manual de configuraciones básicas de los ISP para la v7.

Mil gracias compi!
listo, publicado. Si alguno se anima a probarlo por la dudas... A mí me crea el servidor PPPoE, aunque me lo marca como inválido (creo que es un simple bug, la típica tontada que se queda pillada. No obstante, si alguien lo prueba de verdad, que me diga.

Saludos!
 
listo, publicado. Si alguno se anima a probarlo por la dudas... A mí me crea el servidor PPPoE, aunque me lo marca como inválido (creo que es un simple bug, la típica tontada que se queda pillada. No obstante, si alguien lo prueba de verdad, que me diga.

Saludos!

Creo que @diamuxin lo probó en su día al tener conexión Digi. Si lo puede probar de nuevo y así tenemos el visto bueno con la configuración que has metido en el primer hilo. Aunque puede que no disponga de fijo, quizás si pueda probar que el router de Digi no marque ningún error de conexión al igual que el Mikrotik v7.
Saludos.
 
Creo que @diamuxin lo probó en su día al tener conexión Digi. Si lo puede probar de nuevo y así tenemos el visto bueno con la configuración que has metido en el primer hilo. Aunque puede que no disponga de fijo, quizás si pueda probar que el router de Digi no marque ningún error de conexión al igual que el Mikrotik v7.
Saludos.
Aunque no levante el fijo, con ver que el router del operador coge la ip 10.0.1.2 me vale.

Saludos!
 
Creo que @diamuxin lo probó en su día al tener conexión Digi. Si lo puede probar de nuevo y así tenemos el visto bueno con la configuración que has metido en el primer hilo. Aunque puede que no disponga de fijo, quizás si pueda probar que el router de Digi no marque ningún error de conexión al igual que el Mikrotik v7.
Saludos.
Sin problema, luego a la tarde cuando llegue a casa hago las pruebas pertinentes con un router DIGI que tengo en un cajón a ver si coge IP del pool fake.

S@lu2.
 
Sin problema, luego a la tarde cuando llegue a casa hago las pruebas pertinentes con un router DIGI que tengo en un cajón a ver si coge IP del pool fake.

S@lu2.
Buenas!

Ya lo he probado, el Router de Digi se pone en verde pero no conecta el teléfono, no se enciende la luz de teléfono. La verdad que no lo probé cuando me lo pusieron. Imagino que para llamar al soporte de Digi debería ponerlo detrás de la ONT no? No creo que cuele dejarlo detrás del MikroTik.
Edito: He entrado al router de DIGI por wifi, navego bien, pero en el estado de la conexión se ve como no es capaz de levantar la VoIP. Algo nos debe faltar.
@pokoyo @diamuxin
1657039439135.png
 
Última edición:
Buenas tardes,

Ya he hecho las pruebas, os paso a comentar los resultados.

NOTA: No tengo contratado el teléfono fijo.

Configurado según los pasos descritos por @stargate4you y @pokoyo. Solo he seteado la MTU y MRU del servidor pppoe a 1492. Lo que comenta pokoyo también me pasa, al crear el servidor se queda en color rojo pero se resuelve al sincronizar con el cliente pppoe.

El router de DIGI (ZTE H298Q) sincroniza correctamente:

1657043759896.png


El log del router Mikrotik al conectarlo en el puerto 7 (es mi puerto de pruebas):

1657043840538.png


Y el estado de la interface PPPoE:

1657044021412.png


Me conecto a la LAN del router DIGI y navego correctamente (no obtengo IPv6 pero no me preocupa).

Las capturas en el router de DIGI es similar a las de @Dexter91

1657044156066.png

1657044195437.png


Si necesitáis algo más me lo decís. Lo dejo conectado.

EDITO: Importante tener habilitado el servicio SIP en Mikrotik:

1657046625579.png


S@lu2.
 
Última edición:
Buenas tardes,

Ya he hecho las pruebas, os paso a comentar los resultados.

NOTA: No tengo contratado el teléfono fijo.

Configurado según los pasos descritos por @stargate4you y @pokoyo. Solo he seteado la MTU y MRU del servidor pppoe a 1492. Lo que comenta pokoyo también me pasa, al crear el servidor se queda en color rojo pero se resuelve al sincronizar con el cliente pppoe.

El router de DIGI (ZTE H298Q) sincroniza correctamente:

Ver el adjunto 96618

El log del router Mikrotik al conectarlo en el puerto 7 (es mi puerto de pruebas):

Ver el adjunto 96621

Y el estado de la interface PPPoE:

Ver el adjunto 96624

Me conecto a la LAN del router DIGI y navego correctamente (no obtengo IPv6 pero no me preocupa).

Las capturas en el router de DIGI es similar a las de @Dexter91

Ver el adjunto 96627
Ver el adjunto 96630

Si necesitáis algo más me lo decís.

S@lu2.
Venga, pues edito para meterles MTU/MRU a 1492 y listo.

Gracias compi, muy amable!
 
He leído en otros foros que sincronizando el router de DIGI con el servidor PPPoE Fake y teniendo conexión a Internet (como es mi caso), algún usuario ha conseguido que el SIP se registre sin problema en la parte OLT y levante tono en el puerto "Phone1". Lástima que no tenga fijo para comprobarlo.

Si alguien con DIGI+Teléfono fijo lo puede probar sería de gran ayuda a otros usuarios.

S@lu2.
 
He leído en otros foros que sincronizando el router de DIGI con el servidor PPPoE Fake y teniendo conexión a Internet (como es mi caso), algún usuario ha conseguido que el SIP se registre sin problema en la parte OLT y levante tono en el puerto "Phone1". Lástima que no tenga fijo para comprobarlo.

Si alguien con DIGI+Teléfono fijo lo puede probar sería de gran ayuda a otros usuarios.

S@lu2.

Yo tengo sincronizado el Router de Digi, navego a través de el, tengo el tlf en phone1 y nada -.- He comprobado tener habilitado el servicio SIP y está correcto, me faltaría revisar el MTU pero estando ya navegando me resulta raro que sea eso
 
Yo tengo sincronizado el Router de Digi, navego a través de el, tengo el tlf en phone1 y nada -.- He comprobado tener habilitado el servicio SIP y está correcto, me faltaría revisar el MTU pero estando ya navegando me resulta raro que sea eso
Pues entonces algo se nos escapa de esa configuración. Entiendo que si conectas el router de Digi directamente a la ONT si te funciona el teléfono, no?

S@lu2.
 
Pues entonces algo se nos escapa de esa configuración. Entiendo que si conectas el router de Digi directamente a la ONT si te funciona el teléfono, no?

S@lu2.
Lo voy a probar, porque no lo recuerdo, cuando se fue el técnico a los 5 minutos estaba poniendo el MikroTik. Mañana os comento.
 
Venga, pues edito para meterles MTU/MRU a 1492 y listo.

Gracias compi, muy amable!
Una pregunta compi, en Firewall-Service Ports ya está activada la parte SIP, ¿Es necesario natear también los puertos 5060 y 5061 a la IP del router Digi, o no es necesario?

S@lu2.
 
Una pregunta compi, en Firewall-Service Ports ya está activada la parte SIP, ¿Es necesario natear también los puertos 5060 y 5061 a la IP del router Digi, o no es necesario?

S@lu2.
Diría que no, que para eso está el helper. Pero no me atrevo a asegurártelo al 100%.

De todas formas, creo que @stargate4you lo tenía montado. Quizá sea más sencillo que le de una copia a su config, aplique la publicada, y nos diga si el tema levanta o no.

Saludos!
 
Yo tengo O2. No puedo aplicar la configuración. Pero creo recordar que con RouterOS v6 no hubo ningún problema en levantar el fijo cuando probamos lo mismo.

Saludos.
 
Yo tengo O2. No puedo aplicar la configuración. Pero creo recordar que con RouterOS v6 no hubo ningún problema en levantar el fijo cuando probamos lo mismo.

Saludos.
Calla calla, que es verdad, tú eras de O2 también.

Lo único diferente que hice fue no crear un pool para el pppoe, el resto es calcado a lo que compartiste tú.

Saludos!
 
Lo voy a probar, porque no lo recuerdo, cuando se fue el técnico a los 5 minutos estaba poniendo el MikroTik. Mañana os comento.
Vale genial, entonces si pruebas ONT+Router DIGI, cuando te sincronice, a ver si te funciona el teléfono (se me ocurre que si teniéndolo contratado y no lo usas puede que se haya deshabilitado en algún reinicio).

Si levanta tono, entonces conectas de nuevo ONT+MikroTik con la misma config de este hilo y haces dos pruebas, una con el SIP activado (por defecto) y si no, prueba a desactivarlo y sincroniza de nuevo.

Ya no se me ocurre nada más.

S@lu2.
 
Van a venir a ponerme la fibra de Euskaltel, sobre un Neba de Movistar.

Sabéis si podré seguir usando mi Mikrotik? Actualmente tengo con Vodafone, con la Fibra de Movistar directo desde el conversor al router.

Me gustaría montarlo igual que tengo ahora.

Además, viene con la TV incluido el paquete, igual me complica el tema.
 
Van a venir a ponerme la fibra de Euskaltel, sobre un Neba de Movistar.

Sabéis si podré seguir usando mi Mikrotik? Actualmente tengo con Vodafone, con la Fibra de Movistar directo desde el conversor al router.

Me gustaría montarlo igual que tengo ahora.

Además, viene con la TV incluido el paquete, igual me complica el tema.
No vas a tener problema... Si es Neba, usaras Vlan20 y Cliente DHCP para obtener ip del proveedor. "Euskatel + R + Telecable son del Grupo MasMovil y tienen la misma configuración."
La TV es Agile TV y es darle solamente internet, no necesita nada mas.
 
Arriba