MANUAL: Mikrotik, balanceo de carga PCC con failover

Export completo, please. No se ve como creas las vlans, ni la las interfaces. Quien es “WAN2”?

Por otro lado. ¿Te funcionan de manera alterna? Es decir, si apagas una, te funciona la otra y viceversa?

Saludos!
Buenas,

1643920633700.png


Nexo1 = VLAN20 sobre WAN1 = Ethernet1

Nexo2 = VLAN20 sobre WAN2 = Ethernet2

Si desconecto el cable de la primera, me enruta a internet por WAN3, que es el router 4G (default distance = 3)

La WAN2/Nexo2 no me levanta IP, por lo que la obvia como segundo camino de salida a Internet.

Código:
# feb/03/2022 21:38:34 by RouterOS 7.1.1
# software id = 90P7-FE6V
#
# model = RBD53iG-5HacD2HnD
# serial number = E7290E329005
/interface bridge
add admin-mac=2C:C8:1B:A0:AE:25 auto-mac=no name=bridge
/interface ethernet
set [ find default-name=ether3 ] name="4G ETHER3"
set [ find default-name=ether1 ] name=WAN1
set [ find default-name=ether2 ] name=WAN2
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-XX \
    disabled=no distance=indoors frequency=auto installation=indoor mode=\
    ap-bridge ssid="NEXO ALITER 2.4G" wireless-protocol=802.11
set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=\
    20/40/80mhz-Ceee country=spain disabled=no distance=indoors frequency=\
    auto installation=indoor mode=ap-bridge ssid="NEXO ALITER 5G" \
    wireless-protocol=802.11
/interface vlan
add interface=WAN1 name=NEXO1 vlan-id=20
add interface=WAN2 name=NEXO2 vlan-id=20
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface lte apn
set [ find default=yes ] ip-type=ipv4
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk eap-methods="" \
    group-ciphers=tkip,aes-ccm mode=dynamic-keys supplicant-identity=MikroTik \
    unicast-ciphers=tkip,aes-ccm
/ip pool
add name=dhcp ranges=192.168.0.20-192.168.0.180
/ip dhcp-server
add address-pool=dhcp interface=bridge lease-time=1d name=defconf
/routing bgp template
set default as=65530 disabled=no name=default output.network=bgp-networks
/routing ospf instance
add name=default-v2
/routing ospf area
add disabled=yes instance=default-v2 name=backbone-v2
/interface bridge port
add bridge=bridge ingress-filtering=no interface=ether4
add bridge=bridge ingress-filtering=no interface=ether5
add bridge=bridge ingress-filtering=no interface=wlan1
add bridge=bridge ingress-filtering=no interface=wlan2
/ip neighbor discovery-settings
set discover-interface-list=LAN
/ipv6 settings
set disable-ipv6=yes max-neighbor-entries=8192
/interface list member
add interface=bridge list=LAN
add interface=NEXO1 list=WAN
add interface="4G ETHER3" list=WAN
add interface=NEXO2 list=WAN
/ip address
add address=192.168.0.1/24 comment=defconf interface=bridge network=\
    192.168.0.0
/ip cloud
set ddns-enabled=yes
/ip dhcp-client
add interface=NEXO1
add default-route-distance=2 interface=NEXO2
add default-route-distance=3 interface="4G ETHER3"
/ip dhcp-server network
add address=192.168.0.0/24 comment=defconf dns-server=1.1.1.1 gateway=\
    192.168.0.1 netmask=24
/ip dns
set allow-remote-requests=yes servers=1.1.1.1,1.1.1.3
/ip dns static
add address=192.168.0.1 comment=defconf name=router.lan
/ip firewall filter
add action=accept chain=input comment=\
    "defconf: accept established,related,untracked" connection-state=\
    established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
    invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
    "defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=accept chain=input comment=letsencrypt-challenge-TO-DELETE \
    dst-port=443 protocol=tcp
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
    in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
    ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
    ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related hw-offload=yes
add action=accept chain=forward comment=\
    "defconf: accept established,related, untracked" connection-state=\
    established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
    connection-state=invalid
add action=drop chain=forward comment=\
    "defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
    connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
    ipsec-policy=out,none out-interface-list=WAN
add action=masquerade chain=srcnat out-interface=WAN2
add action=dst-nat chain=dstnat dst-port=8006 in-interface-list=WAN log=yes \
    protocol=tcp to-addresses=192.168.0.11 to-ports=8006
add action=dst-nat chain=dstnat dst-port=8006 in-interface-list=WAN log=yes \
    protocol=udp to-addresses=192.168.0.11 to-ports=8006
add action=dst-nat chain=dstnat dst-port=80 in-interface-list=WAN protocol=\
    tcp to-addresses=192.168.0.12 to-ports=80
add action=dst-nat chain=dstnat dst-port=587 in-interface=NEXO1 \
    in-interface-list=WAN log=yes protocol=tcp to-addresses=192.168.0.11 \
    to-ports=587
add action=dst-nat chain=dstnat dst-port=81 in-interface-list=WAN protocol=\
    tcp to-addresses=192.168.0.196 to-ports=81
add action=dst-nat chain=dstnat dst-port=3390 in-interface-list=WAN log=yes \
    protocol=tcp to-addresses=192.168.0.12 to-ports=3390
add action=dst-nat chain=dstnat dst-port=3390 in-interface-list=WAN log=yes \
    protocol=udp to-addresses=192.168.0.12 to-ports=3390
add action=dst-nat chain=dstnat dst-port=3391 in-interface-list=WAN log=yes \
    protocol=tcp to-addresses=192.168.0.13 to-ports=3391
add action=dst-nat chain=dstnat dst-port=3391 in-interface-list=WAN log=yes \
    protocol=udp to-addresses=192.168.0.13 to-ports=3391
add action=dst-nat chain=dstnat dst-port=3392 in-interface-list=WAN log=yes \
    protocol=tcp to-addresses=192.168.0.14 to-ports=3392
add action=dst-nat chain=dstnat dst-port=3392 in-interface-list=WAN log=yes \
    protocol=udp to-addresses=192.168.0.14 to-ports=3392
add action=dst-nat chain=dstnat dst-port=6036 in-interface-list=WAN log=yes \
    protocol=tcp to-addresses=192.168.0.196 to-ports=6036
add action=dst-nat chain=dstnat dst-port=6036 in-interface-list=WAN log=yes \
    protocol=udp to-addresses=192.168.0.196 to-ports=6036
add action=dst-nat chain=dstnat dst-port=3306 in-interface-list=WAN log=yes \
    protocol=tcp to-addresses=192.168.0.200 to-ports=3306
add action=dst-nat chain=dstnat dst-port=3306 in-interface-list=WAN log=yes \
    protocol=udp to-addresses=192.168.0.200 to-ports=3306
add action=dst-nat chain=dstnat dst-port=5566 in-interface-list=WAN log=yes \
    protocol=tcp to-addresses=192.168.0.200 to-ports=5566
add action=dst-nat chain=dstnat dst-port=5566 in-interface-list=WAN log=yes \
    protocol=udp to-addresses=192.168.0.200 to-ports=5566
add action=dst-nat chain=dstnat dst-port=7850 in-interface-list=WAN log=yes \
    protocol=tcp to-addresses=192.168.0.200 to-ports=7850
add action=dst-nat chain=dstnat dst-port=7850 in-interface-list=WAN log=yes \
    protocol=udp to-addresses=192.168.0.200 to-ports=7850
add action=dst-nat chain=dstnat dst-port=1723 in-interface-list=WAN log=yes \
    protocol=tcp to-addresses=192.168.0.250 to-ports=1723
add action=dst-nat chain=dstnat dst-port=1723 in-interface-list=WAN log=yes \
    protocol=udp to-addresses=192.168.0.250 to-ports=1723
add action=dst-nat chain=dstnat dst-port=587 in-interface-list=WAN log=yes \
    protocol=udp to-addresses=192.168.0.11 to-ports=587
add action=dst-nat chain=dstnat dst-port=1701 in-interface-list=WAN log=yes \
    protocol=tcp to-addresses=192.168.0.250 to-ports=1701
add action=dst-nat chain=dstnat dst-port=1701 in-interface-list=WAN log=yes \
    protocol=udp to-addresses=192.168.0.250 to-ports=1701
add action=dst-nat chain=dstnat dst-port=500 in-interface-list=WAN log=yes \
    protocol=tcp to-addresses=192.168.0.250 to-ports=500
add action=dst-nat chain=dstnat dst-port=500 in-interface-list=WAN log=yes \
    protocol=udp to-addresses=192.168.0.250 to-ports=500
add action=dst-nat chain=dstnat dst-port=4500 in-interface-list=WAN log=yes \
    protocol=tcp to-addresses=192.168.0.250 to-ports=4500
add action=dst-nat chain=dstnat dst-port=4500 in-interface-list=WAN log=yes \
    protocol=udp to-addresses=192.168.0.250 to-ports=4500
/ip service
set www-ssl certificate=letsencrypt-autogen_2022-02-01T19:44:53Z disabled=no
/system clock
set time-zone-name=Europe/Madrid
/system identity
set name=ALITER
/system leds
set 0 interface=wlan1 leds=led1,led2,led3,led4,led5 type=\
    wireless-signal-strength
set 1 leds=poe-led type=poe-out
/system routerboard settings
set cpu-frequency=auto
/tool e-mail
set address=nexo.es from=Aliter port=587 user=mikrotik@nexo.es
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN

Vuelvo a poner el export, sorry.

gracias!
 
Pero, si quitas la ont que sí funciona y la conexión 3G de la ecuación y anulas esos puertos, ¿te llega a dar en algún momento ip la WAN2? Porque, si no lo hace, entonces tenemos que dar un paso atrás y ver porqué esa ONT no tira. O por qué el cliente dhcp no obtiene IP.

Saludos!
 
Pero, si quitas la ont que sí funciona y la conexión 3G de la ecuación y anulas esos puertos, ¿te llega a dar en algún momento ip la WAN2? Porque, si no lo hace, entonces tenemos que dar un paso atrás y ver porqué esa ONT no tira. O por qué el cliente dhcp no obtiene IP.

Saludos!
Buenas @pokoyo, finalmente haciendo pruebas de ensayo/error, el problema era de la segunda ONT. Configuramos la misma ONT pass en otro modelo idéntico (solo cambiaba el color blanco por el negro en la Nokia 010) y ya levanta IP pública en el segundo DHCP client. Muchas gracias!
 
Buenas @pokoyo, finalmente haciendo pruebas de ensayo/error, el problema era de la segunda ONT. Configuramos la misma ONT pass en otro modelo idéntico (solo cambiaba el color blanco por el negro en la Nokia 010) y ya levanta IP pública en el segundo DHCP client. Muchas gracias!
Genial, misterio resuelto. A por otra y listo.

Saludos!
 
Buenos días a todos,
aprovecho este hilo pero no se si es el mas indicado...
Alguno sabe si hay posibilidad de que el Mikrotik te notifique cuando actual el failover? es decir siempre funciona la wan1, pero si cae y el mikrotik automaticamente me saca por rutas recursivas el cambio a la wan2 es transparente y no me enteraria. Hay manera de que envie un email, una notificación o algo diciendo que ha cambiado de wan1 a wan2?

Saludos y muchas gracias por anticipado
 
Buenos días a todos,
aprovecho este hilo pero no se si es el mas indicado...
Alguno sabe si hay posibilidad de que el Mikrotik te notifique cuando actual el failover? es decir siempre funciona la wan1, pero si cae y el mikrotik automaticamente me saca por rutas recursivas el cambio a la wan2 es transparente y no me enteraria. Hay manera de que envie un email, una notificación o algo diciendo que ha cambiado de wan1 a wan2?

Saludos y muchas gracias por anticipado
No me dio por probarlo, pero sospecho que con monitorear con netwatch la IP del gateway y, avisar cuando pierdas conectividad, te valdría, no? En netwatch puedes correr eventos en on-up y on-down, es decir, monitorear cuando cae y cuando levanta.

Saludos!
 
No me dio por probarlo, pero sospecho que con monitorear con netwatch la IP del gateway y, avisar cuando pierdas conectividad, te valdría, no? En netwatch puedes correr eventos en on-up y on-down, es decir, monitorear cuando cae y cuando levanta.

Saludos!
Entiendo que si, pero como avisa? envia email o algo? estoy ahora en netwatch pero no veo como avisa.
Sale host a hacer ping y mensaje al up y mensaje al down pero nada mas
gracias @pokoyo
 
Última edición:
Me contesto a mi mismo...
con un script.
Pero no termino de caer a donde tengo que hacer el ping. Está claro que a 8.8.8.8 no ya que cuando levante wan2 seguira haciento ping por lo que deberia ser a la ruta recursiva pero ahora mismo me he bloqueado y no termino de acertar
 
Última edición:
A la IP del gateway. Si te miras el manual, se saca en el script de lease del DHCP, en el caso de que tu conexión sea DHCP.

Saludos!
 
Aprovecho que se ha animado este hilo para retomar algo que tengo pendiente y no consigo hacer.
Tengo 2 WAN:
1- DIGI por pppoe
2- SIMYO por DHCP client

Simplemente quiero que cada vez que se active o desactive cualquiera de las dos WAN, me envíe un correo electrónico.
Es decir, al final son 4 alertas

Lo he intentado por netwatch, por scripts, y no lo consigo. De hecho en la configuración me queda algún resto de los intentos.

Aquí va:

Código:
/interface ethernet
set [ find default-name=ether1 ] name=1-wan
set [ find default-name=ether2 ] name=2-wan
set [ find default-name=ether3 ] name=3-CFG
set [ find default-name=ether4 ] name=4-SW2
set [ find default-name=ether5 ] name=5-SW1
set [ find default-name=sfp1 ] disabled=yes
/interface vlan
add interface=5-SW1 name=vlan-111-W1 vlan-id=111
add interface=5-SW1 name=vlan-112-W2 vlan-id=112
add interface=5-SW1 name=vlan-113-W3 vlan-id=113
add interface=4-SW2 name=vlan-207-reserva vlan-id=207
add interface=4-SW2 name=vlan-208-MINI PC vlan-id=208
add interface=4-SW2 name=vlan-209-TV vlan-id=209
add interface=4-SW2 name=vlan-210-BROTHER vlan-id=210
add interface=4-SW2 name=vlan-211-KODI vlan-id=211
add interface=4-SW2 name=vlan-212-ALARMA vlan-id=212
add interface=4-SW2 name=vlan-213-D1 vlan-id=213
add interface=4-SW2 name=vlan-214-D2 vlan-id=214
add interface=4-SW2 name=vlan-215-D3 vlan-id=215
add interface=4-SW2 name=vlan-216-D4 vlan-id=216
add interface=1-wan name=vlan20 vlan-id=20
/interface pppoe-client
add add-default-route=yes comment=Netwatch:DIGI disabled=no interface=vlan20 max-mru=1492 max-mtu=1492 name=pppoe-out1 password=xxxx user=xxxx
/interface list
add name=WAN
add name=LAN
/ip pool
add name=pool-4-SW2 ranges=192.168.4.100-192.168.4.200
add name=pool-212-ALARMA ranges=192.168.212.100-192.168.212.200
add name=pool-213-D1 ranges=192.168.213.100-192.168.213.200
add name=pool-214-D2 ranges=192.168.214.100-192.168.214.200
add name=pool-215-D3 ranges=192.168.215.100-192.168.215.200
add name=pool-216-D4 ranges=192.168.216.100-192.168.216.200
add name=pool-211-KODI ranges=192.168.211.100-192.168.211.200
add name=vpn-pool ranges=192.168.100.2-192.168.100.254
add name=pool-207-reserva ranges=192.168.207.100-192.168.207.200
add name="pool-208-MINI PC" ranges=192.168.208.100-192.168.208.200
add name=pool-3-CFG ranges=192.168.3.100-192.168.3.200
add name=pool-209-TV ranges=192.168.209.100-192.168.209.200
add name=pool-210-BROTHER ranges=192.168.210.100-192.168.210.200
add name=pool-111-W1 ranges=192.168.111.100-192.168.111.200
add name=pool-112-W2 ranges=192.168.112.100-192.168.112.200
add name=pool-113-W3 ranges=192.168.113.100-192.168.113.200
add name=pool-5-SW1 ranges=192.168.5.100-192.168.5.200
/ip dhcp-server
add address-pool=pool-4-SW2 disabled=no interface=4-SW2 name=dhcp-4-SW2
add address-pool=pool-212-ALARMA disabled=no interface=vlan-212-ALARMA name=dhcp-212-ALARMA
add address-pool=pool-213-D1 disabled=no interface=vlan-213-D1 name=dhcp-213-D1
add address-pool=pool-214-D2 disabled=no interface=vlan-214-D2 name=dhcp-214-D2
add address-pool=pool-215-D3 disabled=no interface=vlan-215-D3 name=dhcp-215-D3
add address-pool=pool-216-D4 disabled=no interface=vlan-216-D4 name=dhcp-216-D4
add address-pool=pool-211-KODI disabled=no interface=vlan-211-KODI name=dhcp-211-KODI
add address-pool=pool-207-reserva disabled=no interface=vlan-207-reserva
add address-pool=pool-3-CFG disabled=no interface=3-CFG name=dhcp-3-CFG
add address-pool=pool-209-TV disabled=no interface=vlan-209-TV name=dhcp-209-TV
add address-pool=pool-210-BROTHER disabled=no interface=vlan-210-BROTHER name=dhcp-210-BROTHER
add address-pool=pool-111-W1 disabled=no interface=vlan-111-W1 name=dhcp-111-W1
add address-pool=pool-112-W2 disabled=no interface=vlan-112-W2 name=dhcp-112-W2
add address-pool=pool-113-W3 disabled=no interface=vlan-113-W3 name=dhcp-113-W3
add address-pool=pool-5-SW1 disabled=no interface=5-SW1 name=dhcp-5-SW1
/ppp profile
add change-tcp-mss=yes interface-list=LAN local-address=192.168.100.1 name=vpn-profile remote-address=vpn-pool use-encryption=yes
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface detect-internet
set detect-interface-list=all
/interface l2tp-server server
set authentication=mschap2 default-profile=vpn-profile enabled=yes ipsec-secret=XXX use-ipsec=yes
/interface list member
add interface=4-SW2 list=LAN
add interface=5-SW1 list=LAN
add interface=1-wan list=WAN
add interface=pppoe-out1 list=WAN
add interface=2-wan list=WAN
add interface=vlan-216-D4 list=LAN
add interface=3-CFG list=LAN
/ip address
add address=192.168.4.1/24 interface=4-SW2 network=192.168.4.0
add address=192.168.212.1/24 interface=vlan-212-ALARMA network=192.168.212.0
add address=192.168.213.1/24 interface=vlan-213-D1 network=192.168.213.0
add address=192.168.214.1/24 interface=vlan-214-D2 network=192.168.214.0
add address=192.168.215.1/24 interface=vlan-215-D3 network=192.168.215.0
add address=192.168.216.1/24 interface=vlan-216-D4 network=192.168.216.0
add address=192.168.211.1/24 interface=vlan-211-KODI network=192.168.211.0
add address=192.168.207.1/24 interface=vlan-207-reserva network=192.168.207.0
add address=192.168.208.1/24 interface="vlan-208-MINI PC" network=192.168.208.0
add address=192.168.3.1/24 interface=3-CFG network=192.168.3.0
add address=192.168.209.1/24 interface=vlan-209-TV network=192.168.209.0
add address=192.168.210.1/24 interface=vlan-210-BROTHER network=192.168.210.0
add address=192.168.111.1/24 interface=vlan-111-W1 network=192.168.111.0
add address=192.168.112.1/24 interface=vlan-112-W2 network=192.168.112.0
add address=192.168.113.1/24 interface=vlan-113-W3 network=192.168.113.0
add address=192.168.5.1/24 interface=5-SW1 network=192.168.5.0
/ip cloud
set ddns-enabled=yes
/ip dhcp-client
add comment=Netwatch:SIMYO default-route-distance=2 disabled=no interface=2-wan
/ip dhcp-server lease

(...)

/ip dhcp-server network
add address=192.168.3.0/24 dns-server=1.1.1.3,1.0.0.3 gateway=192.168.3.1
add address=192.168.4.0/24 dns-server=1.1.1.3,1.0.0.3 gateway=192.168.4.1
add address=192.168.5.0/24 dns-server=1.1.1.3,1.0.0.3 gateway=192.168.5.1
add address=192.168.102.0/24 dns-server=1.1.1.3,1.0.0.3 gateway=192.168.102.0
add address=192.168.111.0/24 dns-server=1.1.1.3,1.0.0.3 gateway=192.168.111.1
add address=192.168.112.0/24 dns-server=1.1.1.3,1.0.0.3 gateway=192.168.112.1
add address=192.168.113.0/24 dns-server=1.1.1.3,1.0.0.3 gateway=192.168.113.1
add address=192.168.207.0/24 dns-server=1.1.1.3,1.0.0.3 gateway=192.168.207.1
add address=192.168.208.0/24 dns-server=1.1.1.3,1.0.0.3 gateway=192.168.208.1
add address=192.168.209.0/24 dns-server=1.1.1.3,1.0.0.3 gateway=192.168.209.1
add address=192.168.210.0/24 dns-server=1.1.1.3,1.0.0.3 gateway=192.168.210.1
add address=192.168.211.0/24 dns-server=1.1.1.3,1.0.0.3 gateway=192.168.211.1
add address=192.168.212.0/24 dns-server=1.1.1.3,1.0.0.3 gateway=192.168.212.1
add address=192.168.213.0/24 dns-server=1.1.1.3,1.0.0.3 gateway=192.168.213.1
add address=192.168.214.0/24 dns-server=1.1.1.3,1.0.0.3 gateway=192.168.214.1
add address=192.168.215.0/24 dns-server=1.1.1.3,1.0.0.3 gateway=192.168.215.1
add address=192.168.216.0/24 dns-server=1.1.1.3,1.0.0.3 gateway=192.168.216.1
/ip dns
set allow-remote-requests=yes servers=1.1.1.3 use-doh-server=https://cloudflare-dns.com/dns-query verify-doh-cert=yes
/ip dns static
add address=104.16.248.249 name=cloudfare-dns.com
add address=104.16.249.249 name=cloudfare-dns.com
add address=192.168.88.1 comment=defconf name=router.lan
/ip firewall address-list
add address=192.168.211.0/24 list=aislados
add address=192.168.214.0/24 list=aislados
add address=192.168.212.0/24 list=aislados
add address=192.168.207.0/24 list=aislados
add address=192.168.216.0/24 list=aislados
add address=192.168.208.0/24 list=aislados
add address=192.168.209.0/24 list=aislados
add address=192.168.210.0/24 list=aislados
add address=192.168.213.0/24 list=aislados
add address=192.168.215.0/24 list=aislados
add address=192.168.111.0/24 list=aislados
add address=192.168.112.0/24 list=aislados
add address=192.168.113.0/24 list=aislados
add address=192.168.5.0/24 list=aislados
/ip firewall filter
add action=accept chain=input comment="Acepta established,related,untracked" connection-state=established,related,untracked
add action=drop chain=input comment="Rechaza invalidas en input" connection-state=invalid
add action=accept chain=input comment="Acepta ping ICMP" protocol=icmp
add action=accept chain=input comment="allow IPsec" dst-port=4500,500 protocol=udp
add action=accept chain=input comment="allow l2tp" dst-port=1701 protocol=udp
add action=drop chain=input comment="Rechaza todo lo que no venga de la lista LAN" in-interface-list=!LAN
add action=accept chain=forward comment="Acepta trafico ipsec entrante" ipsec-policy=in,ipsec
add action=accept chain=forward comment="Acepta trafico ipsec saliente" ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="Fasttrack para conexiones ya establecidas o relacionadas" connection-state=established,related
add action=accept chain=forward comment="Acepta el resto de trafico no capturado por fasttrack" connection-state=established,related,untracked
add action=drop chain=forward comment="Rechaza invalidas en forward" connection-state=invalid
add action=drop chain=forward comment="Rechaza todo trafico desde la WAN salvo el nateado" connection-nat-state=!dstnat connection-state=new in-interface-list=WAN
add action=accept chain=forward comment="Acepta conexiones entre ENDPOINTS" dst-address=192.168.111.0/24 src-address=192.168.210.200
add action=accept chain=forward dst-address=192.168.111.119 src-address=192.168.111.106
add action=accept chain=forward dst-address=192.168.111.106 src-address=192.168.111.119
add action=accept chain=forward dst-address=192.168.213.0/24 src-address=192.168.210.200
add action=accept chain=forward dst-address=192.168.215.0/24 src-address=192.168.210.200
add action=accept chain=forward dst-address=192.168.216.0/24 src-address=192.168.210.200
add action=accept chain=forward dst-address=192.168.210.200 src-address=192.168.111.0/24
add action=accept chain=forward dst-address=192.168.210.200 src-address=192.168.213.0/24
add action=accept chain=forward dst-address=192.168.210.200 src-address=192.168.215.0/24
add action=accept chain=forward dst-address=192.168.210.200 src-address=192.168.216.0/24
add action=accept chain=forward dst-address=192.168.216.200 src-address=192.168.5.106
add action=accept chain=forward dst-address=192.168.5.106 src-address=192.168.216.200
add action=accept chain=forward dst-address=192.168.5.106 src-address=192.168.111.106
add action=accept chain=forward dst-address=192.168.5.106 src-address=192.168.111.103
add action=accept chain=forward dst-address=192.168.111.106 src-address=192.168.5.106
add action=accept chain=forward dst-address=192.168.111.103 src-address=192.168.5.106
add action=drop chain=forward comment="bloquea toda comunicacion en forward, a cualquier cosa que no sea internet" out-interface-list=!WAN src-address-list=aislados
add action=drop chain=forward comment="permite solamente conexiones de la centralita con servidor Carlus" dst-address=!159.8.126.226 src-address=192.168.212.200
/ip firewall nat
add action=masquerade chain=srcnat comment=masquerade-wan ipsec-policy=out,none out-interface-list=WAN
add action=masquerade chain=srcnat comment="masq. vpn traffic" src-address=192.168.100.0/24
/ip route
add distance=1 dst-address=8.8.4.4/32 gateway=2-wan scope=10
add distance=1 dst-address=8.8.8.8/32 gateway=1-wan scope=10
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www address=192.168.88.0/24,192.168.100.0/24,192.168.216.200/32,192.168.208.117/32,192.168.3.0/24
set ssh disabled=yes port=2200
set api disabled=yes
set winbox address=192.168.88.0/24,192.168.100.0/24,192.168.216.200/32,192.168.111.110/32,192.168.3.0/24
set api-ssl disabled=yes
/ip traffic-flow
set interfaces=vlan-212-ALARMA
/ppp secret
add name=XXX password=XXX service=l2tp
/system clock
set time-zone-name=Europe/Madrid
/system identity
set name=ACM
/system scheduler
add interval=1h name=TEMPCHECK on-event="/system script run TEMPCHECK" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-date=feb/16/2022 start-time=14:00:00
/system script
add dont-require-permissions=no name=TEMPCHECK owner=AlberCM policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source=":global tempSystem [/system health get temperature]\r\
    \n:local DeviceName [/system identity get name]\r\
    \n:local tempMax \"59\";\r\
    \n\r\
    \n:if (\$tempSystem >= \$tempMax) do={\r\
    \n:log error \"Alerta de Temperatura ALTA: \$tempSystem C\";\r\
    \n\r\
    \n# START Send Email\r\
    \n/tool e-mail send to=\"alberto@cuevasmartin.es\" subject=\"\\E2\\9A\\A0 Router Mikrotik \$DeviceName: Alerta de temperatura\" body=\"Temperatura alta: \$tempSystem\";\r\
    \n# END Send Email\r\
    \n\r\
    \n} else={\r\
    \n:log warning \"La temperatura est\E1 dentro de los valores normales: \$tempSystem C\"\r\
    \n}"
/tool e-mail
set address=cXXX from=XXX password=XXX port=465 start-tls=tls-only user=XXX
/tool mac-server
set allowed-interface-list=none
/tool mac-server mac-winbox
set allowed-interface-list=none
/tool mac-server ping
set enabled=no
 
A la IP del gateway. Si te miras el manual, se saca en el script de lease del DHCP, en el caso de que tu conexión sea DHCP.

Saludos!
Pero el gateway está siempre on, es decir el router que haria de gateway en la lan 1 si se queda sin fibra seguiria respondiendo como gateway aunque no tenga salida a internet.
Intenté hacerlo con las gateway de las rutas recursivas pero dan respuesta a ping aunque el ether1 no esté conectado.

Saludos
 
Pero el gateway está siempre on, es decir el router que haria de gateway en la lan 1 si se queda sin fibra seguiria respondiendo como gateway aunque no tenga salida a internet.
Intenté hacerlo con las gateway de las rutas recursivas pero dan respuesta a ping aunque el ether1 no esté conectado.

Saludos
Ahí me pillas compi. Probaré cuando pueda y te digo.

Saludos!
 
Genial! Me extrañó que no lo hicieras por DHCP, porque es la manera más sencilla de que las rutas sean automáticas y se auto-detecte la caída de una ruta (en las estáticas tienes que poner la comprobación vía ping)

Para lo que quieres hacer, una pista: las conexiones de tipo PPP (como el PPPoE que levanta tu conexión principal), llevan asociados perfiles (PPP -> Profile). Puedes crear un nuevo perfil, copia de "default" y usar los eventos "on-up" y "on-down" para llamar al script que manda ese tipo de notificaciones.

Saludos!
Hola @pocoyo
Como ves, sigo liado desde noviembre y no consigo enviar el mail con el failover.
He recuperado este mensaje tuyo y tengo una pregunta:
¿por que sería necesario crear una copia de "default"? ¿no se puede usar directamente los eventos "on-up" y "on-down" de "default"?
Muchas gracias!!
 
Hola @pocoyo
Como ves, sigo liado desde noviembre y no consigo enviar el mail con el failover.
He recuperado este mensaje tuyo y tengo una pregunta:
¿por que sería necesario crear una copia de "default"? ¿no se puede usar directamente los eventos "on-up" y "on-down" de "default"?
Muchas gracias!!
Para no perder la configuración del perfil por defecto, por si quieres usar otro tipo de túnel ppp en tu setup. Es meramente higiénico.

Saludos!
 
hola,
tengo un router MikroTik RB760iGS conectado al ONT de Adamo y quiero conectarlo a un RBM11G con lte con Sim de Movistar, si en algún momento pierdo la conexión de Adamo.
Las 2 líneas funcionan perfectamente de manera individual, pero no sé como hacer para que funcionen en conjunto.
 
hola,
tengo un router MikroTik RB760iGS conectado al ONT de Adamo y quiero conectarlo a un RBM11G con lte con Sim de Movistar, si en algún momento pierdo la conexión de Adamo.
Las 2 líneas funcionan perfectamente de manera individual, pero no sé como hacer para que funcionen en conjunto.
Pero entiendo que en conjunto no las quieres hacer funcionar, sino en modo “failover” (si se cae la principal, que entre la segundaria). ¿No?

Con sacar otro puerto del bridge principal, crearle su direccionamiento y poner que la distancia de la ruta es superior a la ruta por defecto, ya tienes el failover montado.

Aquí tienes un ejemplo sencillo: https://help.mikrotik.com/docs/display/ROS/Load+Balancing

Saludos!
 
No lo hagas a mano. En el cliente DHCP o lo que sea que utilices para conectarte al segundo aparato, métele distancia 2 y listo.

Saludos!
 
Sí, claro que puedes. Creas sendas VLANs:
Código:
/interface vlan
add interface=ether1 name=internet-yg vlan-id=20
add interface=ether2 name=internet-mm vlan-id=20

Y levantar sendos clientes DHCP sobre dichos nombres de VLANs.
Código:
/ip dhcp-client
add interface=internet-yg disabled=no
add interface=internet-mm disabled=no

Saludos!
Buenos días! Tengo una oficina con esta configuración, estaba trabajando solo con una fibra de Masmóvil y hemos activado una segunda fibra del mismo operador, ambas ya fuera de CGNAT. También se ha configurado el failover, asignando distancia 1 y 2 a cada DHCP client.

El problema es que la IPs públicas han dejado de responder y hay puertos abiertos en la configuración del firewall, para acceder a equipos en la red local desde el exterior: NAS, NVR, etc... si hago ping al gateway del operador, sí que responde:

1648371222478.png


Ya no sé si es un problema del operador, ya que al hacer un tracert el segundo salto es el gateway, en vez del la IP pública:

tracert 1.1.1.1.png


O tiene algo que ver con la configuración (he revisado que las VLANs ID 20 sobre las que levanta la conexion WAN estén en la lista de interfaces), dejo un export por si ayuda:

Código:
# mar/25/2022 14:56:51 by RouterOS 7.1.5
# software id = CLA9-Z0BA
#
# model = RB760iGS
# serial number = D4500ED7BAEF
/interface bridge
add fast-forward=no name=bridge_wifi_datos
/interface ethernet
set [ find default-name=ether1 ] comment="Router TP-LIink + 4G backup" name=\
    ether1-WAN
set [ find default-name=ether2 ] name=ether2-LAN1
set [ find default-name=ether3 ] name=ether3-LAN2
set [ find default-name=ether4 ] arp=proxy-arp name=ether4-LAN3
set [ find default-name=ether5 ] comment="Cable Movil" name=ether5-WAN2 \
    poe-out=off
/interface vlan
add interface=ether1-WAN name=Nexo1 vlan-id=20
add interface=ether5-WAN2 name=vlan_fibra vlan-id=20
/interface list
add name=WAN
/interface lte apn
set [ find default=yes ] ip-type=ipv4 use-network-apn=no
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa-psk,wpa2-psk eap-methods="" \
    management-protection=allowed mode=dynamic-keys name=profile_datos \
    supplicant-identity=""
/ip hotspot profile
add hotspot-address=10.5.50.1 html-directory=flash/hotspot name=hsprof1 \
    rate-limit=5M/5M
/ip hotspot user profile
set [ find default=yes ] shared-users=500
/ip ipsec peer
add name=peer1 passive=yes
/ip ipsec profile
set [ find default=yes ] dh-group=modp1024 enc-algorithm=aes-256,3des
/ip ipsec proposal
set [ find default=yes ] enc-algorithms=aes-256-cbc,3des pfs-group=none
/ip pool
add name=dhcp_pool1 ranges=10.10.1.101-10.10.1.254
add name=dhcp_pool2 ranges=10.10.2.51-10.10.2.127,10.10.2.129-10.10.2.254
add name=dhcp_pool3 ranges=10.10.3.50-10.10.3.254
add name=hs-pool-6 ranges=10.5.50.2-10.5.50.254
add name=pool-pptp ranges=10.10.3.20-10.10.3.40
/ip dhcp-server
add address-pool=dhcp_pool1 authoritative=after-2sec-delay interface=\
    bridge_wifi_datos lease-time=8h name=dhcp1
add address-pool=dhcp_pool2 authoritative=after-2sec-delay interface=\
    ether3-LAN2 lease-time=8h name=dhcp2
add address-pool=dhcp_pool3 authoritative=after-2sec-delay interface=\
    ether4-LAN3 lease-time=8h name=dhcp3
/port
set 0 name=serial0
/ppp profile
add local-address=10.10.3.2 name=profile-pptp remote-address=pool-pptp
/queue simple
add limit-at=512k/512k max-limit=10M/10M name="Telefono 100" priority=2/2 \
    queue=default/default target=10.10.3.212/32
add limit-at=512k/512k max-limit=10M/10M name="Telefono 102" priority=2/2 \
    queue=default/default target=10.10.3.200/32
add limit-at=512k/512k max-limit=10M/10M name="Telefono 101" priority=2/2 \
    queue=default/default target=10.10.3.166/32
add limit-at=512k/512k max-limit=10M/10M name="Telefono 107" priority=2/2 \
    queue=default/default target=10.10.3.186/32
add limit-at=512k/512k max-limit=10M/10M name="Telefono 103" priority=2/2 \
    queue=default/default target=10.10.3.133/32
add limit-at=512k/512k max-limit=10M/10M name=Telefono105 priority=2/2 queue=\
    default/default target=10.10.3.76/32
add max-limit=90M/90M name=LAN priority=7/7 queue=\
    ethernet-default/ethernet-default target=10.10.0.0/16
/routing bgp template
set default as=65530 disabled=no name=default output.network=bgp-networks
/routing ospf instance
add name=default-v2
/routing ospf area
add disabled=yes instance=default-v2 name=backbone-v2
/routing table
add fib name=CableMovil
/system logging action
set 0 memory-lines=3000
/user group
set full policy="local,telnet,ssh,ftp,reboot,read,write,policy,test,winbox,pas\
    sword,web,sniff,sensitive,api,romon,dude,tikapp,rest-api"
/interface bridge port
add bridge=bridge_wifi_datos hw=no ingress-filtering=no interface=ether2-LAN1
/ip neighbor discovery-settings
set discover-interface-list=*2000011
/ipv6 settings
set disable-ipv6=yes max-neighbor-entries=8192
/interface l2tp-server server
set enabled=yes
/interface list member
add interface=vlan_fibra list=WAN
add interface=Nexo1 list=WAN
/interface pptp-server server
set authentication=mschap2 enabled=yes
/ip address
add address=10.10.1.1/24 comment=LAN1 interface=bridge_wifi_datos network=\
    10.10.1.0
add address=10.10.2.1/24 comment=LAN2 interface=ether3-LAN2 network=10.10.2.0
add address=10.10.3.1/24 comment=LAN3 interface=ether4-LAN3 network=10.10.3.0
add address=192.168.220.254/24 comment="LAN impresora-grabador" interface=\
    ether4-LAN3 network=192.168.220.0
/ip cloud
set ddns-enabled=yes ddns-update-interval=5m
/ip dhcp-client
add comment="Cable Movil" default-route-distance=2 interface=vlan_fibra
add interface=Nexo1
/ip dhcp-server lease
add address=10.10.3.250 client-id=1:94:c6:91:af:dc:2e mac-address=\
    94:C6:91:AF:DC:2E server=dhcp3
add address=10.10.3.217 client-id=1:40:8d:5c:72:73:5b mac-address=\
    40:8D:5C:72:73:5B server=dhcp3
add address=10.10.3.212 client-id=1:0:b:82:9c:46:fd comment=\
    "telefono 100 y 104" mac-address=00:0B:82:9C:46:FD server=dhcp3
add address=10.10.2.96 client-id=1:1c:1b:d:3e:84:e6 comment="Server gestion" \
    mac-address=1C:1B:0D:3E:84:E6 server=dhcp2
add address=10.10.3.186 client-id=1:c0:74:ad:31:dd:92 comment="Ext 107" \
    mac-address=C0:74:AD:31:DD:92 server=dhcp3
add address=10.10.3.133 client-id=1:c0:74:ad:31:df:7e comment="Ext 103" \
    mac-address=C0:74:AD:31:DF:7E server=dhcp3
add address=10.10.3.76 client-id=1:c0:74:ad:2c:bd:a6 comment="Ext 105" \
    mac-address=C0:74:AD:2C:BD:A6 server=dhcp3
add address=10.10.3.200 client-id=1:c0:74:ad:2b:b8:51 comment="Ext 102" \
    mac-address=C0:74:AD:2B:B8:51 server=dhcp3
/ip dhcp-server network
add address=10.5.50.0/24 comment="hotspot network" gateway=10.5.50.1
add address=10.10.1.0/24 dns-server=10.10.1.1 gateway=10.10.1.1
add address=10.10.2.0/24 dns-server=10.10.2.1 gateway=10.10.2.1
add address=10.10.3.0/24 dns-server=10.10.3.1 gateway=10.10.3.1
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,212.166.132.96,80.58.61.250
/ip firewall address-list
add address=80.28.138.40 list="Acceso Dani"
add address=dani.1punto.com list="Acceso Dani"
add address=10.10.3.76 list=Telefonos
add address=10.10.3.133 list=Telefonos
add address=10.10.3.166 list=Telefonos
add address=10.10.3.186 list=Telefonos
add address=10.10.3.200 list=Telefonos
add address=10.10.3.212 list=Telefonos
add address=10.10.3.94 list=Telefonos
/ip firewall filter
add action=passthrough chain=unused-hs-chain comment=\
    "place hotspot rules here" disabled=yes
add action=accept chain=forward comment="accept established,related" \
    connection-state=established,related
add action=accept chain=input comment="accept established,related" \
    connection-state=established,related
add action=accept chain=input comment=PPTP dst-port=1723 in-interface-list=\
    WAN protocol=tcp
add action=accept chain=input in-interface-list=WAN protocol=gre
add action=accept chain=input comment=L2TP dst-port=1701,4500,500 \
    in-interface-list=WAN protocol=udp
add action=accept chain=input in-interface-list=WAN protocol=ipsec-esp
add action=accept chain=input comment="Acceso Soporte" in-interface-list=WAN \
    src-address-list="Acceso Dani"
add action=drop chain=input comment="drop all from WAN" in-interface-list=WAN
add action=accept chain=forward comment="Acceso impresora" src-address=\
    10.10.2.50
add action=accept chain=forward dst-address=10.10.2.50
add action=drop chain=forward comment="Prohibir acceso entre redes" disabled=\
    yes dst-address=10.10.2.0/24 src-address=10.10.1.0/24
add action=drop chain=forward disabled=yes dst-address=10.10.3.0/24 \
    src-address=10.10.1.0/24
add action=drop chain=forward disabled=yes dst-address=10.10.1.0/24 \
    src-address=10.10.2.0/24
add action=drop chain=forward disabled=yes dst-address=10.10.3.0/24 \
    src-address=10.10.2.0/24
add action=drop chain=forward disabled=yes dst-address=10.10.1.0/24 \
    src-address=10.10.3.0/24
add action=drop chain=forward disabled=yes dst-address=10.10.2.0/24 \
    src-address=10.10.3.0/24
add action=drop chain=forward comment="drop invalid" connection-state=invalid \
    in-interface-list=WAN
/ip firewall mangle
add action=mark-routing chain=prerouting comment=Red1 disabled=yes \
    new-routing-mark=CableMovil passthrough=no src-address=10.10.1.0/24
add action=mark-routing chain=prerouting comment=Red2 disabled=yes \
    new-routing-mark=CableMovil passthrough=no src-address=10.10.2.0/24
add action=mark-routing chain=prerouting comment=Red3 disabled=yes \
    new-routing-mark=CableMovil passthrough=no src-address=10.10.3.0/24
add action=mark-routing chain=prerouting comment=Red4 disabled=yes \
    new-routing-mark=CableMovil passthrough=no src-address=10.5.50.0/24
add action=mark-routing chain=prerouting comment="Telefonos por Cable" \
    new-routing-mark=CableMovil passthrough=no src-address-list=Telefonos
/ip firewall nat
add action=passthrough chain=unused-hs-chain comment=\
    "place hotspot rules here" disabled=yes
add action=masquerade chain=srcnat comment="Salida Internet" \
    out-interface-list=WAN
add action=dst-nat chain=dstnat comment="Camaras grabador" dst-port=100 \
    in-interface=ether1-WAN protocol=tcp to-addresses=192.168.220.59 \
    to-ports=100
add action=dst-nat chain=dstnat dst-port=37778 in-interface=ether1-WAN \
    protocol=udp to-addresses=192.168.220.59 to-ports=37778
add action=dst-nat chain=dstnat dst-port=554 in-interface=ether1-WAN \
    protocol=tcp to-addresses=192.168.220.59 to-ports=554
add action=dst-nat chain=dstnat dst-port=37777 in-interface=ether1-WAN \
    protocol=tcp to-addresses=192.168.220.59 to-ports=37777
add action=dst-nat chain=dstnat comment=\
    "Puerto 21221 Servidor software gestion" dst-port=21221 in-interface=\
    ether1-WAN protocol=tcp to-addresses=10.10.2.96 to-ports=21221
add action=dst-nat chain=dstnat dst-port=21221 in-interface=ether1-WAN \
    protocol=udp to-addresses=10.10.2.96 to-ports=21221
add action=dst-nat chain=dstnat comment="NAS SINERCUS" dst-port=5005 \
    in-interface=Nexo1 in-interface-list=WAN protocol=tcp to-addresses=\
    10.10.2.91 to-ports=5005
add action=dst-nat chain=dstnat dst-port=5005 in-interface=Nexo1 \
    in-interface-list=WAN protocol=udp to-addresses=10.10.2.91 to-ports=5005
add action=dst-nat chain=dstnat dst-port=5006 in-interface=Nexo1 \
    in-interface-list=WAN protocol=tcp to-addresses=10.10.2.91 to-ports=5006
add action=dst-nat chain=dstnat dst-port=5006 in-interface=Nexo1 \
    in-interface-list=WAN protocol=udp to-addresses=10.10.2.91 to-ports=5006
add action=dst-nat chain=dstnat comment="telefono 102 y 106" dst-port=81 \
    in-interface-list=WAN protocol=tcp src-address-list="Acceso Dani" \
    to-addresses=10.10.3.166 to-ports=80
add action=dst-nat chain=dstnat comment="telefono 100 y 104" dst-port=82 \
    in-interface-list=WAN protocol=tcp src-address-list="Acceso Dani" \
    to-addresses=10.10.3.212 to-ports=80
add action=dst-nat chain=dstnat comment="telefono 101 y 105" dst-port=83 \
    in-interface-list=WAN protocol=tcp src-address-list="Acceso Dani" \
    to-addresses=10.10.3.200 to-ports=80
add action=dst-nat chain=dstnat comment="telefono 107" dst-port=84 \
    in-interface-list=WAN protocol=tcp src-address-list="Acceso Dani" \
    to-addresses=10.10.3.186 to-ports=80
add action=dst-nat chain=dstnat comment="telefono centralita" dst-port=85 \
    in-interface-list=WAN protocol=tcp src-address-list="Acceso Dani" \
    to-addresses=10.10.3.94 to-ports=80
/ip firewall service-port
set irc disabled=yes
set h323 disabled=yes
set sip disabled=yes
set pptp disabled=yes
set udplite disabled=yes
set dccp disabled=yes
set sctp disabled=yes
/ip hotspot user
set [ find default=yes ] limit-bytes-total=100000 limit-uptime=30s
add name=admin
add name=user1
add name=user2
add name=user3
add name=user4
add name=user5
/ip ipsec identity
add generate-policy=port-override peer=peer1
/ip route
add comment="Salida Cable movil telefonos" disabled=no dst-address=0.0.0.0/0 \
    gateway=vlan_fibra routing-table=CableMovil
add comment="Salida TP-Link + 4G telefonos Backup" disabled=no distance=2 \
    dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-table=CableMovil
add comment="Salida Backup Cable Movil" disabled=no distance=2 dst-address=\
    0.0.0.0/0 gateway=vlan_fibra
add comment="Netwatch Cable Movil" disabled=no dst-address=8.8.4.4/32 \
    gateway=vlan_fibra
add comment="Netwatch DNS Cable TP-LINK + 4G backup" disabled=no dst-address=\
    8.8.8.8/32 gateway=192.168.1.1
add comment="Salida Cloud PBX" disabled=no dst-address=109.167.0.0/16 \
    gateway=vlan_fibra
/ip service
set telnet disabled=yes
set ftp disabled=yes
set api disabled=yes
set api-ssl disabled=yes
/ip ssh
set allow-none-crypto=yes forwarding-enabled=remote
/ppp secret
add name=user1 profile=profile-pptp
add name=user2 profile=profile-pptp
add name=user3 profile=profile-pptp
add name=user4 profile=profile-pptp
add name=user5 profile=profile-pptp
add name=user6 profile=profile-pptp
add name=salvador profile=profile-pptp service=pptp
/system clock
set time-zone-name=Europe/Madrid
/system identity
set name="Cirilo Amoros"
/system ntp client
set enabled=yes
/system ntp client servers
add address=150.214.94.5
/system package update
set channel=development
/system scheduler
add name=Reboot on-event="system reboot" policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon \
    start-date=jul/30/2021 start-time=06:00:00
add disabled=yes name=Upgrade on-event="system routerboard upgrade" policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon \
    start-date=dec/11/2020 start-time=06:05:00
add disabled=yes name="Reboot 2" on-event="system reboot" policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon \
    start-date=dec/11/2020 start-time=06:10:00
/tool e-mail
set address=mail.oratioo.com from=<info@oratioo.com> port=587 tls=starttls \
    user=info@oratioo.com
/tool netwatch
add comment="TP-Link + 4G backup" down-script="ip firewall mangle enable \"Red\
    1\"\r\
    \nip firewall mangle enable \"Red2\"\r\
    \nip firewall mangle enable \"Red3\"\r\
    \nip firewall mangle enable \"Red4\"\r\
    \ntool e-mail send to=\"soporte@oratioo.com\" subject=\"[DOWN]Alerta Vodaf\
    one Cirilo\" body=\"La linea de Vodafone se ha caido\"" host=8.8.8.8 \
    interval=30s up-script="ip firewall mangle disable \"Red1\"\r\
    \nip firewall mangle disable \"Red2\"\r\
    \nip firewall mangle disable \"Red3\"\r\
    \nip firewall mangle disable \"Red4\"\r\
    \ntool e-mail send to=\"soporte@oratioo.com\" subject=\"[UP]Alerta Vodafon\
    e Cirilo\" body=\"La linea de Vodafone se ha levantado\""
add comment="Cable Movil" down-script="tool e-mail send to=\"soporte@oratioo.c\
    om\" subject=\"[DOWN]Alerta Cable Movil Cirilo\" body=\"La linea de Cable \
    Movil se ha caido\"\r\
    \nip route disable \"Salida Cable movil telefonos\"" host=8.8.4.4 \
    interval=30s up-script="tool e-mail send to=\"soporte@oratioo.com\" subjec\
    t=\"[UP]Alerta Cable Movil Cirilo\" body=\"La linea de Cable Movil se ha l\
    evantado\"\r\
    \nip route enable \"Salida Cable movil telefonos\""
add comment="Cloud PBX" down-script="tool e-mail send to=\"soporte@oratioo.com\
    \" subject=\"[DOWN]Alerta Cloud PBX Cirilo\" body=\"La Cloud PBX se ha cai\
    do\"" host=109.167.99.122 interval=30s up-script="tool e-mail send to=\"so\
    porte@oratioo.com\" subject=\"[UP]Alerta Cloud PBX Cirilo\" body=\"La Clou\
    d PBX se ha levantado\""



Gracias de antemano por vuestros comentarios
 
Si sólo necesitas un failover, no tienes que tocar para nada la tabla de rutas. con ponerle distinta distancia al cliente dhcp, ya lo tienes hecho. Una ruta te aparecerá con la distancia por defecto (1) y la otra con un 2 en azúl, esperando a que la primera se caiga. Si además quieres monitorear activamente el gateway, métele un check-gateway=ping y andando, creando la ruta manualmente.

Saludos!
 
Arriba