MANUAL: Mikrotik, el amigo gorrón [IPTV pululante]

- Nuevo peer
- Nueva Interfaz Wireguard
- Nuevo Túnel Eoip
- Añadir dirección IP del nuevo
- Abrir otro puerto en el HGU donde está Paco.
Es básicamente lo mismo que he tenido que hacer yo.
Salu2;)
 
- Nuevo peer
- Nueva Interfaz Wireguard
- Nuevo Túnel Eoip
- Añadir dirección IP del nuevo
- Abrir otro puerto en el HGU donde está Paco.
Es básicamente lo mismo que he tenido que hacer yo.
Salu2;)
Pero esto sería para un nuevo Pepe correcto?

En principio yo solo necesitaba un peer para gestionar a Paco y el HGU.

Probaré de todos modos todos esos pasos :)

Gracias!
 
Si, eso es para un nuevo Pepe.
Para gestionar el HGU me interesa a mi también, es muy interesante.
Salu2;)
No es complicado, para gestionar el HGU directamente puedes añadirle un DDNS tipo NoIP y lo llamas desde internet.

1669034452886.png


Nateas el puerto de acceso:

1669034621818.png


Y permites el acceso desde fuera:

1669034831788.png


Si lo que quieres es acceder al Mikrotik de Paco, yo le tengo creado una nueva VPN Wireguard tipo road warrior, accedo desde cualquier parte (te evitas muchos viajes a casa de Paco) y además entro en la 192.168.1.1 del HGU para gestionarlo también al estar en la misma subred del bridge-iptv.

S@lu2.
 
Buenas!

Antes de nada muchas gracias por todo, increíble la cantidad de info que compartís. Deciros que tengo montado un Paco y un Pepe sin problemas y funcionando a tope :)

La cuestión es que he intentado agregar un nuevo peer a Paco para desde cualquier sitio, poder gestionarlo, tanto a Paco como al router de la operadora en caso de necesidad y no tener que ir a Pepe o a Paco en persona.

A parte de añadir el peer tengo que hacer algo más en Paco?

Gracias!!
Monta una VPN de tipo roadwarrior en Paco, con un servidor wireguard dedicado, y ya lo tienes. O directamente manejarlo desde la conexión VPN de tu pepe, enrutando los segmentos.

Saludos!
 
Monta una VPN de tipo roadwarrior en Paco, con un servidor wireguard dedicado, y ya lo tienes. O directamente manejarlo desde la conexión VPN de tu pepe, enrutando los segmentos.

Saludos!
La idea era poder entrar en Paco y su HGU desde el teléfono por eso descarté a Pepe :)

He intentado montarla usando la interface winguard que ya hay con un nuevo peer y con otra nueva... pero algo no termina de funcionar... voy a buscar un manual para montarla tipo road warrior y sino abro otro post.

Gracias!
 
No uses la misma interfaz, crea otra ditinta.

Lo de Pepe te lo digo porque yo conecto a Pepe (mi router, de mi casa) y tengo el acceso enrutado para llegar a Paco, Francisco, Juan, Antonio y Damián. Al final, como esos túneles ya están ahí y están funcionando, lo único que neceistas es enrutar el tráfico para llegar al otro extremo y vuelta. Lo digo por si no quieres andar tocando más el Paco, que al final necesitará abrir otro puerto para este cometido, si usas otra interfaz.

Saludos!
 
Segunda opción: equipo mikrotik en modo bridge debajo del Asus + Mikrotik como principal en el otro extremo, este último, de tu elección (un hAP-ac3 puede ser buen candidato).

Saludos!

Buenas @pokoyo.

Lo primero de todo gracias por responder. Me gustaría hacerte otra preguntilla. Si quiero ver la TV en dos casas distintas al mismo tiempo imagino que el mAP 2nd se va a quedar "corto" por el tema del Ethernet 10/100. ¿Qué equipo podría poner para solventar este caso?

Por otro lado, estaba pensando en poner un hAP-ax3 (son unos 50€ de diferencia respecto al ac3) como router neutro en el otro extremo. Merece la pena el cambio?

Un saludo y gracias por adelantado.
 
Lo primero de todo gracias por responder. Me gustaría hacerte otra preguntilla. Si quiero ver la TV en dos casas distintas al mismo tiempo imagino que el mAP 2nd se va a quedar "corto" por el tema del Ethernet 10/100. ¿Qué equipo podría poner para solventar este caso?
No lo subestimes. A menos que hables de 4K, no se queda corto no. Dos o tres peers remotos, sin problema. Aunque sí que es verdad que yo montaría otro equipo que vaya un poco más sobrado de recursos. Rb750gr3, hAP-ac2, etc.

Por otro lado, estaba pensando en poner un hAP-ax3 (son unos 50€ de diferencia respecto al ac3) como router neutro en el otro extremo. Merece la pena el cambio?
Si lo consigues en stock, adelante.

Saludos!
 
No uses la misma interfaz, crea otra ditinta.

Lo de Pepe te lo digo porque yo conecto a Pepe (mi router, de mi casa) y tengo el acceso enrutado para llegar a Paco, Francisco, Juan, Antonio y Damián. Al final, como esos túneles ya están ahí y están funcionando, lo único que neceistas es enrutar el tráfico para llegar al otro extremo y vuelta. Lo digo por si no quieres andar tocando más el Paco, que al final necesitará abrir otro puerto para este cometido, si usas otra interfaz.

Saludos!

Hola @pokoyo

Al final conseguí montar la vpn en Paco para poder ver desde el móvil a Paco pero no consigo ver el HGU (192.168.1.1) ni ningún otro dispositivo en la red de Paco :S

Es posible que no se pueda ya que Paco es un bridge y no deja ver más que a el mismo?

Os dejo el export por si veis algo raro :)

Código:
# nov/23/2022 22:10:04 by RouterOS 7.6
# software id = 2DGK-EBKD
#
# model = RB750Gr3
# serial number = HCM07MHF5PP
/interface bridge
add igmp-snooping=yes name=bridge-iptv
add admin-mac=DC:2C:6E:FB:54:39 auto-mac=no name=bridge-lo
/interface eoip
add local-address=172.17.0.1 mac-address=FE:E0:53:05:DD:99 mtu=1500 name=\
    eoip-iptv remote-address=172.17.0.2 tunnel-id=0
/interface wireguard
add listen-port=54321 mtu=1420 name=wg-sts-iptv
add listen-port=54322 mtu=1420 name=wireguard1
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=hotspot
/ip pool
add name=pool-lo ranges=192.168.79.2-192.168.79.254
/ip dhcp-server
add address-pool=pool-lo interface=bridge-lo name=dhcp-lo
/port
set 0 name=serial0
/interface bridge port
add bridge=bridge-lo interface=ether2
add bridge=bridge-iptv interface=ether1
add bridge=bridge-iptv interface=eoip-iptv
/interface wireguard peers
add allowed-address=172.17.0.2/32 endpoint-address=xxxx.ddns.com \
    endpoint-port=54321 interface=wg-sts-iptv public-key=\
    "PpiAUwSmYQhocR+sCmxBDSSJAcTCVzN2J3izBKMFjkM="
add allowed-address=10.255.255.3/32 interface=wireguard1 public-key=\
    "wZ06L0PPDYk7+/C4s8Wo7dYevb8pHh4TZhW/mLtcYhE="
/ip address
add address=192.168.79.1/24 interface=bridge-lo network=192.168.79.0
add address=172.17.0.1/30 interface=wg-sts-iptv network=172.17.0.0
add address=10.255.255.1/24 interface=wireguard1 network=10.255.255.0
/ip cloud
set ddns-enabled=yes
/ip dhcp-client
add interface=bridge-iptv
/ip dhcp-server network
add address=192.168.79.0/24 gateway=192.168.79.1
/ip dns
set servers=8.8.8.8,8.4.4.8
/system clock
set time-zone-name=Europe/Madrid
/system identity
set name=gorron

Saludos!
 
Simplemente necesitas natear dicha subred. Date cuenta que ese dispositivo sólo conoce qué hacer con el segmento de red que le llega al bridge, nada más.
Mira el primer manual que hice de Wireguard y verás un ejemplo de ese setup.

Saludos!
 
Simplemente necesitas natear dicha subred. Date cuenta que ese dispositivo sólo conoce qué hacer con el segmento de red que le llega al bridge, nada más.
Mira el primer manual que hice de Wireguard y verás un ejemplo de ese setup.

Saludos!
Muchas gracias @pokoyo ! Conseguido! :love:

Ya que os he dado la turra, dejo lo que me faltaba por si a alguien le apaña:

Código:
/ip firewall nat
add action=masquerade chain=srcnat src-address=10.255.255.0/24

Paco + Pepe a todo gas!!! :love:

Saludos!
 
Hola, buenas tardes.
Me ha pasado algo extraño, hoy de golpe y porrazo solo tengo acceso desde Pepe2 a los canales generalistas (La1, La2, Antena3, Cuatro...etc) y ninguno de la plataforma, si le doy a menú aparece problema de red, alguien más le ha pasado esto?
Llevaba varios días sin problema, muy raro.
Me sale en DCHP server defconf interface bridge en rojo, ahí creo está el error.
Gracias y Salu2;).
 
Última edición:
Hola, buenas tardes.
Me ha pasado algo extraño, hoy de golpe y porrazo solo tengo acceso desde Pepe2 a los canales generalistas (La1, La2, Antena3, Cuatro...etc) y ninguno de la plataforma, si le doy a menú aparece problema de red, alguien más le ha pasado esto?
Llevaba varios días sin problema, muy raro.
Me sale en DCHP server defconf interface bridge en rojo, ahí creo está el error.
Gracias y Salu2;).
Pepe, hasta donde yo sé, no utiliza el DHCP server para nada en la ecuación del IPTV. Revisa que ambos túneles estén levantados, tanto wireguard como EoIP.

Saludos!
 
Solucionado.
No se cómo pero detecta en la red de Pepe2 un Xiaomi TV Box y el fútbol no deja verlo.
Si lo apagas funciona sin problema.
Salu2;)
 
Buenas,

Sigo peleándome con esta config. He estado investigando y creo que el problema viene de la apertura de puertos. Por algún motivo no consigo que el router de movistar asigne una ip fija al map. En la configuración del HGU fijo una ip a la MAC del bridge, pero la MAC cambia cada vez que el map se reinicia. ¿Puedo hacer que el map pida directamente la misma ip? Imagino que será en la parte de DHCP Client, pero no entiendo bien qué implican las opciones que hay ahí.

Me planteaba otra posibilidad una vez que consiga que esto me funcione. ¿Cómo podría hacer para que la casa con M+ (que tiene un map conectado a su HGU) pueda acceder a mi subred?

Saludos!
 
Simplemente ponle una admin-mac al bridge, de cualquiera de los puertos que lleve dentro. Así no cambiará de dirección cuando reinicie. O, en IP -> Address, pones la IP a mano, perteneciente al rango del HGU, sobre la interfaz bridge, en lugar de andar con reservas del DHCP en el HGU.

Lo segundo lo consigues enrutando el tráfico de la tabla de rutas. Aunque, funcionando en modo bridge, no sé si es una buena idea.

Saludos!
 
Gracias! De poner la IP a mano (p.ej., 192.168.1.20), ¿que network tendría que poner? ¿192.168.1.0?
la network se pone sola cuando pones la notación CIDR. Y sí, es esa.
Código:
/ip address
add address=192.168.1.20/24 interface=bridge-iptv

Saludos!
 
Arriba