MANUAL: FTTH Movistar/Jazztel con router neutro Mikrotik

Hola. Os quería pedir ayuda. He comprado un hex RB750Gr3 para sustituir el router Comtrend Movistar que tenía hasta ahora. Tengo ONT independiente. Me funciona todo correctamente excepto el deco de tv. He leído mensajes, tutoriales, revisado mi configuración, y no consigo solucionarlo. He configurado el puerto 5 del RB750 exclusivamente para el deco, con una subred independiente (ya tenía algo similar con el Comtrend, usando subredes diferentes), y veo que pilla la IP correctamente (192.168.1.200). He hecho captura de tráfico en el interface dedicado a IPTV y veo que se comunica con una IP pública, pero no consigo hacerlo funcionar. Os pongo mi configuración por si alguien ve el fallo que tendré, porque tras dos días sin conseguir dar con ello empiezo a desesperarme:

Código:
/interface bridge
add igmp-snooping=yes name=bridge-IPTV
add igmp-snooping=yes multicast-router=disabled name=bridge-LAN \
    protocol-mode=none
/interface ethernet
set [ find default-name=ether1 ] comment=WAN name=ether1-WAN
set [ find default-name=ether2 ] name=ether2-LAN
set [ find default-name=ether3 ] name=ether3-LAN
set [ find default-name=ether4 ] name=ether4-LAN
set [ find default-name=ether5 ] comment="Deco MOVISTAR" name=ether5-LAN-DECO
/interface vlan
add interface=ether1-WAN name=vlan2-IPTV vlan-id=2
add interface=ether1-WAN name=vlan3-VOIP vlan-id=3
add interface=ether1-WAN name=vlan6-INTERNET vlan-id=6
/interface pppoe-client
add add-default-route=yes allow=pap,chap disabled=no interface=vlan6-INTERNET \
    keepalive-timeout=60 max-mru=1492 max-mtu=1492 name=pppoe-out1 password=\
    adslppp use-peer-dns=yes user=adslppp@telefonicanetpa
/interface list
add comment="Vlan2 (Iptv) & Vlan3 (Voip)" name=Vlan2&3
add name=WAN
add name=LAN
add name=DECO
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip dhcp-server option
add code=240 name=option_para_deco value=\
    "':::::239.0.2.10:22222:v6.0:239.0.2.30:22222'"
/ip pool
add name=dhcp-lan ranges=192.168.5.100-192.168.5.150
add name=dhcp-iptv ranges=192.168.1.200-192.168.1.223
/ip dhcp-server
add address-pool=dhcp-lan disabled=no interface=bridge-LAN lease-time=30m \
    name=dhcp-LAN
add address-pool=dhcp-iptv disabled=no interface=bridge-IPTV lease-time=10h \
    name=dhcp-IPTV
/interface bridge filter
add action=drop chain=output dst-address=239.0.0.0/8 ip-protocol=udp \
    mac-protocol=ip out-interface=ether4-LAN
/interface bridge port
add bridge=bridge-LAN interface=ether2-LAN multicast-router=disabled
add bridge=bridge-LAN interface=ether3-LAN multicast-router=disabled
add bridge=bridge-LAN interface=ether4-LAN multicast-router=disabled
add bridge=bridge-IPTV interface=ether5-LAN-DECO multicast-router=disabled
/interface list member
add interface=vlan3-VOIP list=Vlan2&3
add interface=vlan2-IPTV list=Vlan2&3
add interface=ether1-WAN list=WAN
add interface=bridge-LAN list=LAN
add interface=bridge-IPTV list=DECO
/interface pptp-server server
set authentication=mschap2 enabled=yes
/ip address
add address=192.168.1.1/24 comment="Para Movistar+" interface=bridge-IPTV \
    network=192.168.1.0
add address=192.168.5.1/24 comment="LAN PCs" interface=bridge-LAN network=\
    192.168.5.0
add address=[IP_de_VLAN2]/9 comment=\
    "Mi Telefonica IPTV address, sacada de la config del router Comtrend" \
    interface=vlan2-IPTV network=10.128.0.0
/ip dhcp-client
add add-default-route=no disabled=no interface=vlan3-VOIP use-peer-ntp=no
add disabled=no interface=ether1-WAN
/ip dhcp-server network
add address=192.168.1.0/24 dhcp-option=option_para_deco dns-server=\
    172.26.23.3 gateway=192.168.1.1 netmask=24
add address=192.168.5.0/24 dns-server=192.168.5.1,1.1.1.1 gateway=192.168.5.1 \
    netmask=24
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.1.1 name=router1
add address=192.168.5.1 name=router5
/ip firewall filter
add chain=forward comment="default configuration" connection-state=\
    established
add chain=forward comment="default configuration" connection-state=related
add action=accept chain=input protocol=icmp
add action=accept chain=input connection-state=established
add action=accept chain=input connection-state=related
add action=accept chain=input comment="Accept vlan2 Iptv IGMP packets" \
    in-interface=vlan2-IPTV protocol=igmp
add action=accept chain=input comment=\
    "Accept vlan2 & 3  (Iptv & Voip) multicast & broadcast traffic" \
    dst-address-type=!unicast in-interface-list=Vlan2&3
add action=drop chain=forward comment=\
    "Drop all new unicast traffic from vlan3 & 2 (Voip & Iptv) not DSTNATed" \
    connection-nat-state=!dstnat connection-state=new dst-address-type=\
    unicast in-interface-list=Vlan2&3
add action=drop chain=forward comment="default configuration" \
    connection-state=invalid
add action=drop chain=input in-interface-list=!LAN
/ip firewall mangle
add action=set-priority chain=postrouting comment="Prioritise Voip packets" \
    new-priority=5 out-interface=vlan3-VOIP passthrough=yes
add action=set-priority chain=postrouting comment="Prioritise Iptv packets" \
    new-priority=4 out-interface=vlan2-IPTV passthrough=yes
add action=set-priority chain=postrouting new-priority=1 out-interface=\
    pppoe-out1
/ip firewall nat
add action=masquerade chain=srcnat comment="default configuration" \
    out-interface=pppoe-out1
add action=masquerade chain=srcnat comment="default configuration" \
    out-interface=ether1-WAN
add action=masquerade chain=srcnat comment="default configuration" \
    out-interface=vlan2-IPTV
add action=masquerade chain=srcnat comment="default configuration" \
    out-interface=vlan3-VOIP
add action=dst-nat chain=dstnat comment=VOD dst-address-type=local \
    in-interface=vlan2-IPTV to-addresses=192.168.1.199
add action=dst-nat chain=dstnat dst-port=80 in-interface=pppoe-out1 protocol=\
    tcp to-addresses=192.168.5.25
add action=dst-nat chain=dstnat dst-port=443 in-interface=pppoe-out1 \
    protocol=tcp to-addresses=192.168.5.25
add action=dst-nat chain=dstnat disabled=yes dst-port=1194 in-interface=\
    pppoe-out1 protocol=udp to-addresses=192.168.5.25
add action=dst-nat chain=dstnat disabled=yes dst-port=1195 in-interface=\
    pppoe-out1 protocol=tcp to-addresses=192.168.5.26
add action=dst-nat chain=dstnat disabled=yes dst-port=8111 in-interface=\
    pppoe-out1 protocol=tcp to-addresses=192.168.5.6
add action=dst-nat chain=dstnat disabled=yes dst-port=8080 in-interface=\
    pppoe-out1 protocol=tcp to-addresses=192.168.5.6
add action=dst-nat chain=dstnat comment="VOD Movistar 1 Desco" \
    dst-address-type=local in-interface=vlan2-IPTV to-addresses=192.168.1.200
add action=masquerade chain=srcnat comment=\
    "masq. vlan2 & vlan3 (Iptv & Voip)" out-interface-list=Vlan2&3
/ip firewall service-port
set sip disabled=yes ports=5060,5070
/ip route
add disabled=yes distance=255 gateway=255.255.255.255
/ppp profile
set *FFFFFFFE dns-server=192.168.3.250 local-address=192.168.3.250 \
    remote-address=*2
/routing igmp-proxy interface
add alternative-subnets=0.0.0.0/0 interface=vlan2-IPTV upstream=yes
add interface=ether5-LAN-DECO
/routing rip interface
add interface=vlan3-VOIP passive=yes receive=v2
add interface=vlan2-IPTV passive=yes receive=v2
/routing rip network
add network=10.0.0.0/8
add network=172.26.0.0/16
/system clock
set time-zone-name=Europe/Madrid
/system identity
set name=MikroTik-AyV
/system ntp client
set enabled=yes primary-ntp=150.214.94.5 secondary-ntp=150.214.94.10
/tool sniffer
set filter-interface=bridge-IPTV
Tienes dos configuraciones a elegir en el post de las configuraciones básicas de los ISPs, que están probadas y funcionan. Tienes muchas cosas raras en esa configuración que te podrían estar causando problemas, como por ejemplo tener igmp snooping en los dos bridges, y luego aplicarle filtrado.
Te recomiendo aplicar una de las dos, sobre la configuración por defecto, y olvidarte de esta que tienes.

Saludos!
 
Tienes dos configuraciones a elegir en el post de las configuraciones básicas de los ISPs, que están probadas y funcionan. Tienes muchas cosas raras en esa configuración que te podrían estar causando problemas, como por ejemplo tener igmp snooping en los dos bridges, y luego aplicarle filtrado.
Te recomiendo aplicar una de las dos, sobre la configuración por defecto, y olvidarte de esta que tienes.

Saludos!
Gracias por tu respuesta. El problema es que la configuración publicada tiene el AP en un puerto separado, y yo necesito que lo esté el deco, porque el AP que tengo va conectado a un switch PoE sin IGMP snooping donde van más equipos.
De todas formas probaré la configuración que dices a ver si así me funciona.

Corrijo: Veo que hay una configuración que si es con el puerto 2 para el deco. Voy a probarla. Gracias de nuevo.
 
Última edición:
Tienes dos configuraciones a elegir en el post de las configuraciones básicas de los ISPs, que están probadas y funcionan. Tienes muchas cosas raras en esa configuración que te podrían estar causando problemas, como por ejemplo tener igmp snooping en los dos bridges, y luego aplicarle filtrado.
Te recomiendo aplicar una de las dos, sobre la configuración por defecto, y olvidarte de esta que tienes.

Saludos!
He cargado la configuración básica y ya está funcionando bien. Ahora voy a hacerle las adaptaciones que necesito.
Muchas gracias @pokoyo
 
He cargado la configuración básica y ya está funcionando bien. Ahora voy a hacerle las adaptaciones que necesito.
Muchas gracias @pokoyo
Wenas, qué configuración has usado en concreto...? Veo que hay una parte en una de las opciones que requiere "buscar" la ip (10.x.x.x) del deco... ¿por qué opción has ido? Gracias !!
 
Wenas, qué configuración has usado en concreto...? Veo que hay una parte en una de las opciones que requiere "buscar" la ip (10.x.x.x) del deco... ¿por qué opción has ido? Gracias !!

Por si te sirve de ayuda puedes empezar echando un vistazo a los siguientes hilos:

Para obtener los datos del deco:

Saludos.
 
Por si te sirve de ayuda puedes empezar echando un vistazo a los siguientes hilos:

Para obtener los datos del deco:

Saludos.
Ok, aclarado como obtener la ip del deco, gracias ! :)
 
Arriba