MANUAL: FTTH Movistar/Jazztel con router neutro Mikrotik

Perdonad la demora:

Con EoIP puedo ver todo en todos los descos (el de mis suegros principal directo al router, el de mis suegros a través del AP y el mío en mi casa tunel EoIP)

El único problema que tengo con todo operativo, es el tema de VOD, es decir, en desco remoto de mi casa, y el segundo de mis suegros que pasa por el AP.
Vale. Ya me he aclarado. El puente EoIp funciona. Efectivamente, es cuestión del VOD y del script de @toniros
 
Actualizo pruebas:
Si la regla:
/ip firewall nat
add action=dst-nat chain=dstnat comment="VOD Script" dst-address-type=local in-interface=vlan2 to-addresses=192.168.1.201

Le cambio la IP manualmente a cualquiera de los otros descos (192.168.1.202 o 192.168.1.203)
funcionan correctamente (pero solo uno de cada vez.

Así que entiendo que ni afecta el túnel EoIP desde mi casa a casa de mis suegros, ni afecta la configuración del AP (RB951) donde está el deco2 de mis suegros.

Y si pongo las 3 reglas consecutivas (cada uno con una IP) solo funciona el primero...
Creo recordar que me habíais comentado en un mensaje anterior, que esta regla, no debería crearla manualmente, sino dejar que el script la crease sola. Pero revisando el script, lo que debería hacer es que si detecta una regla creada con ese comentario, la debería haber borrado, y sobre-escribirla con la nueva regla IP...

No se...hay algo que no termino de ver...y fijo que es una gilipollez.

Ya me diréis...

Gracias por todo, igualmente.

A ver. La regla NAT es la que encamina el tráfico VOD como te decía, efectivamente. Y el script tiene la detección y eliminación de una regla comentada, con lo cual NO la elimina. Solo la elimina, más adelante en el script, si la dirección del desco que emite el comando es distinta del de la regla existente. Por todo ello, y para no liarlo, es mejor no tener ninguna regla puesta a mano. También puedes quitar el comentario de la primera rama del script (el if), para eliminar la reglas preexistentes automáticamente, claro.

Pero el problema que creo que tienes no es ese. La clave es ver si la regla de detección del comando de arranque del RTSP que está en el mangle está funcionando o no adecuadamente. Como te decía:

=========

Es por ello, que te decía hace unos días que te fijaras si la regla 3) chutaba o no con el desco conectado al AP PERO viendo si se iniciaba una conexión TCP en el router principal. Para ello, te sugería añadir a la regla un log para ver que pasaba por allí:

4) regla 3 con log

add action=add-src-to-address-list address-list=vod-receiver \
address-list-timeout=1m chain=postrouting comment="RTSP - VOD Movistar" \
dst-port=554 out-interface=vlan2 protocol=tcp log=yes log-prefix="VOD marcado"

====

Lo que creo que sucede es que el paquete donde está el comando, cuando viene desde el túnel, no transita por la cadena de post routing del router principal, que es el que debe detectar ese paquete, identificar la dirección del desco que lo ha generado y meterlo en una lista, que después usará el scrip para generar la regla NAT correspondiente. Puede que el paquete transite SOLO por el bridge, y por eso no llega a esa cadena, o es que hay algo que se me escapa en el packet flow. Mira, por favor, el log, una vez hayas puesto la regla de mangle y analizamos que está pasando.

Ya después hablamos.


Suerte!!
 
Se me ha "jodido" el tema.
Se pusieron a actualizar los descos 2 y 3 se han quedado bloqueados. Coincidencia? Pues no. Creo que me han "pillado" y me han capado el poder usar más de un desco.
 
Hola a tod@s,

Tengo jazztel neba y he usado una de las configs que he visto en este post, pero por ahora a parte de tener internet en mikrotik (y mi red) y en livebox (se enciende el led y coge ip), me falta la voip en el livebox.
No se si alguien puede mirarlo a ver si me sabe decir qué me falta o qué tengo mal.
Gracias de antemano
Código:
# oct/25/2020 15:25:05 by RouterOS 6.47.4
# software id = QUXP-
#
# model = RB760iGS
# serial number = XXXXXX
/interface bridge
add name=bridge1
/interface ethernet
set [ find default-name=ether1 ] mac-address=XX:XX:XX:XX:XX:XX name=\
    ether1-gateway
set [ find default-name=ether2 ] arp=proxy-arp name=ether2-master-local
set [ find default-name=ether3 ] name=ether3-slave-local
set [ find default-name=ether4 ] name=ether4-slave-local
set [ find default-name=ether5 ] name=ether5-slave-local
/interface vlan
add interface=ether1-gateway name=vlan1 vlan-id=20
add interface=bridge1 name=vlan1_livebox vlan-id=20
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/ip pool
add name=dhcp ranges=192.168.1.20-192.168.1.90
add name=poolvoip ranges=192.168.2.100
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge1 name=default
add address-pool=poolvoip disabled=no interface=vlan1_livebox name=voip
/ppp profile
set *FFFFFFFE dns-server=62.36.225.150,63.37.228.20 local-address=192.168.1.1 \
    remote-address=dhcp
/interface bridge port
add bridge=bridge1 interface=ether2-master-local
add bridge=bridge1 interface=ether3-slave-local
add bridge=bridge1 interface=ether4-slave-local
add bridge=bridge1 interface=ether5-slave-local
/interface detect-internet
set detect-interface-list=all
/ip address
add address=192.168.1.1/23 comment="default configuration" interface=\
    ether2-master-local network=192.168.1.0
add address=192.168.2.1/24 interface=vlan1_livebox network=192.168.2.0
/ip dhcp-client
add comment="default configuration" disabled=no interface=vlan1
/ip dhcp-server network
add address=192.168.1.0/23 comment="default configuration" gateway=192.168.1.1
add address=192.168.2.0/24 comment=VOIP gateway=192.168.2.1
/ip dns
set allow-remote-requests=yes cache-size=4096KiB max-udp-packet-size=512
/ip dns static
add address=192.168.1.1 name=router
/ip firewall filter
add chain=input comment="default Configuration" connection-state=\
    established,related
add action=fasttrack-connection chain=forward comment=Fasttrack \
    connection-state=established,related
add chain=forward comment="default configuration" connection-state=\
    established,related
add chain=input comment="default configuration" protocol=icmp
add chain=input dst-port=1723 in-interface=vlan1 protocol=tcp
add action=accept chain=input comment=webfig disabled=yes dst-port=81 \
    in-interface=vlan1 protocol=tcp
add action=accept chain=input comment="Winbox Remoto" disabled=yes dst-port=\
    8291 in-interface=vlan1 protocol=tcp
add action=drop chain=input comment="default configuration" in-interface=\
    vlan1
add action=drop chain=forward comment="default configuration" \
    connection-state=invalid
add action=drop chain=forward comment="default configuration" \
    connection-nat-state=!dstnat connection-state=new in-interface=vlan1
/ip firewall nat
add action=masquerade chain=srcnat comment="default configuration" \
    out-interface=vlan1
add action=masquerade chain=srcnat comment="default configuration" \
    out-interface=vlan1_livebox
add action=masquerade chain=srcnat comment="default configuration" \
    out-interface=ether1-gateway
/ip service
set www port=81
set www-ssl disabled=no
set api disabled=yes
/ip upnp
set allow-disable-external-interface=yes
/ip upnp interfaces
add interface=vlan1 type=external
add interface=ether2-master-local type=internal
/system clock
set time-zone-name=Europe/Madrid
/system ntp client
set enabled=yes primary-ntp=129.6.15.28 secondary-ntp=129.6.15.29
/system routerboard settings
set auto-upgrade=yes
 
Hola a tod@s,

Tengo jazztel neba y he usado una de las configs que he visto en este post, pero por ahora a parte de tener internet en mikrotik (y mi red) y en livebox (se enciende el led y coge ip), me falta la voip en el livebox.
No se si alguien puede mirarlo a ver si me sabe decir qué me falta o qué tengo mal.
Gracias de antemano
Código:
# oct/25/2020 15:25:05 by RouterOS 6.47.4
# software id = QUXP-
#
# model = RB760iGS
# serial number = XXXXXX
/interface bridge
add name=bridge1
/interface ethernet
set [ find default-name=ether1 ] mac-address=XX:XX:XX:XX:XX:XX name=\
    ether1-gateway
set [ find default-name=ether2 ] arp=proxy-arp name=ether2-master-local
set [ find default-name=ether3 ] name=ether3-slave-local
set [ find default-name=ether4 ] name=ether4-slave-local
set [ find default-name=ether5 ] name=ether5-slave-local
/interface vlan
add interface=ether1-gateway name=vlan1 vlan-id=20
add interface=bridge1 name=vlan1_livebox vlan-id=20
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/ip pool
add name=dhcp ranges=192.168.1.20-192.168.1.90
add name=poolvoip ranges=192.168.2.100
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge1 name=default
add address-pool=poolvoip disabled=no interface=vlan1_livebox name=voip
/ppp profile
set *FFFFFFFE dns-server=62.36.225.150,63.37.228.20 local-address=192.168.1.1 \
    remote-address=dhcp
/interface bridge port
add bridge=bridge1 interface=ether2-master-local
add bridge=bridge1 interface=ether3-slave-local
add bridge=bridge1 interface=ether4-slave-local
add bridge=bridge1 interface=ether5-slave-local
/interface detect-internet
set detect-interface-list=all
/ip address
add address=192.168.1.1/23 comment="default configuration" interface=\
    ether2-master-local network=192.168.1.0
add address=192.168.2.1/24 interface=vlan1_livebox network=192.168.2.0
/ip dhcp-client
add comment="default configuration" disabled=no interface=vlan1
/ip dhcp-server network
add address=192.168.1.0/23 comment="default configuration" gateway=192.168.1.1
add address=192.168.2.0/24 comment=VOIP gateway=192.168.2.1
/ip dns
set allow-remote-requests=yes cache-size=4096KiB max-udp-packet-size=512
/ip dns static
add address=192.168.1.1 name=router
/ip firewall filter
add chain=input comment="default Configuration" connection-state=\
    established,related
add action=fasttrack-connection chain=forward comment=Fasttrack \
    connection-state=established,related
add chain=forward comment="default configuration" connection-state=\
    established,related
add chain=input comment="default configuration" protocol=icmp
add chain=input dst-port=1723 in-interface=vlan1 protocol=tcp
add action=accept chain=input comment=webfig disabled=yes dst-port=81 \
    in-interface=vlan1 protocol=tcp
add action=accept chain=input comment="Winbox Remoto" disabled=yes dst-port=\
    8291 in-interface=vlan1 protocol=tcp
add action=drop chain=input comment="default configuration" in-interface=\
    vlan1
add action=drop chain=forward comment="default configuration" \
    connection-state=invalid
add action=drop chain=forward comment="default configuration" \
    connection-nat-state=!dstnat connection-state=new in-interface=vlan1
/ip firewall nat
add action=masquerade chain=srcnat comment="default configuration" \
    out-interface=vlan1
add action=masquerade chain=srcnat comment="default configuration" \
    out-interface=vlan1_livebox
add action=masquerade chain=srcnat comment="default configuration" \
    out-interface=ether1-gateway
/ip service
set www port=81
set www-ssl disabled=no
set api disabled=yes
/ip upnp
set allow-disable-external-interface=yes
/ip upnp interfaces
add interface=vlan1 type=external
add interface=ether2-master-local type=internal
/system clock
set time-zone-name=Europe/Madrid
/system ntp client
set enabled=yes primary-ntp=129.6.15.28 secondary-ntp=129.6.15.29
/system routerboard settings
set auto-upgrade=yes


Hola Tito.

No estoy seguro de cómo va la configuración de JAZZTEL (vivo fuera de España y llevo tiempo sin pelearme con los operadores de ahí, a excepción de los de Movis de mis suegros)
Si funciona de un modo similar, el montaje, creo que te falta declarar la vlan correspondiente al VOIP. Es decir, solo veo una VLAN creada para el acceso a internet.
Según configuraciones Movistar, cada servicio va por una VLAN diferente: INTERNET, VOIP y VOD.

A ver si hay alguien más puesto en el tema, que te pueda ayudar al respecto...

PD: tienes acceso al router de JAZZTEL, del que puedas exportar y mostrar la configuración? Quizá podría darme más pistas al respecto.

Un saludo,
 
Hola Tito.

No estoy seguro de cómo va la configuración de JAZZTEL (vivo fuera de España y llevo tiempo sin pelearme con los operadores de ahí, a excepción de los de Movis de mis suegros)
Si funciona de un modo similar, el montaje, creo que te falta declarar la vlan correspondiente al VOIP. Es decir, solo veo una VLAN creada para el acceso a internet.
Según configuraciones Movistar, cada servicio va por una VLAN diferente: INTERNET, VOIP y VOD.

A ver si hay alguien más puesto en el tema, que te pueda ayudar al respecto...

PD: tienes acceso al router de JAZZTEL, del que puedas exportar y mostrar la configuración? Quizá podría darme más pistas al respecto.

Un saludo,
Gracias por responder.

Yo en los rsc de @Malosa veo que la diferencia entre el de jazztel y jazztelVoip es que crea otra vlan "vlan1074lan". Yo hice lo mismo pero con vlan20 (con jazztel neba internet, voip y tv va por la triple vlan 20)

lo único que veo en su configuracion que no tengo en la mia es lo siguiente:
Código:
add action=masquerade chain=srcnat disabled=yes out-interface=vlan1074lan
add action=masquerade chain=srcnat disabled=yes out-interface=ether2-master-local
No sé si es esto lo que me falta... (pero con vlan1_livebox y bridge1 en vez de vlan1074lan y ether2-master-local)
 
Gracias por responder.

Yo en los rsc de @Malosa veo que la diferencia entre el de jazztel y jazztelVoip es que crea otra vlan "vlan1074lan". Yo hice lo mismo pero con vlan20 (con jazztel neba internet, voip y tv va por la triple vlan 20)

lo único que veo en su configuracion que no tengo en la mia es lo siguiente:
Código:
add action=masquerade chain=srcnat disabled=yes out-interface=vlan1074lan
add action=masquerade chain=srcnat disabled=yes out-interface=ether2-master-local
No sé si es esto lo que me falta... (pero con vlan1_livebox y bridge1 en vez de vlan1074lan y ether2-master-local)

Como te comenté, a nivel Jazztel, desconozco la configuración (solo he llegado a hacer funcionar Movistar y Orange).
En ambos casos, los servicios van siempre por separado, cada uno por su VLAN.

Lo ideal, sería si puedes ver la configuración del router de Jazztel, y de ahí sacar la información exacta. (puede que los scripts estén desactualizados, pero así tendrías una referencia para comparar)
Si puedes generar un fichero de exportación del router de jazztel, sería de ayuda también, para revisar todo mejor.

Aún así, insisto, tiene toda la pinta, de que deberás crear las vlans y separar los servicios si o si...

Ya vas diciendo.

Un saludo,
 
No, de hecho no tengo ni movistar desde hace tiempo ya. Para el túnel EoIP no tienes que abrir ningún puerto, sólo permitir el tráfico GRE del otro extremo de la conexión. Pero sí, tienes razón, lo puedes correr encima de otro túnel si te da problemas de rendimiento el IPSec.

Ahora mismo no se me ocurre de dónde puede venir el fallo, pero si se me enciende la lucecita, te digo.

Saludos!

Buenas! Comentaros que ya he dado con la solución. Revisando en el foro de mikrotik, vi un hilo que comentaban un problema parecido al añadir el EOIP al Bridge. Era un problema de MTU, el EOIP tenia la misma MTU que el Bridge y es lo que hacia fallar todo. Forzando tamaño de MTU a 1500 sobre el Bridge ya está funcionando todo correcto.
 
Buenas! Comentaros que ya he dado con la solución. Revisando en el foro de mikrotik, vi un hilo que comentaban un problema parecido al añadir el EOIP al Bridge. Era un problema de MTU, el EOIP tenia la misma MTU que el Bridge y es lo que hacia fallar todo. Forzando tamaño de MTU a 1500 sobre el Bridge ya está funcionando todo correcto.
Cual era tu problema original? Porque, si estabas montando EoIP, en el propio manual se dice bien claro especificar un MTU a 1500 para evitar fragmentación de paquetes.

Lo primero que tenemos que tener claro es qué es el protocolo EoIP. Básicamente, y como su nombre indica, es un protocolo para transportar ethernet sobre IP (transportar capa 2, sobre capa 3). Es un túnel capaz de correr encima de otro túnel. Es decir, puedes enlazar A con B con un túnel de otro tipo, como L2TP, PPTP, IPIP, y montar esto encima. Utiliza el protocolo GRE para montar el túnel (ojo con el firewall, hay que permitir ese tráfico en input) y añade un extra de 42 bytes al tamaño del paquete, así que mejor poner un MTU a 1500 para eliminar problemas de fragmentación.

Decir que el MTU hace referencia al del túnel, no al del bridge. El bridge, por lo general, al contener interfaces ethernet con un MTU por defecto de 1500, ya estará funcionando con ese tamaño de MTU como efectivo.

Saludos!
 
Cual era tu problema original? Porque, si estabas montando EoIP, en el propio manual se dice bien claro especificar un MTU a 1500 para evitar fragmentación de paquetes.

Lo primero que tenemos que tener claro es qué es el protocolo EoIP. Básicamente, y como su nombre indica, es un protocolo para transportar ethernet sobre IP (transportar capa 2, sobre capa 3). Es un túnel capaz de correr encima de otro túnel. Es decir, puedes enlazar A con B con un túnel de otro tipo, como L2TP, PPTP, IPIP, y montar esto encima. Utiliza el protocolo GRE para montar el túnel (ojo con el firewall, hay que permitir ese tráfico en input) y añade un extra de 42 bytes al tamaño del paquete, así que mejor poner un MTU a 1500 para eliminar problemas de fragmentación.

Decir que el MTU hace referencia al del túnel, no al del bridge. El bridge, por lo general, al contener interfaces ethernet con un MTU por defecto de 1500, ya estará funcionando con ese tamaño de MTU como efectivo.

Saludos!

Fallaba el menu de Movistar TV en cuanto añadía el tunel EOIP al Bridge. El problema no estaba en el MTU del EoIP (estaba en 1492), si no en el MTU del Bridge, estaba por defecto en 1492 y petaba todo. Al poner 1500 en el MTU del Bridge se ha solucionado el problema.
 
Fallaba el menu de Movistar TV en cuanto añadía el tunel EOIP al Bridge. El problema no estaba en el MTU del EoIP (estaba en 1492), si no en el MTU del Bridge, estaba por defecto en 1492 y petaba todo. Al poner 1500 en el MTU del Bridge se ha solucionado el problema.

Pues me temo que no está bien solucionado. La solución es poner el MTU del túnel a 1500, tal y como se indica en el manual, y no tocar el del bridge, que siempre va a tomar el MTU más pequeño de los MTU’s de todos los puertos que lo formen, razón por la que se te iba a 1492 al meter el túnel dentro de él. Pero la solución buena es aumentar el MTU del túnel, a 1500 en ambos extremos, no tocar el del bridge.

Saludos!
 
Pues me temo que no está bien solucionado. La solución es poner el MTU del túnel a 1500, tal y como se indica en el manual, y no tocar el del bridge, que siempre va a tomar el MTU más pequeño de los MTU’s de todos los puertos que lo formen, razón por la que se te iba a 1492 al meter el túnel dentro de él. Pero la solución buena es aumentar el MTU del túnel, a 1500 en ambos extremos, no tocar el del bridge.

Saludos!

Ok, lo pruebo y te digo. ¡Muchas gracias!
 
Hola,

Para aquellos de vosotros que tengan diversos decos y utilicéis mikrotik como router, notareis que el VOD sólo funciona en uno, si no se han cometido errores en la configuración.

Propongo un "apaño" para conseguir tener VOD en todos los decos, expongo mi solución.

En primer lugar, deshabilitar o eliminar la regla en las configuraciones actuales.
Concretamente:
Código:
add action=dst-nat chain=dstnat dst-address-type=localin-interface=\
    vlan2comment="VOD" to-addresses=192.168.1.199
Si no desea eliminar, se puede deshabilitar:
Código:
add action=dst-nat chain=dstnat dst-address-type=local in-interface=\
    vlan2comment="VOD" disabled=yes to-addresses=192.168.1.199
Entiendo que si tenéis diversos decos la configuracion de dhcp la habréis tuneado para cada uno de ellos.
Una vez tengamos esto, explico en que consiste el "apaño":

1.- Detectar las conexiones RTSP realizadas por los decos:
Código:
/ip firewall layer7-protocol add comment="VODMovistar" name=rtsp regexp="SETUP rtsp.*"
2.- Registrar la IP del deco que ha originado la conexión:
/ip firewall mangle add action=add-src-to-address-listaddress-list=vod-receiver\
address-list-timeout=1m chain=postrouting\
comment="RTSP - Real Time Streaming Protocol" layer7-protocol=rtsp\
out-interface=vlan2

Código:
/ip firewall mangle
add action=add-src-to-address-list address-list=vod-receiver address-list-timeout=1m chain=postrouting comment="RTSP - VOD Movistar" dst-port=554 out-interface=vlan2 protocol=tcp
3.- Definir un script que monitorice la address-list=vod-receiver, y cree la correspondiente dst-nat rule:
Código:
/system script add name=vod owner=admin policy=read,write source=\
   "/ip firewall nat remove [find comment=\"VOD Script\"];\
    \n/ip firewall nat add action=dst-nat chain=dstnat comment=\"VOD Script\"\
   dst-address-type=local in-interface=vlan2 to-addresses=\
   [/ip firewall address-list get [:pick [/ip firewall address-list\
   find list=\"vod-receiver\"] ([:len [/ip firewall address-list\
   find list=\"vod-receiver\"]]-1)] address];"
4.- Crear una scheduler task que cada n segundos (en mi caso30) ejecute el script anterior:
Código:
/system scheduler add interval=30s name=vod on-event=vod policy=read,write
Notas sobre el punto 3:
Primero eliminamos las posibles reglas existentes que coincidan con el comentario “VOD Script” si no hay ninguna, no hay problema. Para después añadir la regla correspondiente. Se debe tener en cuenta que una vez iniciado un flujo de datos entre los servidores UDP y el deco, la regla dst-nat se puede eliminar sin problemas ya que el router “recuerda” hacia donde debe enviar este flujo y la nueva regla enviara el correspondiente flujo al nuevo deco.
Este codigo
Código:
/ip firewall address-list get [:pick [/ipfirewall address-list find list="vod-receiver"] ([:len [/ip firewall address-list find list="vod-receiver"]]-1)] address
solo pretende conseguir la ultima ip existente en la address-list.

Con estas modificaciones están funcionando todos mis decos, de momento sin problemas.

Espero que os sirva de ayuda.

Buenas @toniros,

He estado probando tu script y me he dado cuenta, que en el caso de visualizar: 'Últimos 7 días', 'Grabaciones' o 'Ver desde el principio', el deco hace peticiones TCP hacia el puerto 554 cada 30 segundos. Esto provoca que cada 30 segundos la siguiente regla:

Código:
/ip firewall mangle
add action=add-src-to-address-list address-list=vod-receiver address-list-timeout=1m chain=postrouting comment="RTSP - VOD Movistar" dst-port=554 out-interface=vlan2 protocol=tcp

Está creando la lista de nuevo, por lo que ese deco "acapara" la regla dstnat mientras se están visionando estos contenidos. Para solucionarlo, lo que he hecho es modificar la regla para que sólo escriba la lista, cuando detecta la primera solicitud TCP (SYN), que es la que nos interesa para saber que un deco está demandando algo bajo demanda y por lo tanto es en ese momento cuando necesitamos cambiar la IP y luego dejar la regla dsnat libre por si quiere usarlo otro deco. Para ello he modificado la regla de esta manera (añadiendo connection-state=new):

Código:
/ip firewall mangle
add action=add-src-to-address-list address-list=vod-receiver address-list-timeout=1m chain=postrouting comment="RTSP - VOD Movistar" connection-state=new dst-port=554 out-interface=vlan2 protocol=tcp

Creo que de esta manera se mejora algo tu script.

Muchas gracias y espero que ayude a otros foreros ;)
 
Genial, @josepc !!.
Lo he probado y tienes toda la razón. Si se tienen dos descos y se está haciendo VOD con los dos simultáneamente, si no se limita la regla de mangle como tú propones, en algunos casos puede que se quede atascado uno de ellos y no responda cuando queremos hacer VOD en el desco atascado a otro canal o a otro contenido bajo demanda. Si hacemos lo que propones, esto no sucede, y se puede hacer VOD simultáneamente sin atascos (el único problema que persiste es que hay que dar la orden de inicio de VOD en el desco "nuevo" dos veces, hasta que el script programado actúe y genere la regla NAT del "nuevo" desco. Esto se podría arreglar si con RouterOS se pudiera invocar desde esta regla de mangle un script para generar la regla de NAT directamente en ese momento, pero no es posible, lamentablemente, y por eso hay que acudir al script de @toniros en el schedule y de ahí el retardo).

@pokoyo, creo que habría que corregir la configuración básica de dos descos con esta buena propuesta de @josepc

Muchas gracias y saludos!!
 
Genial, @josepc !!.
Lo he probado y tienes toda la razón. Si se tienen dos descos y se está haciendo VOD con los dos simultáneamente, si no se limita la regla de mangle como tú propones, en algunos casos puede que se quede atascado uno de ellos y no responda cuando queremos hacer VOD en el desco atascado a otro canal o a otro contenido bajo demanda. Si hacemos lo que propones, esto no sucede, y se puede hacer VOD simultáneamente sin atascos (el único problema que persiste es que hay que dar la orden de inicio de VOD en el desco "nuevo" dos veces, hasta que el script programado actúe y genere la regla NAT del "nuevo" desco. Esto se podría arreglar si con RouterOS se pudiera invocar desde esta regla de mangle un script para generar la regla de NAT directamente en ese momento, pero no es posible, lamentablemente, y por eso hay que acudir al script de @toniros en el schedule y de ahí el retardo).

@pokoyo, creo que habría que corregir la configuración básica de dos descos con esta buena propuesta de @josepc

Muchas gracias y saludos!!
Por supuesto. Pásame cómo queda el script, y lo corrijo.

Saludos!
 
Por supuesto. Pásame cómo queda el script, y lo corrijo.

Saludos!
No. El script queda igual. Sólo hay que cambiar esta regla, añadiéndole "connection-state=new". Quedaría así:

/ip firewall mangle
add action=add-src-to-address-list address-list=vod-receiver address-list-timeout=1m chain=postrouting comment="RTSP - VOD Movistar" connection-state=new dst-port=554 out-interface=iptv-vlan2 protocol=tcp

Saludos!!
 
No. El script queda igual. Sólo hay que cambiar esta regla, añadiéndole "connection-state=new". Quedaría así:

/ip firewall mangle
add action=add-src-to-address-list address-list=vod-receiver address-list-timeout=1m chain=postrouting comment="RTSP - VOD Movistar" connection-state=new dst-port=554 out-interface=iptv-vlan2 protocol=tcp

Saludos!!

Listo, actualizado, añadiendo el connection-state=new en la regla de mangle para VOD

Saludos!
 
Genial, @josepc !!.
Esto se podría arreglar si con RouterOS se pudiera invocar desde esta regla de mangle un script para generar la regla de NAT directamente en ese momento, pero no es posible, lamentablemente, y por eso hay que acudir al script de @toniros en el schedule y de ahí el retardo)

Esta es la espinita que tengo clavada (me da cosa ver como sube el número de ejecuciones del script cada 5 segundos :p), porque así tendríamos una solución 100% funcional, pero como dices hasta que RouterOS no permita ejecutar script directamente, tendremos que darle 2 veces al botón sobre visionado.
 
Arriba