MANUAL: FTTH Movistar/Jazztel con router neutro Mikrotik

Buenas!

Tengo configuración de ONT + Mikrotik con el script de @toniros para movistar+ (¡muchas gracias!) funcionando a la perfección con 2 decos: 1 zyxel HD y un Arris 4K.

El único problema es que en el Arris 4k, parece no funcionar la guía ni la info de películas o canales, revisando el DHCP que da el HGU, parece que el options le está entregando: 239.0.2.29:22222, en vez de 239.0.2.30:22222, lo he cambiado pero no parece tener efecto. ¿Alguien tiene un Arris 4k con mikrotik funcionando la guía y la información de canales?

Un saludo,

Jose.

Sobre esto, os comento que el problema de no poder acceder a la guía, he detectado que es al añadir una interfaz EOIP al Bridge del Mikrotik, en cuanto borro el EOIP funciona la guía y los menús perfectamente.

¿Alguien tiene la solución en Mikrotik con IPTV Movistar e interfaces EOIP en el mismo Bridge con todo funcionando correctamente? ¿podríais compartir la config?

Saludos,
 
Sobre esto, os comento que el problema de no poder acceder a la guía, he detectado que es al añadir una interfaz EOIP al Bridge del Mikrotik, en cuanto borro el EOIP funciona la guía y los menús perfectamente.

¿Alguien tiene la solución en Mikrotik con IPTV Movistar e interfaces EOIP en el mismo Bridge con todo funcionando correctamente? ¿podríais compartir la config?

Saludos,
Uhmmm! Qué raro! pasa tu configuración con hide-sensitive y lo miro. Me suena a que no está bien configurado el firewall y no entran los paquetes de la guía por eso. O porque no está correcto el masquerade. ¿tienes voip e iptv con Movistar, no?
 
Uhmmm! Qué raro! pasa tu configuración con hide-sensitive y lo miro. Me suena a que no está bien configurado el firewall y no entran los paquetes de la guía por eso. O porque no está correcto el masquerade. ¿tienes voip e iptv con Movistar, no?
Buenas Furny, siempre al pie del cañón ;) Comparto la configuración:

Código:
[admin@MikroTik] > export hide-sensitive
# model = RBD52G-5HacD2HnD
/interface bridge
add igmp-snooping=yes name=bridge1
/interface ethernet
set [ find default-name=ether1 ] name=ether1-gateway
set [ find default-name=ether2 ] name=ether2-local
set [ find default-name=ether3 ] name=ether3-local
set [ find default-name=ether4 ] name=ether4-local
set [ find default-name=ether5 ] name=ether5-local
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-eC country=spain disabled=no frequency=auto mode=ap-bridge ssid=MOVISTAR_XXXX \
    station-roaming=enabled
set [ find default-name=wlan2 ] band=5ghz-onlyac channel-width=20/40/80mhz-eeeC country=spain disabled=no frequency=auto mode=ap-bridge ssid=\
    MOVISTAR_PLUS_XXXX station-roaming=enabled
/interface eoip
add allow-fast-path=yes disabled=yes mac-address=02:A0:XX:XX:XX:XX name=eoip-tunnel1 remote-address=(el extremo del tunel PPTP) tunnel-id=XXX
/interface vlan
add comment="Movistar FTTH IPTV" interface=ether1-gateway name=vlan2 vlan-id=2
add comment="Movistar FTTH VoIP" interface=ether1-gateway name=vlan3 vlan-id=3
add comment="Movistar FTTH Data" interface=ether1-gateway name=vlan6 vlan-id=6
/interface pppoe-client
add add-default-route=yes allow=pap,chap disabled=no interface=vlan6 keepalive-timeout=60 max-mru=1492 max-mtu=1492 name=pppoe-out1 use-peer-dns=yes user=\
    adslppp@telefonicanetpa
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk eap-methods="" mode=dynamic-keys supplicant-identity=MikroTik
/ip dhcp-server option
add code=240 name=option_para_deco value="':::::239.0.2.10:22222:v6.0:239.0.2.30:22222'"
/ip firewall layer7-protocol
add comment=VODMovistar name=rtsp regexp="SETUP rtsp.*"
/ip pool
add name=dhcp ranges=192.168.1.30-192.168.1.199
/ip dhcp-server
add address-pool=dhcp bootp-support=dynamic disabled=no interface=bridge1 name=Servidor_DHCP
/ppp profile
add change-tcp-mss=yes name=default-encryption use-encryption=yes
/interface pptp-client
add allow=mschap2 connect-to=XXXXXX disabled=no name=XXXXXX profile=default-encryption user=XXXXXX
/interface bridge port
add bridge=bridge1 interface=ether2-local
add bridge=bridge1 interface=ether3-local
add bridge=bridge1 interface=ether4-local
add bridge=bridge1 interface=ether5-local
add bridge=bridge1 interface=wlan1
add bridge=bridge1 interface=wlan2
/interface bridge settings
set use-ip-firewall-for-pppoe=yes use-ip-firewall-for-vlan=yes
/ip settings
set tcp-syncookies=yes
/ip address
add address=192.168.1.1/24 comment="Red local" interface=bridge1 network=192.168.1.0
add address=192.168.100.10/24 comment="Acceso ONT" interface=ether1-gateway network=192.168.100.0
add address=10.X.X.X/10 comment="IPTV Movistar" interface=vlan2 network=10.64.0.0
/ip cloud
set ddns-enabled=yes ddns-update-interval=10m
/ip dhcp-client
add add-default-route=no disabled=no interface=vlan3 use-peer-ntp=no
/ip dhcp-server lease
add address=192.168.1.200 client-id=XXXXX dhcp-option=option_para_deco mac-address=0C:08:XX:XX:XX:XX server=Servidor_DHCP
/ip dhcp-server network
add address=192.168.1.0/24 dns-server=80.58.61.250,80.58.61.254 gateway=192.168.1.1 netmask=24
add address=192.168.1.200/29 dhcp-option=option_para_deco dns-server=172.26.23.3 gateway=192.168.1.1 netmask=24
/ip dns
set servers=80.58.61.250,80.58.61.254
/ip firewall filter
add action=accept chain=input protocol=icmp
add action=accept chain=input connection-state=established
add action=accept chain=input connection-state=related
add action=drop chain=input in-interface=pppoe-out1
add action=fasttrack-connection chain=forward connection-state=established,related
add action=accept chain=forward connection-state=established
add action=accept chain=forward connection-state=related
add action=drop chain=forward connection-state=invalid
/ip firewall mangle
add action=set-priority chain=postrouting new-priority=4 out-interface=vlan3
add action=set-priority chain=postrouting new-priority=4 out-interface=vlan2
add action=set-priority chain=postrouting new-priority=1 out-interface=pppoe-out1
add action=add-src-to-address-list address-list=vod-receiver address-list-timeout=1m chain=postrouting comment="RTSP - VOD Movistar" dst-port=554 \
    out-interface=vlan2 protocol=tcp
/ip firewall nat
add action=masquerade chain=srcnat out-interface=pppoe-out1
add action=masquerade chain=srcnat out-interface=ether1-gateway
add action=masquerade chain=srcnat out-interface=vlan2
add action=masquerade chain=srcnat out-interface=vlan3
add action=dst-nat chain=dstnat comment="VOD Script" dst-address-type=local in-interface=vlan2 to-addresses=192.168.1.200
/ip route
add distance=255 gateway=255.255.255.255
/ip upnp interfaces
add interface=bridge1 type=internal
add interface=pppoe-out1 type=external
/routing igmp-proxy
set query-interval=1m
/routing igmp-proxy interface
add alternative-subnets=0.0.0.0/0 interface=vlan2 upstream=yes
add interface=bridge1
/routing rip interface
add interface=vlan3 passive=yes receive=v2
add interface=vlan2 passive=yes receive=v2
/routing rip network
add network=10.0.0.0/8
add network=172.26.0.0/16
/system clock
set time-zone-name=Europe/Madrid
/system ntp client
set enabled=yes primary-ntp=129.6.15.28 secondary-ntp=129.6.15.29
/system routerboard settings
set silent-boot=yes
/system scheduler
add interval=5s name=vod on-event=vod policy=read,write start-time=startup
/system script
add dont-require-permissions=no name=vod owner=admin policy=read,write source=":local iplist [:len [/ip firewall address-list find list=\"vod-receiver\"]]\
    \n:local rules [:len [/ip firewall nat find where comment=\"VOD Script\"]]\
    \n#:log info \"VODScript: IPs in list are \$iplist !\"\
    \n#:log info \"VODScript: Rules are \$rules !\"\
    \n:if (\$iplist = 0 and \$rules > 0) do={\
    \n\t#/ip firewall nat remove [find comment=\"VOD Script\"];\
    \n\t#:log info \"VODScript: Rule removed !\"\
    \n} else {\
    \n\t:local ipadressnew [/ip firewall address-list get [:pick [/ip firewall address-list find list=\"vod-receiver\"] (\$iplist-1)] address]\
    \n\t:local ipadressold \"None\"\
    \n\t#:log info \"VODScript: IP adress new is \$ipadressnew !\"\
    \n\t:if (\$iplist > 0 ) do {\
    \n\t\tif (\$rules > 0 ) do {\
    \n\t\t\t:set ipadressold [/ip firewall nat get [find comment=\"VOD Script\"] to-addresses] \
    \n\t\t\t#:log info \"VODScript: IP adress old is \$ipadressold !\"\
    \n\t\t}\
    \n\t\t:if (\$ipadressnew != \$ipadressold) do={\
    \n\t\t\tif (\$rules > 0 ) do {\
    \n\t\t\t\t/ip firewall nat remove [find comment=\"VOD Script\"];\
    \n\t\t\t}\
    \n\t\t\t/ip firewall nat add action=dst-nat chain=dstnat comment=\"VOD Script\" dst-address-type=local in-interface=vlan2 to-addresses=\$ipadressnew\
    \n\t\t\t:log info \"VODScript: IP adress changed from \$ipadressold to \$ipadressnew !\"\
    \n\t\t}\
    \n\t}\
    \n}"

En cuanto añado al bridge1 la interfaz EOIP deja de funcionar menú y guía (multicast sigue funcionando)

add bridge=bridge1 interface=eoip-tunnel1

En el otro extremo tengo un Mikrotik con server PPTP y EOIP configurado en modo Bridge a un solo puerto ethernet.

he probado activar/desactivar allow-fast-path en EOIP pero nada funciona. En cuanto pongo a disabled la interfaz EOIP en el Bridge1, el menú y la guía vuelve a funcionar correctamente.
Saludos,
 
Bueno. Por este lado no veo nada raro, al contrario: tienes una configuración de firewall poco restrictiva que deja entrar todo lo que venga de vlan2 y 3. Pero hay que ver la del otro lado del túnel. No tengo experiencia en este tipo de túneles, pero creo que, sin embargo, cuando se hace un túnel EoIp lo que haces es unir a través del bridge interfaces que están en sitios distintos en nivel 2, como hacer un "mega switch". Y como para tratar el triple vlan de Movistar ponemos esta regla:
/interface bridge settings
set use-ip-firewall-for-pppoe=yes use-ip-firewall-for-vlan=yes
creo que pueden influir las reglas de firewall en un lado y en otro del túnel. Podría ser alguna regla del otro router la que se "come" los paquetes UDP "no solicitados" (la guía y tal) que vienen de 10.0.0.0/8 o de 172.26.0.0/16.
 
Espera, además, en el router principal del túnel EoIP creo que debes añadir una regla para admitir el tráfico:
/ip firewall filter add action=accept chain=input comment="Accept GRE tunnel traffic" protocol=gre

La regla habría que ponerla en la cadena input justo antes de la regla de ICMP
 
Ayer publiqué un manual sobre cómo enlazar dos routers con EoIP, donde uno sea el router completo, el de casa, y otro un router tonto sin reglas de firewall ni nat, que lo único que hará será puentear la WAN para acceder a nuestro router de casa con un túnel EoIP, por si te interesa @josepc

Saludos!
 
Ayer publiqué un manual sobre cómo enlazar dos routers con EoIP, donde uno sea el router completo, el de casa, y otro un router tonto sin reglas de firewall ni nat, que lo único que hará será puentear la WAN para acceder a nuestro router de casa con un túnel EoIP, por si te interesa @josepc

Saludos!
ah!, mira! estupendo, @pokoyo. Lo voy a mirar. Te recomiendo, @josepc, que lo mires tu también por si hay algo del túnel mal configurado y después analizamos otra vez las dos configuraciones de ambos routers.
Por cierto, que en el hilo https://www.adslzone.net/foro/mikro...rm-movistar-fusion.520825/page-2#post-3407935
hay una configuración de triple vlan para Movistar que acaba de hacer @pokoyo (con algún apunte mío), donde las reglas de firewall están más claras, basadas en la configuración actual por defecto, que las que tienes tú, que es de una configuración más antigua, por si te interesa actualizarlo.
 
Ayer publiqué un manual sobre cómo enlazar dos routers con EoIP, donde uno sea el router completo, el de casa, y otro un router tonto sin reglas de firewall ni nat, que lo único que hará será puentear la WAN para acceder a nuestro router de casa con un túnel EoIP, por si te interesa @josepc

Saludos!
Buenas @pokoyo

Le he echado un vistazo y no hay diferencias grandes entre lo que yo ya tengo con EOIP, lo único que yo monto el EOIP bajo un túnel PPTP o L2TP, en vez de hacerlo directamente. (por temas de no estar abriendo más puertos y rendimiento, ya que IPSEC me consume la CPU)

De hecho, la solución de HGU gestionando las 3 VLAN, con un Mikrotik detrás en modo Bridge, accedo perfectamente por EOIP a esa sede a todos los servicios, asi que el EOIP lo tengo bien montado. Es cuando me quiero deshacer del HGU y dejar ONT + Mikrotik, que en la sede principal funciona todo correcto con la config que he subido, pero en cuanto añado el EOIP al Bridge de la sede principal, empieza a fallar la Guía y el Menú del Deco IPTV.

Si no me equivoco, no tenias IPTV, ¿no?

Muchas gracias por tus tutoriales, que están genial ;)
 
Última edición:
Buenas @pokoyo

Le he echado un vistazo y no hay diferencias grandes entre lo que yo ya tengo con EOIP, lo único que yo monto el EOIP bajo un túnel PPTP o L2TP, en vez de hacerlo directamente. (por temas de no estar abriendo más puertos y rendimiento, ya que IPSEC me consume la CPU)

De hecho, la solución de HGU las 3 VLAN, con un Mikrotik detrás en modo Bridge, accedo perfectamente por EOIP a esa sede a todos los servicios, asi que el EOIP lo tengo bien montado. Es cuando me quiero deshacer del HGU y dejar ONT + Mikrotik, que en la sede principal funciona todo correcto con la config que he subido, pero en cuanto añado el EOIP al Bridge de la sede principal, empieza a fallar la Guía y el Menú del Deco IPTV.

Si no me equivoco, no tenias IPTV, ¿no?

Muchas gracias por tus tutoriales, que están genial ;)

No, de hecho no tengo ni movistar desde hace tiempo ya. Para el túnel EoIP no tienes que abrir ningún puerto, sólo permitir el tráfico GRE del otro extremo de la conexión. Pero sí, tienes razón, lo puedes correr encima de otro túnel si te da problemas de rendimiento el IPSec.

Ahora mismo no se me ocurre de dónde puede venir el fallo, pero si se me enciende la lucecita, te digo.

Saludos!
 
Buenas tardes a todos.
He llevado a cabo la instalación en casa de mis suegros de un router mikrotik con la siguiente configuración:
ONT-RouterMikrotik-AP Mikrotik
donde tengo 2 desco de Movistar UHD conectados (1 al router directamente) y otro al AP.
Me funciona todo perfectamente, excepto una "tontería". En el segundo deco (el que se conecta a través del AP) no me funciona la funcion de "volver al inicio" de un programa o película empezado. Me dice que hay un problema con la red y que no ha sido posible realizar la petición. Y al darle a aceptar el mensaje, se mantiene en el "directo".

Todo lo demás, como os comento, me funciona perfectamente.

A ver si hay alguien que me pueda echar un poco de luz con mi problema.

Gracias de antemano a todos.

PD: si no toca aquí me disculpo de antemano. Si tengo que abrir un hilo nuevo, que me digan los moderadores.

Un saludo
 
Buenas tardes a todos.
He llevado a cabo la instalación en casa de mis suegros de un router mikrotik con la siguiente configuración:
ONT-RouterMikrotik-AP Mikrotik
donde tengo 2 desco de Movistar UHD conectados (1 al router directamente) y otro al AP.
Me funciona todo perfectamente, excepto una "tontería". En el segundo deco (el que se conecta a través del AP) no me funciona la funcion de "volver al inicio" de un programa o película empezado. Me dice que hay un problema con la red y que no ha sido posible realizar la petición. Y al darle a aceptar el mensaje, se mantiene en el "directo".

Todo lo demás, como os comento, me funciona perfectamente.

A ver si hay alguien que me pueda echar un poco de luz con mi problema.

Gracias de antemano a todos.

PD: si no toca aquí me disculpo de antemano. Si tengo que abrir un hilo nuevo, que me digan los moderadores.

Un saludo
Buenas. Mira lo que publiqué en este hilo hace unos meses: #7,635. Si lo has mirado, lo tienes configurado así y no consigues en el segundo desco ver "el inicio" al segundo intento, puede que haya algo en el AP que chafe al segundo desco. Si me puedes pasar más detalles, quizá podamos analizar lo que pasa. En cualquier caso, ese segundo AP debería tener activado el IGMP-snooping, si fuera posible, pues si no, los paquetes de IPTV inundarán la red wifi y bajará su calidad.

Saludos!
 
Buenas. Mira lo que publiqué en este hilo hace unos meses: #7,635. Si lo has mirado, lo tienes configurado así y no consigues en el segundo desco ver "el inicio" al segundo intento, puede que haya algo en el AP que chafe al segundo desco. Si me puedes pasar más detalles, quizá podamos analizar lo que pasa. En cualquier caso, ese segundo AP debería tener activado el IGMP-snooping, si fuera posible, pues si no, los paquetes de IPTV inundarán la red wifi y bajará su calidad.

Saludos!
Gracias por contestar tan pronto Furny. Eso ya lo había revisado, y ni con esas. Siendo el ap un 951 igual que el router, tamien he configurado IGMP-snooping en el bridge. Probaré lo de parar y volver a iniciar, que es lo único que no he hecho. A nivel de configuración del AP, no creo que sea. Pruebo y te digo algo...
 
Nada, con mi configuración (2 desco UHD) y router y ap mikrotik (RB951) el segundo desco, siempre da error al querer reproducir desde inicio.
Si quieres subo config del AP y del Router (pero diría que no es el caso)

Ya me dices, y sino, pues me espero a que alguien "de con la tecla"
 
Nada, con mi configuración (2 desco UHD) y router y ap mikrotik (RB951) el segundo desco, siempre da error al querer reproducir desde inicio.
Si quieres subo config del AP y del Router (pero diría que no es el caso)

Ya me dices, y sino, pues me espero a que alguien "de con la tecla"
Vaya, lo siento. Sí, sube la config del router y del AP y cuando pueda le hecho un vistazo. Fíjate también si el script de @toniros cambia bien la regla NAT cuando pasas de un desco a otro, no vaya a ser que tengas una errata en el script. (la última versión de su script tiene hasta mensajes al log que se pueden habilitar o no para comprobar si se está ejecutando bien). Otra cosa que puedes hacer es cambiar la regla NAT de VOD Script a mano para ver si es problema de la conexión al segundo desco o que pasa. Me suena muy raro.

Saludos!
 
Subo mis config.
Ya me diras si ves tu algo que se me escape...:unsure:
 

Adjuntos

  • ConfigAP_OK.txt
    2 KB · Visitas: 44
  • ConfigRB_OK.txt
    7.8 KB · Visitas: 77
Subo mis config.
Ya me diras si ves tu algo que se me escape...:unsure:
Bueno, ya le he echado un vistazo y veo sólo lo siguiente (a menos que tengas unos descos fuera de lo común, el tratamiento debería ser idéntico para todos ellos):

1) Esta regla creo que es innecesaria. Es más, creo que podría darte problemas. Yo no la usaría:
/ip dhcp-server option sets
add name=set1 options=option_para_deco

Usa sólo la regla:

/ip dhcp-server option
add code=240 name=option_para_deco value=\
"':::::239.0.2.10:22222:v6.0:239.0.2.30:22222'"
... y quita las menciones al set1

2) En cambio, a pesar de que tienes esta regla (ya he quitado la mención al set1):

/ip dhcp-server network
add address=192.168.1.200/29 dhcp-option=option_para_deco dns-server=172.26.23.3 gateway=192.168.1.1 netmask=24

habría que poner en cada uno de los descos, tras hacerlos estáticos, la option-para-deco:

/ip dhcp-server lease
add address=192.168.1.200 client-id="41:52:52:49:53:5f:56:49:50:35:32:34:32:5f\
:43:38:35:32:36:31:33:35:38:42:38:45" comment="DECO SALON 1" mac-address=\
C8:52:61:35:8B:8E server=dhcp.lan dhcp-option=option_para_deco
add address=192.168.1.201 address-lists=vod-receiver client-id="48:55:4d:41:58\
:5f:50:54:54:31:30:30:30:5f:45:53:5f:45:38:42:32:46:45:30:41:30:45:31:38" \
comment="DECO SALON 2" dhcp-option=option_para_deco \
mac-address=E8:B2:FE:0A:0E:18 server=dhcp.lan
add address=192.168.1.202 client-id="48:55:4d:41:58:5f:50:54:54:31:30:30:30:5f\
:45:53:5f:45:38:42:32:46:45:30:45:34:34:39:36" comment=\
"DECO SALON 3" mac-address=E8:B2:FE:0E:44:96 server=dhcp.lan dhcp-option=option_para_deco

3) El script de @toniros está bien, lo he repasado, pero estas tres reglas:

add action=dst-nat chain=dstnat comment="VOD Script" dst-address-type=local \
in-interface=vlan2 to-addresses=192.168.1.200
add action=dst-nat chain=dstnat comment="VOD Script" dst-address-type=local \
in-interface=vlan2 to-addresses=192.168.1.201
add action=dst-nat chain=dstnat comment="VOD Script" dst-address-type=local \
in-interface=vlan2 to-addresses=192.168.1.202

Supongo que las has puesto tú a mano. El script solo pone una cada vez que un desco pide algo de VOD, y borra la anterior (porque NO puede haber dos o más reglas de estas a la vez, solo funciona la primera. El script solo te estaba borrando una regla, pero siempre había dos y la cosa no funcionaba). Pero el router "recuerda" el camino de los paquetes que se hubieran iniciado con el otro desco y la otra regla creada; por ello puede hacerse VOD simultáneamente en dos descos.

SOLUCIÓN: Borra las tres reglas anteriores y deja que el script cree dinámicamente una sola cada vez desde el desco que lo demande y borre la anterior. Para eso está.

Eso es lo que he observado y me llama la atención. Una vez hagas esos cambios, apaga por completo los descos y los vuelves a encender.

Ya me dirás el resultado.

Suerte!!!
 
Última edición:
Bueno, ya le he echado un vistazo y veo sólo lo siguiente (a menos que tengas unos descos fuera de lo común, el tratamiento debería ser idéntico para todos ellos):

1) Esta regla creo que es innecesaria. Es más, creo que podría darte problemas. Yo no la usaría:
/ip dhcp-server option sets
add name=set1 options=option_para_deco

Usa sólo la regla:

/ip dhcp-server option
add code=240 name=option_para_deco value=\
"':::::239.0.2.10:22222:v6.0:239.0.2.30:22222'"
... y quita las menciones al set1

2) En cambio, a pesar de que tienes esta regla (ya he quitado la mención al set1):

/ip dhcp-server network
add address=192.168.1.200/29 dhcp-option=option_para_deco dns-server=172.26.23.3 gateway=192.168.1.1 netmask=24

habría que poner en cada uno de los descos, tras hacerlos estáticos, la option-para-deco:

/ip dhcp-server lease
add address=192.168.1.200 client-id="41:52:52:49:53:5f:56:49:50:35:32:34:32:5f\
:43:38:35:32:36:31:33:35:38:42:38:45" comment="DECO SALON 1" mac-address=\
C8:52:61:35:8B:8E server=dhcp.lan dhcp-option=option_para_deco
add address=192.168.1.201 address-lists=vod-receiver client-id="48:55:4d:41:58\
:5f:50:54:54:31:30:30:30:5f:45:53:5f:45:38:42:32:46:45:30:41:30:45:31:38" \
comment="DECO SALON 2" dhcp-option=option_para_deco \
mac-address=E8:B2:FE:0A:0E:18 server=dhcp.lan
add address=192.168.1.202 client-id="48:55:4d:41:58:5f:50:54:54:31:30:30:30:5f\
:45:53:5f:45:38:42:32:46:45:30:45:34:34:39:36" comment=\
"DECO SALON 3" mac-address=E8:B2:FE:0E:44:96 server=dhcp.lan dhcp-option=option_para_deco

3) El script de @toniros está bien, lo he repasado, pero estas tres reglas:

add action=dst-nat chain=dstnat comment="VOD Script" dst-address-type=local \
in-interface=vlan2 to-addresses=192.168.1.200
add action=dst-nat chain=dstnat comment="VOD Script" dst-address-type=local \
in-interface=vlan2 to-addresses=192.168.1.201
add action=dst-nat chain=dstnat comment="VOD Script" dst-address-type=local \
in-interface=vlan2 to-addresses=192.168.1.202

Supongo que las has puesto tú a mano. El script solo pone una cada vez que un desco pide algo de VOD, y borra la anterior (porque NO puede haber dos o más reglas de estas a la vez, solo funciona la primera. El script solo te estaba borrando una regla, pero siempre había dos y la cosa no funcionaba). Pero el router "recuerda" el camino de los paquetes que se hubieran iniciado con el otro desco y la otra regla creada; por ello puede hacerse VOD simultáneamente en dos descos.

SOLUCIÓN: Borra las tres reglas anteriores y deja que el script cree dinámicamente una sola cada vez desde el desco que lo demande y borre la anterior. Para eso está.

Eso es lo que he observado y me llama la atención. Una vez hagas esos cambios, apaga por completo los descos y los vuelves a encender.

Ya me dirás el resultado.

Suerte!!!
Disculpa que haya tardado en contestar.
Comentarte que he probado lo que me has dicho, y al parecer, el script no está funcionando como debiera, ya que no crea las reglas dinámicamente.
Lo que si he visto, es que con la regla estátita, puedo forzar que funcione en uno u otro desco.
Así mismo, he probado a crear la regla, y que la registrase sobre un rango de ips, en vez de sobre una dirección única, y eso no le ha gustado (por probar...)

Seguiré "investigando" y si encuentro algo, os lo haré saber.

Un saludo, y gracias por todo.
 
Disculpa que haya tardado en contestar.
Comentarte que he probado lo que me has dicho, y al parecer, el script no está funcionando como debiera, ya que no crea las reglas dinámicamente.
Lo que si he visto, es que con la regla estátita, puedo forzar que funcione en uno u otro desco.
Así mismo, he probado a crear la regla, y que la registrase sobre un rango de ips, en vez de sobre una dirección única, y eso no le ha gustado (por probar...)

Seguiré "investigando" y si encuentro algo, os lo haré saber.

Un saludo, y gracias por todo.
Bueno, no me he expresado correctamente. El script NO crea una regla de nat dinámica, sino una estática apuntando a un desco concreto que es el que ha pedido una acción VOD, y que quita la estática que hubiera puesto anteriormente de otro desco. Eso es lo que debiera hacer, y habiendo revisado tu script, me parece que está correcto, pero se me puede haber pasado algún símbolo. Lo que he visto que te falta es activar el firewall para que analice protocolos de nivel 7 (RTSP):

/ip firewall layer7-protocol add comment=VOD2Descos name=rtsp regexp="SETUP rtsp.*"

Lo debes poner antes de cualquier regla de firewall. Sin eso no funciona el script.

Disculpa, no me había dado cuenta antes.

Suerte!!
 
Última edición:
Hola de nuevo Furny.
He creado la regal en IP firewall layer7 protocols como me has comentado (es la única que tengo ahí, por lo tanto está de primera)
He eliminado las reglas estáticas de los demás descos y me esperé a que el contador del script se moviera...ha pasado un buen rato, y no veo como crea la regla estática nueva ni nada (y están operativos 2 descos)
No se...es extraño.
Intentaré revisar bien todo de nuevo...a ver qué se me escapa...

Gracias igualmente!
 
Hola de nuevo Furny.
He creado la regal en IP firewall layer7 protocols como me has comentado (es la única que tengo ahí, por lo tanto está de primera)
He eliminado las reglas estáticas de los demás descos y me esperé a que el contador del script se moviera...ha pasado un buen rato, y no veo como crea la regla estática nueva ni nada (y están operativos 2 descos)
No se...es extraño.
Intentaré revisar bien todo de nuevo...a ver qué se me escapa...

Gracias igualmente!
Pues no sé... si puedes, vuélveme a pasar con hide-sensitive un export de tu config, a ver si hay algo que se me escapa.

¿dices que el contador del scheduler no se mueve? ¿que no se crea ninguna regla ni progresa el script?

Si te fijas en el script hay escrituras al log para depurar, pero está con un comentario, por ejemplo, en la 5ª línea:

\n#:log info \"VODScript: IPs in list are \$iplist !\"\

si ponemos:

\n:log info \"VODScript: IPs in list are \$iplist !\"\

Si que hará entradas al log, si pasa por ese punto

y lo mismo en las otras líneas de log que están comentadas, podrás hacer un seguimiento de depuración. (puedes tocar el script que está en ejecución en la pestaña "/system scripts". Allí, en tu script, en source, lo verás, y puedes quitar los #), pero antes, me mandas el config tal cual lo tienes.

Suerte.
 
Arriba